taniwha

[1.3.1] Extraplanetary Launchpads v5.9.0

Recommended Posts

1 hour ago, keithcarla said:

@taniwha

Or is there a way to just disable kernel's skill function? Making it more like a sandbox?

 

1 hour ago, goldenpsp said:

It is baked into the dll so no.

You can edit the Trait cfg to adjust how the Trait is managed - i.e. you can give the all the Kerbals the skill function which the same efficiency at every level if you so choose.  

But as goldenpsp said, they do need it as it is baked in as a requirement.

Peace.

Share this post


Link to post
Share on other sites

Since the update to 5.8.0, right-clicking on construction parts doesn't show the UI to select a vessel to build. Anyone else having this problem?

Also running MKS. Sorry, I actually don't know how to record a log.

Share this post


Link to post
Share on other sites
2 hours ago, mejdrich said:

Since the update to 5.8.0, right-clicking on construction parts doesn't show the UI to select a vessel to build. Anyone else having this problem?

Also running MKS. Sorry, I actually don't know how to record a log.

Logs are recorded automatically by the game, the above link will describe where to find them. 

Share this post


Link to post
Share on other sites

I'm operating an orbital recycler, and it doesn't seem to be producing anything.  I have a ship with a recycler, metal tank, rocketparts tank, etc (no storage for MetalOre or ScrapMetal) but when I recycle something, no metal is produced.  I've played with this mod before, and I thought a simple recycler could be just a blue scoop and a metal tank.  Bug or am I doing something wrong?

Share this post


Link to post
Share on other sites

@Jetski: Indeed the recycler used to recycle to metal, but now it recycles to scrap metal. The change was for reasons of verisimilitude, but if you prefer the old behavior, simply edit ScrapMetal to Metal in ExtraplanetaryLaunchpads/Resources/Recipes.cfg in the RocketParts EL_RecycleRecipe node.

Share this post


Link to post
Share on other sites

I've been having trouble with the stakes. I put one into the ground, and I don't know how to construct from them. I'm in the construction menu, but they don't show up.

Share this post


Link to post
Share on other sites
10 minutes ago, Ragingdonut said:

I've been having trouble with the stakes. I put one into the ground, and I don't know how to construct from them. I'm in the construction menu, but they don't show up.

Do you have a survey station nearby?  That's where your build controller for them is.  (How close it needs to be will depend on what level of pilot you have in it...)

Share this post


Link to post
Share on other sites

That I do not. Thank you, you may have solved my issue.

Share this post


Link to post
Share on other sites

@taniwha, the only part that seems to be capable of storing scrap metal is the smelter.  Can you please give us a tank for holding scrap metal?  The recycler is hard to use without such a thing.

Share this post


Link to post
Share on other sites

@waucka: I'm working on it, but in the meantime, you can use the tanks in Talisar Parts along with Modular Fuel Tanks. You will need to change the tank type to Talisar Utility (via MFT) to be able to store EL resources in them.

Share this post


Link to post
Share on other sites
Posted (edited)

Trying to get this to work, but I'm running out of options to try out... and by running out, I mean I've exhausted everything I can think of. It's a really heavily modded game, but I've not experienced a total "mod doesn't work at all" yet in the campaign aside from this. My mod list is here: https://hottipsmedia.com/ksp-mods 

 

Here's the details. I hope you can shed some light on what I'm missing here:

output_log.txt: https://mega.nz/#!ZGQgUBQS!1z4WG3LWC1oVDIbjDS5Z85tRS_pR8Ld-fKwBGn7wcic

KSP Version: 1.2.2
EL version: 5.7.1
Installed via: CKAN

I'm using this mod with MKS, and I've tried to create a craft from my VAB design here at the Minmus base I have. The Pioneer module has an EL Survey station in it, and should be capable of producing a craft on the surface, as supported by both text in game, as well as this documentation here: https://github.com/UmbraSpaceIndustries/MKS/wiki/Functions-(Extraplanetary-Launchpads)

As you can see by the attached screenshot, my survey stake is very close to the base. I have numerous Kerbals on board this vessel, including two decent engineers, two pilots, and a couple others with various other roles. I have all of the supplies I should need to produce this craft from the VAB, and meet all resource requirements. However, upon attempting to build it, my Kerbal Alarm Clock goes off immediately telling me the craft was completed - despite the EL window clearly showing me 0% and 0s remaining. I cannot get this mod to build anything, whether it's this craft or another. It's just not working.

Screenshot: https://mega.nz/#!wPpwkCyR!dOmPH5jeGcrXOLxPoxfBQBIV5eHwByZbGbMLAzBHxmM 

My entire series/mission being produced depends on this mod functioning. I hope I'm missing something simple here, but I've put 3 hours into trying various things from dismantling and replacing stakes, to placing 4 stakes in a square, to changing the crew, changing the craft, changing the craft's design source (VAB or SPH), etc. There's nothing I can do to get this to work. 

I recently booted up the game and tried to build it, and then shut the game off. I was hoping this would reduce the amount of irrelevant data in the log. 

I appreciate any help you have to give. Thank you for your time.

- Charlie

EDIT: Important clarification I forgot to mention: My productivity is 0.3, hence, above 0.

Edited by charliepryor
Added additional detail, and noted it.

Share this post


Link to post
Share on other sites
Posted (edited)

@charliepryor: While it is still woefully incomplete, I suggest you read EL's manual (pdf in EL's GameData directory, more up to date version linked in the OP), focusing on section 2.2 (Productivity).

Your problem is that you seem to have only the one engineer (Alejandro B. Kerman) and he is too inexperienced for his stupidity/courage combination (get him to level 2 in a full workshop or 3 for any other workshop and he will be fine).

[edit] (sorry, forgot the most important thing) Right clicking on any workshop (or command pod) will show the vessel's productivity. This is based on workshop quality and the kerbals themselves. If the vessel productivity is zero or negative, production will not progress.

As a rule of thumb, if the kerbal's stupidity bar is less than half full, the kerbal is guaranteed to be positively productive if the kerbal is an engineer (more accurately, has the construction skill) and is in a suitable workshop (any for one or more stars, or fully equipped for zero stars). Reading section 2.3 (Construction Skill) of the manual may be of use.

As an aside, pilots make for better surveyors than do engineers.

Edited by taniwha

Share this post


Link to post
Share on other sites

I have released versions 5.8.1 AND 5.7.3 (for KSP 1.2.2) of Extraplanetary Launchpads.

Changes from 5.8.0/5.7.2:

  • A little more documentation work: ship design tips.
  • Add a productivity display to the build window. Shows as red if productivity is less than or equal to zero, yellow for between zero and one, green for one or higher. The idea behind the colors is red means not going to happen, yellow will be slow, and green "fast" (compared to the time shown in the editor info panel).

 

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, taniwha said:

@charliepryor: While it is still woefully incomplete, I suggest you read EL's manual (pdf in EL's GameData directory, more up to date version linked in the OP), focusing on section 2.2 (Productivity).

Your problem is that you seem to have only the one engineer (Alejandro B. Kerman) and he is too inexperienced for his stupidity/courage combination (get him to level 2 in a full workshop or 3 for any other workshop and he will be fine).

[edit] (sorry, forgot the most important thing) Right clicking on any workshop (or command pod) will show the vessel's productivity. This is based on workshop quality and the kerbals themselves. If the vessel productivity is zero or negative, production will not progress.

As a rule of thumb, if the kerbal's stupidity bar is less than half full, the kerbal is guaranteed to be positively productive if the kerbal is an engineer (more accurately, has the construction skill) and is in a suitable workshop (any for one or more stars, or fully equipped for zero stars). Reading section 2.3 (Construction Skill) of the manual may be of use.

As an aside, pilots make for better surveyors than do engineers.

I have two engineers though, both stationed in the module with EL survey station installed, and my productivity is above 0. Wouldn't there at least be some sort of progress made here? 

I'll read the manual as instructed, but it seems to me with my modules having productivity above 0, and their being 6 Kerbal at this station including two Engineers, there would be at least some progress on this construction.

Edit: also I'll update the mod to 5.7.3 - since this update has been released.

Edited by charliepryor

Share this post


Link to post
Share on other sites

@charliepryor: I may have misread your logs, but it certainly looked like a productivity issue. However, your problem was the impetus for me to finally put in that display (it has been requested a few times, but I kept forgetting).

Share this post


Link to post
Share on other sites
4 hours ago, taniwha said:

@charliepryor: I may have misread your logs, but it certainly looked like a productivity issue. However, your problem was the impetus for me to finally put in that display (it has been requested a few times, but I kept forgetting).

Okay, now that this UI factor is in the game, I can see that my productivity is actually quite poor, and after looking into my staff, it seems that the two engineers that are on the base have 80% stupidity. --- I'll cycle new crew to this base and try again. - In the meantime, is there any way to train these kerbals to be less stupid, aside from modifying save files (which I refuse to do for any other purpose than bug mitigation or naming kerbals in game for the video series)

- Charlie

Share this post


Link to post
Share on other sites
1 hour ago, charliepryor said:

Okay, now that this UI factor is in the game, I can see that my productivity is actually quite poor, and after looking into my staff, it seems that the two engineers that are on the base have 80% stupidity. --- I'll cycle new crew to this base and try again. - In the meantime, is there any way to train these kerbals to be less stupid, aside from modifying save files (which I refuse to do for any other purpose than bug mitigation or naming kerbals in game for the video series)

- Charlie

No way to train them to be less stupid - but they'll be more productive at higher experience levels.

Share this post


Link to post
Share on other sites

Yeah, depending on your workshop, level 2 or 3 is sufficient to guarantee productivity. Aanything with a productivity factor >= 1, or with the fully equipped flag set, needs only level-2, otherwise level-3.

Oh, and the productivity shown in the build window is for the entire vessel (Vessel Productivity in PAWs). For the productivity of individual workshops, you still need to click around. I'd like to add such a display, but I need to rework EL's gui first.

Share this post


Link to post
Share on other sites

I used to be a "light" version using pre existing items. I can not find that MOD anymore. Any one know the link or name?

Share this post


Link to post
Share on other sites
56 minutes ago, Ericwi said:

I used to be a "light" version using pre existing items. I can not find that MOD anymore. Any one know the link or name?

I think you mean this:

 

Share this post


Link to post
Share on other sites

Downloaded v5.8.1. The package lacks "Plugins" directory.

Share this post


Link to post
Share on other sites

@Horus: egad, combination of a merge failure and a build-script failure such that I failed to notice the error. Thank you.

I have released version 5.8.2 of EL.

Changes from 5.8.1:

  • Fix an accidental reversion to KSP 1.2 api due to a merge error. Oops.
  • Check for errors in my release script. Double oops.

* taniwha dons a brown paper bag.

Share this post


Link to post
Share on other sites

I learned.. or relearned.. something.  If you place a single survey stake and build something on it such that the built object intersects the stake... well... don't.  If you delete that stake from the tracking station later and switch back to your base, you might find it, say, 3000m above the surface, in free fall.  Or you might not have deleted the stake.. in which case you might find the stake buried 10000m below the surface.  Which is ok since that doesn't teleport your base thousands of meters above the surface and cause it to violently impact the ground.

Share this post


Link to post
Share on other sites

Yeah, that's the main (or even the) reason multiple stakes of the same setting are supported, with the average of their positions being used.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now