taniwha

[1.5.1] Extraplanetary Launchpads v6.3.1

Recommended Posts

Posted (edited)

nvm.. answered my own question.. lol

Edited by Talavar

Share this post


Link to post
Share on other sites

Hi, ive just started using EL and could do with help. Im using it alongside MKS and so far have no problems apart from one thing.

When building craft, i select craft and window apears to show amount of material kits and specialused parts required. Below us sliders for the on board parts. Even if i set sliders on these, when my craft is built it always apoears ok, but without any materials on board. Ie uranium, electrical charge always missing.

Any ideas what im doing wrong or is this a bug.

Thanks for reading.

Share this post


Link to post
Share on other sites
3 hours ago, Bionic bulldog said:

Hi, ive just started using EL and could do with help. Im using it alongside MKS and so far have no problems apart from one thing.

When building craft, i select craft and window apears to show amount of material kits and specialused parts required. Below us sliders for the on board parts. Even if i set sliders on these, when my craft is built it always apoears ok, but without any materials on board. Ie uranium, electrical charge always missing.

Any ideas what im doing wrong or is this a bug.

Thanks for reading.

Quick guess: Are you building using ground stakes?  You can't fill resources using ground stakes (survey builds) construction - so the sliders don't have any affect.

If you build using a launchpad, you should still be able to fill using those sliders - but I don't believe MKS has any launchpads at the moment (maybe one, in a depreciated form factor), so you'd have to have it with some other parts pack - or the EL parts.  (Which I know there's a patch to hide in MKS, though I can't remember if it's active by default.)

Share this post


Link to post
Share on other sites

 

37 minutes ago, DStaal said:

Quick guess: Are you building using ground stakes?  You can't fill resources using ground stakes (survey builds) construction - so the sliders don't have any affect.

If you build using a launchpad, you should still be able to fill using those sliders - but I don't believe MKS has any launchpads at the moment (maybe one, in a depreciated form factor), so you'd have to have it with some other parts pack - or the EL parts.  (Which I know there's a patch to hide in MKS, though I can't remember if it's active by default.)

Yes, using stakes, not got round to orbital construction yet. Ok, so not a bug, just me being dumb. Although did read everything i could find and didnt see this mentioned. 

Ok back to building ☺ 

Thanks.

Share this post


Link to post
Share on other sites
Posted (edited)

Heya fellas, It's been a long time since I used this mod. Is kethane/karbonite still required to mine ore, or does it now function with the default KSP drills?

 

Edited by Talavar

Share this post


Link to post
Share on other sites
10 hours ago, Bionic bulldog said:

Yes, using stakes, not got round to orbital construction yet. Ok, so not a bug, just me being dumb. Although did read everything i could find and didnt see this mentioned. 

It's mentioned in the manual. You need to find a way to get resources to the built ship (eg, KAS pipe connectors).

Share this post


Link to post
Share on other sites

I've been trying to get this to work for awhile, but maybe I just don't understand it. I have all the rocket parts and everything, but in everything that produces a rocket (orbital construction dock and launchpad, etc) has a productivity of 0. I've tried so many different things to fix this, can't. Any help?

Share this post


Link to post
Share on other sites
3 hours ago, SteelFrenchFries said:

I've been trying to get this to work for awhile, but maybe I just don't understand it. I have all the rocket parts and everything, but in everything that produces a rocket (orbital construction dock and launchpad, etc) has a productivity of 0. I've tried so many different things to fix this, can't. Any help?

You also need crew space that allows for building the rockets, plus qualified engineers onboard. If an engineer is not skilled enough (no stars) and/or too stupid, productivity is low or negative. So test in Sandbox whether your craft works with 5-star engineers with low stupidity. If it doesn't, you're missing something on your craft.

Share this post


Link to post
Share on other sites

Hey @taniwha - Can't seem to get Finalize Build to work. Console keeps throwing error: "Method not found - UnityEngine.Texture2D.LoadImage"  - several of them every time I click finalize build. I am running 1.4 (I understand from one of your previous posts that there wouldn't be much breaking changes). 

Kxtdvgm.jpg

Share this post


Link to post
Share on other sites
4 hours ago, porschiey said:

Hey @taniwha - Can't seem to get Finalize Build to work. Console keeps throwing error: "Method not found - UnityEngine.Texture2D.LoadImage"  - several of them every time I click finalize build. I am running 1.4 (I understand from one of your previous posts that there wouldn't be much breaking changes).

First, EL doesn't try to load images (there is no call to LoadImage anywhere in EL's source). Second, even if there were any calls, it's very possible the signature for LoadImage changed thus requiring a recompile. Third, this is what I said (emphasis added)

On 3/8/2018 at 11:55 AM, taniwha said:

EL seems to be largely unaffected, just some Unity deprecations I had to clean up, but I need to do careful testing, make sure there aren't any hidden surprises. Also, I have a pile of save-breaking changes in the works and I don't want to cause too much trouble with them.

The first little bit about EL being largely unaffected was with compiling: any issues caused by methods adding parameters with default values would go unnoticed (but very much would be noticed by someone using a DLL compiled against a different version of Unity or KSP).

Anyway, in an attempt to be actually helpful, I suspect you're building a part for a mod that does call LoadImage, and that mod has yet to be updated, too. A good way to find out is to try building a vessel made up of stock parts. An even better way is to check your KSP.log file: The exceptions will have stack traces attached. Since the exceptions happen when you hit Finalize, I expect EL will be in there, but I suspect also that some other mod will be (expectation, from bottom to top: EL's OnGUI, KSP (probably ShipConstruct or ShipConstruction), then the culprit mod at the top).

Lastly, that you got that far indicates EL is working fairly well and I shouldn't have too much work to do :).

And as for the save-breaking changes, I'm about two thirds through the last one: I've got the supporting code written, and the chemistry for the new configs, I just need to rework the converter code to put it all together. I am rebalancing the smelters to be more believable: they will consume LFO to produce both the required heat and the carbon and hydrogen needed to reduce MetalOre to Metal. Every ton of metal produced will required about 0.8t of LFO (same ratio as engines: turns out to be a good mix for smelting, assuming RP-1 and LOX). As a benefit, those of you using appropriate mods will get copious quantities of Carbon, CarbonMonoxide, CarbonDioxide, Formaldehyde*, Hydrogen and Water (*I doubt even CRS has Formaldehyde, and I imagine other C-H-O compounds come out of partial combustion, but I noticed CH2O was possible, looked it up to see if it existed and found Formaldehyde). I might even add ElectricCharge to the outputs (a multi-megawatt process shouldn't notice a few kilowatts being tapped). If you're wondering whence the megawatts, by investigating KSP's engines, I found that LFO has at least 6MJ/kg of chemical energy. KSP's lowest power rocket (LV-1R) produces 3.1MW of thrust (4.8MJ/kg). The Mainsail produces a whopping 2.3GW (4.6MJ/kg), and the Poodle is the most efficient with 429MW (5.9MJ/kg). Hmm, I just noticed I'm missing the 3.5m engines fand the OMS rom my spreadsheet.

Oh, OMS is monoprop.

Share this post


Link to post
Share on other sites
Posted (edited)

@taniwha - thanks for the thorough reply. I know I look like a new user but I'm a long time player and fan of your work. I know you're working hard on things and new game versions are painful for mod devs. Sorry about the miss understanding.

The item I am trying to build is just a rocket parts cylinder with a KAS port/connector. (2 parts total) I'm mobile atm, but ill check out the stack trace for you later. 

I can easily get around my current issue by downgrading temporarily. In the future,  I will use GitHub issues to report something. 

Best,

Porschiey

Edited by porschiey
Forgot some stuff

Share this post


Link to post
Share on other sites

@porschiey: Another positive comment: thanks for confirming that the survey plaques work in 1.4 :)

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, tytyguy15 said:

any word on a 1.4 release?

@tytyguy15 Yes the word is "Don't" ask, Mods get updated when the author is ready to do so and asking is against forum rules, also constant requests have been known to stop updates completely.

If your new to this every update breaks mods and OP will if still active update as soon as they are willing and able to. don't forget they do this for free in there own time so don't have to update at all if they don't want to. 

Edited by Kwarazi

Share this post


Link to post
Share on other sites

Surprisingly, KSP 1.4 seems to have not broken EL, but I strongly recommend against using 5.9.0 with 1.4 because I am breaking compatibility with old saves. While there is that forum rule, I am quite willing to state that an update should be soon as I am getting close to getting this last breaking change done (the smelter rebalance I mentioned above). I've got the converter recipes themselves working (the recipes are now separate from the part), support for efficiency seems to be working correctly (0% consumes just LFO, 100% consumes LFO and MetalOre at the right rate, and outputs are appropriate) and I'm getting close to having the module do the mass to resource unit conversions. Then it will be handing heat (temperature will affect efficiency), and finally make sure it works nicely for when efficiency is not a factor.

  • Like 5

Share this post


Link to post
Share on other sites

Hey,

firstly, I have to say that I absolutely love this mod, it adds so much to the game and I can't imagine playing without it.

About a year or so ago I had an awesome orbital shipyard which used a part called orbital pad, and another part called something something workshop, I believe they were from the same mod.

The workshop module was pretty big, kind of looked like a stretched out hitchhiker can, and had room for 12 kerbals I think, also had a great workshop productivity factor.

If anyone has any ideas of which mod that was I would be so grateful, can't for the life of me remember which one it was.

Lastly, EPL has been working great for me in the latest update, granted I haven't gotten round to the whole mining, smelting and making rocketparts yet, just been sending up tons of rocketparts from Kerbin to assemble a few orbital stations and shipyards before I venture to any planetary surfaces.

Thanks again for a great mod!

Share this post


Link to post
Share on other sites
8 hours ago, Agnemon said:

@degenerate . Try KW Rocketry Rebalanced (it replaces KW Rocketry Redux which in turn replaced KW Rocketry).

 

http://spacedock.info/mod/1497 maintained by @linuxgurugamer

 

 

Been using KW for years, never noticed there are any parts for building ships (such as the EPL launchpads) or the workshop part I mentioned, you sure you understood me correctly? :rolleyes:

Share this post


Link to post
Share on other sites
1 hour ago, taniwha said:

It might be one of @Angel-125's mods.

I remember using some of his mods, I'll give them a look again, thanks!

Share this post


Link to post
Share on other sites

Hi. Excellent mod!!!!

 

Q: Is there a way for me to change the speed at which the ships are being built ? I want to build a space station in orbit but assembling it in like a day it mess unrealistic for me. I want such a thing to take months/years.

is there some variable in some file i need to modify ? Please help !

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Nicky21 said:

Hi. Excellent mod!!!!

 

Q: Is there a way for me to change the speed at which the ships are being built ? I want to build a space station in orbit but assembling it in like a day it mess unrealistic for me. I want such a thing to take months/years.

is there some variable in some file i need to modify ? Please help !

I don't think so, but it's a question I'd like answered as well.  More because I'd like to balance the speed between EL and GC - I use both in my game, and the fact that EL is faster than GC is kinda weird.  :wink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now