taniwha

[1.7.3] Extraplanetary Launchpads v6.6.2

Recommended Posts

Is there a GitHub for dummies?  I mean, I am not a "dummie', just that git is new to me, but I can follow directions and EPL was/is part of my career an would like to be able to continue it, if possible.

Thanks,

Share this post


Link to post
Share on other sites

@gamerscircleGithub is really easy, and there are lots of tutorials out there. Or do you mean Git itself? Well, same thing applies there. BUT. Neither Github nor Git are the problem. Getting Taniwha's build tree to correctly build and install under Windows requires some trickery and magic, short of using Cygwin (which I refuse to do; anything that doesn't build under MSYS out-of-the-box has an inadequate build system - period). It would simply not be very productive to describe the intricacies of solving the various problems that came up.

So I decided to just do it myself and leave it here:

[1.1.3] ExtraplanetaryLaunchpads-v5.3.2.git#f2d3f73.zip

My career isn't quite at the point where I really use it, so I didn't do extensive testing. No refunds.

Edited by MaxRebo
made clear for any potential passers-by that this is, indeed, compiled against KSP 1.1.3

Share this post


Link to post
Share on other sites

Sorry about the delays, guys. Don't worry, I haven't forgotten.

Share this post


Link to post
Share on other sites
6 hours ago, MaxRebo said:

@gamerscircleGithub is really easy, and there are lots of tutorials out there. Or do you mean Git itself? Well, same thing applies there. BUT. Neither Github nor Git are the problem. Getting Taniwha's build tree to correctly build and install under Windows requires some trickery and magic, short of using Cygwin (which I refuse to do; anything that doesn't build under MSYS out-of-the-box has an inadequate build system - period). It would simply not be very productive to describe the intricacies of solving the various problems that came up.

So I decided to just do it myself and leave it here:

[1.1.3] ExtraplanetaryLaunchpads-v5.3.2.git#f2d3f73.zip

My career isn't quite at the point where I really use it, so I didn't do extensive testing. No refunds.

Firstly!  Thank you for the help and support.  Part of my KSP 1.1.2 / 1.1.3 career stalled because of this, but that is the nature of the beast?  I did read a couple of tutorials and was going to attempt it, but I just didn't want to mess anything up.  Also, I had had just a little more time in a day, I think I would be able to apply myself.  Trying to stream and work.. well.. time! :) thanks again.

 

Share this post


Link to post
Share on other sites
32 minutes ago, gamerscircle said:

I did read a couple of tutorials and was going to attempt it, but I just didn't want to mess anything up.  Also, I had had just a little more time in a day, I think I would be able to apply myself.  Trying to stream and work.. well.. time! :) thanks again.

Provided I'm assuming correctly and you do use Windows, then I don't think there's anything in the way of tutorials out there that could have possibly provided you with the means to get EL to compile. If I didn't have extensive experience with cross-compiling all sorts of stuff for both Unix and Windows environments, I wouldn't have been able to do it.

But it's no biggie; I was getting a bit impatient to finally upgrade to 1.1.3 myself, so no worries.

Share this post


Link to post
Share on other sites

Thank you very much @MaxRebo! (Love the band, btw. Glad you guys made it off the sail barge) I just might have time to test your unofficial build later this evening.

Edited by Baythan

Share this post


Link to post
Share on other sites
On 6/28/2016 at 8:02 AM, LeuZ said:

Which mod do you need to mine stuff which you can convert into Rocketparts?

Karbonite?

Or no mod?

No mod, just stock is all you need at this point, IIRC.

Share this post


Link to post
Share on other sites

Something of a wishlist item. It would be great to have a container for scrapmetal as well as metalore and the other EL resources, so you can scrap at one place and smelt it at another as well as scrap larger vessels without filling up the scrapmetal store if you are only using a small smelter for example. Also eagerly awaiting update to 1.1.3 so we can get back to building ships in orbit. :)
Thank you for an awesome mod.

Share this post


Link to post
Share on other sites
5 hours ago, Baythan said:

Thank you very much @MaxRebo! (Love the band, btw. Glad you guys made it off the sail barge) I just might have time to test your unofficial build later this evening.

I thought we split up soon after with Droopy disappearing into the dunes and Sy leaving, me pursuing a solo career and finally settling down on Coruscant. But then some higher entity changed reality, and now everything's different... I don't know what I know anymore :confused:

Share this post


Link to post
Share on other sites
On 29/06/2016 at 8:47 AM, MaxRebo said:

@gamerscircleGithub is really easy, and there are lots of tutorials out there. Or do you mean Git itself? Well, same thing applies there. BUT. Neither Github nor Git are the problem. Getting Taniwha's build tree to correctly build and install under Windows requires some trickery and magic, short of using Cygwin (which I refuse to do; anything that doesn't build under MSYS out-of-the-box has an inadequate build system - period). It would simply not be very productive to describe the intricacies of solving the various problems that came up.

So I decided to just do it myself and leave it here:

[1.1.3] ExtraplanetaryLaunchpads-v5.3.2.git#f2d3f73.zip

My career isn't quite at the point where I really use it, so I didn't do extensive testing. No refunds.

Thankyou! I did try and compile it myself but by the sounds of it I'd have never got it working.

Share this post


Link to post
Share on other sites

HI everybody,

Having a little trouble getting the parts to show up in the VAB UI.  I manually installed 5.2.95 on my 1.0.5 KSP install.  Opening sandbox session, I see lots of parts from other devs like Wild Blue and USI that act as "launchpad", "target" and "workshop", but I'm not seeing any EL native parts except for rocket parts cans and survey stake.  No orbital workshop, augers, smelters, orbital docks or launchpads.

Is this normal or should those things be there?

Thanks!

Share this post


Link to post
Share on other sites
2 hours ago, mjl1966 said:

HI everybody,

Having a little trouble getting the parts to show up in the VAB UI.  I manually installed 5.2.95 on my 1.0.5 KSP install.  Opening sandbox session, I see lots of parts from other devs like Wild Blue and USI that act as "launchpad", "target" and "workshop", but I'm not seeing any EL native parts except for rocket parts cans and survey stake.  No orbital workshop, augers, smelters, orbital docks or launchpads.

Is this normal or should those things be there?

Thanks!

Could be. would need more info.  There was a time when MKS hid EL parts.  But you will have to probably research via release notes on your own as it is hard to support past versions.

Share this post


Link to post
Share on other sites
4 hours ago, mjl1966 said:

HI everybody,

Having a little trouble getting the parts to show up in the VAB UI.  I manually installed 5.2.95 on my 1.0.5 KSP install.  Opening sandbox session, I see lots of parts from other devs like Wild Blue and USI that act as "launchpad", "target" and "workshop", but I'm not seeing any EL native parts except for rocket parts cans and survey stake.  No orbital workshop, augers, smelters, orbital docks or launchpads.

Is this normal or should those things be there?

Thanks!

With USI addons like MKS/OKS, most of the normal EL parts get hidden because the USI mods replace things like the orbital workshop, dock, launchpads etc. The documentation on those mods should state what parts are hidden as well as defining the new resource chain required to create ships in-situ. Using an older version of all those mods will make it more difficult to get the exact info though, because both MKS and EL have changed slightly since 1.0.5.

Share this post


Link to post
Share on other sites

I don't believe the current version of UKS hides EL parts - but if you have a version or two old, or if you have files from back then hanging around, you might still have the config file that hides them.

Share this post


Link to post
Share on other sites

Thanks guys!  This gives me something to go look at.  Much appreciated.

Share this post


Link to post
Share on other sites
On 2016-06-29 at 9:47 AM, MaxRebo said:

@gamerscircleGithub is really easy, and there are lots of tutorials out there. Or do you mean Git itself? Well, same thing applies there. BUT. Neither Github nor Git are the problem. Getting Taniwha's build tree to correctly build and install under Windows requires some trickery and magic, short of using Cygwin (which I refuse to do; anything that doesn't build under MSYS out-of-the-box has an inadequate build system - period). It would simply not be very productive to describe the intricacies of solving the various problems that came up.

So I decided to just do it myself and leave it here:

[1.1.3] ExtraplanetaryLaunchpads-v5.3.2.git#f2d3f73.zip

My career isn't quite at the point where I really use it, so I didn't do extensive testing. No refunds.

Just tested your build, works fine for building ships at least, and all interfaces work again, however recycler seems to need some more work as that bit is not working. Anyway, its partly usable again at least.. :)

Share this post


Link to post
Share on other sites

this and uks, kis/kas, ker,mechjeb.heavy lifters and scansat is my normal mod list. this mod makes building alot eeasier. cause trying to build a lifter for my station to take it all up at once is a poodle.

Share this post


Link to post
Share on other sites
13 hours ago, JohanMax said:

however recycler seems to need some more work as that bit is not working

In what way is it not working?

Share this post


Link to post
Share on other sites

Hi there - I have used EPL in 1.1.2 to build and deploy some items for my current KSP career, but unless something had change.  I can no longer seem to build anything.

Here is a link to the EPL screen:
http://imgur.com/5CgBV4X

I have tried various crafts , large and small and when I press build, I get the notice that is it 'done', but nothing.

When I installed EPL, I did it manually and kept only the mallet and the stakes for parts. [same as I did for 1.1.2]

Let me know if there is anything that I am doing wrong or anything else that I can provide for help.

Share this post


Link to post
Share on other sites
42 minutes ago, gamerscircle said:

Hi there - I have used EPL in 1.1.2 to build and deploy some items for my current KSP career, but unless something had change.  I can no longer seem to build anything.

Here is a link to the EPL screen:
http://imgur.com/5CgBV4X

I have tried various crafts , large and small and when I press build, I get the notice that is it 'done', but nothing.

When I installed EPL, I did it manually and kept only the mallet and the stakes for parts. [same as I did for 1.1.2]

Let me know if there is anything that I am doing wrong or anything else that I can provide for help.

Details?  The way you wrote it sounds like you were on 1.1.2 but are now on 1.1.3?  This however is unclear.  If this is in fact the case read up.

Share this post


Link to post
Share on other sites
8 minutes ago, goldenpsp said:

Details?  The way you wrote it sounds like you were on 1.1.2 but are now on 1.1.3?  This however is unclear.  If this is in fact the case read up.

Currently in 1.1.3, I was attempting to state that I am trying to use EPL as I did in 1.1.2, apologies for being unclear.

Share this post


Link to post
Share on other sites
1 minute ago, gamerscircle said:

Currently in 1.1.3, I was attempting to state that I am trying to use EPL as I did in 1.1.2, apologies for being unclear.

Then read up.  There is a newbie with 1 post with your answer (hint, it's not updated for 1.1.3 yet)

Share this post


Link to post
Share on other sites
13 minutes ago, goldenpsp said:

Then read up.  There is a newbie with 1 post with your answer (hint, it's not updated for 1.1.3 yet)

Ah, I thought it was recompiled, etc for 1.1.3.

15 hours ago, JohanMax said:

Just tested your build, works fine for building ships at least, and all interfaces work again, however recycler seems to need some more work as that bit is not working. Anyway, its partly usable again at least.. :)

I am not able to get the ship building to work.  Is there another update outside of what was linked?  When I attempt to build [having all of the resources needed] I click build and it just shows... 0% in the two progress bars.

Share this post


Link to post
Share on other sites
14 minutes ago, gamerscircle said:

Ah, I thought it was recompiled, etc for 1.1.3.

I am not able to get the ship building to work.  Is there another update outside of what was linked?  When I attempt to build [having all of the resources needed] I click build and it just shows... 0% in the two progress bars.

Last I recall reading is the source is up on github if you want to compile yourself.  I am pretty sure Taniwha has not release a compiled new version yet.

Edited by goldenpsp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.