Jump to content

[1.8-1.10] Extraplanetary Launchpads v6.8.3


Recommended Posts

35 minutes ago, StarkRG said:

The mod is reporting that it's incompatible with 1.9.

It will always do that until updated, because it does a simple version comparison. It does not mean it cannot work, which it seems to do as far as I can see.... So just ignore the message for now - just means you cannot report it as a bug if it does not work.

Link to post
Share on other sites
On 2/15/2020 at 8:06 PM, Warezcrawler said:

just means you cannot report it as a bug if it does not work

Not true, as I (and other modders, I'm sure) would want to know it doesn't work. What it does mean is that you should make backups of your saves before proceeding (and if you don't, and things go wrong, you have only yourself to blame).

Link to post
Share on other sites
  • 2 weeks later...

@taniwha Question: How to build this project in Windows? I don't see any .csproj and .sln files but many makefile files. 

I did some research and knew to use the "make" command, but it doesn't work. Maybe I'm doing something wrong

I would appreciate it if you could give me some help or tips.

:)

Link to post
Share on other sites

@tinygrox: I'm sorry, but you don't (without a lot of effort). Not only is the build-system highly linux dependent, it turns out it's even dependent on my (I have some wrapper scripts around blender that mess up some things for others, but I don't remember what just now, plus it requires my blender .mu addon).

That said, if all you want is the dll, then you should be able to put together a csproj file using the cs files found in the Source tree (recursive), and make sure it references the dlls in KSP's KSP_Data/Managed directory.

Link to post
Share on other sites

@taniwha Has any thought been given to a recipe for an electrically heated smelter like an electric arc or induction heated furnace?  I've got an orbital station that I'm using for a ship construction site and the smelter is sucking LFO as fast as I can resupply it.  I'd prefer to run the heating aspect of the smelter off a nuclear reactor and just use LFO for the chemical reactions necessary for the smelting process. It may also allow the efficiency to go up if you can run it higher temperatures than LFO heating would allow.

Link to post
Share on other sites

I'm playing on KSP 1.7.3 with the associated versions of this mod and Modular Kolonization System. I noticed that MKS seems to have swapped over the "SpecializedParts" object to "Sp" for some reason, but this mod still requires the original material. Is there a way to change the config in the settings to use "Sp" instead? I understand it's a mod conflict and I guess technically the fault lies with MKS but it seems like it might be an easier fix on this side, since I assume I'd have to mess with Ground Construction too if I wanted to change "Sp" to "SpecializedParts."

 

I much prefer this mod to Ground Construction, so I'm really hopeful that there's an easy fix. I'm not very well versed in editing configs.

 

EDIT: Huh, for some reason when I reloaded it worked. Never mind then, must have been a glitch on my end.

Edited by terrendos
Link to post
Share on other sites

Hi @taniwha , I'm trying to use EL for the first time, and I'm not sure if I'm doing something wrong.  I've created a basic space dockyard, with a construction drone, 1600 RP in its internal inventory, and 6 control points ready to add fuel storage and start expanding the base.

I get it to orbit, turn on power, and try to start building a fuel tank on to one of the control points, before recycling the booster that brought the station to orbit, but right-click on the control point or drone shows nothing relevant, do I need an actual workshop before I can start construction?

Craft file is here :- https://www.dropbox.com/s/c1mtv4lx2m3fsjl/orbital shipyard.craft?dl=0

Built with Restock+, and I think the reactor is from Kerbal Atomics.

I should mention that I've changed the recycler to produce Metal, as I don't want to have to deal with the amount of fuel needed to run a smelter in orbit.

Edited by Ravlain
Added extra information
Link to post
Share on other sites

@Ravlain: I took a look at your craft and you do not have anywhere to build anything: use an orbital dock or micro pad (disposable pad) (or a suitable part from another mod that supports EL). Otherwise, it looks like you have everything you need.

(just took another look) The control reference is for switching your "control from here" while landing.

Link to post
Share on other sites
On 3/18/2020 at 8:40 AM, taniwha said:

@Ravlain: I took a look at your craft and you do not have anywhere to build anything: use an orbital dock or micro pad (disposable pad) (or a suitable part from another mod that supports EL). Otherwise, it looks like you have everything you need.

(just took another look) The control reference is for switching your "control from here" while landing.

@taniwha Oops, I misread something earlier in the thread. Time for a second try. 

Thanks for a great mod.

Link to post
Share on other sites

Odd. Might be a rounding issue making it look like it's done when there's a tiny fraction left to go.. The displayed resource numbers aren't high precision.

Edited by taniwha
Link to post
Share on other sites

OK, checked the save and it requires an additional 3.5762787774729077E-05 rocket parts, annoying as I thought I had enough.

If I adjust BuildResrouce in BuildCost and BuiltStuff to the even 1600 will this release the build?

 

Edited by Ravlain
Link to post
Share on other sites

@taniwha This is what I came up with for an electric smelter. I tried working up a variable efficiency based on heating the smelter, but I wasn't having any luck getting the smelter to actually heat up and I'd already spent way more time on this than I wanted. In the ELConverter for the part itself I'm running a rate of 500 that consumes 220EC for ~8 units of metal per second.  Fuel consumption is about ~1.05 units of liquid fuel per unit of metal. 

Spoiler
EL_ConverterRecipe
{
    // Smelter uses electricity for heating instead of LFO combustion.  Liquid
    // fuel is mixed with metal ore to remove O3. The resulting reaction
    // produces metal (Fe) along with water (H20) and carbon dioxide (C02).
    //
    // From existing EL recipes:
    //
    // LiquidFuel is assumed to be RP-1 which is further assumed to be C12H16
    // and thus is 160.25544g/mol
    //
    // MetalOre is assumed to be hematite (Fe2O3) which is 159.6882g/mol
    //
    // Metal is Iron (Fe) 55.845g/mol
    // Carbon Dioxide (CO2) 44.0095g/mol
    // Water (H2O) 18.01528g/mol.
    //
    // This gives the following reaction:
    //   32Fe203 + 3C12H16 = 64FE + 24H20 + 36C02
    //
    // With the following masses:
    //
    // Input:
    //     Fe2O3 = 5110.022g
    //     C12H16 = 480.7663
    //
    // Output:
    //     FE  = 3574.08g
    //     H2O = 432.3667g
    //     CO2 = 1584.342g
    //
    // Total Mass (in & out) = 5590.789 (Used for EC rate)
    // 
    // From wikipedia Electric Arc Furnace uses 440 kWh per ton per hour
    //   440kWh = (440,000w/hour)/(1,000,000g/hour) = 0.44w/g 
    //
    //	 1 EC assumed to be 1 watt, NFE uses 1 EC/s = 1000w. But this seems to
    //	 to be a really low power consumption.  
    //
    //   440kw/hour = 122.222 watt/s (use for scaling rate in part definition)
    //   Use Rate in EL_Converter definition of part to fine tune.
    name = ECHeatedSmelter
    Input
    {
        efficiency = 1.0
        ElectricCharge = 0.002459947 // 0.005590789*0.44
        MetalOre = 0.005110022
        LiquidFuel = 0.000480766
    }
    Output
    {
        efficiency = 1.0
        Metal = 0.00357408
        Water* = 0.000432367
        CarbonDioxide* = 0.001584342
    }
}
EL_ConverterRecipe
{
    // Remelter is simpler just consume EC at 0.44 EC/g
    name = ECHeatedRemelter
    Input
    {
        efficiency = 1
        ElectricCharge = 0.00044
        ScrapMetal = 0.001
    }
    Output
    {
        efficiency = 1
        Metal = 0.001
    }
}

 

 

Link to post
Share on other sites
59 minutes ago, taniwha said:

@leatherneck6017: not really. It bothers me too, but I don't have multiple pads often enough for it to be in my face. Also, I think you might be the first person to complain about it (to me).

I'm surprised I'm the first. For some reason I built a KPBS base with 2 launchpads and I face this every time I build something. No big deal, just thought I'd ask. Thanks for the reply.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...