Jump to content

[1.8-1.12] Extraplanetary Launchpads v6.99.1


taniwha
 Share

Recommended Posts

  • 2 weeks later...

I had this working in 1.11 ... in 1.12, I think the ."load stuff from any save game" has.. broken it.  I can't even get the pad UI to go away after it's opened ><  so.. gonna uninstall until it updates;  not that there's many other options, globalconstruction seems to have its own set of issues :(

Link to comment
Share on other sites

Sorry I've been out of touch for a while. I got burned out on KSP stuff again (not just dev, but playing, even), got busy with quakeforge stuff*, and now I've got a job (and have been playing a lot of Elite Dangerous).

I have NOT abandoned EL, but I don't know when I'll make some updates. Part of the problem is I was in the middle of a rather major update to EL when I got burned out. However, it does look like I should be able to accept PRs without too much trouble.

It's nice to see there is still interest in EL, though. Thank you all :)

On 6/26/2021 at 10:50 PM, cgw said:

You apparently have an error on 1 page in the description

5.8.3 Is it 6.8.3?

Thanks. Fixed.

Link to comment
Share on other sites

3 hours ago, taniwha said:

Sorry I've been out of touch for a while. I got burned out on KSP stuff again (not just dev, but playing, even), got busy with quakeforge stuff*, and now I've got a job (and have been playing a lot of Elite Dangerous).

I have NOT abandoned EL, but I don't know when I'll make some updates. Part of the problem is I was in the middle of a rather major update to EL when I got burned out. However, it does look like I should be able to accept PRs without too much trouble.

It's nice to see there is still interest in EL, though. Thank you all :)

Thanks. Fixed.

Really happy to see you back and slightly more active :D

No pressure on mod releases, everyone needs breaks. Hopefully now that 1.12 is out and they've stopped updating that means less work for you

Maybe if you are not up for maintaining it at the moment someone in the community would be willing to? As an active user of your mod I would love to see an update into 1.12, after I discovered how good this mod is it is now a vital component in all of my save games. No more absurdly large launch vehicles for me hehe

Link to comment
Share on other sites

No Taniwha THANK YOU. I'm on the same page as "Our Benefactors". This is such an amazingly cool mod! And is similarly an integral part of my save games. I use it to launch missions from my Minmus base to save delta V as well and also as a 3D printer whenever any parts are needed for the base or any nearby contracts. I just save the part as a subassembly and print it out as normal. I'm sure there will be a 3D printer on Mars one day so I like to think my KSP has accelerated that timeline and managed to put one on Minmus :D

I wish I knew about C# and the framework of the game enough to go in and help. It seems the problem exists when you go in and try to select a craft. The calls to invoke the craft loading system probably just have to be tweaked to play friendly with the new system. I tried going into the code but I got lost real quick lol.

Currently I launch into a portable 1.11.2 if I need to launch a new craft or print anything then save and go back to 1.12. It's not ideal but it allows me to keep using the mod and still catch some 1.12 gameplay

Best of luck to you Taniwha in your new ventures and whatever you choose to do!

Link to comment
Share on other sites

Yeah, this has become a must-have for any playthroughs i do - And so far i've been busy setting up the infrastructure on the different planetary bodies to support my launchpad colonies.

Did a quick check in the log, and of course its a 'NRE', likely brought on by changes to the vehicle loading code from the latest patch...

On 7/10/2021 at 1:28 PM, taniwha said:

Part of the problem is I was in the middle of a rather major update to EL when I got burned out.

Here's hoping that this can be solved with a minor quick-fix applied to the current release-branch, but you never know...
I've tried downloading the source before but could never get makefile to work properly with windows, otherwise i'd be inclined to take a look myself :/

In any case - Know that we're waiting patiently @taniwha and look forward to any news from you regarding development!

Link to comment
Share on other sites

 

On 7/10/2021 at 4:28 AM, taniwha said:

Sorry I've been out of touch for a while. I got burned out on KSP stuff again (not just dev, but playing, even), got busy with quakeforge stuff*, and now I've got a job (and have been playing a lot of Elite Dangerous).

ED burned me out so hard I didn't even realize I'd (basically) abandoned Trade Dangerous until I jokingly typed "pip install tradedangerous" and it did because the guys who picked it up did a kick-ass job.

Link to comment
Share on other sites

On 7/10/2021 at 7:28 AM, taniwha said:

Sorry I've been out of touch for a while. I got burned out on KSP stuff again (not just dev, but playing, even), got busy with quakeforge stuff*, and now I've got a job (and have been playing a lot of Elite Dangerous).

I have NOT abandoned EL, but I don't know when I'll make some updates. Part of the problem is I was in the middle of a rather major update to EL when I got burned out. However, it does look like I should be able to accept PRs without too much trouble.

It's nice to see there is still interest in EL, though. Thank you all :)

Thanks. Fixed.

 Looking forward to seeing what the finalized mod scene looks like, since KSP is finally wrapped up.
A few of you fellas have been around for the long haul, and I recognize you instantly on any forum post.
One more pass, and you can all lay the programming battle axe to rest.
I just want to say thanks one last time, Taniwha.
I know it's a selfless job, but It's truly been much appreciated.
 

Link to comment
Share on other sites

Does EL for 1.8.1 have some sort of conflict with Principia? I tried to launch a ship from an orbital construction dock, the game goes into an infinite freeze. 

I had task manager opened on the side, I'm sure it's not because of the limitations of my machine. Maybe something about the physics of Principia and how EL generates a new craft disagree with each other. 

Link to comment
Share on other sites

  • 2 weeks later...
On 8/11/2021 at 3:18 PM, zeant93 said:

Does Extraplanetary Launchpads works in ksp 1.11? 

 

4 hours ago, Kamilo said:

Is an updated planned for 1.12?

You could like, I dunno, read up a handful of posts to get the current state of the mod.

Link to comment
Share on other sites

8 hours ago, Kamilo said:

Sadly I didnt find anything. If you have something it would be kind of you to post it.

Then look again.  Further up the page you have a post from the mod author himself explaining his and the mod's current situation.

Link to comment
Share on other sites

16 minutes ago, Kamilo said:

I saw that post, but this just goes up to version 1.10 and not 1.12,  right?

That's right.  Currently only 1.10 is supported.  Taniwha will update when he finds the energy to do so.  Asking lots is likely to result in energy being drained.

Link to comment
Share on other sites

2 minutes ago, theJesuit said:

That's right.  Currently only 1.10 is supported.  Taniwha will update when he finds the energy to do so.  Asking lots is likely to result in energy being drained.

Totally understandable. It should work if I roll back to 1.10 to select a craft and then switch to 1.12 again?

Link to comment
Share on other sites

17 minutes ago, Kamilo said:

Totally understandable. It should work if I roll back to 1.10 to select a craft and then switch to 1.12 again?

That seems to be the experience of others.

On 7/13/2021 at 3:42 PM, Philip Kerman said:

Currently I launch into a portable 1.11.2 if I need to launch a new craft or print anything then save and go back to 1.12. It's not ideal but it allows me to keep using the mod and still catch some 1.12 gameplay

So apparently you can go to 1.11 without problems either.  In the end Squad changed the way craft are called and stored so things break.

Link to comment
Share on other sites

On 8/14/2021 at 11:33 AM, theJesuit said:

way craft are called

The strange thing is - Global Construction(former Ground Construction) didn't broke in 1.12, i have no clue why. It smh uses stock vessel selector. Sadly, it doesn't have some EL's advantages like survey stakes and launchpad parts, can't build in sea and so on. Maybe someone more experienced can look at the code and make a PR? 

 

Edited by Hohmannson
Link to comment
Share on other sites

6 hours ago, General Apocalypse said:

Can we do anything to help get this mod up to speed ? It's definitely one of the best mods out there.

1.  Quietly wait patiently?  If you read Taniwha's post above he is a bit burned out and busy with RL.  In general seeing constant posts asking can actually have a negative impact on their burnout.

2. If you know coding, the code is all available.  I would imagine whatever fix is necessary between 1.11 and 1.12 shouldn't be super major and Taniwha may appreciate the help.

3.  Not saying that money talks, but I'd imagine getting a chunk of "thank you" cash can help even the burned out get motivated to at least put together an update patch.  There is a patreon link in the OP.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...