taniwha

[1.8-1.9] Extraplanetary Launchpads v6.7.2

Recommended Posts

So I just started getting to the point of using this mod in Career mode and it doesn't seem to work. All the parts are in the game but the icon isn't in the toolbar settings, and right clicking on the various launchpads from both USI and EL only gives the option to rename them. I've tried installing the latest beta of this mod and the results are the same. Any help would be appreciated.

Mod list (all through CKAN):


"name": "ContractConfigurator-RemoteTech",
"version": "2.0.01"

"name": "CrowdSourcedScience",
"version": "v3.0"

"name": "DockingPortAlignmentIndicator",
"version": "6.2.0"

"name": "FerramAerospaceResearch",
"version": "3:0.15.5.1"

"name": "KAS",
"version": "0.5.4"

"name": "KerbalAlarmClock",
"version": "v3.4.0.0"

"name": "KerbalJointReinforcement",
"version": "v3.1.4"

"name": "KIS",
"version": "1.2.2"

"name": "KSPInterstellarExtended",
"version": "1.5.11"

"name": "KWRocketry",
"version": "2.7.0-community"

"name": "MechJeb2",
"version": "2.5.3"

"name": "MechJebFARExt",
"version": "1.0.0"

"name": "ModuleManager",
"version": "2.6.8"

"name": "RemoteTech",
"version": "v1.6.8"

"name": "StationScience",
"version": "1.5"

"name": "TACLS",
"version": "v0.11.1.20"

"name": "TACLS-Config-Stock",
"version": "v0.11.1.20"

"name": "Toolbar",
"version": "1.7.9"

"name": "TweakScale",
"version": "v2.2.1"

"name": "FilterExtensions",
"version": "2.4.1"

"name": "CrossFeedEnabler",
"version": "v3.3"

"name": "KSP-AVC",
"version": "1.1.5.0"

"name": "DistantObject",
"version": "v1.6.2"

"name": "ModularFlightIntegrator",
"version": "1.1.1"

"name": "CommunityResourcePack",
"version": "0.4.4"

"name": "InterstellarFuelSwitch",
"version": "1.17"

"name": "InterstellarFuelSwitch-Core",
"version": "1.17"

"name": "ModuleAnimateEmissive",
"version": "v1.11"

"name": "KWRocketry-CommunityFixes",
"version": "0.3.0"

"name": "ScienceAlert",
"version": "1.8.9"

"name": "StageRecovery",
"version": "1.5.7"

"name": "ContractConfigurator-UsefulSpaceStations",
"version": "1.1.1"

"name": "RasterPropMonitor-Core",
"version": "v0.23.1"

"name": "USITools",
"version": "0.5.1"

"name": "USI-EXP",
"version": "0.4.1"

"name": "USI-SRV",
"version": "0.3.1"

"name": "FirespitterCore",
"version": "v7.1.4"

"name": "UKS",
"version": "0.31.10"

"name": "ModuleRCSFX",
"version": "v4.2"

"name": "AstronomersPack-SurfaceGlow",
"version": "Interstellar.V2"

"name": "AstronomersPack-Snow",
"version": "Interstellar.V2"

"name": "AstronomersPack-Sandstorms",
"version": "Interstellar.V2"

"name": "AstronomersPack-DistantObjectEnhancement",
"version": "Interstellar.V2"

"name": "AstronomersPack-Lightning",
"version": "Interstellar.V2"

"name": "AstronomersPack-Eve-Jool-Clouds-8K",
"version": "Interstellar.V2"

"name": "AstronomersPack-PlanetShine",
"version": "Interstellar.V2"

"name": "AstronomersPack",
"version": "Interstellar.V2"

"name": "AstronomersPack-AtmosphericScattering",
"version": "Interstellar.V2"

"name": "AstronomersPack-Clouds-High",
"version": "Interstellar.V2"

"name": "PlanetShine",
"version": "0.2.3.1"

"name": "AstronomersPack-Auroras-8K",
"version": "Interstellar.V2"

"name": "ContractConfigurator",
"version": "1.7.6"

"name": "EnvironmentalVisualEnhancements",
"version": "7-4"

"name": "ContractConfigurator-ContractPack-SCANsat",
"version": "v0.5.2.1"

"name": "FinalFrontier",
"version": "0.8.6-1370"

"name": "RasterPropMonitor",
"version": "v0.23.1"

"name": "SCANsat",
"version": "v14.2"

"name": "VesselView",
"version": "v0.71"

"name": "ActionGroupManager",
"version": "1.4.0"

"name": "CustomAsteroids-Pops-Stock-Outer",
"version": "v1.1.0"

"name": "KopernicusExpansion",
"version": "0.1.2"

"name": "OuterPlanetsMod",
"version": "1:1.8"

"name": "CustomAsteroids",
"version": "v1.1.0"

"name": "Kopernicus",
"version": "1:beta-04"

"name": "TextureReplacer",
"version": "2.4.10"

"name": "ScienceRevisitedRevisited",
"version": "1.3.1"

"name": "ExtraPlanetaryLaunchpads",
"version": "5.2.2"

"name": "InfernalRobotics",
"version": "v0.21.3"

"name": "TweakableEverything",
"version": "1.13"

"name": "TweakableEverything-EngineStagingToggle",
"version": "1.13"

"name": "TweakableEverything-FairingStagingToggle",
"version": "1.13"

"name": "ToadicusTools",
"version": "16"

"name": "EVAManager",
"version": "6"

"name": "ContractConfigurator-Tourism",
"version": "1.3.0"

"name": "KerbalStats",
"version": "2.0.0"

EDIT: I should mention I am running a modified 64 bit install (actually more stable than unmodded 32 for me), but I'm currently setting up a 32 bit install to see if that's the problem

EDIT 2: Derp, ran unfixer again and it worked. Sorry for wasting anyone's time

Edited by namAehT

Share this post


Link to post
Share on other sites

Reviewed it already.

And in the future, you may want to bring up potential stock bugs in the appropriate venue vs. calling something out as being "certainly" (your words not mine) a stock bug (when in fact this user's issue was 'certainly' being caused by a mod).

Ping me off-forum if you wish to discuss this further.

Edited by RoverDude

Share this post


Link to post
Share on other sites

I have an issue when I run the game, when I placed the large ore scanner it deploys and can't access the menu when left click.

Share this post


Link to post
Share on other sites
I have an issue when I run the game, when I placed the large ore scanner it deploys and can't access the menu when left click.

If your talking about the OMD, (the large cyndrical white one), it currently only works if you have Kethane installed. (i posted a module manager config a page or two back which address this if you want)

You can also use the stock resource scanning tools(or the small magnetometor included in EPL) just fine and they will find metalore.

Share this post


Link to post
Share on other sites

I currently have EPL installed, but not Kethane. I have Karbonite installed instead. I heard there was an adaptation to get this mod to work with Karbonite. I'm uncertain what exactly I need in order to get this working.

I'm running KSP 1.0.4 on Windows, 32-bit.

Share this post


Link to post
Share on other sites
I currently have EPL installed, but not Kethane. I have Karbonite installed instead. I heard there was an adaptation to get this mod to work with Karbonite. I'm uncertain what exactly I need in order to get this working.

I'm running KSP 1.0.4 on Windows, 32-bit.

Hubbazooot, you dont need anything for EPL to work :)

If you dont have Kethane installed it will work just fine via the stock system :) (the augers included in the pack, and smelters etc) will work with the entire, production chain.

Karbonite is kinda of a side issue :P

Share this post


Link to post
Share on other sites
Hubbazooot, you dont need anything for EPL to work :)

If you dont have Kethane installed it will work just fine via the stock system :) (the augers included in the pack, and smelters etc) will work with the entire, production chain.

Karbonite is kinda of a side issue :P

Alright, well the modified augers by BahamutoD aren't working at all. Any ideas?

Share this post


Link to post
Share on other sites
Alright, well the modified augers by BahamutoD aren't working at all. Any ideas?

BahamutoD's EPL drills havent been updated in a while, (.23 i belive) They might still work with Kethane, never tested it) But they do not have a stock config, You could easily change the resource extraction module on them to the Stock (or EL Extractor module) but they also use the Kethane Animator Module, and im not sure if they work with the Stock Animation module.

long story short :) unless you wanna go and play with configs, your best off using the Augers that come with EPL

Share this post


Link to post
Share on other sites
BahamutoD's EPL drills havent been updated in a while, (.23 i belive) They might still work with Kethane, never tested it) But they do not have a stock config, You could easily change the resource extraction module on them to the Stock (or EL Extractor module) but they also use the Kethane Animator Module, and im not sure if they work with the Stock Animation module.

long story short :) unless you wanna go and play with configs, your best off using the Augers that come with EPL

Thanks for all your help, man. Are there any...prettier...augers?

Share this post


Link to post
Share on other sites
Thanks for all your help, man. Are there any...prettier...augers?

You can use a MM config to use the stock drill for MetalOre extraction



@PART[RadialDrill]
{
MODULE
{
name = ModuleResourceHarvester
HarvesterType = 0
Efficiency = 1
ResourceName = MetalOre
ConverterName = Surface Harvester
StartActionName = Start Surface Harvester
StopActionName = Stop Surface Harvester
ImpactTransform = ImpactTransform
ImpactRange = 5
AutoShutdown = false
GeneratesHeat = false
UseSpecialistBonus = true
SpecialistEfficiencyFactor = 0.2
SpecialistBonusBase = 0.05
Specialty = Engineer
EfficiencyBonus = 1



INPUT_RESOURCE
{
ResourceName = ElectricCharge
Ratio = 15
}
}

Share this post


Link to post
Share on other sites
You can use a MM config to use the stock drill for MetalOre extraction



@PART[RadialDrill]
{
MODULE
{
name = ModuleResourceHarvester
HarvesterType = 0
Efficiency = 1
ResourceName = MetalOre
ConverterName = Surface Harvester
StartActionName = Start Surface Harvester
StopActionName = Stop Surface Harvester
ImpactTransform = ImpactTransform
ImpactRange = 5
AutoShutdown = false
GeneratesHeat = false
UseSpecialistBonus = true
SpecialistEfficiencyFactor = 0.2
SpecialistBonusBase = 0.05
Specialty = Engineer
EfficiencyBonus = 1



INPUT_RESOURCE
{
ResourceName = ElectricCharge
Ratio = 15
}
}

Thanks for all your help, man. Would I just add that to the end of KSP_DIR/GameData/WombatConversions/EL_StockOre.cfg?

Share this post


Link to post
Share on other sites
Thanks for all your help, man. Would I just add that to the end of KSP_DIR/GameData/WombatConversions/EL_StockOre.cfg?

Or in its own seperate .cfg file, does not matter. (though if your using a config for stock ore, which i assume you are you'll wanna change the "resourceName" line from metalore, to Ore.

Share this post


Link to post
Share on other sites

Any configs for better integrating Near Future? As in allowing the extraction/gathering of Near Future resources.

EDIT: Nvm noticed NFT is already compatible with vanilla ore.

Edited by Sokar408

Share this post


Link to post
Share on other sites

I seem to be having an issue with this mod. after i installed it every solar body (including the sun) disappeared. I saw no anomalous log info. Every object i had in space kept its orbit though.

Share this post


Link to post
Share on other sites

elijahlorden: EL has never done such a thing. I will need your full log file to be able to help you.

Share this post


Link to post
Share on other sites

I have released EXPERIMENTAL version 5.2.91 of EL. The link to 5.2.2 is still in the OP as I imagine playing with the new features of EL until they are proven fairly solid will not be everyone's cup of tea.

Changes from 5.2.90:

  • Force the active vessel if the recycled vessel is active.
  • Fix the resource transfer logic so stalled resources dump properly, but otherwise are recovered at the correct rate.
  • Check the validity of the editors ship parts list. (for smjjames)
  • Project the z axis onto the horizontal plane. For when only y and z directions are specified.
  • Allow the y-axis to be specified. The function I used forced "up" to be "up", which meant that y would always point up, no matter what stakes you planted. Oops.
  • Give pilots a use (as surveyors, extending survey range).
  • Add EL parts to base and station contracts.
  • Make the OMD useful without Kethane. (thanks to rabidninjawombat)
  • Fix up the build ETA display.
  • Allow low productivity workshops to be fully equipped.

The thinking behind using pilots as surveyors is pilots are navigators and navigators are not far from surveyors.

The base range of survey stations has been reduced to 20m (from 100m), but this is for unmanned stations. Manned stations start at 50m (no skill at all), 100m for 0-star pilots, up to 2000m for 5-star pilots.

"fully equipped" is for inexperienced engineer purposes: simply add "FullyEquipped = true" to the workshop MODULE node and workshops with a productivity factor less than 1 will be considered to be fully equipped (greater than or equal to 1 are always fully equipped at this stage). This will allow people to mod EL to build at a slower rate until I get the kerbal-hours/ton un-hardcoded (I forgot to do so for 5.2.90, and still have not gotten around to it).

Please, bash away at it and submit any issues to github.

Share this post


Link to post
Share on other sites

smjjames: Thank you for the confirmation. That bug was annoyingly close to being fixed before (just one more null check was necessary).

Share this post


Link to post
Share on other sites

What is the bare minimum requirement (lightest) in order to be able to build something on another planet's surface?

Share this post


Link to post
Share on other sites
What is the bare minimum requirement (lightest) in order to be able to build something on another planet's surface?

I figure the minimum would be a survey station, some rocket parts, at least one survey stake (if you don't want whatever you're building to spawn on top of the survey station), a mallet, and a kerbal (to put the survey stake down, if anything).

If you mean a mass requirement, I'm not aware of one.

Share this post


Link to post
Share on other sites
I figure the minimum would be a survey station, some rocket parts, at least one survey stake (if you don't want whatever you're building to spawn on top of the survey station), a mallet, and a kerbal (to put the survey stake down, if anything).

If you mean a mass requirement, I'm not aware of one.

I have the survey station down, and I have rocket parts. Do the survey stakes have to be physically attached to the survey station in any manner? Are there any crew requirements?

Share this post


Link to post
Share on other sites
I have the survey station down, and I have rocket parts. Do the survey stakes have to be physically attached to the survey station in any manner? Are there any crew requirements?

Stakes attach to the ground

Share this post


Link to post
Share on other sites

You'd need the kerbal to be in the survey station too I think, fairly sure they don't work uncrewed. What happened to robotic construction in the end?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.