taniwha

[1.8.1] Extraplanetary Launchpads v6.7.0

Recommended Posts

F5, edit quicksave file, F9

look for the pad in question, and its BuiltStuff node, Required. set amounts to 0 for build, or to what's in BuildCost for teardown (yeah, backwards)

Share this post


Link to post
Share on other sites

I have released version 6.6.2 of Extraplanetary Launchpads

Changes from 6.6.1:

  • Fix incorrect handling of skinned meshes for craft hulls
  • Allow rotation about the "vertical" axis for regular launch pads (orbital dock, etc)
  • Make survey sites update the craft hull placement when the site is modified
  • Fix survey station when ReStock is installed

Share this post


Link to post
Share on other sites

Hi, I just tried bulding my first vessel on an orbital station and when it finished I pressed the "Finalize construction" button and the game froze. It happens every time I try after reloading the game. I have the 6.6.2.0 version with 1.7.3 KSP. Sorry if it has been solved before but I could not find it in the last few pages of this thread.

Share this post


Link to post
Share on other sites
On 10/14/2019 at 2:47 PM, taniwha said:

@Pichixox: which pad did you use? Orbital dock or the micro-pad?

KS-OCD orbital construction dock.

Edited by Pichixox
made a mistake

Share this post


Link to post
Share on other sites
1 hour ago, taniwha said:

Hmm, odd. I'd tested that, but must have missed something.

Is it possible that I tried building something using a part from an incompatible mod ?
My mod list:

B9 Part Switch (B9PartSwitch v2.10.1)
BetterBurnTime (BetterBurnTime 1.9.1)
ClickThrough Blocker (ClickThroughBlocker 0.1.7.2)
Community Category Kit (CommunityCategoryKit 4.3.0.0)
Community Resource Pack (CommunityResourcePack 1.2.0.0)
Easy Vessel Switch (EVS) (EasyVesselSwitch 1.11)
Extraplanetary Launchpads (ExtraPlanetaryLaunchpads 6.6.2.0)
Kerbal Attachment System (KAS 1.4)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.6.0)
Kerbal Inventory System (KIS 1.22)
Kerbal Planetary Base Systems (KerbalPlanetaryBaseSystems v1.6.9)
Kethane Mining (Kethane 0.10.2)
Module Manager (ModuleManager 4.0.3)
Near Future IVA Props (NearFutureProps 1:0.5.1)
Progressive Colonization System (ProgressiveColonizationSystem v1.0.6)
Stockalike Station Parts Expansion Redux (StationPartsExpansionRedux 1.2.1)
Toolbar (Toolbar 1:1.7.22.2)

I'm quite new to KSP modding so I appologize if that's the case.

Share this post


Link to post
Share on other sites

Hello,

I don't know if it's CKAN or your mod related and who to inform but just wanted to let you know that when installing via CKAN, it detects "craft" files as duplicate or conflicting mod and aborts installing. This is true for ALL the crafts which includes parts from this mod I assume or perhaps they are some craft files which comes with the mod (Because they re-appeared after renaming them; Mun base, Orbital Scanner, Ore Scanner)

I used to have this mod back in KSP v1.4, those craft files are from back then. Now I'm doing a clean mod installations for KSP v1.8 (Hoping that 6.6.2.0 works for it?) and receiving errors with CKAN. Temporarily removing files or renaming extensions solves it.

Here's the error I receive;

Quote

Oh no!

It looks like you're trying to install a mod which is already installed,
or which conflicts with another mod which is already installed.

As a safety feature, the CKAN will *never* overwrite or alter a file
that it did not install itself.

If you wish to install ExtraPlanetaryLaunchpads 6.6.2.0 via the CKAN,
then please manually uninstall the mod which owns:

Ships/VAB/shipname.craft

and try again.
Your GameData has been returned to its original state.
Error during installation!
An unknown error occurred, please try again!

ALSO

I would like to use Karbonite instead of rocketparts (or metal ore etc, I don't know how the materials changed)

The link provided in the first page for ExtraPlanetaryLaunchpads->Karbonite Alternate workshop is not working anymore.

I do have Modular Kolonization System installed but I can't see any option to change the required materials to Karbonite in game.

Would really love an up to date explanation on how to achieve this.

 

Edited by Problemless Mods Wanter
About Karbonite

Share this post


Link to post
Share on other sites

Problems with EL 6.6.2 and KAS.  And wish list.

I am having difficulties with Extraplanetary LaunchPad 6.6.2, on KSP 1.7.3. 

With EL 6.1.0, it is my practise to build a part (typically on an orbital dock), then finalize it, but never release it.  Instead I send out my engineer, to KAS the part where I want it.  I am then able to re-use the orbital dock (EL Pad) to build another part.  Under EL6.6.2, this does not work at all, in that while my engineer can KAS the part elsewhere, the EL GUI insists I must release the moved part (which then floats on nothing) before building another, then makes the first KAS-ed part disappear when the second is finalized.   When I release things as EL 6.6.2 wants, they can float or slide off the dock before I can get my engineer out.

I find this behavior unacceptable, and so have stuck with EL 6.1.0.  This means I am behind on the other upgrades, but it really has to work with KAS better.

Note: I said part above, when I really should said ship.  This is because it is frequently my practise to build single parts and KAS them into my base.  Which means I have a whole bunch of single part ships in the SPH and VAB inventory.  Support for single part build would be nice.

Also, in EL 6.6.2, unlike 6.1.0,  the right-click menu on the orbital dock no longer has the "show UI" or "rename pad" options.  The app button still works.  But re-naming pads is important.  Especially if one is as fond of building orbital docks with orbital docks as I am.

In 6.6.2 and 6.1.0, when the EL survey station is present is appears as a fictitious 'pad' appears in the GUI.  This without and survey sticks deployed or even present.  Then a "might explode" warning appears, and the new finalized part appears in a random spot, with potential explosions.  This appears to be two problems - a) a survey station is never a valid build pad, only a deployed survey stake and (b) the default naming of all ELpads as "pad-X" can be confusing, try naming them 'orbital dock' or 'launchpad' or 'survey stake'

But a good point of EL 6.6.2 over 6.1.0 is that does not forcibly filter anything with ELworkshop or RocketParts into the EL Items category within the DLL.  Module manager should be used for that.  More cfg configurable options for EL in the settings would be helpful.  (E.g. disable survey station and stakes; recycler recipe)

In summary, these days I can not imagine building my base without EL and KAS.  But I will stick with EL 6.1.0 until the new release works better with KAS removal instead of release.  Thank you for the mod.

Edited by krbolson
spelling

Share this post


Link to post
Share on other sites

Bug ????

I have a starbase core. Using multiple disposable pads i'm expanding it.

I started constructing one expansion. I started building the second expansion at the same time. It's now under construction. I switch to the fist expansion to check on it: it still reports 130 days left. I pause teh second expansion to speed up the first one. With the second expansio paused, I check on the first expansion expecting it to be ready in 65 days. It STILL reads as 130 days.

Shouldn't the workforce be moved to active projects once others are paused ?

Later edit: after moving some kerbals around everything went back to normal. The workforce from the paused project now migrates to the active project.

Edited by Nicky21

Share this post


Link to post
Share on other sites
On 10/22/2019 at 2:37 PM, krbolson said:

With EL 6.1.0, it is my practise to build a part (typically on an orbital dock), then finalize it, but never release it.  Instead I send out my engineer, to KAS the part where I want it.  I am then able to re-use the orbital dock (EL Pad) to build another part.  Under EL6.6.2, this does not work at all, in that while my engineer can KAS the part elsewhere, the EL GUI insists I must release the moved part (which then floats on nothing) before building another, then makes the first KAS-ed part disappear when the second is finalized.   When I release things as EL 6.6.2 wants, they can float or slide off the dock before I can get my engineer out.

Hmm, this sounds like a regression, and I do such a lot myself (especially KIS boxes full of useful small parts), but I haven't had time to do much playing lately, so failed to notice

On 10/22/2019 at 2:37 PM, krbolson said:

Support for single part build would be nice

This is something I want, too, but the UI is an issue (getting a good parts list in flight mode... (and as EL is GPL, I have to be careful about using other people's code)).

 

On 10/22/2019 at 2:37 PM, krbolson said:

Also, in EL 6.6.2, unlike 6.1.0,  the right-click menu on the orbital dock no longer has the "show UI" or "rename pad" options.  The app button still works.  But re-naming pads is important.  Especially if one is as fond of building orbital docks with orbital docks as I am

Odd, it's working here (just now tested both oribital doc and micro pad).

On 10/22/2019 at 2:37 PM, krbolson said:

In 6.6.2 and 6.1.0, when the EL survey station is present is appears as a fictitious 'pad' appears in the GUI.  This without and survey sticks deployed or even present.  Then a "might explode" warning appears, and the new finalized part appears in a random spot, with potential explosions.  This appears to be two problems - a) a survey station is never a valid build pad, only a deployed survey stake and (b) the default naming of all ELpads as "pad-X" can be confusing, try naming them 'orbital dock' or 'launchpad' or 'survey stake'

Actually, the survey station is the builder, and the survey site (stake set) is where the build will be placed. That is, you can change where the build will be placed by choosing a different survey site as much as you want up until you actually finalize the build. Part of the reasoning behind this is I did not want to have to deal with locking down survey stakes that are used in a build.

As for the default naming scheme... hmm. It should be easy enough to add a default name to each pad type (I might even make it a part config item (I can think of a certain mod author or two who might appreciate that)).

As for extra options for EL, I do have plans for difficulty settings, but haven't had time to work out the details, let alone implement anything. That said, the whole point of the recipe system (most of which is hidden away unless you use something like that USI patch for EL, or maybe WBI (don't remember if @Angel-125 did special resources for EL builds)) is precisely that: difficulty settings for required build resources. Smelting recipes was actually a "hey, I can do that now" thing (and proof of concept for eventually implementing the smelting system outlined in the Landis paper (links in the first page or two of the topic)).

Share this post


Link to post
Share on other sites

Hi there, apologies for spamming you @taniwha but I thought I'd post a reference to this error logspam I'm getting which may (or may not) be related to ExtraplanetaryLaunchpads?

Are you familiar with this? Is this even related to EL?

Again, here's the logspam I'm getting:

[LOG 14:08:04.626] [ExperienceSystem]: Found 0 trait types
[LOG 14:08:04.631] [ExperienceSystem]: Found 31 effect types
[ERR 14:08:04.647] ExperienceTrait: Cannot add effect 'ExSurveySkill' as it does not exist.
[ERR 14:08:04.652] ExperienceTrait: Cannot add effect 'ExSurveySkill' as it does not exist.
[ERR 14:08:04.652] ExperienceTrait: Cannot add effect 'SurveySkill' as it does not exist.
[ERR 14:08:04.652] ExperienceTrait: Cannot add effect 'ExConstructionSkill' as it does not exist.
[ERR 14:08:04.653] ExperienceTrait: Cannot add effect 'ConstructionSkill' as it does not exist.
[ERR 14:08:04.654] ExperienceTrait: Cannot add effect 'ConstructionSkill' as it does not exist.
[ERR 14:08:04.654] ExperienceTrait: Cannot add effect 'ExConstructionSkill' as it does not exist.
[ERR 14:08:04.655] ExperienceTrait: Cannot add effect 'SurveySkill' as it does not exist.
[ERR 14:08:04.656] ExperienceTrait: Cannot add effect 'ExSurveySkill' as it does not exist.
[ERR 14:08:04.656] ExperienceTrait: Cannot add effect 'ExSurveySkill' as it does not exist.
[ERR 14:08:04.656] ExperienceTrait: Cannot add effect 'ExSurveySkill' as it does not exist.
[ERR 14:08:04.657] ExperienceTrait: Cannot add effect 'SurveySkill' as it does not exist.
[ERR 14:08:04.657] ExperienceTrait: Cannot add effect 'ExConstructionSkill' as it does not exist.

Any thoughts? Of course, I can provide a more full log if necessary.

 

Share this post


Link to post
Share on other sites
6 minutes ago, taniwha said:

Ex->EL for the skill name. Whatever configs you are using are old.

Thanks again for looking at this. I was actually going through the SimpleConstruction mod's CFG files, and sure enough: there's ExSurveySkill and ExConstructionSkill as traits. All the other CFG files were updated to us "EL" but just not the experience stuff. Anyway, I won't clutter the EL thread with SC stuff, but hopefully anyone having this problem in the future will find this! Appreciate your help.

Share this post


Link to post
Share on other sites
On 23/6/2018 at 8:29, taniwha said:

He lanzado la versión 6.1.0 de Extraplanetary Launchpads.

Cambios desde 6.0.0:

  • Verifique la versión de verificación para KSP 1.4.4.
  • Arregle el diálogo de selección de manualidades para KSP 1.4.4. También es compatible con Steam.
  • Agregar soporte para CCK (LouisCyfer)
  • Desactive efectivamente el enfriamiento activo en las fundiciones (espero).

nesecito el link de la descarga;.;;.;

Share this post


Link to post
Share on other sites
59 minutes ago, Xander el interplanetario said:

 

I need the download link ;.;;.;

Please post in English when you're not using the other language subforums. 

Share this post


Link to post
Share on other sites

Hi, 

I Know this is not updated to 1.8 yet, but can someone confirm if it's working? Someone using it with 1.8?

Edited by Aspira

Share this post


Link to post
Share on other sites
4 hours ago, Aspira said:

Hi, 

I Know this is not updated to 1.8 yet, but can someone confirm if it's working? Someone using it with 1.8?

Try it and let us know.

Share this post


Link to post
Share on other sites

I will never understand this kind of answer. I was nothing but polite.

Maybe you are confident about your modding skills, I am certainly not about mine. I lost the count on how many times I screwed everything up trying to mod games, including KSP. Fresh install, install each mod again, and the ammount of time I have to actually play is gone.

 

So, since I just made a question, which I imagine a lot of people wants to know, I see no reason for this kind of answer.  Also, I tried to find this answer reading the last pages, but I couldn`t find.

It`s beyond me as a simple and polite question from someone unknown can make someone prefer to answer this instead of be silent.

I suppose it`s my fault, maybe I don`t understand how forums work, I though it was a place to make and answer questions in the best interest of the community. It seems I am wrong.

Edited by Aspira

Share this post


Link to post
Share on other sites

I shall endeavour to answer your question. I've been using it with 1.8.0 and more recently with 1.8.1
I've been using its functionality, not the parts that come with it and have had no problems at all.

i built a base using KPBS from Nils

An amazing mod if you haven't tried it and all the parts that replicate ELs parts work fine.

Go for it :)

Share this post


Link to post
Share on other sites
2 hours ago, Aspira said:

I will never understand this kind of answer. I was nothing but polite.

Maybe you are confident about your modding skills, I am certainly not about mine. I lost the count on how many times I screwed everything up trying to mod games, including KSP. Fresh install, install each mod again, and the ammount of time I have to actually play is gone.

 

So, since I just made a question, which I imagine a lot of people wants to know, I see no reason for this kind of answer.  Also, I tried to find this answer reading the last pages, but I couldn`t find.

It`s beyond me as a simple and polite question from someone unknown can make someone prefer to answer this instead of be silent.

I suppose it`s my fault, maybe I don`t understand how forums work, I though it was a place to make and answer questions in the best interest of the community. It seems I am wrong.

And mine was rude?  You asked.  In 4 hours nobody had replied.  It's not hard to drop a KSP mod in and test it out.  In doing so you could be one of those forum posters who says "Hey I tried this mod and it seems to work" instead of one of the 'does this work?"

 

 

Share this post


Link to post
Share on other sites
30 minutes ago, goldenpsp said:

And mine was rude?  You asked.  In 4 hours nobody had replied.  It's not hard to drop a KSP mod in and test it out.  In doing so you could be one of those forum posters who says "Hey I tried this mod and it seems to work" instead of one of the 'does this work?"

In addition, we don't know what other mods that a player might have installed, and the possible interactions between them.  There are very likely no two players on here with the exact same mod mix.

 

3 hours ago, Aspira said:

I lost the count on how many times I screwed everything up trying to mod games, including KSP. Fresh install, install each mod again, and the ammount of time I have to actually play is gone.

Step one: make a backup of your KSP install before installing something.  If things get messed up, simply restore from backup.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.