Jump to content

[1.2.0] Toolbar 1.7.13 - Common API for draggable/resizable buttons toolbar


blizzy78
 Share

Recommended Posts

do we know when this will be supported for .90? It is really bugging me because it does not work for me right now so I cannot open any of the mods that depend on it. Or is there a way to fix it on my own or am I just missing something because it is not working for me.

Edited by Itzak7
Link to comment
Share on other sites

blizzy, if your mod works for .90, please actually release a version that does not say it's not. Training people to ignore the compatibility warning is a really, really bad idea. :\

For the record, I'm not training anyone. If I would, the warning wouldn't make any sense at all and could be removed.

Link to comment
Share on other sites

did you use a proper text editor like notepad++ because i did mine and havent had an issue

WTH?

Using regular MS Notepad, my version.txt file looks like this: 0.24.0,0.24.1,0.24.2,0.25.0,0.90.0

When I copied and pasted it to my preferred editor, gVIM, it appears on two lines:

0.24.0,0.24.1,0.24.2,0.25.0

,0.90.0

No wonder there was a problem. Ugh!!!!!

So, I corrected it (in gVIM) and it's golden).

Link to comment
Share on other sites

  • 4 months later...
Sorry for the bump, but is this mod confirmed to be working with 1.0/1.0.2?

It's working for me in 1.0.2. Though on startup the game does warn that it's incompatible. I expect a recompile will be needed to remove the warning

Link to comment
Share on other sites

  • 3 weeks later...

Well, Toolbar is quite good, but I have been experiencing a 'problem' with it.

Whenever I have Toolbar installed, I cannot access the right-click menus in the VAB or SPH, and I play with a fair amount of mods which I need those menus to use properly.

And I have no idea how to fix this, because I know that removing Toolbar from my game's files, completely and utterly, will fix this, but, some of the mods I'm using need Toolbar to work.

Help please.

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

Hi,

I'm trying to use the ToolbarWrapper.cs in my mod that I'm writing.

I'm having a problem in that if I merely include the file in my project (and yes, I did change the namespace to match my mod), I am getting the following error:


[LOG 11:37:05.142] AssemblyLoader: Loading assembly at D:\KerbalInstalls\1.0 We Have Liftoff\test\KSP_1.0.4_mod_development\GameData\MinAmbience\MinAmbience.dll
[LOG 11:37:05.144] Load(Assembly): SpaceTux/AS/Plugins/AutomatedScreenshots
[LOG 11:37:05.144] AssemblyLoader: Loading assembly at D:\KerbalInstalls\1.0 We Have Liftoff\test\KSP_1.0.4_mod_development\GameData\SpaceTux\AS\Plugins\AutomatedScreenshots.dll
[LOG 11:37:05.147] AssemblyLoader: Loading assemblies
[ERR 11:37:05.165] AssemblyLoader: Exception loading 'AutomatedScreenshots': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0
Additional information about this exception:
System.TypeLoadException: Could not load type 'AutomatedScreenshots.ToolbarTypes' from assembly 'AutomatedScreenshots, Version=1.0.5678.19092, Culture=neutral, PublicKeyToken=null'.
System.TypeLoadException: Could not load type '<>c__DisplayClass3' from assembly 'AutomatedScreenshots, Version=1.0.5678.19092, Culture=neutral, PublicKeyToken=null'.

There are no calls to it, if I remove it from the project, it works fine.

What am I missing?

I'm using Xamian Studio.

Thanks in advance.

LGG

Edited by linuxgurugamer
Link to comment
Share on other sites

:-(

It was, somehow it got changed to 4.5 :-(

I'll recompile and try again, thanks for getting back to me quickly.

Yup. That was it, thanks.

I have no idea how it got changed :-(

- - - Updated - - -

Blizzy78,

Are you going to recompile the mod anytime soon for 1.0.4? I know it works, its just annoying that a warning message comes up every time that it is incompatible with 1.0.4

Not a big deal, just curious.

Again, thanks for your help.

LGG

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...