blizzy78

[1.2.0] Toolbar 1.7.13 - Common API for draggable/resizable buttons toolbar

Recommended Posts

Please upload your toolbar-settings.dat like you did with the log file. I'd like to see that without it being mangled by the forum software.

Share this post


Link to post
Share on other sites

Indeed, those doubling looks pretty weird. Try removing those double entries and see how it goes. I'll have a look at the Toolbar code.

Share this post


Link to post
Share on other sites
Indeed, those doubling looks pretty weird. Try removing those double entries and see how it goes. I'll have a look at the Toolbar code.

I reinitialized each of the toolbar entry settings with:

toolbar

{

x = 300

y = 300

width = 250

height = 38

autoHide = False

drawBorder = True

useKSPSkin = False

buttonOrder =

visibleButtons =

}

Seems to be working fine now.

Share this post


Link to post
Share on other sites

Now that I think of it, one of the mods I downloaded included the toolbar, but it was an old version. Which is how I discovered the toolbar plugin. The toolbar prompted me to update, which I did, but the settings may have already been borked by that time.

Anyways, thanks for your help. Great mod. It makes my screen much more manageable. You are a god among men.

Share this post


Link to post
Share on other sites
Anyways, thanks for your help. Great mod. It makes my screen much more manageable. You are a god among men.

Uhh, now that's a very bold statement right there :)

Share this post


Link to post
Share on other sites

It should only ever disappear if there is not a single button that could be shown.

Share this post


Link to post
Share on other sites
It should only ever disappear if there is not a single button that could be shown.

Cool thanks. I think it was because I turned on engineer redux toolbar, but I did not have the part on my ship.

Share this post


Link to post
Share on other sites

Can somebody help me, i already have a folder called 000-toolbar, but now i have downloaded a other also with a folder called 000-toolbar how do i use them both?

Share this post


Link to post
Share on other sites

but doesn't that one delete the other buttons from the other mod?

Share this post


Link to post
Share on other sites

It shouldn't do as the visible buttons are stored in the settings, which isn't in the Toolbar folder.

Edited by ObsessedWithKSP

Share this post


Link to post
Share on other sites

I think that i need to download a newer version.

Share this post


Link to post
Share on other sites

Oke i download the newest version but i dont get other icons from other mod.

Share this post


Link to post
Share on other sites
but doesn't that one delete the other buttons from the other mod?

The Toolbar doesn't contain the buttons. The Toolbar just exists. The mods themselves put buttons on the Toolbar by themselves.

Share this post


Link to post
Share on other sites
Have you made them visible?
The Toolbar doesn't contain the buttons. The Toolbar just exists. The mods themselves put buttons on the Toolbar by themselves.

Hi, i dont get it, how do i add then the other buttons? becuase i have final Frontier and magicsmoke industrie mod installed but i only see the Final Frontier button.

Share this post


Link to post
Share on other sites
Hi, i dont get it, how do i add then the other buttons? becuase i have final Frontier and magicsmoke industrie mod installed but i only see the Final Frontier button.

Click the little down arrow on the toolbar and select "show/hide buttons." Not all buttons will work in all scenes, but I figure those buttons should show in normal (controlling the ship) mode if they're enabled.

Share this post


Link to post
Share on other sites
Hi, i dont get it, how do i add then the other buttons? becuase i have final Frontier and magicsmoke industrie mod installed but i only see the Final Frontier button.

Please see the FAQ in the first post:

So many buttons! Can I hide the ones I don't need?

Click on the little triangle button on the toolbar, then select "Configure Visible Buttons" from the menu. Activate or deactivate buttons as desired. Click "Close" to close the configuration window.

Share this post


Link to post
Share on other sites

I really need help with the toolbar plugin. I don't understand what is going on. Everything works as expected except that on certain screens the toolbar doesn't like having buttons added to it. It starts spazzing and glitching. From what I can see from the flashing it is trying to flip between a size that includes all the buttons and the default size. This makes it extremely difficult to use the toolbar. Attempting to re-size it manually only makes it worse, at best. Certain buttons also don't have graphics and just take a slot (and are functional). This would be livable if it wasn't for the fact that the main game scene is one of the scenes that doesn't work.

Any suggestions for how to fix this would be much appreciated. I tried re installing Toolbar as well as using the included versions from mods. Nothing seems to help. I deleted the toolbar-settings.dat but that just led to the same issues coming back. What aggravates me so much is that I see pictures of people using it fine with even more mods than I have.

Share this post


Link to post
Share on other sites

Please check that there is exactly one Toolbar.dll in your complete GameData\ folder (it should be at GameData\000_Toolbar\Toolbar.dll).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.