blizzy78

[1.2.0] Toolbar 1.7.13 - Common API for draggable/resizable buttons toolbar

Recommended Posts

So, the following are from me crashing upon attempting to enter the VAB:

https://www.dropbox.com/s/11wddl6c8c0lrlm/error.log?dl=0

https://www.dropbox.com/s/o2vxldgd4yfikfd/KSP.log?dl=0

which is actually kind of a first. I usually just freeze trying to enter the VAB, the crashes happen everywhere else.

edit: Running Windows 10 Pro, i7-4790k (no oc), 8GB RAM, KSP install is on a 128GB SSD

edit2: And I seriously appreciate yall's help. I love this game, I just really wish I could run KSPI-E :/

edit3: Also, i'll be copying this over to the KSPI-E thread to see if anyone there has any idea what's going on

Edited by CajunInABox

Share this post


Link to post
Share on other sites

Cajun: You've uploaded the logs that help the least. Please upload "output_log.txt" found in KSP_Data folder of KSP.

The Logs

These are text files that the game spits out for debugging purposes as it runs; if something broke horribly in-game, there will be something in here about it. You should upload the entire log as a file (i.e. not to pastebin); you can use dropbox or an equivalent host to upload the file. Make sure the entire file gets uploaded; you may have to zip it first, as logs can be very long. Here is where you can find the log:

  • Windows: KSP_win\KSP_Data\output_log.txt (32bit) or KSP_win64\KSP_x64_Data\output_log.txt (64bit)

Edited by StoryMusgrave

Share this post


Link to post
Share on other sites
Cajun: You've uploaded the logs that help the least. Please upload "output_log.txt" found in KSP_Data folder of KSP.

edit: I re-read that summary. I'll upload the right one shortly.

here's my output_log file from my KSP Data folder: https://www.dropbox.com/s/xrysk224tvwi5vk/output_log.txt?dl=0

this is after I froze trying to enter the VAB

Edited by CajunInABox

Share this post


Link to post
Share on other sites

So someone in the KSPI-E thread told me to force DX11 with the following line:

"G:\Games2\Kerbal Space Program\KSP.exe" -force-d3d11

This change, on its own, fixed all of my major issues, all of my minor issues, and everything in between. Didn't have to remove any mods (actually added a few more lol). Haven't had a single crash, bug, freeze, or anything in the past hour. I really wish I had known about it sooner.

Share this post


Link to post
Share on other sites

nope,sadly

Share this post


Link to post
Share on other sites

Excuse me for this probably very stupid question, but how can I hide the default toolbar (in the upper right corner when flying, lower right when in VAB/SPH)? There are a clutter of icons (both from native game and mods) that I'd rather not see (or have them only in custom toolbars of this plugin).

P.S. Also, how can I add custom buttons from native game to this toolbar? (Like Contracts, Resources, etc)

Edited by aluc24

Share this post


Link to post
Share on other sites
Excuse me for this probably very stupid question, but how can I hide the default toolbar (in the upper right corner when flying, lower right when in VAB/SPH)? There are a clutter of icons (both from native game and mods) that I'd rather not see (or have them only in custom toolbars of this plugin).

For that you want Malah's QuickHide

Share this post


Link to post
Share on other sites
For that you want Malah's QuickHide

Okay, thanks, but how can I then add some of these icons to Toolbar mod? For example, Contracts, and like Trajectory Planner? They don't show up in the list.

Share this post


Link to post
Share on other sites

^^

Its up to each mods' developer to include Toolbar support in their mod...So stock buttons cannot be added to the Toolbar, nor any mod that does not include support...Basically, if the button shows up in the Toolbar list, thats what you can add...Also, most mods that DO include Toolbar support, should have a checkbox or something in the mod's own UI or Settings window... So if you have a mod that does not support Toolbar, post a request to add it, on THAT mod's release thread...And maybe if enough others reply agreeing with you, the mod author may add support to their mod...

Edited by Stone Blue

Share this post


Link to post
Share on other sites

hi all, i have added a button to a folder, how do i remove it from the folder back to the top layer of the toolbar? cheers

Share this post


Link to post
Share on other sites

blizzy, can you simply post an update to the toolbar that gets rid of the incompatibility popup with 1.0.4?

Share this post


Link to post
Share on other sites

Quick test shows this one seems to be working in 1.0.5.

blizzy, can you simply post an update to the toolbar that gets rid of the incompatibility popup with 1.0.4?

Edit the version.txt file to show 1.0.4, or 1.0.5 as appropriate to avoid the message.

Share this post


Link to post
Share on other sites

Yes that works but seeing as the entire purpose of the message is to bug the user until THEY update, the user should also feel inclined to bug the modders to update as well.

Share this post


Link to post
Share on other sites
Yes that works but seeing as the entire purpose of the message is to bug the user until THEY update, the user should also feel inclined to bug the modders to update as well.

Seeing as the user didn't ask for the mod to be updated to do anything different or correct any bugs, only to not display the message, I figured the user might like to handle it themself, rather than wait an indeterminate amount of time for an update.

Share this post


Link to post
Share on other sites
Seeing as the user didn't ask for the mod to be updated to do anything different or correct any bugs, only to not display the message, I figured the user might like to handle it themself, rather than wait an indeterminate amount of time for an update.

The message being displayed in itself *is* a bug, since the toolbar is perfectly compatible with 1.0.4 or 1.0.5.

It's called "package maintaining".

Share this post


Link to post
Share on other sites

Either way, I think I will just remove the check altogether. Now that KSP is well beyond release 1.0, I hope the API will stay stable enough so that the check is no longer necessary.

Share this post


Link to post
Share on other sites

That does rather assume that the switch to Unity 5 won't cause problems. Squad have promised to try and keep the current GUI API working, but Unity 5 might just alter something that throws out the way some mod UIs operate.

Share this post


Link to post
Share on other sites
I am confused from reading above posts. does toolbar work in KSP 1.0.5?

Lol. Yes. Blizzy is just going to release (hopefully) an update to simply get rid of the incompatibility message on start up. It's fully compatible as-is now.

Share this post


Link to post
Share on other sites
Lol. Yes. Blizzy is just going to release (hopefully) an update to simply get rid of the incompatibility message on start up. It's fully compatible as-is now.

so, it will just be annoying but working for a while, thank you.

Share this post


Link to post
Share on other sites
so, it will just be annoying but working for a while, thank you.

Or, update the version.txt file to 1.0.5

Share this post


Link to post
Share on other sites

Toolbar Plugin 1.7.10 is now available for download, disabling the KSP compatibility check for the time being.

Note: If the download page is linking an older version for you, press F5 in your browser.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.