Jump to content

[1.2.0] Toolbar 1.7.13 - Common API for draggable/resizable buttons toolbar


blizzy78
 Share

Recommended Posts

2 minutes ago, Drew Kerman said:

Also @Torih was that a joke? The App Launcher is supposed to scroll once its max height is reached

Why is that in anyway a joke. The icons are off the bottom of the page, just because you can scroll does not change that fact in the slightest.

Edited by Torih
Link to comment
Share on other sites

Just now, Torih said:

Why is that in anyway a joke. The icons are off the bottom of the page that just because you can scroll does not change that fact in the slightest.

What is the resolution of your screen? The max height of the App Launcher might be fixed rather than take into account your screen height so in that case it would be possible to have it run off the bottom. That would be a design oversight on the devs part

Link to comment
Share on other sites

32 minutes ago, Drew Kerman said:

yes you do. In the Settings menu you can scale all sorts of things, including the App Launcher (stock toolbar). I keep it at default tho - personally I don't think most of the icons scale well

Also @Torih was that a joke? The App Launcher is supposed to scroll once its max height is reached

you can already say how noob i am to ksp, didn't play from old days of 0.9 :P

Link to comment
Share on other sites

5 hours ago, Luke Duckwalker said:

CKAN doesn't see the update. How to solve?

 

46 minutes ago, softweir said:

Manual download until CKAN catches up. See first post for download address.

I did manual download and did not realize the error of older ( 1.7.12 )  until i tried loading game where avc said it was outdated version. so i deleted toolbar folder and config file for toolbar and downloaded the refreshed version. it unpacks as 1.7.13 but ckan still says its 1.7.12 and it doesnt seem to work in game.  i dont know if first install of toolbar has left some kind of registration somewhere ? but im stumped

Link to comment
Share on other sites

1 hour ago, Tes Daus said:

Is it ok, that I do not see Toolbar in VAB and in SPH (only in KSC, map and outside hangars)?

after further investigation i found that this was the case with me too. tool bar only appears in tracking station and outside play but not in the places i need them :( lol

Link to comment
Share on other sites

14 minutes ago, sAssIn said:

after further investigation i found that this was the case with me too. tool bar only appears in tracking station and outside play but not in the places i need them :( lol

Try deleting "toolbar-settings.dat" in GameData. This is the settings of where and how the toolbar is setup on each screen. May have popped up in an odd location outside where you can grab / move it?

Edited by V8jester
Link to comment
Share on other sites

Your issue is probably you enabled an icon on the KSC screen that doesn't appear in another scene like the VAB then it will make the bar invisible if no other icons are enabled. 

For example waypoint manager. enable that and only that on the KSC then the bar disappears in the VAB since waypoint manager isn't used/enabled for that scene.

Edited by Torih
Link to comment
Share on other sites

12 minutes ago, V8jester said:

Try deleting "toolbar-settings.dat" in GameData. This is the settings of where and how the toolbar is setup on each screen. May have popped up in an odd location outside where you can grab / move it?

tried with same results. the toolbar appears in the same place on screen in tracking station and outside screens but are not on the VAB and SPH screens and im pretty sure it could not hide off screen, as i can still see the tip of my curser when i edge it round. though im not savvy enough to know how far it could hide "off screen" but the delete didnt help. is there a hot key to try ?

 

9 minutes ago, Torih said:

Your issue is probably you enabled an icon on the KSC screen that doesn't appear in another scene like the VAB then it will make the bar invisible if no other icons are enabled. 

its definately not this, no other icons have been clicked or used in KSC to cause this.

Link to comment
Share on other sites

2 minutes ago, sAssIn said:

tried with same results. the toolbar appears in the same place on screen in tracking station and outside screens but are not on the VAB and SPH screens and im pretty sure it could not hide off screen, as i can still see the tip of my curser when i edge it round. though im not savvy enough to know how far it could hide "off screen" but the delete didnt help. is there a hot key to try ?

 

its definately not this, no other icons have been clicked or used in KSC to cause this.

 I agree with you in both answers...

Link to comment
Share on other sites

12 hours ago, Torih said:

Your issue is probably you enabled an icon on the KSC screen that doesn't appear in another scene like the VAB then it will make the bar invisible if no other icons are enabled. 

For example waypoint manager. enable that and only that on the KSC then the bar disappears in the VAB since waypoint manager isn't used/enabled for that scene.

 

Torih, You are right. After installing the mod MechJeb panel of toolbar appeared in the hangar too. For some reason I have formed the opinion that, to version 1.2 these mods like FinalFrontier and [x]Science!, added their own buttons to the toolbar of the hangar. I was wrong...

Edited by Tes Daus
Link to comment
Share on other sites

14 hours ago, Torih said:

Your issue is probably you enabled an icon on the KSC screen that doesn't appear in another scene like the VAB then it will make the bar invisible if no other icons are enabled. 

For example waypoint manager. enable that and only that on the KSC then the bar disappears in the VAB since waypoint manager isn't used/enabled for that scene.

I couldnt select any toolbar from KSC as it didnt show up on that screen just the tracking station screen and on launch. It may be because i dont have mods that run in blizzys tools. I uninstalled waypoint and tool bar has dissappeared. i havent installed mechjeb yet as it doesnt appear quite ready for 1.2 , I think Ive just assumed the tool bar would show without. I do have a few mods but it seems they have toolbars attached to the core game and waypoint manager is the only thing that appeared in blizzys bar. .... maybe ?

Link to comment
Share on other sites

3 hours ago, sAssIn said:

I couldnt select any toolbar from KSC as it didnt show up on that screen just the tracking station screen and on launch. It may be because i dont have mods that run in blizzys tools. I uninstalled waypoint and tool bar has dissappeared. i havent installed mechjeb yet as it doesnt appear quite ready for 1.2 , I think Ive just assumed the tool bar would show without. I do have a few mods but it seems they have toolbars attached to the core game and waypoint manager is the only thing that appeared in blizzys bar. .... maybe ?

Some mods have their own settings where you can disable the stock toolbar. Then they will appear in blizzys bar ( [x]Science! for example)

Link to comment
Share on other sites

23 hours ago, Tes Daus said:

Some mods have their own settings where you can disable the stock toolbar. Then they will appear in blizzys bar ( [x]Science! for example)

yep, my noobishness is apparent lol. ive been away from ksp for awhile and though i was expecting some teething issues its still early days for 1.2 and it does seem that blizzys toolbar now appears when a relavent mod is installed i just assumed it would show blank toolbar square when i first tried it. it didnt help when i didnt read post properly about refreshing dl page so i messed up from the start and thought that was my problem. its all good now thanks for the help :)

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...