shaw

BROKEN [0.90] TextureReplacer 2.1.2 (20.12.2014)

Recommended Posts

TR doesn't affect your saved games in any way.

Thanks, since I like to be able to know that I can always fire up an all-stock install and load a pre-made save. :D

Also, this is an AWESOME mod, and I'm quite happy with Jeb's new "tough guy" beard.

Share this post


Link to post
Share on other sites

I'm flirting on the edge of my VRAM limit without using any compression except for the default TR setting. I've watched the game load and it finishes the splash menu at around 2.9GB, then goes into the Loading screen and there the VRAM jumps sometimes as high as 3.8GB and then crashes the game. Sometimes. It just did it now where it spiked and crashed and I tried again and it spiked to 3.6GB but then settled down to 3.4GB and entered the main screen. Anyone know what this load spike is and if there's any way to mitigate it? I'm posting here as I suspect it might be texture-related

Share this post


Link to post
Share on other sites

I don't know what the spike is. RAM usage shouldn't increase drastically after the textures are loaded (~40% of progressbar in loading screen). Models and parts (the latter are only binding together models, textures & configurations), which are loaded last, eat much lesser proportion than textures. Just before the main menu TR releases most of the textures in RAM, hence the drop.

Try the same with stock install and then with ATM.

Share this post


Link to post
Share on other sites

shucks, things are never easy right? :P Ok Thanks for the response shaw I'll play around some more to see if I can determine the cause of the spike

EDIT: Well I loaded the Squad/Nasa folders along with my TextureReplacer folder (with extra textures in it), and the loading pattern I see is the VRAM going up and then down with each texture load. It levels at around 1.2GB while all the parts are loading and then when it goes to the main screen it increases to 1.5GB. So I don't see any VRAM reduction when entering the loading menu, but I do see it going up and down while the textures are loading so I assume that's TextureReplacer working? I've restarted the game a few times and this is what I'm consistently seeing. I'm also seeing a lot of Squad/Props loading at the very end:

PartLoader: Compiling Internal Space 'Squad/Props/switchWithGuards/prop/switchWithGuards'

EDIT2: I do see

Unloading 97 unused Assets to reduce memory usage. Loaded Objects now: 39348.

At the end of the output_log.txt prior to the scene change log item, but still don't see any VRAM reduction during that time. I'm thinking this is just the game reserving some chunk proportional to the amount of textures already loaded or something? It's nice if TR can keep RAM usage down but VRAM is what actually crashes the game, as it is reserved in chunks in advance of the growth of RAM (so the game can crash at 4.1GB of VRAM while only be using ~3.6GB of RAM). I'm pretty sure this is outside the control of mods.

Bummer

Edited by Gaiiden

Share this post


Link to post
Share on other sites

TR releases only textures from RAM before the main menu opens, not from VRAM. KSP "shadows" all PNGs, TGAs, JPEGs and, in special cases, also MBMs in RAM for the case that some mod needs access to pixel data, but that's very rarely required ("keepReadable" setting in TR's config files tells which textures should remain loaded). I cannot unload them earlier, e.g. immediately after a texture is loaded, because images' pixels are often accessed during model loading, to convert certain normal maps to Unity format.

The only way to reduce VRAM usage is dynamic loading of textures (there's some mod for that) or texture compression. However, the latter can't be done for textures that are only loaded to VRAM. Normal maps and most of MBMs are such example. Luckily, (diffuse) MBMs are mostly compressed by default, but not the normal maps. ATM can work around that by pre-loading all textures before KSP loading even begins.

Share this post


Link to post
Share on other sites

Thanks for the explanation. I have my eye on the mod that's working to load textures as needed, for sure

Share this post


Link to post
Share on other sites

I was told to come here instead of using Universe Replacer for 0.23

I previously used UR to great success from whenever it was released up to 0.22

All I want to do (for now, anyway) is to reinstall planet pack textures, (clouds? not sure if that was handled by UR or Visual Enhancements), skyboxes. I find the instructions rather obfuscatory compared to UR. Can I get some clarification here regarding files and folders?

If I'm interpreting the readme correctly, what I want to do is extract all the raw textures from their file folders and hierarchies and place them all in /gamedata/texturereplacer/default, yes?

So the end result for planet texture replacements would end up being /default/Kerbin.png for example?

And skyboxes go in default as well, or in EnvMap?

Share this post


Link to post
Share on other sites

Kerbin texture must be e.g. `Default/KerbinScaledSpace300.png`. You can look at texture packs linked in OP for examples.

Share this post


Link to post
Share on other sites

OK, with a little more time and a second look at the readme it's becoming more clear.

The language in the OP is very different from the instructions for all other mods I use or have used, hence my confusion. Not sure what exactly can be done to make the language clearer, but perhaps a picture showcasing a replacement image with the 'kerbinscaledspace300' name as well as a side-by-side image of the readme might help. Looking through the thread, I'm clearly not the only one who had this problem.

Share this post


Link to post
Share on other sites

@Glyph: Thanks, updating texture packs.

@cardgame: You mean it's complicated or that it's crappy English? I don't know how to write clearer/shorter instructions that would still be precise. Images you suggested may be helpful, but would only cover specific use-cases.

Share this post


Link to post
Share on other sites

I want to see custom Kerbal heads for Scott, Edlu, Randall, Gus, Alan, Buzz, and Kirk. (all of those are possible with the name generator, and they shouldn't have female heads on any of these, and the young face doesn't make sense on Scott or Buzz.

Custom suits as well

Scott: THIS shirt. for the IVA Suit, Default EVA Suit.

Edlu: Orange "Veteran" IVA Suit, Orange "Veteran" EVA suit. Both with "B612" Written in place of "KSP".

Randall: Very Barebones, not very detailed EVA or IVA suit.

Gus: Gemini EVA/IVA Suit.

Alan: Mercury IVA/"EVA" Suit.

Buzz (Yeah, I know it's supposed to be Aldrin)

Kirk: Golden shirt with Delta-Sheild logo (Star Trek symbol) IVA Suit, THIS EVA suit

Edited by GregroxMun

Share this post


Link to post
Share on other sites

Hello Kerbonauts,

I have a little problem. Either I'm too stupid, or my game installation doesn't want to load the mods. I would like to have PimpMyClouds and PimpMyKerbals. My \GameData looks like this

2014-06-29_1449.png

and the TextureReplacer like this

2014-06-29_1449_001.png

When loading the game I can read a few TextureReplacer lines, but InGame nothing is shown

Click Here for Picture

Could anybody please tell me what I'm doing wrong?

Thanks in advance! :)

Share this post


Link to post
Share on other sites
@pingonaut:

That image shows development version of female head texture from scart91 (I don't know if he ever participated on this forum, I contacted him on Imgur).

Here's the link: https://dl.dropboxusercontent.com/u/9508397/scart91.zip

The textures are CC BY.

I intended to merge them with Syllith's pack but ran out of motivation :(

If you're able to extract hairstyles into a separate layer, you're welcome to further extend Extended Sylith's pack (see OP for the link with source images) into Super-extended Sylith-scart91's pack :P

I would love to extract the hairstyles, I just need to figure out how to do so without taking the green of the skin with me, and without making the hair to face transition too sharp. Any suggestions?

Share this post


Link to post
Share on other sites

@Metro: PimpMyKerbals is in the old format, before configuration files existed. Proot released KSP Renaissance Compilation which includes improved & updated textures from PimpMyKerbals among many other things (you don't need to install whole pack, just TextureReplacer folder without Default/Squad). If you still prefer the PimpMyKerbals pack, KSPRC can at least serve you as an example where to put textures and for the configuration file :)

Share this post


Link to post
Share on other sites
Why you no use volumetric clouds, though?

Hm, what are volumetric clouds exactly and how to enable them? First I have to find out how to optimize the performance. With my GTX 660 I'm getting 20 FPS when launching. Even when I disabled AA and set every graphics settings to low I have a bad amount of FPS. In fact less than before, ~ 14.

Any suggestions though?

Share this post


Link to post
Share on other sites
Hm, what are volumetric clouds exactly and how to enable them? First I have to find out how to optimize the performance. With my GTX 660 I'm getting 20 FPS when launching. Even when I disabled AA and set every graphics settings to low I have a bad amount of FPS. In fact less than before, ~ 14.

Any suggestions though?

It's enabled by this mod using either Astronomer's Visual Pack, which also adds Auroras and dust storms on Duna and other planets, or , which is not as extensive (and sometimes adds things that are very out of place). I would also suggest using Distant Object Enhancement along with them.

If you want volumetric clouds you're going to want to have a planet texture that does not have clouds.

Share this post


Link to post
Share on other sites

I am unable to edit my posts due to a bug, so I have to repost it to fix the broken link.

It's enabled by this mod using either Astronomer's Visual Pack, which also adds Auroras and dust storms on Duna and other planets, or Better Atmospheres, which is not as extensive (and sometimes adds things that are very out of place). I would also suggest using Distant Object Enhancement along with them.

If you want volumetric clouds you're going to want to have a planet texture that does not have clouds.

Share this post


Link to post
Share on other sites
I am unable to edit my posts due to a bug, so I have to repost it to fix the broken link.

Thank you! I guess these mods will require even more power, so I will first try to play without those. After removing HotRockets my FPS doubled, I already guessed that it is it's fault, but I'm not happy about removing it really. You see engines all the time, seeing prettier engines is even better.

Share this post


Link to post
Share on other sites
Thank you! I guess these mods will require even more power, so I will first try to play without those. After removing HotRockets my FPS doubled, I already guessed that it is it's fault, but I'm not happy about removing it really. You see engines all the time, seeing prettier engines is even better.

I'ts not all about graphic power,did you check your nvidia GeForce experience for optimal settings?Most power this game needs is from CPU!

P.S. As long you see green time at upper left corner don't bother with FPS it's not fps.:P

Edited by sebi.zzr

Share this post


Link to post
Share on other sites
I'ts not all about graphic power,did you check your nvidia GeForce experience for optimal settings?Most power this game needs is from CPU!

P.S. As long you see green time at upper left corner don't bother with FPS it's not fps.:P

Thank you very much for your suggestion!

However, after applying GeForce Experience optimal settings and adding the HotRocket Mod I still have a very low amount of FPS. Next time I will check my CPU usage, maybe my i5 2500K ist too low?

Share this post


Link to post
Share on other sites

So I've been using this for skybox replacement forever, but I've started poking around with Kerbal textures, and now I have a question:

Is there a reasonably convenient way to have, say, half of the generic kerbals be the default/classic "black, widow's peak" sort, and the other half a random mix? Without, say, making multiple copies of the default texture so that the ratio comes out right, or doing it all by hand - putting everyone's name in the config file and flipping a coin to see what they get?

Share this post


Link to post
Share on other sites
Thank you very much for your suggestion!

However, after applying GeForce Experience optimal settings and adding the HotRocket Mod I still have a very low amount of FPS. Next time I will check my CPU usage, maybe my i5 2500K ist too low?

Your CPU is fine,i'm using i5 3570k and gtx 670 and get solid 50FPS for 100 part ship,but i must point out i'm using active texture management (ATM) mod.(my mod count is 35)

@Commander Zoom:You should put all suits in suit directory including the one in default folder,and suits will be randomly assigned.

Edited by sebi.zzr

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.