Sign in to follow this  
jfull

.23 and Mods

Recommended Posts

Protractor is working, but mechjeb is not for me (I want a stable version not a dev version)

Share this post


Link to post
Share on other sites
OP should add list of mods that are working, not just the ones that aren't. I have a feeling the list of the working ones will be much shorter than the broken ones for a while

I'm pretty sure the working mods list is longer. Mods that only add parts should be fine, and even some with plugins are working fine

Share this post


Link to post
Share on other sites
Deadly Reentry isn't anymore. Thank taniwha and arsenic87. :)

Wow you really scared me there for a second... I read that without context as you didn't quote anything, what you actually mean is "Deadly Reentry isn't incompatible anymore."

I thought there might've been some license problem and it went away. Nearly gave me a heart attack there :huh:

Share this post


Link to post
Share on other sites
Wow you really scared me there for a second... I read that without context as you didn't quote anything, what you actually mean is "Deadly Reentry isn't incompatible anymore."

I thought there might've been some license problem and it went away. Nearly gave me a heart attack there :huh:

I read the post as "it isn't deadly", and so I'm like - oh - it's broke still. Darn

Share this post


Link to post
Share on other sites
The following mods work fine for me:

Aviation Lights

Cagesystem Panels

KAS

Kethane

Magic Smoke

Romfarer's Sunbeam

TacSelfDestruct

FASA Asteroids seems ok, except for a graphical glitch in the VAB when you mouseover the item in the parts panel, but the actual parts seem to be fine once launched.

Magic Smoke (Infernal Robotics) isn't working for me, but KAS and Kethane are.

Share this post


Link to post
Share on other sites

Remove Home_Powerplant from GameData, it allows the game to load, but I haven't teste

So, .23 is out, and it might have some implications for those who use mods.

First, has anyone found any mods that definitively aren't compatible with .23?

Second, with .23's claims of optimization, exactly how many more mods can one install now, while keeping ksp stable?

Share this post


Link to post
Share on other sites

B9's Sabres seem to be broken, Modular Fuel System doesn't work at all (can't adjust fuels or anything). Haven't been able to do much because none of my rockets have useable fuel.

Not using RSS at the moment so I can't report on that, can't test FAR because no engines, but B9's engines all seem to be broken.

AIES works fine it seems, and Procedural Fairings seems to be fine as well

Edited by Mmmmyum

Share this post


Link to post
Share on other sites
What shall we do with Universe Replacer and enhanced textures? Uninstall or keep it for .23?

May I suggest using Texture Replacer instead? It's working fine for me.

Share this post


Link to post
Share on other sites

I've had no issue with KAS katex-3, whats happening for you?

as an addition i'd like to say, i've had no issues with B-9, Fire Spitter(besides perma-brake wheels), and Kerbal Interstellar pack, i've had some small issues with Kethane (drill is broken, and wont read it being deployed making my mining null and impossible), and Romferor Lazor system, seems to not work, though the game does not crash.

Edited by Kaethorin
wanted to add in working/ non--working mods for me

Share this post


Link to post
Share on other sites

Can someone please tell me which mods could be causing ships to only partially load in the VAB? since updating to .23 If i load a ship only a small part of it loads and the rest is invisible. also attachment points on the part that did load are all messed up and stacking is not working for it. Starting a new ship seems to work though.

Share this post


Link to post
Share on other sites
What shall we do with Universe Replacer and enhanced textures? Uninstall or keep it for .23?

Universe Replacer seems to be working fine for me in 0.23, as is BoulderCo's Texture Compressor.

Share this post


Link to post
Share on other sites

I've had a slight issue with Firespitter- nothing serious or game breaking, but with the updated version (which is awesome btw), the lift display in the SPH don't seem to be working... Could be a clash with FAR, possibly?

Share this post


Link to post
Share on other sites
I tried that "working dev version" of mechjeb. About the only thing working is the mechjeb case is available as a part. Other than that its basically useless. The main tab isn't even there...

Works for me. It just unpacks the files in the wrong place, so you have to stick them into the right folder for mods yourself.

Sort the folders out BEFORE LOADING THE GAME. I lost my Duna mission to that, had to quickload to get it back.

Share this post


Link to post
Share on other sites
Magic Smoke (Infernal Robotics) isn't working for me, but KAS and Kethane are.

Hmmm that's strange. I tested out each and every one of the items from robotics and they all work normally. Speed adjustments work normally, items move normally. What problem are you having specifically, I'll try to replicate it...

Share this post


Link to post
Share on other sites
"MechJeb2-2.1.0.0-136" is working for me.

I believe this is the latest version:

http://jenkins.mumech.com/job/MechJeb2/lastBuild/

Did you try (un-)docking? This makes it crash over here:

[EXC 19:59:30.181] NullReferenceException: Object reference not set to an instance of an object
[ERR 19:59:30.203] MechJeb module MechJebModuleThrustController threw an exception in Drive: System.NullReferenceException: Object reference not set to an instance of an object
at MuMech.CelestialBodyExtensions.RealMaxAtmosphereAltitude (.CelestialBody body) [0x00000] in <filename unknown>:0
at MuMech.VesselState.TerminalVelocity () [0x00000] in <filename unknown>:0
at MuMech.MechJebModuleThrustController.TerminalVelocityThrottle () [0x00000] in <filename unknown>:0
at MuMech.MechJebModuleThrustController.Drive (.FlightCtrlState s) [0x00000] in <filename unknown>:0
at MuMech.MechJebCore.Drive (.FlightCtrlState s) [0x00000] in <filename unknown>:0
[LOG 19:59:30.388] Docking to vessel Minimus QuadroLaunch MKII
[EXC 19:59:30.530] StackOverflowException: The requested operation caused a stack overflow.

Edited by moemoe

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this