Sign in to follow this  
jfull

.23 and Mods

Recommended Posts

Deadly Reentry isn't anymore. Thank taniwha and arsenic87. :)

In that case it may just be that I've made a mistake; but I can't find any of the parts for it... The mechanics are working okay, but the parts are missing, even from Sandbox.

Share this post


Link to post
Share on other sites

Apparently Kethane won't display the overlay if any other of your mods with pluggins aren't up to date.

Share this post


Link to post
Share on other sites
Did you try (un-)docking? This makes it crash over here:

No, I'm doing career mode and I have not gotten to docking ports yet.

Well try it when I get to them. I also still use ORDA for docking, but will try Mechjeb too.

Share this post


Link to post
Share on other sites
Apparently Kethane won't display the overlay if any other of your mods with pluggins aren't up to date.

That doesn't make much sense. How would it know what's going on with other mods?

Currently running HOME/DEMV4 from bobcat, chatterbot, ehanced navball, firespitter, Jool V Heavy Launcher, Kerbal Engineer, Kethane, KSPX, MechJeb2, Orbital Construction, Planet Factory, TAC fuel balencer and Alarm Clock. All seem to be working (haven't rigerously tested most of them since I'm in career mode) but no kethane overlay in map view.

Edited by The Ideal Gas Lawyer

Share this post


Link to post
Share on other sites
That doesn't make much sense. How would it know what's going on with other mods?

Currently running HOME/DEMV4 from bobcat, chatterbot, ehanced navball, firespitter, Jool V Heavy Launcher, Kerbal Engineer, Kethane, KSPX, MechJeb2, Orbital Construction, Planet Factory, TAC fuel balencer and Alarm Clock. All seem to be working (haven't rigerously tested most of them since I'm in career mode) but no kethane overlay in map view.

If there is a bug in some displays in one if the mods, it likely affects the rest of the mods on the same updateloop. There is a bug in TAC fuel balancer that doesn't show GUI, so perhaps uninstalling that?

Share this post


Link to post
Share on other sites
If there is a bug in some displays in one if the mods, it likely affects the rest of the mods on the same updateloop. There is a bug in TAC fuel balancer that doesn't show GUI, so perhaps uninstalling that?

I'll give it a shot when I get home from work but TAC seems to be working fine, GUI and all. I used it with the KAS pipes to rescue a science mission that got stuck on the moon

Share this post


Link to post
Share on other sites
That doesn't make much sense. How would it know what's going on with other mods?

Currently running HOME/DEMV4 from bobcat, chatterbot, ehanced navball, firespitter, Jool V Heavy Launcher, Kerbal Engineer, Kethane, KSPX, MechJeb2, Orbital Construction, Planet Factory, TAC fuel balencer and Alarm Clock. All seem to be working (haven't rigerously tested most of them since I'm in career mode) but no kethane overlay in map view.

It is very odd, but Majiir seemed to confirm it. Says he's working on a fix.

I think the main incompatible mod I have at the moment is Near Future Propulsion, the reactors aren't working, which is unfortunate, because I'm powering my Kethane Base with one.

Edited by jfull

Share this post


Link to post
Share on other sites

I found that EVA chutes are hit or miss. A few times deploying the chute accelerated my kerbal very quickly into the ground.

The Spy Camera mod disables after one film is transferred to the film pod.

I haven't had time to test the very few other mods I have.

Share this post


Link to post
Share on other sites
Beer Swiggler and Jointify appear to be broken, but Drank Too Many Martinis And Gonna Be Late For Work is working fine.

Man..... I've been trying to hold off on buying more martini fixings. I almost gave in yesterday and now you got me thinking again.

Share this post


Link to post
Share on other sites

Having read that the following mods should all be working with 0.23, I installed the following:

Remote Tech

Scansat

Deadly Reently

Ioncross crew support

Kethane

Interstellar

Engineer

When I started a new career, the tree loader from Interstellar came up and I selected the Interstellar tree. In the VAB there were no command pods to choose from. The only parts available were from Deadly Reentry and Engineer.

I'll have to go through one by one tonight to see what is going on, but has anyone seen this before?

Share this post


Link to post
Share on other sites
Currently running HOME/DEMV4 from bobcat, chatterbot, ehanced navball, firespitter, Jool V Heavy Launcher, Kerbal Engineer, Kethane, KSPX, MechJeb2, Orbital Construction, Planet Factory, TAC fuel balencer and Alarm Clock. All seem to be working (haven't rigerously tested most of them since I'm in career mode) but no kethane overlay in map view.

What is the currently working version of Orbital Construction? I haven't messed with it for a couple of versions, so I wanted to try it again.

Share this post


Link to post
Share on other sites

I have about a dozen mods installed, and about half of them have not updated to the new version. My Kethane grid displays fine unless I turn my view so I can't see the center of the planet. Which, I believe, is normal.

Share this post


Link to post
Share on other sites
That doesn't make much sense. How would it know what's going on with other mods?

Kethane has a plugin system for resource generators. Plugins built for the wrong KSP version can crash the loader when it looks for resource generators. I've addressed the issue, and the fix will be in the next Kethane release.

Share this post


Link to post
Share on other sites
Really!? The latest DEV build (4.0) already bugged out in 0.22 for me. What version are you using?

For me, it was buggy in .22, and in .23 it stayed the same. For all intents and purposes it still scans the surface and writes to .csv, but everytime you go back to a satellite to continue scanning, the display on screen defaults to blank. It will continue to append to the .csv file, but it looks like you start completely over in the game itself.

err...this was intended for isa mapsat

Edited by johngault007
Forgot the Mod Name...duh

Share this post


Link to post
Share on other sites
Really!? The latest DEV build (4.0) already bugged out in 0.22 for me. What version are you using?

I use the latest version too - works ok for me, but I have to be a bit careful about how many other mods I load. YMMV I guess.

Share this post


Link to post
Share on other sites

My question is this, is there a non dev build mechjeb operational yet for .23? Also any new installs for the following:

Romfarers lazor docking cam

Novapunch pack

Procedural fairings

Be kind in your replies pls I'm doing this atm from an iPhone so I can't fully research it

Share this post


Link to post
Share on other sites
My question is this, is there a non dev build mechjeb operational yet for .23? Also any new installs for the following:

Romfarers lazor docking cam

Novapunch pack

Procedural fairings

Be kind in your replies pls I'm doing this atm from an iPhone so I can't fully research it

Earlier in the thread, folks have confirmed NovaPunch and Procedural Fairings working. I think Lazor was listed on the first page as broken.

There seems to be a dev build for MechJeb that works with the newest 0.23. Not sure how stable it is, though.

Share this post


Link to post
Share on other sites
My question is this, is there a non dev build mechjeb operational yet for .23? Also any new installs for the following:

Romfarers lazor docking cam

Novapunch pack

Procedural fairings

Be kind in your replies pls I'm doing this atm from an iPhone so I can't fully research it

You can always get the latest MechJeb build here. It works beautifully. Novapunch has not been updated and has some issues. Lazor docking cam and procedural fairings have both been updated for 0.23 and work fine. I'm using both.

Share this post


Link to post
Share on other sites

Ive heard the dev build mj has issues which is why i asked if there was a NON DEV BUILD version that was up

Share this post


Link to post
Share on other sites

Yeah...with mod updates coming out so fast, (daily or even several times a day.. (THANK you mod devs!! :thumbsup:)), right on the heels of 0.23, I think its a bit too early to be whining about whats not updated or working for it yet....give it a month or so, and that might be another matter, though...lol

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this