Jump to content

[1.12.x] Ship Manifest (Crew, Science, & Resources) - v 6.0.6.0 - 19 Jan 22


Papa_Joe
 Share

Recommended Posts

It's in Ship Manifest's settings. If you scroll down to the bottom of the list, you'll see two circle. One's enable debug log on error and the other is enable debug window, or something like it. Uncheck the second option, and it goes away. Uncheck the first option and it should stop popping up.

Link to comment
Share on other sites

Hello i'm having trouble with ship manifest-kas-mks... all mods works good until i use two pipe end point (from kas) to "dock" 2 vessels and transfer fuel. when i link both pipe end point and open the ship manifest gui the slider to adjust the amount of fuel or resource doesn't move (can't change the digits above neither) and when i click "xfer" a small amount of fuel is transferred (i don't remember what i did but i realized that a fuel tank ended with negative values).

Quick save and load doesn't fix this.

Unlink the pipe end points doesn't fix this.

to get ship manifest work back i need to go back to space center and get back to my vessel (docked-linked) or restart the game.

And finally i got this error when i link with pipe end point 2 parts of my base (MKS) there's a lot of resources.

Error:  in drawGui.  Error:  Operation is not valid due to the current state of the object 

at System.Linq.Enumerable.Single[KeyValuePair`2] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.Single[KeyValuePair`2] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0
at ShipManifest.ManifestController.get_Vessel () [0x00000] in <filename unknown>:0
at ShipManifest.ManifestController.drawGui () [0x00000] in <filename unknown>:0

Sorry for my English :sealed:

Link to comment
Share on other sites

Hello i'm having trouble with ship manifest-kas-mks... all mods works good until i use two pipe end point (from kas) to "dock" 2 vessels and transfer fuel. when i link both pipe end point and open the ship manifest gui the slider to adjust the amount of fuel or resource doesn't move (can't change the digits above neither) and when i click "xfer" a small amount of fuel is transferred (i don't remember what i did but i realized that a fuel tank ended with negative values).

Quick save and load doesn't fix this.

Unlink the pipe end points doesn't fix this.

to get ship manifest work back i need to go back to space center and get back to my vessel (docked-linked) or restart the game.

And finally i got this error when i link with pipe end point 2 parts of my base (MKS) there's a lot of resources.

Error:  in drawGui.  Error:  Operation is not valid due to the current state of the object 

at System.Linq.Enumerable.Single[KeyValuePair`2] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.Single[KeyValuePair`2] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0
at ShipManifest.ManifestController.get_Vessel () [0x00000] in <filename unknown>:0
at ShipManifest.ManifestController.drawGui () [0x00000] in <filename unknown>:0

Sorry for my English :sealed:

I've been having the same issues... Started first using MKS modules (which are essentially attached using KAS pipes). But I also was having similar problems with another ship which did not have KAS parts attached.

Link to comment
Share on other sites

https://www.dropbox.com/s/cx7ot1fo89opkuv/output_log5.txt?dl=0

Throwing this log up if anyone can find it useful. Got a weird flying-away-from-the-camera bug, then Ship Manifest threw up a debug screen with an error a few moments later, but I clicked clear instead of save, so hopefully there's something still in the log. It's a good 10 megs, was getting alot of "Input is Null" and "Current crew is 6, cannot be more than 0" errors, not sure if that's SP related or not.

Link to comment
Share on other sites

Hey all.

Back from my work binge. Just starting to slog thru the posts and my code in light of 0.24.2.

I will be posting soon. I'm thinking of getting a quick fix out, that corrects the most glaring issues quickly. after that, I will start on the highlighting nightmare that exists with changing vessels...

Thanks for your patience!

Link to comment
Share on other sites

In a summary what does this mod do or tries to do? I've read the OP but it is unclear what's the purpose. Does it work with latest KSP? 0.24.2?

I can transfer science via Kerbal EVA, go take sample or data, store them in a different module.

Transfer Kerbals via EVA.

Pump fuel around or get TAC fuel balancer for the features that are useful in regards to fuel.

What's a Ship manifest for?

To move Kerbals without going EVA and only click a button or drag their name between modules? etc. similar for other resources on the ship? Like a different interface to pump fuel around that is more user friendly?

Link to comment
Share on other sites

Hi guys, first post here.

I've been having problems making this mod work. I have the toobar installed (1.7.6), the module manager (2.3.5) and a ton of different mod (MechJeb, FAR, B9, KAS, KW Rocketry, etc.).

My problem is the button doesn't appear on the toolbar. It just doesn't appear. I've downloaded the Connected Living Space mod that works with this one and it appears, but this one doesn't and I don't know why.

Any help?

Link to comment
Share on other sites

In a summary what does this mod do or tries to do? I've read the OP but it is unclear what's the purpose. Does it work with latest KSP? 0.24.2?...

The reason for using this or another mod to transfer science and other resources is that it can be a pain to right-click, alt-right-click the parts/tanks you want to move them between without a mod, especially if you have to keep moving the camera around to see first one, then the other and particularly if you have some parts hidden within fairings or some other structure that are really hard to click ever.

The reasons for using this or another mod to move Kerbals around is that it doesn't make sense - and is a huge waste of time - for them to have to suit-up, exit the vehicle and do an EVA just to move between, say, two adjacent hitch-hiker cans. Apollo astronauts didn't do EVA to get to and from the lander - they went through the airlock/docking ports.

The reason to use ShipManifest instead of a couple of other mods is that this does it all - Kerbals and all resources.

Link to comment
Share on other sites

Thanks Pecan.

@ jackCY: You are absolutely correct. This mod does nothing you cannot to in game without mods.

In fact, you do not need any mods to play KSP. There are some that will NEVER install a mod. EVER. That is the beauty of this game. Play it the way you want. Use it, don't use it, your choice.

I on the other hand, have 20+ mods installed, and play a much different game than you. Not better, just different. So, to those that find value in my mod Thanks! For those that don't, Thanks!

Finally, it does work with 0.24.2

In other news, Update pending. Verifying DMagic support code is working as intended. I have not merged recently, mainly to get a working version out there. I will dive deeper, once we have a stable version "in the wild"

Please note that highlighting in CLS mode is still not right, and will take some work to fix. I'm hoping you don't get any errors, just weird highlighting issues. I did add a close button to the debug window, so at least you can close it right there :P

Edited by Papa_Joe
Link to comment
Share on other sites

Nice to read about some progress :)

Btw would be cool if you could add support for Tarsier Space Tech parts too. Ship manifest does not detect it as science containing. So the parts get not listed.

I'm in the midst of rewriting the science transfer and detection. I was using ModuleScienceContainer and ModuleScienceExperiment. I added partial IScienceDataContainer support, but it was incomplete. Correcting that now.

Should detect anyting implementing IScienceDataContainer now. DMagic and Tarsier both use that...

Link to comment
Share on other sites

Ok.

Almost there. testing my Toolbar detection code now. This version will include optional toolbar support. This mod is now dependency free.

I expect a release today (CDT).

Release!

Version 0.24.2_3.3.2 - 28 Sep, 2014 - 0.24.2 and bug fixes edition

- New: Ship manifest is now dependency free. You don't need other mods to use Ship Manifest.

- New: Blizzy Toolbar is now optional. If you install it, you can enable it. Off by default.

- New: Removed auto enable of CLS. CLS is now Off by default. If CLS is installed, can be turned on in Settings.

- New: Bug fixes to correct crashing and errors on startup.

- New: Added Close button to Debug window.

- New: Revised Science transfer code to ensure compatibility with DMagic Parts (i hope).

- Other Undocumented changes. I was in the middle of other updates (bug fixes) when 0.24.2 hit.

0.24.2_3.3.2 Is now live. I still have issues with CLS and highlighting. I'm reworking the way I do business there. That and hatches will likely be the last features in Ship manifest.

Scream loudly if you feel Ship Manifest needs anything else... make your case.

Let me know about any issues. I've added a close button to the debug for convenience. I'm also hoping that science behaves. let me know there. as well.

Thanks to all for your patience, for using the plugin, and thanks for the feedback!

Edited by Papa_Joe
Link to comment
Share on other sites

I got this log:

Info: CLS Installed? False

Error: in OnVesselChange. Error: Object reference not set to an instance of an object

at ShipManifest.ShipManifestBehaviour.OnVesselChange (.Vessel newVessel) [0x00000] in <filename unknown>:0

It happened after launch of ship and when the mod Science Alert alerted me of science. I click on Science Alert for the first time and then clicked EVA report from SE mod, then this error came up from Ship Manifest.

Link to comment
Share on other sites

Good works with DMagic devices. thanx

Awesome. I was hoping I got it resolved.

I got this log:

Info: CLS Installed? False

Error: in OnVesselChange. Error: Object reference not set to an instance of an object

at ShipManifest.ShipManifestBehaviour.OnVesselChange (.Vessel newVessel) [0x00000] in <filename unknown>:0

It happened after launch of ship and when the mod Science Alert alerted me of science. I click on Science Alert for the first time and then clicked EVA report from SE mod, then this error came up from Ship Manifest.

Thanks. I'll log it and start investigation.

Edited by Papa_Joe
Link to comment
Share on other sites

Awesome. I was hoping I got it resolved.

Thanks. I'll log it and start investigation.

If you need my KSP log for it I saved it and I can also give you a mod list too, just let me know if you need it.

It happened again, so I can report it happens when I start a new career mode and the first time I ever click on the Science Alert, then click SE EVA report. It happens when the Kerbal EVAs. I don't get it any time after, just like that first time.

Link to comment
Share on other sites

If you need my KSP log for it I saved it and I can also give you a mod list too, just let me know if you need it.

It happened again, so I can report it happens when I start a new career mode and the first time I ever click on the Science Alert, then click SE EVA report. It happens when the Kerbal EVAs. I don't get it any time after, just like that first time.

Also, if this helps I am not using CLS mod.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...