Jump to content

[v0.24] Tarsier Space Technology (v4.5c Now with GALAXIES!!!)


tobyb121
 Share

Recommended Posts

Any plans to provide an alternate download? KerbalStuff maybe?

What's wrong with curse, I'm loathed to upload elsewhere as it's just another step when I want to release a build, and I've had no problems with curse that would particularly want to make me switch.

Link to comment
Share on other sites

I don't know if this helps, but I've noticed that there are two options. When I used Curse for the first time, I used kerbal.curseforge.com. Couldn't understand why people disliked it so much. But I forgot to bookmark it. So next time I was using Curse, I used curse.com - and I thought; WTF! Where are all my subscriptions? Why do I have to pay to see them?

So maybe you should link to: http://kerbal.curseforge.com/ksp-mods/222276-tarsier-space-technology instead?

Curse and CurseForge are, at least for me, two completely different experiences.

Link to comment
Share on other sites

The scopes work but Im getting null reference exceptions spam, when i click the show galaxies button.

In the galaxies.cfg file the url you have for the pictures does not include the files extension, dunno if your dll automatically recognizes the filetype though.

Other than that, what is the purpose of the science lab? Its identical to the stock, only you have removed its crew capacity and the science modules.

Im on 64bit, in sandbox mode btw, and the KSP.log doesnt show anything out of the ordinary, beside the exceptions.

EDIT: I also saw this post while searching the pages here:

FYI, I got a bug report in my thread that I think is related to your mod. It seems to be throwing a NullReferenceException in TSTProgressTracker.OnLoad.

Could that be related ?, since im using TAC as well.

Edited by Thourion
Link to comment
Share on other sites

The scopes work but Im getting null reference exceptions spam, when i click the show galaxies button.

I am having the same problem. tobyb121 told me it might be mod related, but i yet have to provide him a a list of the mods i have installed (there are quite a lot).

Link to comment
Share on other sites

I am having the same problem. tobyb121 told me it might be mod related, but i yet have to provide him a a list of the mods i have installed (there are quite a lot).

I dint have the time earlier to do this (RL stuff), but i just went and put this mod on a total clean installation. I was still getting the same errors. I spoted a bright blinking thing while in orbit at some point, while looking through the scope, and after i zoomed in (along with jkli controls), i was able to zoom and take a picture of what it seemed like a total white monolith lol, and the game text said it was the purple nebula..

Dunno, maybe its a 64 bit issue? Or something went loose with the latest update.

Link to comment
Share on other sites

Hey !

I can't find help anywhere for my problem, so try it here.

i installed the mod and i can build anything from it. but i can't right - click ont it , so i can't use the parts. (ok, to be precise, i can click but nothing happens when i am doing it)

i am playing sandbox mode.

how can i FIX this , please ?!

Link to comment
Share on other sites

I've had a look through the log but it doesn't look like the problem is with TST from an initial look. I would recommend removing all of your mods and adding them one at a time until you find the problem

I tried a fresh copy of ksp with all the mods and it didn't work but right after i removed tst it now loads to the menu screen so either its a problem with tst or module manager isn't updated (gonna try that)

EDIT : Updating module manager seems to have fixed it

Edited by Anduqwer
Link to comment
Share on other sites

I tried a fresh copy of ksp with all the mods and it didn't work but right after i removed tst it now loads to the menu screen so either its a problem with tst or module manager isn't updated (gonna try that)

EDIT : Updating module manager seems to have fixed it

Glad to hear you got it working, not sure why module manager would interfere, I don't any of the module manager stuff in my mod? Maybe it didn't like the galaxies stuff??
What is the different between this Mobile Processing Lab and the stock one? Besides stock can hold crew.

Woops!!! You weren't supposed to see that yet!!! It is the next part I'm working on, currently does nothing but I must have left it in by accident when I built the latest version....for now it can be safely ignored :)

Link to comment
Share on other sites

Has anyone followed up on the problem someone brought up eariler?

*checks past pages*

Mauzdar was the one to bring it up i think.

I'll include logs at the bottom.

*prepares screens* <-actually has KSP open on other screen

*realises halfway through post that I can just use the url links, feels silly, fixes*

here the galaxies are hidden, framerate is pretty good, however there is epic spam of that null object exception thing in debug.

Galaxies "showing", framerate like halved. new spam message complaining about key not found.

Here is when I pause the game, with the galaxies "showing", "Cross" still visable. no more null object errors, but now the key errors are spamming and do not stop even when game paused.

I hid galaxies and paused and quickly un-paused/paused then took the screen, the object reference errors stop when game is paused.

now for the annoying bug/issue/Feature! :D

SCANsat does not work with tarsier installed. I know it is TST due to installing mods one by one with the first two being mechjeb and SCANsat. I have a feeling that it has something to do with the gui issues that come with TST (for me at least)

Also, minor and major gui issues occur with telescopes, i'm not sure about anything else, though it might be the science module, but i think issues happened without. however, mechjeb seems to be utterly immune to gui glitches, thank goodness.

Screens:

Science window glitch

SCANsat doesn't work, no readings and no animations

Science windows only open when game paused. ie. click log "xxxxx" --> no windows open, ever. --> pause game and then science window opens --> unpause and window is still open and can use as normal

Interestingly some gui glitches are fixed ONLY while game paused, but glitches reappear as soon as unpaused.

Interesting TST debugs

Log for this kerbal session:

https://www.dropbox.com/s/q4cpuo7gz4a3mnc/KSP.log?dl=0

Mods:

(In order of installation)

MechJeb

SCANsat

B9 Aerospace

KWRocketry

TST

hope this helps

Link to comment
Share on other sites

@vovlangor Yeah i hope toby sees this and finds a fix. Like i said in my earlier posts, i have the same thing happen to me on a clean install. So i dont think its related just to mod conflicts.

Although in my case i dont get null reff exceptions if i dont click "show galaxies", and also once i show them and get the errors spam, if i hide them afterwards the messages stop again.

And im also getting the "cross" thing you have on your pics.

Link to comment
Share on other sites

I'll take a look at those logs when I have some time, probably at the weekend now, I know someone a few pages back had a problem with an older version on module manager causing problems, even though this isn't used in TST. Even if you didn't install module manager some other mods install include so take a good look around and delete all old versions then try to upgrade to the lastest. May not be a fix for everyone but worth checking

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...