Jump to content

InfiniteDice -=Skillful=- Combat Damage & Weapons Mod


Recommended Posts

InfiniteDice, I've changed my turret keybindings and those work fine, but when I try to change the keybindings of the stationary guns, I can't seem to find the place to put the variable?

Any assistance would be appreciated.

(I don't have a home key)

Link to post
Share on other sites
InfiniteDice, I've changed my turret keybindings and those work fine, but when I try to change the keybindings of the stationary guns, I can't seem to find the place to put the variable?

Any assistance would be appreciated.

(I don't have a home key)

Inside:

MODULE

{

name = projectileWS

}

just add:

customFire = Home

Follow this link in the first post of the thread/or user manual for the different keys you can assign.

Link to post
Share on other sites
Hello Infinite. I have tested your mod for some time and i have found some issues. I'll try to explain them as well as i can. First of all, i have tested the mod both with a stock KSP and a strongly moded KSP. The issues happen in both installs.

The rocket pod mount has a serious issue:

The rocket pod mount has a big issue. When you load the rockets on EVA an extra rocket spawns in middle of the air between the ship and the ground, or inside the ship's structure. This rocket seems to be linked to the ship and if you try to take off the ship starts to wobble and breaks apart. Also, when you load a missile pod, the parts on the ship change their position slightly ( idon't know if this bug is related to the other one).Thanks for creating this amazing mod InfiniteDice.

The pod might be very picky on where it's placed. If you see my included tank craft it doesn't have issues as far as I know. I've mounted these on aircraft and spacecraft as well... I'll keep my eyes open for someone else having the problem and try to figure out what it could be. Off the top of my head, it could be a clipping issue, try to space the pod out further from the body, perhaps with a small truss box, see if that changes anything.

Link to post
Share on other sites
The pod might be very picky on where it's placed. If you see my included tank craft it doesn't have issues as far as I know. I've mounted these on aircraft and spacecraft as well... I'll keep my eyes open for someone else having the problem and try to figure out what it could be. Off the top of my head, it could be a clipping issue, try to space the pod out further from the body, perhaps with a small truss box, see if that changes anything.

I have tested the problem further, and i have discovered that it only happens if i select the ordinance and load the pods on EVA. If you select the ordinance and load the missiles on the hangar (previously to the launch), the strange extra missile dosen't spawn (in that case you can rearm the missiles on EVA without problems too).

Link to post
Share on other sites
I have tested the problem further, and i have discovered that it only happens if i select the ordinance and load the pods on EVA. If you select the ordinance and load the missiles on the hangar (previously to the launch), the strange extra missile dosen't spawn (in that case you can rearm the missiles on EVA without problems too).

Awesome... see in testing I had always loaded the pod in the hangar first. I'll need to make a fix but for now... preload the pod in the hangar. Thanks for figuring that out.

Link to post
Share on other sites
With any glitch report please list what other mods you have installed, it will help with diagnosing this stuff. Kingster not sure what it could be other than some form of mod compatibility issue. I've loaded this thing about 200 times today. I think I had one crash in all that time. Get me more details.

DO you want the crash report.

Link to post
Share on other sites
Awesome... see in testing I had always loaded the pod in the hangar first. I'll need to make a fix but for now... preload the pod in the hangar. Thanks for figuring that out.

I'm glad to help :)

Now, it is time for airship combat!

kUrNB1B.jpg

Link to post
Share on other sites
uhm... installation instructions? do i just put it into gamedata? or put the individual folders in the ksp ffolder??

Standard installation... the IDSkillfulR1 folder goes into the Gamedata folder. Make sure there is only ONE IDSkillfulR1 folder, some methods of extraction will double the directory. So inside IDSkillfulR1 you'll have all the standard folders: Parts, Effects, Sounds, etc...

Link to post
Share on other sites
Standard installation... the IDSkillfulR1 folder goes into the Gamedata folder. Make sure there is only ONE IDSkillfulR1 folder, some methods of extraction will double the directory. So inside IDSkillfulR1 you'll have all the standard folders: Parts, Effects, Sounds, etc...

please just put this on the front page... i got confused and broke my game without a backup :(

(oh well... no prob to fix)

Link to post
Share on other sites

Special Instructions for adding the targeter to any cockpit:

On the external part cfg add:

MODULE

{

name = cockpitMemory

}

In the Internal space region of the part cfg - (look for the other ones) put:

PROP

{

name = IDtargeterProp

position = 0, 0.5, -0.625

rotation = 0, 0, 0, 1

scale = 1, 1, 1

}

That should add the reticule to any cockpit. Read the manual for how to adjust the targeter.

The targeter is NOT perfect. It's a demo I made to help with aiming. In some cases (from a fixed view ie: cockpits) it helps your eye identify the impact area better. I've scored some good hits using it.

Once adjusted the targeter will remember it's position for that vessel. When you load a new instance of the craft you'll need to adjust those as well. These adjustment keys are not changeable and are aggravating to use.. sorry as I said it's not perfect.

Want to add the targeter to any part? Put this in that parts cfg (remember it might spawn INSIDE the part... so you'll need to use the adjustment keys until you can see the targeter - the targeter is only viewable from ONE side!):

MODULE

{

name = IDtargeterEXT

}

MODULE

{

name = cockpitMemory

}

I'm not supporting the targeter... it's just a test solution, so if it works for you great... if not, sorry. :) A better solution might be coming in R2.

Edited by InfiniteDice
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...