Firov

[1.0.4] Smart Parts v1.6.6 | DDS Textures and Bug Fixes | July 5

Recommended Posts

May i request an additional smart part? A resource monitor (RM) which will fire an event (like the altimiter) when a resource gets below (or above) a certain value.

Example 1: A drilling rigg. The drills consume a lot of electricity and provide ore.

actiongroup 9 starts the drills, actiongroup 10 stops the drills and disables RM3

RM1 checks if the electricity of the vessel is lower then 1000 and fires actiongroup 10 when below

RM2 checks if the ore is above 2000 (or a percentage) and fires actiongroup 10 when above

RM3 checks if the ore is below 1000 (or a percentage) and fires actiongroup 9

In this example i used electricity and ore but all resources should be made possible.

I would consider such a a great addition to KSP.

Example 2: Automatic deployment of solarpanels when batteriepower runs out

Share this post


Link to post
Share on other sites

Excellent suggestion, TheCardinal!

This enables the use of building blocks like transistors and amplifiers, logic gates etc!

Share this post


Link to post
Share on other sites
is there any way to change the trigger scale for some of these parts. ?

I am trying to use the prox sensor to trigger when 2 m from surface. The lowest number I can set is 25 meters.

I appreciate any help with this.

Thanks and cheers.

Just checking back in to see if anyone can tell me how to make the scale for the values finer or change them.

Cheers.

Share this post


Link to post
Share on other sites

Did a quick search didn't tur. Up anything to recent, so excuse this if it has been asked a lot. Is there any plans for a velocity sensor? I want to dump my LAS stage after going hypersonic on a resized system and would like a sensor for that. I don't always hit the velocity at the same altitude so the altimeter does quite meet my need. Thanks for making such a wonderfully simple to use mod!

Share this post


Link to post
Share on other sites

Smart Parts seems to be affecting my GUI in the VAB.

https://www.dropbox.com/s/5p7cflfk0hph3ra/screenshot5.png?dl=0

Throws this up in the log:

[LOG 08:43:19.407] DragCubeSystem: Creating drag cubes for part 'km.smart.alt.low'

[LOG 08:43:19.420] PartLoader: Compiling Part 'SmartParts/Parts/Smart-Controller/km_smart_fuel/km_smart_fuel'

[ERR 08:43:19.425] Exception when attempting to register listener: Lib.Stager, SmartParts, Version=1.6.6.0, Culture=neutral, PublicKeyToken=null.changeListener

[EXC 08:43:19.426] ArgumentException: Message argument is null

KSPAPIExtensions.PartMessage.PartMessageListener..ctor (System.Type delegateType, PartRelationship relations, GameSceneFilter scenes)

System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType)

System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit)

System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, Boolean inherit)

System.Reflection.MonoMethod.GetCustomAttributes (Boolean inherit)

KSPAPIExtensions.PartMessage.ServiceImpl.Register[stager] (Lib.Stager obj)

UnityEngine.GameObject:AddComponent(Type)

Part:AddModule(String)

Part:AddModule(ConfigNode)

PartLoader:ParsePart(UrlConfig, ConfigNode)

:MoveNext()

[ERR 08:43:19.430] Exception when attempting to register listener: Lib.Stager, SmartParts, Version=1.6.6.0, Culture=neutral, PublicKeyToken=null.changeListener

[EXC 08:43:19.430] ArgumentException: Message argument is null

KSPAPIExtensions.PartMessage.PartMessageListener..ctor (System.Type delegateType, PartRelationship relations, GameSceneFilter scenes)

System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType)

System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit)

System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, Boolean inherit)

System.Reflection.MonoMethod.GetCustomAttributes (Boolean inherit)

KSPAPIExtensions.PartMessage.ServiceImpl.Register[stager] (Lib.Stager obj)

UnityEngine.Object:Instantiate(Object)

PartLoader:CreatePartIcon(GameObject, Single&)

PartLoader:ParsePart(UrlConfig, ConfigNode)

:MoveNext()

[LOG 08:43:19.431] PartLoader: Part 'SmartParts/Parts/Smart-Controller/km_smart_fuel/km_smart_fuel' has no database record. Creating.

[ERR 08:43:19.433] Exception when attempting to register listener: Lib.Stager, SmartParts, Version=1.6.6.0, Culture=neutral, PublicKeyToken=null.changeListener

[EXC 08:43:19.433] ArgumentException: Message argument is null

KSPAPIExtensions.PartMessage.PartMessageListener..ctor (System.Type delegateType, PartRelationship relations, GameSceneFilter scenes)

System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType)

System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit)

System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, Boolean inherit)

System.Reflection.MonoMethod.GetCustomAttributes (Boolean inherit)

KSPAPIExtensions.PartMessage.ServiceImpl.Register[stager] (Lib.Stager obj)

UnityEngine.GameObject:SetActive(Boolean)

DragCubeSystem:SetupPartForRender(Part, GameObject)

:MoveNext()

UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)

:MoveNext()

UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)

:MoveNext()

[LOG 08:43:19.434] DragCubeSystem: Creating drag cubes for part 'km.smart.fuel'

[LOG 08:43:19.447] PartLoader: Compiling Part 'SmartParts/Parts/Smart-Controller/km_smart_proximity/km_prox_sensor'

Share this post


Link to post
Share on other sites

@Daveroski: Can you try the tweaked .dll I posted in post #472?

The tweak I did to fix slotter's issue also dealt with the KSPAPIExtensions .dll so with a lot of luck it might also fix your issue.

Alternatively can you check to make sure you only have one KSPAPIExtensions.dll file in your GameData directory? People have reported issues with multiple versions of KSPAPIExtensions installed before.

D.

Share this post


Link to post
Share on other sites

I'm using this mod a lot and it's awesome! BUT, I noticed that when using the Real Chute mod the altimeter sensor can't stage the parachutes. The light turns red so it's activated, but the stage icon of the parachute doesn't change color. Instead, if I manually stage, the icon turns blue and it means that the parachute is being deployed.

This time I double-checked, I'm sure it doesn't work! :sticktongue:

Thanks in advance.

Share this post


Link to post
Share on other sites
is there any way to change the trigger scale for some of these parts. ?

I am trying to use the prox sensor to trigger when 2 m from surface. The lowest number I can set is 25 meters.

I appreciate any help with this.

Thanks and cheers.

Hey drtedastro. What you're wanting to do actually is possible. The arrows are for moving in larger increments. If you want to set the altimeter (or any smartpart) in finer increments you can click and drag directly on the green bar. So adjust the distance to 0 meters using the arrows, then drag the green bar until it gets up to 2 meters.

May i request an additional smart part? A resource monitor (RM) which will fire an event (like the altimiter) when a resource gets below (or above) a certain value.

...

In this example i used electricity and ore but all resources should be made possible.

I would consider such a a great addition to KSP.

Example 2: Automatic deployment of solarpanels when batteriepower runs out

This is actually already possible, to a certain extent, using the "Drainex 1" auto stager. It can't detect if a resource goes above a certain level, but it is capable of detecting any resource (including electric charge) dropping below the predefined percentage.

Did a quick search didn't tur. Up anything to recent, so excuse this if it has been asked a lot. Is there any plans for a velocity sensor? I want to dump my LAS stage after going hypersonic on a resized system and would like a sensor for that. I don't always hit the velocity at the same altitude so the altimeter does quite meet my need. Thanks for making such a wonderfully simple to use mod!

This has been asked for a couple of times, and is definitely something I will consider adding in the future once I finish fixing some of the minor issues that have cropped up and developed the intra-vessel proximity detector.

Smart Parts seems to be affecting my GUI in the VAB.

https://www.dropbox.com/s/5p7cflfk0hph3ra/screenshot5.png?dl=0

Throws this up in the log:

...

I'll be honest. So far, I'm not having much luck tracking down exactly what's causing this bug. It's related to KSPAPIExtension and it's resource change tracking, but I don't know why it's causing these null argument exceptions. Out of curiosity, beyond the log messages, what actual effects are you seeing ingame, and when are you seeing them? That might help me localize the source of this particular error.

I'm using this mod a lot and it's awesome! BUT, I noticed that when using the Real Chute mod the altimeter sensor can't stage the parachutes. The light turns red so it's activated, but the stage icon of the parachute doesn't change color. Instead, if I manually stage, the icon turns blue and it means that the parachute is being deployed.

This time I double-checked, I'm sure it doesn't work! :sticktongue:

Thanks in advance.

Honestly, I've never had good luck trying to stage RealChutes parachutes. To confirm, I just tested it and staging it fails to deploy the chute, whether it's being staged manually by me or by a smart part. However, activating it via action group (arm or deploy), it works perfectly. Honestly, I think this may be an issue with RealChute since the stage function on SmartParts is functionally identical to you hitting the stage button. You may want to bring this up in the RealChute thread.

Share this post


Link to post
Share on other sites
@Daveroski: Can you try the tweaked .dll I posted in post #472?

hey Diazo I noticed the same exceptions in my log and went and tried out your updated DLL - it worked. The exceptions are gone

Share this post


Link to post
Share on other sites

I can't find any smart-controllers parts. I think that the folder for them is not loading. I did find the breakers, and the valve. :\ Anyone else had this problem before? It's 6am, so I'm pretty useless at the moment. lol. Although I don't think it is user error.

Share this post


Link to post
Share on other sites

I am trying to get two probes to transfer to minmus together with the remote control, however the throttle does not relate in real time. Am I doing something wrong? When I clock transmit throttle the other probe just goes full throttle even though the active vessel is at 0 throttle.

Share this post


Link to post
Share on other sites

@blnk2007: If you check the part's right-click menu, I believe their is a setting in there for the level of throttle to send. It does not match your current vessel's throttle setting as far as I know.

D.

Share this post


Link to post
Share on other sites

@Sobanaut: Pretty sure that is an issue with KSPAPIExtenstions.

Can you search your GameData and make sure you only have one copy of it present please?

D.

Share this post


Link to post
Share on other sites

@Diazo

Yeap, I got 4 of them) But they are all in different mod folders. Are they all the same and I can leave just 1 in one of the folders?

Edit: On the KSPAPI Extension github page it says:

"To use these you must include the KSIAPIUtils.dll in your project rather than just copying the code as there's an election process to ensure the latest version is being run."

So does it really matter if I have more than 1?

Edited by Sobanaut

Share this post


Link to post
Share on other sites

@Sobanaut: The way KSPAPIExtentions is intended to work is that each mod that uses it supplies a copy in it's own folder and that a mod only uses the copy in it's own folder, hence the instructions in the KSPAPI thread you quoted.

Unfortunately, something went screwy in the KSP 1.0 update and having multiple copies, especially of different versions, of KSPAPIExtenstions in your GameData folder can cause issues.

The last time this missing rows issue came up, the fix was to make sure only a single KSPAPIExtensions.dll file was present in the entire GameData directory.

Removing KSPAPI from a mod's folder should not cause issues, KSP is smart enough to find the single copy of the .dll file and point any mod trying to use KSPAPI to it.

D.

Share this post


Link to post
Share on other sites

@Diazo: Understood, thanks for prompt response. Will try to leave only one copy of the .dll and report on results. Cheers

Share this post


Link to post
Share on other sites

I'd like to request that the altimeter be configurable to heights over 1000m, as I'd like to have it trigger drogue chutes in Kerbin re-entry and those should fire up around 2500m. Over Duna, the height needs to be even higher, so configuring up to 10km would be useful.

As an aside, a trigger that is able to fire chutes just when it's safe to do so would be really useful for probes in a RemoteTech world (since it can be very challenging to get them to fire otherwise).

Share this post


Link to post
Share on other sites

@Diazo Reporting back on KSPAPI.dll issues.

Steps:

1) Grabbed newest KSPAPI.dll

2) Removed all but one KSPAPI file in Gamedata and replaced it with the newest version. Result: The game didn't even load.

3) Left all KSPAPI files I had in Gamedata and replaced all of them with the newest version. Result: Voila. Everything works now.

Hope this helps

Share this post


Link to post
Share on other sites

I've got a new idea for a smart part: Toggle lights or anything else when there's no sunlight and toggle back when sunlight is detected.

Share this post


Link to post
Share on other sites
I'd like to request that the altimeter be configurable to heights over 1000m, as I'd like to have it trigger drogue chutes in Kerbin re-entry and those should fire up around 2500m. Over Duna, the height needs to be even higher, so configuring up to 10km would be useful.

As an aside, a trigger that is able to fire chutes just when it's safe to do so would be really useful for probes in a RemoteTech world (since it can be very challenging to get them to fire otherwise).

Set the altitude for chutes below where the craft will be going slow enough.

Try the "Use Kilometers" button for distances over 1000m (1km).

I was going to request cyclical activation on timers but I just realized you can add its reset option to the action group it triggers and initiate it again with a second timer started by the first ones action group.

I want chaff/flares to launch in a single salvo. I have itt alternating chaff and flares, each triggering the other's times and resetting itself.

Share this post


Link to post
Share on other sites

So you have gone through all the right channels, got this listed with NathanKell, so we shouldn't run into any more problems with your Mod bugging out due to the conflicts? I looked at the KSPAPIExtensions thread and did not see your Mod in the list of, "Approved I guess", Mods that are currently using KSPAPI?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.