Jump to content

[1.0.x] Habitat Pack v0.41


Porkjet
 Share

Recommended Posts

[...]

THIS fixes the animation issues and fixes any issues with boarding the habitat that were linked to the animations. (starting rotation doesn't deflate the centrifuge. Inflating the centrifuge does not stop rotation. You should be able to enter the habitat as long as it is inflated)

[...]

Hey, Starwaster!

Can I merge this fix with an older one (by yourself) like this?

@PART[centrifuge1]
{
@MODULE[ModuleAnimateGeneric],0
{
@name = ModuleLayeredAnimator
animationName = deploy
startEventGUIName = Deploy
endEventGUIName = Retract
actionGUIName = Toggle Deployment
layer = 1
}
@MODULE[ModuleAnimateGeneric],1
{
@name = ModuleLayeredAnimator
animationName = rotation
startEventGUIName = Spin
endEventGUIName = Reverse
toggleActionName = Toggle Rotation
layer = 2
}
}

EDIT: Ah! I acknowledge when I inflate some of the modules, they turn habitable. But:

  1. Are they accessible only by EVA?
  2. What about life support resources? I use IFI Life Support and it has a patch to add itself to every crewable part, but the inflated parts don't get affected...

Can you (or someone else) help me on this?

Edited by jlcarneiro
Added more questions to avoid double posting
Link to comment
Share on other sites

Hey, Starwaster!

Can I merge this fix with an older one (by yourself) like this?

You should get rid of the older fix. It was just a workaround of execrable quality. Just use the most recent patch file and delete anything older that I did.

EDIT: Ah! I acknowledge when I inflate some of the modules, they turn habitable. But:

  1. Are they accessible only by EVA?
  2. What about life support resources? I use IFI Life Support and it has a patch to add itself to every crewable part, but the inflated parts don't get affected...

Can you (or someone else) help me on this?

You should be able to move Kerbals into them by any means that Kerbals could ordinarily be transferred into a crew ready part. i.e, mods that transfer Kerbals, EVA Kerbals trying to enter hatch or stock crew transfer system. Please note that the inflatable will not highlight when using the stock crew transfer mechanism. Probably because it's checking the prefab instead of the part itself to see if it's crew capable for highlighting purposes. It will however still allow the transfer.

Link to comment
Share on other sites

You should get rid of the older fix. It was just a workaround of execrable quality. Just use the most recent patch file and delete anything older that I did.

Thanks!

You should be able to move Kerbals into them by any means that Kerbals could ordinarily be transferred into a crew ready part. i.e, mods that transfer Kerbals, EVA Kerbals trying to enter hatch or stock crew transfer system. Please note that the inflatable will not highlight when using the stock crew transfer mechanism. Probably because it's checking the prefab instead of the part itself to see if it's crew capable for highlighting purposes. It will however still allow the transfer.

Ok, but problems are:

  1. I can't transfer them using ShipManifest nor using stock crew transfer mecanism;
  2. I can't assign kerbals to them in VAB nor SPH;
  3. What about resources (like IFILS) are they loaded?

Link to comment
Share on other sites

Thanks!

Ok, but problems are:

  1. I can't transfer them using ShipManifest nor using stock crew transfer mecanism;
  2. I can't assign kerbals to them in VAB nor SPH;
  3. What about resources (like IFILS) are they loaded?

  1. Sounds like you don't have the plugin installed. Both the config file AND the plugin from the post that I linked to need to be installed.
  2. They can't have Kerbals in them until inflated at all. Or... what are you trying to do exactly, inflate them IN the VAB and assign Kerbals???
  3. Is that a life support mod? You should ask the mod's developer to provide support for the inflatables. Unless you want to write a config to do that. Or switch to Ioncross which supports the inflatable habs out of the box.

Link to comment
Share on other sites

  1. Sounds like you don't have the plugin installed. Both the config file AND the plugin from the post that I linked to need to be installed.
  2. They can't have Kerbals in them until inflated at all. Or... what are you trying to do exactly, inflate them IN the VAB and assign Kerbals???
  3. Is that a life support mod? You should ask the mod's developer to provide support for the inflatables. Unless you want to write a config to do that. Or switch to Ioncross which supports the inflatable habs out of the box.

Thanks! Here are the answers:

  1. Oh! I have it installed! Both animations work fine simultaneously (although spinning can't be stopped but that is well-known);
  2. Thought so as a way to assign some kerbals to it...
  3. Yes, it is. I'll download Ioncross and take a peek at its .cfg files...

EDIT:

Ok, I've looked into Ioncross and made a few patches to gave Habitat Pack IFILS support. As this is my first MM patch, can you please syntax check it? :wink:


//------------------------ IFILS for Habitat Pack
@PART[centrifuge1]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}

@PART[orbitalorb]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 6
maxAmount = 6
}
}

@PART[inflatoFlat]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}

@PART[inflato2]:HAS[!MODULE[IFILifeSupport]]
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}

@PART[inflato1]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 18
maxAmount = 18
}
}

BTW, this is how I copied your fix (I've also installed the your plugin):


@PART[centrifuge1]
{
@MODULE[ModuleAnimateGeneric],0
{
@name = ModuleLayeredAnimator
layer = 1
}
@MODULE[ModuleAnimateGeneric],1
{
@name = ModuleLayeredAnimator
layer = 2
}
}

Edited by jlcarneiro
Avoid double posting
Link to comment
Share on other sites

Thanks! Here are the answers:

  1. Oh! I have it installed! Both animations work fine simultaneously (although spinning can't be stopped but that is well-known);
  2. Thought so as a way to assign some kerbals to it...
  3. Yes, it is. I'll download Ioncross and take a peek at its .cfg files...

EDIT:

Ok, I've looked into Ioncross and made a few patches to gave Habitat Pack IFILS support. As this is my first MM patch, can you please syntax check it? :wink:


@PART[centrifuge1]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}


RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}


@PART[orbitalorb]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}


RESOURCE
{
name = LifeSupport
amount = 6
maxAmount = 6
}
}


@PART[inflatoFlat]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}


RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}


@PART[inflato2]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}


RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}


@PART[inflato1]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}


RESOURCE
{
name = LifeSupport
amount = 18
maxAmount = 18
}
}

Looks ok as far as syntax, but your inflato2 is missing a {

I replaced it in my quotation of your code.

Link to comment
Share on other sites

Hello, guys!

As I said before, I'm trying to integrate CLS and IFILS to Habitat Pack.

These are the MM patches I'm using so far to integrate CLS:

//------------------------ CLS compatibility for Habitat Pack
@PART[orbitalorb]:HAS[!MODULE[ModuleConnectedLivingSpace]]{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}
@PART[inflato2]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}
@PART[inflato1]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}
@PART[centrifuge1]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}
@PART[inflatoFlat]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}

About IFILS, these are the patches so far. I'd appreciate any input (including regarding balance):

//------------------------ IFILS for Habitat Pack
@PART[orbitalorb]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 6
maxAmount = 6
}
}

@PART[inflato2]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 12
maxAmount = 12
}
}

@PART[inflato1]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 18
maxAmount = 18
}
}

@PART[centrifuge1]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 60
maxAmount = 60
}
}

@PART[inflatoFlat]:HAS[!MODULE[IFILifeSupport]]
{
MODULE
{
name = IFILifeSupport
}

RESOURCE
{
name = LifeSupport
amount = 60
maxAmount = 60
}
}

About balance, I considered the smaller module orbitalorb as a simple capsule. Inflato2 and inflato1 were considered proportionally larger versions of orbitalorb. And the long-period ones (centrifuge1 and inflatoflat) as a 15-day module with full crew.

What do you think?

Link to comment
Share on other sites

Hello, guys!

As I said before, I'm trying to integrate CLS and IFILS to Habitat Pack.

These are the MM patches I'm using so far to integrate CLS:

<snipped!>

About balance, I considered the smaller module orbitalorb as a simple capsule. Inflato2 and inflato1 were considered proportionally larger versions of orbitalorb. And the long-period ones (centrifuge1 and inflatoflat) as a 15-day module with full crew.

What do you think?

CLS looks fine; balance isn't really relevant there....

As for the life support, 15 days seems pretty sparse. They should have months worth of supplies. Of course that is by Earth standards where we can't afford to keep launching rockets multiple times per day as the Kerbals apparently can.... but that's my opinion: should be more.

Hi, the habitat pack works fine in .90 (I did however recompile Habitat.dll just to be sure) except the F.L.A.T., which is missing its texture. Any ideas why?

Looks like the .tga bug introduced in 0.25 is still unfixed. It tends to be random. Restart the game and the FLAT may look fine while some other part is messed up. Restart it again and still another might be flat white or maybe all tga parts. Or even none of them :(

Link to comment
Share on other sites

[...] As for the life support, 15 days seems pretty sparse. They should have months worth of supplies. Of course that is by Earth standards where we can't afford to keep launching rockets multiple times per day as the Kerbals apparently can.... but that's my opinion: should be more. [...]

Thought so, but I'm new to this and got a little "shy"... How long would you suggest (in case HabitatPack gets updated or I decide to use it anyway)?

Link to comment
Share on other sites

Looks like the .tga bug introduced in 0.25 is still unfixed. It tends to be random. Restart the game and the FLAT may look fine while some other part is messed up. Restart it again and still another might be flat white or maybe all tga parts. Or even none of them :(

Do you think either ATM or manual conversion to DDS and using DDSLoader would resolve that issue?

Link to comment
Share on other sites

Looks like the .tga bug introduced in 0.25 is still unfixed. It tends to be random. Restart the game and the FLAT may look fine while some other part is messed up. Restart it again and still another might be flat white or maybe all tga parts. Or even none of them :(

You're right, thanks. I had to restart a couple of times...

Link to comment
Share on other sites

  • 3 weeks later...

Hey everyone, I love the mod, and had a question about a config I'm creating for tweakscale. Basically I need the base sizes of each part and I'm having trouble figuring out what the base size is for each node for the defaultScale line should be. I'm using the mod with Realism Overhaul/RSS so I wanted it to look as scaled as it should on a large-scaled space station. I've gone with 1.25 for the Capsule [edit: this did not work, it's an issue with the mods included in the RO pack], which was easy as it doesn't inflate, but I'm having trouble with the rest. Anyone know what I should input here?

*Edit* I was going to delete this, but I figured someone else may have this question. I found out RO does its own rescaling, and while it's possible to append tweakscale to include these rescaled models, it really isn't necessary.

Edited by shoe7ess
Link to comment
Share on other sites

*Edit* I was going to delete this, but I figured someone else may have this question. I found out RO does its own rescaling, and while it's possible to append tweakscale to include these rescaled models, it really isn't necessary.

Completely unrelated: I feel like I'm the only one around here who can sing along to your signature! :) Am I?!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...