Jump to content

[1.2] TweakableEverything 1.16-beta - For all your part tweaking needs


toadicus
 Share

Recommended Posts

I think there's a misplaced decimal point somewhere in the tweakable reaction wheels dll. I tried flying a plane with the Mk 1 inline cockpit, and as soon as I touched the controls it leaped violently off the ground and spun at insane speeds. On right-clicking the cockpit, the Reaction Wheel Force slider was at 10000%! The minimum I could get the slider to go at one pixel, was 600%, which was still mostly uncontrollable, so I turned it off and completed my flight.

Then I renamed TweakableReactionWheels.dll to .dllx, relaunched the game, and it works fine now. This just started happening when CKAN installed the latest update tonight.

Link to comment
Share on other sites

I still got a lot of the errors in my previous post with 1.11.3, but it's mostly only the first error.

^Yup, this really messes with the game too :D SAS on = instant Armageddon.

Kinda entertaining though.

Good thing i had Kerbal Joint Reinforcement on... I have never seen such a massive ship turn on a dime like that...

Edited by Mokmo
Link to comment
Share on other sites

FirroSeranel, steve_v, and anyone else with excessively high SAS/RCS throttle issues: I changed the way those tweakables work from a 0..100 scale to a 0..1 scale. There's nothing misplaced in the code (I don't think), but I neglected to get anything in there to convert older saves (saved ships, active craft, etc) from the large numbers. So, now if it detects a number higher than 1, it will divide it by 100 and reset the range on the tweakable to 0..1 (converted to % by string formatting magic).

Can you give this dev version a try and see if it resolves the issue? Thanks! [zip] [tar.gz] [tar.xz]

Mokmo, the report you gave previously, based on everything I know about Squad's Staging subsystem, suggests that you have some parts in your ship that are incorrectly identified as being on a stage with an index higher than the actual highest stage on the ship. Because of the way Squad keeps track of the index, this gets their code confused and it all falls apart. The difficulty with that is that I don't have a more authoritative source of the stage count in a ship than Squad is exposing, so I can't just put some code in to say "make sure your inverse stage is smaller than X", since I apparently can't trust X in every case. I haven't been able to make TStaging duplicate your issue, but I haven't actually tried to play the game properly in weeks and I can only get so creative in my lab tests. Do you have a .craft file for a ship exhibiting these problems, that uses no or minimal mods? If you're not sure what mods it uses, you can upload it to KerbalX; they'll tell you.

Link to comment
Share on other sites

Sweeeet! that dev build squashed it :D Thanks muchly.

On a less positive note, I'm now having issues with AntennaRange (1.8a release): Science doesn't transmit from the experiment dialog, logs are spamming:

"Missing method ToadicusTools.Tools::getModulesOfType<[1]>(Vessel) in assembly /home/steve/KSP_linux-1002/GameData/ToadicusTools/ToadicusTools.dll, referenced in assembly /home/steve/KSP_linux-1002/GameData/AntennaRange/AntennaRange.dll".

Selecting "transmit data" from the antenna right-click menu works ok.

Do I need a more recent AntennaRange build to play nice with this?

Link to comment
Share on other sites

steve_v, glad that helped! I'll upload it shortly. In the meantime, I've answered your AntennaRange query over in the AntennaRange thread. :)

- - - Updated - - -

TweakableEverything has been updated to version 1.11.4! Because we just can't get enough of bugmaking and bugfixing lately, this version fixes problems I created in the last update, which is apparently the new normal.

CHANGELOG:


v.1.11.4 [2015-05-22]
* TweakableRCS: Fixed the throttle slider for saved craft to no longer increase RCS strength to laughable proportions.
* TweakableReactionWheels: Fixed the throttle slider for saved craft to no longer increase reaction wheel strength to laughable proportions.
* TweakableParachutes: Added FerramAerospaceResearch to the exclusions list in the .cfg so we don't load up when we don't need to.

Link to comment
Share on other sites

Unhinging reality, laughable proportions.. Has toadicus finally gone insane?! :D

I like to think that were I to go insane, there would be no questioning the matter. ;)

My fuel tank have a tweakable for "True Pump". Is that from this mod? What is it?

No sir. "TweakableFuelPumps" actually only adds action group items, and no tweakables at all. The name is a lie.

Link to comment
Share on other sites

I like to think that were I to go insane, there would be no questioning the matter. ;)

No sir. "TweakableFuelPumps" actually only adds action group items, and no tweakables at all. The name is a lie.

Yes, True Pump was an action group item. Is this added by Tweakable Everything? If not i'm confused by where it came from.

Also still getting spontaneous staging problem with "MissingMethodException: Method not found: 'ToadicusTools.Tools.getModulesOfType'." in logs. Seems to only be affecting only one of my vessels at this time though. KSP Logs 5-23.zip

Here is a screeny of the affected craft in the VAB with the tweakables for the malfunctioning separator. Note that staging is disabled for this part. The separator is in Beales Tantares parts mod.

125uFJT.png

Edited by Gristle
Link to comment
Share on other sites

Gristle, I do add a tweakable to turn the pumps on and off, though I'm not sure why it'd be named "True". I'll check it out. Also, those exceptions are probably caused by your old version of AntennaRange; it's broken WRT the most recent ToadicusTools. Grab a dev build now, or I should have it released later today. :)

Link to comment
Share on other sites

Gristle, I do add a tweakable to turn the pumps on and off, though I'm not sure why it'd be named "True". I'll check it out. Also, those exceptions are probably caused by your old version of AntennaRange; it's broken WRT the most recent ToadicusTools. Grab a dev build now, or I should have it released later today. :)

I have whatever is latest on CKAN. Where would I find something newer?

Link to comment
Share on other sites

That staging bug is back......................

screenshot84_zpsykclilxx.png

screenshot83_zpsp0odn6fi.png

Also something is screwing up the editor somehow when I return from launchpad with that ship.

screenshot86_zpsitxd2aob.png

http://sta.sh/01ggfwlswton

I already did some thorough testing today for zodiusinfuser when I ran into a major problem with the closed beta build of IR rework, but what the hell, maybe I'll try to find out what the hell is causing this..................................................................................

Link to comment
Share on other sites

Okay, I've reproduced this bug:

screenshot24_zpshd1smkhk.png

and this

screenshot25_zpsqotgu7jw.png

with this craft: http://sta.sh/022v581b5g9d

STEPS:

1. Load craft in VAB

2. click and move the siver tank and everything below it as a whole to observe the error spam

3. When done observing error spam, put silver tank and the rest back on.

4. remove the decoupler and rest of stuff below it.

5. detach the mainsail.

6. put it back.

7 observe the extra empty stage.

8. detach the mainsail.

9. put it back.

10. observe the extra empty stage.

11. repeat 8 9 and 10 ad infinitum.

Link to comment
Share on other sites

Thanks smjjames, that was useful. Can you try out this dev build?

[zip] [tar.gz] [tar.xz]

Edit: I'm also trying a slight tweak to the way parts get put back in to the staging list to try and get decouplers to be "smarter" about it. Let me know how that works out. :)

Edited by toadicus
Link to comment
Share on other sites

Thanks smjjames, that was useful. Can you try out this dev build?

[zip] [tar.gz] [tar.xz]

Edit: I'm also trying a slight tweak to the way parts get put back in to the staging list to try and get decouplers to be "smarter" about it. Let me know how that works out. :)

Its fixed now, thanks. :)

Edit: Not quite gone completely, I was having some of that (not the exception) when I had a procedural fairing base ring on and didn't without it, so, theres something with procedural fairings.

Edited by smjjames
Link to comment
Share on other sites

I was approaching my Mun station with a re-supply ship and as soon as I undocked the tug and switched to it my log immediately began filling with:

[EXC 11:48:36.817] ArgumentOutOfRangeException: Argument is out of range.Parameter name: index
System.Collections.Generic.List`1[StageGroup].CheckIndex (Int32 index)
System.Collections.Generic.List`1[StageGroup].Insert (Int32 index, .StageGroup item)
Staging.addStageAt (Int32 index)
Staging.AddStageAt (Int32 index)
TweakableEverything.ModuleStagingToggle.SwitchStaging (Boolean enabled)
TweakableEverything.ModuleStagingToggle.LateUpdate ()

I didn't notice any slowness or lagging at first but after 10 minutes of juggling cargo around, with the exceptions spamming the log, the game became unplayable.

Log: Here

Link to comment
Share on other sites

For some reason this mod is not compatible with Procedural Fairings, if you try to edit the interstage fairing base with right click then you can't right click any parts in the VAB.

Link to comment
Share on other sites

I was approaching my Mun station with a re-supply ship and as soon as I undocked the tug and switched to it my log immediately began filling with:
[EXC 11:48:36.817] ArgumentOutOfRangeException: Argument is out of range.Parameter name: index
System.Collections.Generic.List`1[StageGroup].CheckIndex (Int32 index)
System.Collections.Generic.List`1[StageGroup].Insert (Int32 index, .StageGroup item)
Staging.addStageAt (Int32 index)
Staging.AddStageAt (Int32 index)
TweakableEverything.ModuleStagingToggle.SwitchStaging (Boolean enabled)
TweakableEverything.ModuleStagingToggle.LateUpdate ()

I didn't notice any slowness or lagging at first but after 10 minutes of juggling cargo around, with the exceptions spamming the log, the game became unplayable.

Can conform this. For me my game crashed but it could be something else that cause the crash


ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
at System.Collections.Generic.List`1[StageGroup].CheckIndex (Int32 index) [0x00000] in <filename unknown>:0
at System.Collections.Generic.List`1[StageGroup].Insert (Int32 index, .StageGroup item) [0x00000] in <filename unknown>:0
at Staging.addStageAt (Int32 index) [0x00000] in <filename unknown>:0
at Staging.AddStageAt (Int32 index) [0x00000] in <filename unknown>:0
at TweakableEverything.ModuleStagingToggle.SwitchStaging (Boolean enabled) [0x00000] in <filename unknown>:0
at TweakableEverything.ModuleStagingToggle.LateUpdate () [0x00000] in <filename unknown>:0

Log: https://dl.dropboxusercontent.com/u/30637586/KSPForum/Kerbal%20Space%20Program.zip

Link to comment
Share on other sites

I have a workaround for that Procedural Fairings interaction bug people have been posting about. I've narrowed down the problem file to TweakableDecouplers.cfg in GameData/TweakableEverything/ . When I remove that one config, everything goes back to working perfectly.

I'm using the dev build of TE that was linked on page 67 of this thread and the latest version of PF (3.14).

Link to comment
Share on other sites

I already posted another workaround for this bug some pages ago.

The workaround for this issue is next: in Procedural Fairings Adapter config file you must

replace

ejectionForce = 0

to

ejectionForce = 10

Correctly speaking, it's not TE's bug itself, it's KSPAPIExtensions.dll incorrect interactions with 0 base values in UI_Float.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...