DMagic

[1.5.x - 1.6.x] DMagic Orbital Science: New Science Parts [v1.4.2] [1/10/2019]

Recommended Posts

7 hours ago, dannyo862 said:

Hi, I've just loaded up my saved game after not playing for a week - and a load of my ships and stations have not loaded because the magnetometer boom and gamma spec box are missing!  Literally nothing has changed since I last played this.  I've uninstalled and re-installed this but it still happens.  But I can see the boom in my parts list (though the gamma experiment seems to be genuinely missing).  It took me so much time and effort to build my stations etc. after already starting from scratch once for a different reason I REALLY do not want to lose all this.

Is anyone having this same issue or does this sound familiar?  Obviously more info may be needed which I can provide if someone wants it.  Thanks in advance for any help!

I haven't had any issues with any DMagic parts changing names or disappearing, and I'm on a fairly heavily modded game, so it sounds like a local issue.

Share this post


Link to post
Share on other sites
On 17.9.2017 at 0:04 PM, dannyo862 said:

Hi, I've just loaded up my saved game after not playing for a week - and a load of my ships and stations have not loaded because the magnetometer boom and gamma spec box are missing!  Literally nothing has changed since I last played this.  I've uninstalled and re-installed this but it still happens.  But I can see the boom in my parts list (though the gamma experiment seems to be genuinely missing).  It took me so much time and effort to build my stations etc. after already starting from scratch once for a different reason I REALLY do not want to lose all this.

Is anyone having this same issue or does this sound familiar?  Obviously more info may be needed which I can provide if someone wants it.  Thanks in advance for any help!

did you do any updates pre starting the game?
try downloading an older version of the mod

Edited by danielboro

Share this post


Link to post
Share on other sites

@Vorg The values for ModuleResourceScanner and the SCANsat modules are different, the stock module (ModuleResourceScanner) just has an upper limit, while the SCANsat module (ModuleSCANresourceScanner) has a range (they are defined in a MM config file in the Resources folder). The values in the latest version are 30-60k, with 50k ideal. It's possible that another mod is altering those values, though.

 

@dannyo862 It's probably science parts from another mod causing the problem. Bluedog Design Bureau has a few, along with Coatl Aerospace Probes Plus.

Share this post


Link to post
Share on other sites
1 hour ago, zeant93 said:

Witch part will I use if I want to do a irradiance scan?

GORESat

Share this post


Link to post
Share on other sites

Hey there ... I recently came back to KSP and from memory I used to get contracts that involved the DMagic science parts ... for some reason this new career I don't seem to be being offered any

I have Contract Configurator installed with a few packs ... but from memory the same ones I used to have.   Am I missing something?

Share this post


Link to post
Share on other sites
2 hours ago, Mordrehl said:

Hey there ... I recently came back to KSP and from memory I used to get contracts that involved the DMagic science parts ... for some reason this new career I don't seem to be being offered any

I have Contract Configurator installed with a few packs ... but from memory the same ones I used to have.   Am I missing something?

Have you acquired the necessary parts in the tech tree and enough reputation to get the contracts?  Have you accepted your max number of contract, in which case no more can be offered until you complete some?  Could you have inadvertently filtered out the DMagic contracts in the CC settings?

Share this post


Link to post
Share on other sites
4 hours ago, Brigadier said:

Have you acquired the necessary parts in the tech tree and enough reputation to get the contracts?  Have you accepted your max number of contract, in which case no more can be offered until you complete some?  Could you have inadvertently filtered out the DMagic contracts in the CC settings?

Ahhh might be the reputation ... I'll check the CC settings too

Share this post


Link to post
Share on other sites

@mkalaska It seems okay for 1.3.1. There were no changes that I'm aware of related to anything Orbital Science does, and it doesn't have the same issue that causes some mods to directly crash KSP.

@1990eam Any planet pack should work fine. There will only be default science results since any custom planet requires custom science results text, but otherwise it will be fine.

Edited by DMagic

Share this post


Link to post
Share on other sites

@DMagic after much mixing of mods, it appears that DMagic Orbital Science (but not the DMagicScienceAnimate folder) disables 

but only partially. KEI will work on initial saved game launch, but upon exiting the R&D building (regardless of any purchases), knocks it out.

Share this post


Link to post
Share on other sites
4 hours ago, DorkaniusMaximus said:

@DMagic after much mixing of mods, it appears that DMagic Orbital Science (but not the DMagicScienceAnimate folder) disables KEI but only partially. KEI will work on initial saved game launch, but upon exiting the R&D building (regardless of any purchases), knocks it out.

Personally, I'm not seeing that problem. My current save (and several past saves) has KEI and DMOS (and several other science mods) and they play fine together.

Share this post


Link to post
Share on other sites

Heya!

I'm trying to add DMagic Science Modules to Raidernick's Probes, and it really seems to work in some way :)

So far, I managed to make the experiments show up in the right click menu on the Cassini probe body, they can be performed, boom animation plays, but they all repeat the animation of extending the boom/antennae. I entered Cassini's animation name into the DM science modules but don't know how to make all experiments recognize the proper animation state of the boom.

Would someone like to point me out how to fix this?

I'm quite fresh to writing MM stuff, I understand some elements, but most of them are still somewhat obscure to me, especially the "keepDeployedMode = 2" and "waitForAnimationTime= -1"

 

Here is what I have whipped up so far:

(mostly copypasted actually)

Spoiler

//Patch intended to go with RN US probes.

@PART[rn_cassini]:NEEDS[DMagicOrbitalScience]
{
  MODULE
  {
    name = DMModuleScienceAnimate

    animationName = Deploy

    experimentID = scopeScan

    customFailMessage = This telescope is not suitable for use during atmospheric flight or on the surface, try again in space.

    experimentAnimation = True
    experimentWaitForAnimation = True
    keepDeployedMode = 2

    showEndEvent = False
    showStartEvent = False
    showToggleEvent = False
    startEventGUIName = Open Shutter
    endEventGUIName = Close Shutter
    toggleEventGUIName = Toggle Shutter

    experimentActionName = Log Visual Observations
    resetActionName = Discard Observations

    useStaging = False
    useActionGroups = True
    hideUIwhenUnavailable = True
    rerunnable = True
    usageReqMaskExternal = 8

    xmitDataScalar = 1.0

    dataIsCollectable = True
    collectActionName = Take Data
    interactionRange = 1.2
    externalDeploy = True
  }

  MODULE
  {
    name = DMModuleScienceAnimate

    animationName = Deploy

  	experimentID = dmImagingPlatform

  	experimentActionName = Log Imaging Data
  	resetActionName = Discard Data

  	customFailMessage = The Imaging Platform is not suitable for atmospheric use or surface deployment, try again in space.
  	experimentAnimation = True
  	experimentWaitForAnimation = True
  	keepDeployedMode = 2

  	animSpeed = 1
  	showEndEvent = False
  	showStartEvent = False
  	showToggleEvent = False
  	startEventGUIName = Deploy Imager
  	endEventGUIName = Retract Imager
  	toggleEventGUIName = Toggle Imager

  	useStaging = False
  	useActionGroups = True
  	hideUIwhenUnavailable = True
  	rerunnable = True

  	xmitDataScalar = 1.0

  	dataIsCollectable = True
  	collectActionName = Take Data
  	interactionRange = 1.2
  	externalDeploy = True
  	usageReqMaskExternal = 8

  	asteroidReports = True
  	asteroidTypeDependent = True
  }

  MODULE
  {
    name = DMModuleScienceAnimate

  	animationName = Deploy

  	experimentID = magScan

  	experimentAnimation = True
  	experimentWaitForAnimation = True
  	waitForAnimationTime = -1
  	keepDeployedMode = 2

  	deployingMessage = Close proximity to the craft scrambles the magnetometer's sensors, deploying the scanner now.
  	customFailMessage = The magnetometer is not suitable for use during atmospheric flight, try again on the ground or in space.

  	animSpeed = 2
  	endEventGUIName = Retract Magnetometer
  	showEndEvent = False
  	startEventGUIName = Deploy Magnetometer
  	showStartEvent = False
  	toggleEventGUIName = Toggle Magnetometer
  	showToggleEvent = False
  	showEditorEvents = True

  	experimentActionName = Log Magnetometer Data
  	resetActionName = Discard Magnetometer Data

  	useStaging = False
  	useActionGroups = True
  	hideUIwhenUnavailable = True
  	rerunnable = True

  	xmitDataScalar = 1.0

  	dataIsCollectable = True
  	collectActionName = Take Data
  	interactionRange = 1.2
  	externalDeploy = True
  	usageReqMaskExternal = 8

  	asteroidReports = True
  	asteroidTypeDependent = True
  }

  MODULE
  {
    name = DMModuleScienceAnimate

    animationName = Deploy

  	experimentID = rpwsScan

  	experimentActionName = Log Radio Plasma Wave Data
  	resetActionName = Discard Data

  	customFailMessage = The RPWS Antenna is not suitable for atmospheric use or surface deployment, try again in space.
  	deployingMessage = With the antennae retracted the sensors can't read anything, deploying the system now.
  	experimentAnimation = True
  	experimentWaitForAnimation = True
  	keepDeployedMode = 2

  	animSpeed = 1.5
  	showEndEvent = False
  	showStartEvent = False
  	showToggleEvent = False
  	startEventGUIName = Deploy RPWS
  	endEventGUIName = Retract RPWS
  	toggleEventGUIName = Toggle RPWS

  	useStaging = False
  	useActionGroups = True
  	hideUIwhenUnavailable = True
  	rerunnable = True

  	xmitDataScalar = 1.0

  	dataIsCollectable = True
  	collectActionName = Take Data
  	interactionRange = 1.2
  	externalDeploy = True
  	usageReqMaskExternal = 8
  }
}

 

 

Edited by h0yer
addition

Share this post


Link to post
Share on other sites

@h0yer One part with four science modules? That probably won't ever work right if you want it to sync up with the animation. You could try setting one of them to have an animation and disable it for the others (set experimentAnimation = false, and delete the animationName field).

Share this post


Link to post
Share on other sites
24 minutes ago, DMagic said:

@h0yer One part with four science modules? That probably won't ever work right if you want it to sync up with the animation. You could try setting one of them to have an animation and disable it for the others (set experimentAnimation = false, and delete the animationName field).

A'ight, thanks a lot for the advice, I'll fiddle around a bit more :)

Share this post


Link to post
Share on other sites

Hullo, fellow Kerbals!

First and formost thanks to DMagic for this amaze mod. I do not play without it anymore (This is true for others as well he made.)

I love using the science tools and this is why I am bothered by two facts: incompatibility with ForScience mod and the Sigint deployment. 

It might be my mistake, but when I try to install ForScience mod with CKAN it says it is in conflict. As far as I know it wasn’t with 1.3. 

Regarding Sigint, it is just annoying, that the dish is not retractable or at least it would deploy when I want it (it deploys as soon as I am in space at launch. Also sigint causes a lot of lag after 1.3.1. Updated. But it might be only my mods or setup. No crashes just mini freezes when I use the radar.

any advice or info would be greatly appreciated.

 

Share this post


Link to post
Share on other sites

@Aldaris5 They have been marked incompatible for a long time; at one point there was, potentially at least, a bug that might have been caused when using them both together, I don't think that's still an issue, but I have left it that way because ForScience doesn't work with or interact with Orbital Science parts properly, so using the two together is likely to cause confusion.

For the SIGINT, if you want to be able to retract the dish you can change the oneshot = true line (under the DMSIGINT MODULE) in the part config to false. There is also a button for the SIGINT that can be used to prevent it from being used as a science transmission antenna, which is generally the only way that the SIGINT would be automatically deployed. It can also be deployed by staging (it uses the fairings staging icon), that can also be disabled by setting the stagingDeploy = true field to false. The same goes for the soil moisture part, which can also be used as an antenna.

Share this post


Link to post
Share on other sites

@DMagic Thank you for your quick reply. That means bye bye ForScience then.

Also thanks for the detailed answer for the solutions. One question though: which file needs to be changed if I wanna change the oneshot=false thing to all future sigint antenna? 

 

 

Share this post


Link to post
Share on other sites

I've received a contract to "perform neutron scattering analysis" and im a bit lost as to what part does this. Any help?

Share this post


Link to post
Share on other sites

The Soil Moisture Sensor says that it can be used as a powerful communications antenna, but I see no such ability. Is it because I'm using RemoteTech? If so, what values should it have? I can try to mess with configs to get it working for me.

@Not Sure  Sounds like it wants you to use the experiment "Dynamic Albedo of Neutrons."

Share this post


Link to post
Share on other sites

@Not Sure Yes, it's the DAN part, the experiment name is actually Surface Hydrogen Scan, I should probably change all of the contract titles to reflect the actual name of the experiment so that you can use the KSPedia entry or the part tooltips to figure out which ones are required.

@Aldaris5 You would need to change the oneShot line in the DMSIGINT Modules of all of the SIGINT part configs in the GameData/DMagicOrbitalScience/OversizeScience folder, there are three of them (though one of them, SIGINT.cfg, is deprecated and can't actually be added to new vessels). You can just manually change the config files or use module manager to do the same.

@Zekario It looks like RT has specific MM patches for all of the antennas in stock and lots of mod antennas. You would have to either get them to add one for Orbital Science, make one yourself, or wait for me to add one (which might be a while).

Share this post


Link to post
Share on other sites
2 hours ago, DMagic said:

@Aldaris5 You would need to change the oneShot line in the DMSIGINT Modules of all of the SIGINT part configs in the GameData/DMagicOrbitalScience/OversizeScience folder, there are three of them (though one of them, SIGINT.cfg, is deprecated and can't actually be added to new vessels). You can just manually change the config files or use module manager to do the same.

Thanks a billion! Done. I will see that it would work this evening.

Share this post


Link to post
Share on other sites
3 hours ago, DMagic said:

@Not Sure Yes, it's the DAN part, the experiment name is actually Surface Hydrogen Scan, I should probably change all of the contract titles to reflect the actual name of the experiment so that you can use the KSPedia entry or the part tooltips to figure out which ones are required

Oh that would be great, I kept looking at what expiriment was performed rather than the name.

Share this post


Link to post
Share on other sites

I have just put a probe into orbit for a Mag and Plasma orbit mission. I have checked all of the boxes of the mission bar one: 

 

-Maintain proper orbit for 75 days. 

 

I am in the orbit required (0.20 + eccentricity & 18.0 + inclination) however there is no countdown on the time. Have I done something wrong or will it complete automatically after 75 days? Or have I just missed something entirely? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.