DMagic

[1.8.x] DMagic Orbital Science: New Science Parts [v1.4.3] [11/2/2019]

Recommended Posts

It happened again with another craft.

Edit: When I do the same craft with just stock instruments, it's fine. Also, I notice that the restore message for the mini goo container and mini materials bay isn't a bolded light green, just normal text.

Edit2: Okayyy, I'm running into some serious symmetry bug wierdness with the parts from here.

Craft file: http://sta.sh/011k7zsqf2rc

Mods required for craft:

Dmagic orbital science (obviously)

IR model rework core pack (trusses)

USI exploration pack (structural part)

Kerbal Foundries

Modular Rocket Systems (structural part and batteries)

modlist:

modlist_zpsmb5sy06w.png

Edited by smjjames

Share this post


Link to post
Share on other sites
I too am wondering why the UniversalStorage Parts are at the place in the Community Tech Tree, like the PresMat/2 Hot in Subsonic Flight

This is really confusing. The Universal Storage versions of many parts seem to be strewn about the CTT tech tree almost at random. I was getting very frustrated because I couldn't even find several of them - until I started hunting in the config files, and even then I ended up having to look in the KSP log to locate the module manager patch that was actually responsible for placing the US parts where they are.

What are science wedges for rockets doing in aircraft parts nodes like subsonic & high altitude flight, specialized flight systems, and heavy & experimental aerodynamics, when the parts they supposedly contain are in totally different (and far more sensible) science-related nodes? Why is the RPWS wedge in Actuators while the normal RPWS is in Space Exploration, along with the barometer? And why is the Accel/Grav wedge in Advanced Unmanned Tech, which you can also get without picking up either of the stock devices it combines?

It's almost as if they were moved out of the sensible nodes listed in the default patches on each part purely for the sake of placing them in different nodes in the CTT version of the tree... Not that some of the normal tech tree locations for the US wedge versions make significantly more sense. Normal GORESat in Advanced Electrics, with the US version in Precision Engineering with the SALLI instead? Why not put the US version of each part in the same node as the normal version, in both versions of the tech tree? I can't see any benefit to splitting them up. It seems to me that it's just a recipe for unnecessary headaches.

Don't get me wrong, I absolutely love this pack. This was one of the first mods I looked for when I got back into KSP shortly after hearing it had finally hit the "1.0" release and playing stock for a while to get used to the various career mode additions I'd missed in recent versions. You've done so much exceptional work on all of these great parts, and all the standard versions of the parts seem well placed in the tech tree. And I love the models and animations for extending the GORESat and telescope from the US wedges! It just seems like the tech nodes for US versions of the parts could be more sensibly chosen, for consistency's sake. If nothing else, it would've avoided the frustration and confusion I just went through trying to figure out "what was wrong with my install". :)

Share this post


Link to post
Share on other sites
They're still in the science section, I can see them with Universial Storage.

do they exist without the universal storage parts?

Share this post


Link to post
Share on other sites

Noob question, are the universal storage experiments supposed to show even if you don't have universal storage?

US scares and confuses me and my laptop is already having a brain haemorrhage with the amount of mods.

Thanks DMagic, great mod.

Share this post


Link to post
Share on other sites
do they exist without the universal storage parts?
Noob question, are the universal storage experiments supposed to show even if you don't have universal storage?

No. Universal Storage science parts require Universal Storage to work at all. If you edit the configs you can get them to show up without US installed, but they won't work at all.

If you don't want to use US, or you don't want the US science parts you can delete that folder (DMagicOrbitalScience/UniversalStorage). The reverse is not true, the US science parts rely on assets in the regular part folders to work.

Share this post


Link to post
Share on other sites
No. Universal Storage science parts require Universal Storage to work at all. If you edit the configs you can get them to show up without US installed, but they won't work at all.

If you don't want to use US, or you don't want the US science parts you can delete that folder (DMagicOrbitalScience/UniversalStorage). The reverse is not true, the US science parts rely on assets in the regular part folders to work.

Thanks, didn't know whether ckan was playing with me :-D

Share this post


Link to post
Share on other sites

I'm finding some errors in the log for the new KAS. Basically it is looking for 'KASModuleGrab' which doesn't exist in the new KAS.

Share this post


Link to post
Share on other sites
I'm finding some errors in the log for the new KAS. Basically it is looking for 'KASModuleGrab' which doesn't exist in the new KAS.

I don't have a clue about what is going on with KAS and KIS. If someone wants to figure it out and make configs that allow these parts (the KAS and tweakscale modules for Universal Storage parts are handled by US, not me) to be picked up and moved I'll add it to the download package.

Share this post


Link to post
Share on other sites

KAS no longer has a 'KASModuleGrab' module to enable grabbing parts. KAS now relys on KIS for this but I'm not sure what it takes to enable it.

Share this post


Link to post
Share on other sites
The science must be transmitted and must have some value left. If there isn't enough value left you will have to return the results to Kerbin.

Did you see a message like this after transmission? This is what happens when the results don't have enough science value left to count. This generally only happens when you conduct science after an orbital survey contract is offered, but before you actually accept it.

http://i.imgur.com/cxkybSq.png

It would be nice if you added a note to the contract explaining that the result must actually be returned, not only transmitted, that way people don't waste their time making a probe unable to return to kerbin.

Share this post


Link to post
Share on other sites

I took a contract to conduct Surface magnetic field readings on Kerbin, so I could test my VTOL lander out. When I land at the sites, I gather the data using the magnetometer and nothing happens, the data has no value, and none of the contract conditions are satisfied. I also tried storing the no value data and recovering at KSC, nothing again. Bit confused...

Share this post


Link to post
Share on other sites

The contract to scan the magnetic fields of planets are acting strange for me. Basically the timer seems to reset itself from time to time...

Share this post


Link to post
Share on other sites

Hi there,

is there a way to get the "Process in lab" button for the experiments added by OS? I can only transmit or keep them, while the stock experiments can go to the MPL. Thanks in advance if anyone knows how this works and can give me the solution :)

Share this post


Link to post
Share on other sites

When playing with this mod in career mode, are there suggestions on how to alter the science levels to keep the progression balanced? I love having the extra variety from this mod - especially with probes and rovers - but it obviously creates "extra" science when compared to the stock game. I've been playing at 80% of normal and I wondering what others are doing.

Share this post


Link to post
Share on other sites
It would be nice if you added a note to the contract explaining that the result must actually be returned, not only transmitted, that way people don't waste their time making a probe unable to return to kerbin.

Clearer contract notes and descriptions will be coming. Also, use Contracts Window +, it allows you to view the contract notes at any time, unlike the stock contract app that only lets you read the parameter notes, not the overall contract note.

I took a contract to conduct Surface magnetic field readings on Kerbin, so I could test my VTOL lander out. When I land at the sites, I gather the data using the magnetometer and nothing happens, the data has no value, and none of the contract conditions are satisfied. I also tried storing the no value data and recovering at KSC, nothing again. Bit confused...
The contract to scan the magnetic fields of planets are acting strange for me. Basically the timer seems to reset itself from time to time...

Need more info on these.

Hi there,

is there a way to get the "Process in lab" button for the experiments added by OS? I can only transmit or keep them, while the stock experiments can go to the MPL. Thanks in advance if anyone knows how this works and can give me the solution :)

The only current way to do this (for experiments that have 100% transmission levels) is to manually remove it from the instrument and move it to the science lab, or some other science container, like a command pod. You can process it after reviewing it there. A fix for this will be included whenever 1.0.3 releases.

When playing with this mod in career mode, are there suggestions on how to alter the science levels to keep the progression balanced? I love having the extra variety from this mod - especially with probes and rovers - but it obviously creates "extra" science when compared to the stock game. I've been playing at 80% of normal and I wondering what others are doing.

That depends on a number of factors; you'll have to decide for yourself. There is also my [thread=80220]science values editor[/thread] that lets you adjust the science reward values for each planet and situation. I haven't tested it with KSP 1.0.2, but I think it should still work.

I've been playing on a "hard-mode" career game (science at 60%) with the Community Tech Tree. The biggest source of science for me (I'm playing with RemoteTech and still haven't left the Kerbin system) is still stock science, the gravity sensor and surface samples in particular. If anything needs a reduction in science returns it's those two experiments, along with probably asteroid samples.

I've also made several balancing changes to my contracts that will be included in the next update. Science rewards will be significantly reduced (around 60-80% reduction), along with some other rewards balancing.

Share this post


Link to post
Share on other sites
The only current way to do this (for experiments that have 100% transmission levels) is to manually remove it from the instrument and move it to the science lab, or some other science container, like a command pod. You can process it after reviewing it there. A fix for this will be included whenever 1.0.3 releases.

Thanks mate, looking forward for it :)

Share this post


Link to post
Share on other sites
I've also made several balancing changes to my contracts that will be included in the next update. Science rewards will be significantly reduced (around 60-80% reduction), along with some other rewards balancing.

I'm playing a Medium difficulty save myself. I used your contract editor to cut down science and rep rewards from your contracts by about that amount, so I'd say you're in a good ballpark, balance-wise.

Share this post


Link to post
Share on other sites

Has anyone encountered a bug where one's Kerbals and/or crafts are not recoverable when Orbital science is installed? I had the described problem, removing the mod seems to have fixed it, in that it doesn't occur anymore. I'm on a Mac, using 1.02 of KSP and 1.03 of Orbital Science

Share this post


Link to post
Share on other sites

I had an odd behaviour on a magnetic scan satellite contract. I already had one satellite with magnetometer and RPWS orbiting the Mun for one contract, and got a contract for a similar satellite for kerbin. While it was still ascending from launch, I looked at the contracts pulldown and it was showing that the "orbit with eccentricity above .24" was satisfied, even though it was not yet in orbit (but the eccentricity was indeed above .24). When I got into a circular orbit eccentricity of .001, the requirement was still showing as satisfied.

There didn't seem to be a requirement that the orbit be around kerbin, so I'm wondering if it was giving me credit for the satellite I had orbiting the Mun with eccentricity above 0.24?

Share this post


Link to post
Share on other sites

The one complaint I have about this mod is the overabundance of Sun orbital surveys that involve experiments from low orbit. Everything else is great!

Share this post


Link to post
Share on other sites

Hi DMagic, for some reason I'm getting a log spam of this kind:


dmImagingPlatform

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)


dmSolarParticles

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)


dmRadiometerScan

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)


dmImagingPlatform

Did I get a debug version or what? :)

Here's my output_log.txt

Share this post


Link to post
Share on other sites
Has anyone encountered a bug where one's Kerbals and/or crafts are not recoverable when Orbital science is installed? I had the described problem, removing the mod seems to have fixed it, in that it doesn't occur anymore. I'm on a Mac, using 1.02 of KSP and 1.03 of Orbital Science

Need more info on this.

I had an odd behaviour on a magnetic scan satellite contract. I already had one satellite with magnetometer and RPWS orbiting the Mun for one contract, and got a contract for a similar satellite for kerbin. While it was still ascending from launch, I looked at the contracts pulldown and it was showing that the "orbit with eccentricity above .24" was satisfied, even though it was not yet in orbit (but the eccentricity was indeed above .24). When I got into a circular orbit eccentricity of .001, the requirement was still showing as satisfied.

There didn't seem to be a requirement that the orbit be around kerbin, so I'm wondering if it was giving me credit for the satellite I had orbiting the Mun with eccentricity above 0.24?

It should be checking if you are in orbit before assigning anything as complete. Do you have another vessel in orbit around Kerbin with both of the required parts? That is the only way that the parameter should be completed. Vessels in orbit around other bodies won't count.

Hi DMagic, for some reason I'm getting a log spam of this kind:

That looks like it's coming from someone else who can't be bothered to generate useful log spam...

Share this post


Link to post
Share on other sites

I had a few missions active that use this mod. A series of scans of Minmus and the Mun.

Due to a glitch with my settings going back to default every time I start KSP, I removed all mods and also tried a fresh install if KSP after backing up my saves.

Now I see that these missions are gone. They're not active, canceled, failed or available.

Will I be offered these missions again at some point, or does the mod think I've already done them?

Share this post


Link to post
Share on other sites
I had a few missions active that use this mod. A series of scans of Minmus and the Mun.

Due to a glitch with my settings going back to default every time I start KSP, I removed all mods and also tried a fresh install if KSP after backing up my saves.

Now I see that these missions are gone. They're not active, canceled, failed or available.

Will I be offered these missions again at some point, or does the mod think I've already done them?

They should come up again at some point. The only way that contracts are tracked is through the list of completed contracts, so if they aren't there you can see them again.

Share this post


Link to post
Share on other sites

All right, thanks for the info. I'll just keep watching for those missions to come up again..

By the way, I've also got Universal Storage and I notice that some of the US versions of your experiments are in different nodes than the standard versions. Was that intended, or just a glitch that slipped through? For instance I notice that the standard Magnometer boom is in Engineering 101 while the US version of it is 4 tiers up in Miniaturization.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.