Jump to content

[1.8.x] DMagic Orbital Science: New Science Parts [v1.4.3] [11/2/2019]


DMagic
 Share

Recommended Posts

Hi there.

I'm playing RO/RP0 and having trouble transmitting data from the orbital perturbation sensor.  It records and starts transmitting properly, but at the end of the transmission process, no science is added, and the experiment is not recorded as complete at the space center.  I used to sometimes have this problem if I tried to do an experiment w/using time acceleration, but I stuck to 1x time for the whole process and still no luck

The sensors based off of standard science gear - like the 2hot thermometer - I can transmit off of just fine, so I thought this might be a Orbital science problem.  Any ideas? 

Edit: Ok maybe this is a US problems issue, when I sent the data twice (to force it to go through the communotron as well) it worked fine, will go post in RN's thread about the grab 1

Edited by Maxsimal
Link to comment
Share on other sites

Version 1.3.1 is out; get it on Space Dock.

It includes a new KSPedia entry with information on the requirements and conditions for each experiment, asteroid experiments, non-standard instruments, contracts, and some information about use with other mods.

It also fixes a bug with the asteroid scanner, adds an indicator for which experiments can be used with asteroids in the VAB/SPH info window, and removes some... potentially offensive and/or rule breaking science results. :wink::wink::wink:

 

* Some of the panels are not quite up-to-date with the release version.

Link to comment
Share on other sites

Thanks for the quick update!

 

51 minutes ago, DMagic said:

,,,and removes some... potentially offensive and/or rule breaking science results. :wink::wink::wink:

The church thought Galileo's science results were offensive too, but that didn't stop him!

Edited by Nightside
sp
Link to comment
Share on other sites

So, kind of a random question... is there any way to allow (through, for example, a config file or MM patch file) parts other than the mag/USmag and RPWS/USRPWS to complete magnetic field survey contracts?

Here's why I ask: I'm kind of a realism enthusiast, in that I'm somewhere between completely stock KSP and RSS/RO. If I send a probe to Duna, for example, I kind of like it to look like the Kerbal's take on a real-world mission. To that end, I've done things like repurpose a model file for an antenna as a RPWS, or use the magnetometer from the Interstellar mod as an alternate to the DMagic mag-boom.

Making my franken-parts act as DM mag/RPWS science experiment instruments is easy. But, in reading earlier posts in this topic, and browsing through the source on GitHub, it seems if the part name doesn't match, it's a no go as far as the contract is concerned (specifically, completing the orbital parameters part of the contract).

As another example would be the ProbesPlus pack RPWS antenna, but I think it would have the same problem because *its* part names don't match any more than my franken-parts.

Looking for an answer that will let me have my cake and eat it too, but any thoughts on the question would be welcome.

Also, many thanks for this wonderful mod.

Link to comment
Share on other sites

@akardam That's easy, just check in the contract settings file: GameData/DMagicOrbitalScience/Resource/DMContracts.cfg

There are settings for each contract type, check under the DMMag section for the lines Magnetometer_Parts and RPWS_Parts. You can either add the desired part names to the ends of those lines (with each additional part separated by a comma), or make a MM patch to do the same, though I'm not sure exactly what the syntax is for adding something to the end of a line. The same is possible for the recon contracts.

I should also tell @akron about that so that a MM patch can be included in Probes Plus.

Edited by DMagic
Link to comment
Share on other sites

I'm having a gamebreaking problem with DMOS mod.

Mods list: Bluedog Design Bureau, CactEye, Contract Configurator (contract packs: Clever Sats, Bases and Stations, Tourism, Anomaly Surveyor), KIS, Kopernicus, Mechjeb, NearFuture (all packs), Final Frontier, Outer Planets Mod, RealPlume, SCANSat, Sigma Binary (for OPM), Tantares, TantaresLV, TarsierSpaceTech, Waypoint Manager. Most of the mods and dependencies are updated to the latest, 1.1.3-compatible versions.

The problem: in Career mode, after I complete the initial four contracts, new contracts don't appear when I decline them. That might lead to no contracts at all. Switching scene (main menu, VAB, flight) might sometimes result in several contracts appearing. As soon as I delete DMOS from my install, the contracts work normal (even on the same save). If I delete every other mod (even MM) and leave only DMOS, contracts are still bugged.

I have the following error in my log every time I switch buildings:

[EXC 20:45:13.253] MissingMethodException: Method not found: 'FinePrint.Utilities.CelestialUtilities.GenerateOrbit'.
	Contracts.Contract.Generate (System.Type contractType, ContractPrestige difficulty, Int32 seed, State state)
	Contracts.ContractSystem.GenerateContract (Int32 seed, ContractPrestige difficulty, System.Type contractType)
	Contracts.ContractSystem.GenerateContract (System.Int32& seed, ContractPrestige difficulty)
	Contracts.ContractSystem.GenerateContracts (System.Int32& seed, ContractPrestige difficulty, Int32 count)
	Contracts.ContractSystem.RefreshContracts ()
	Contracts.ContractSystem+<UpdateDaemon>c__Iterator81.MoveNext ()

 

Link to comment
Share on other sites

24 minutes ago, DMagic said:

I'll need actual log files, not excerpts.

Here you go: https://drive.google.com/open?id=0B-l1kSh8cSSAS000WFU5blNwSFU

Both KSP.log and output_log from KSP_x64_Data.

What I did there:

  1. Created a new career save, with funds and science set to maximum via custom career options (I've also disabled decline penalty).
  2. Accepted "Launch first vessel" and "Collect science from Kerbin" contracts, created really simple "ship" (Mk1, RT-5, chute), launched, collected crew report, launched ship, recovered ship. Both contracts were completed.
  3. Went to the mission control and declined several contracts (various "get crew report below\above" etc). No bug.
  4. Accepted two remaining contracts ("Escape atmosphere" and "Orbit Kerbin"). Created another simple ship (Mk1, chute, some tanks from BlueDog mod, stock engine). Launched it to orbit. Both contracts were completed.
  5. Went to the mission control and started to decline contracts. Several declines later (about 6 or 7, I think) the bug appeared - instead of refreshing, the contracts started to disappear.
  6. Switched scenes several times, after each scene I went to the mission control to check. It seems that any switch to the 3D scene (VAB, SPH, tracking station, menu) gives you two or three contracts. If you switch to the active craft from the tracking station, it can give you more (probably just a coincidence).
  7. Exited game, uploaded both logs and wrote this :)
Link to comment
Share on other sites

@biohazard15 Yep, that's definitely a problem. I'm not really sure how that bug snuck in there. I'll try to get an update out soon.

In the mean time you can either use Contract Configurator to disable the dmReconContract type, or edit the max allowed Recon contracts in the dmContracts.cfg file in the DMagicOrbitalScience/Resources folder to 0 (set maxOffers and maxActive to 0 in the DMRecon section).

Link to comment
Share on other sites

@DMagic Hi I have an issue that only occurred after CKAN updated this mod and a few other engine part mods.

When I accept any kind of contract and then go to the VAB the contract just disappears.
It doesn't show up in the "Alt+f12" menu or in Mission control.
I still have the Advancement funds from each accepted contract but no contract to complete.

I'm sorry if this has nothing to do with your mod, I just thought because of the Update something may have gone wrong.
I'm a noob at reading logs.

logs : https://www.dropbox.com/sh/5eli0bi5cnl5jqe/AAATciRKmJoJulUrXcUZEyM0a?dl=0

Thanks

 

Link to comment
Share on other sites

Thanks for the awesome mod!

Unfortunately, I had to revert from 0.3.3 to 0.3.2.  After updating to 0.3.3, all my existing contracts disappeared.  These included 1 tourism plus contract, and 4 stock contracts (perform eva in mun orbit, orbit kerbin for one week, launch two kerbals to orbit, perform docking in space around kerbin).  The only one which didn't disappear was Strategia: Mun Probes.

Link to comment
Share on other sites

@ii_DyNaMiCs_ii I'm not quite sure how, but it seems like you have two copies of the DMagic plugin somewhere. I'm seeing duplicates of some of the log entries for DMOS.

The root cause of the specific problem you are having is Squad's carelessness, they aren't checking for duplicate entries in a dictionary that is used for the contract weighting system. The only way that I can think of for that to be a problem is if two copies of the same assembly get loaded. The only problem is that I don't see any mention of a second assembly being loaded in the log files. Check your GameData folder (and maybe look in those other folders in the root KSP folder; Kerbal Space Program/Plugins, etc...)

@Zero_Out Version 0.3.3 and 0.3.2 of what? This mod is on version 1.3.2.

Link to comment
Share on other sites

@DMagic Thank you for replying :)
I have checked my DMagic Folder in /GameData and there was nothing duplicated and nothing out of the ordinary (
Also the /plugins and /pluginData folders are completely empty.
Is there any other logs or files that could help me figure this issue out ? 

I will attach my Dmagic.DLL, I've no idea if this is useful to you or not.
https://www.dropbox.com/s/6i8ms513ikymahp/DMagic.dll?dl=0

Folder Link : https://www.dropbox.com/sh/5eli0bi5cnl5jqe/AAATciRKmJoJulUrXcUZEyM0a?dl=0
Thanks

Edited by ii_DyNaMiCs_ii
Link to comment
Share on other sites

30 minutes ago, ii_DyNaMiCs_ii said:

@DMagic Thank you for replying :)
I have checked my DMagic Folder in /GameData and there was nothing duplicated and nothing out of the ordinary (
Also the /plugins and /pluginData folders are completely empty.
Is there any other logs or files that could help me figure this issue out ?

Something has gone wrong when you installed a mod called "CryoTanks". There are DLLs inside GameData\CryoTanks\Plugins that should absolutely not be there. Delete every dll inside that folder except SimpleBoiloff.dll (or better yet, download the new version released by @Nertea as he's already fixed the problem). This is probably your issue

Spoiler

Quote

[LOG 02:54:39.474] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\Assembly-CSharp-firstpass.dll
[LOG 02:54:39.479] Load(Assembly): CryoTanks/Plugins/Assembly-CSharp
[LOG 02:54:39.480] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\Assembly-CSharp.dll
[LOG 02:54:39.513] AssemblyLoader: KSPAssembly 'KSP' V1.1
[LOG 02:54:39.514] Load(Assembly): CryoTanks/Plugins/KSPAssets
[LOG 02:54:39.514] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\KSPAssets.dll
[LOG 02:54:39.517] Load(Assembly): CryoTanks/Plugins/KSPUtil
[LOG 02:54:39.518] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\KSPUtil.dll
[LOG 02:54:39.521] Load(Assembly): CryoTanks/Plugins/Mono.Cecil
[LOG 02:54:39.522] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\Mono.Cecil.dll
[LOG 02:54:39.525] Load(Assembly): CryoTanks/Plugins/Mono.Security
[LOG 02:54:39.526] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\Mono.Security.dll
[LOG 02:54:39.528] Load(Assembly): CryoTanks/Plugins/SaveUpgradePipeline.Core
[LOG 02:54:39.529] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\SaveUpgradePipeline.Core.dll
[LOG 02:54:39.532] Load(Assembly): CryoTanks/Plugins/SimpleBoiloff
[LOG 02:54:39.532] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\SimpleBoiloff.dll
[LOG 02:54:39.535] Load(Assembly): CryoTanks/Plugins/TDx.TDxInput
[LOG 02:54:39.536] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\TDx.TDxInput.dll
[LOG 02:54:39.538] Load(Assembly): CryoTanks/Plugins/TrackIRUnity
[LOG 02:54:39.539] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\TrackIRUnity.dll
[LOG 02:54:39.541] Load(Assembly): CryoTanks/Plugins/UnityEngine
[LOG 02:54:39.542] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\UnityEngine.dll
[LOG 02:54:39.547] Load(Assembly): CryoTanks/Plugins/UnityEngine.UI
[LOG 02:54:39.548] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\UnityEngine.UI.dll
[LOG 02:54:39.551] Load(Assembly): CryoTanks/Plugins/Vectrosity
[LOG 02:54:39.551] AssemblyLoader: Loading assembly at C:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\CryoTanks\Plugins\Vectrosity.dll

 

Link to comment
Share on other sites

  • 2 weeks later...

Not sure if this is a ScanSat issue or an Orbital Science one, but I've just noticed that the Magnetometer says "not for use during atmospheric flight" and yet it's max altitude is below the Kerman line. Is it just WAD that you can't use it to scan Kerbin or am I missing something?

Link to comment
Share on other sites

24 minutes ago, baldamundo said:

Not sure if this is a ScanSat issue or an Orbital Science one, but I've just noticed that the Magnetometer says "not for use during atmospheric flight" and yet it's max altitude is below the Kerman line. Is it just WAD that you can't use it to scan Kerbin or am I missing something?

You can use it on surface or in orbit out of atmosphere. But it is not suitable to use in atmospheric flight, because it will break apart on slightly higher velocity and probably cause unstability on craft aerodynamic.

Link to comment
Share on other sites

What @kcs123 says is the idea, though none of that would actually happen, you just have to pretend that it would happen if you were to extend it during flight. :sticktongue:

As for the Ore scanning altitude, it isn't meant to scan Kerbin (I'm not sure why anyone would really want to scan Kerbin for Ore anyway). It is intentionally crippled as a resource scanner since it comes so much earlier than the Narrow-Band scanner (which also has other useful functions). 

Edited by DMagic
Link to comment
Share on other sites

3 hours ago, DMagic said:

What @kcs123 says is the idea, though none of that would actually happen, you just have to pretend that it would happen if you were to extend it during flight. :sticktongue:

As for the Ore scanning altitude, it isn't meant to scan Kerbin (I'm not sure why anyone would really want to scan Kerbin for Ore anyway). It is intentionally crippled as a resource scanner since it comes so much earlier than the Narrow-Band scanner (which also has other useful functions). 

Ahhh, that makes sense! :) Cheers

Link to comment
Share on other sites

Found an odd bug when using this mod in conjunction with Real Solar System that prevents my craft from leaving the Moon's SOI and returning to Earth. Looking at the output log it seems that when entering the Moon's SOI for the first time DMagic.Contracts.DMReconContract.Generate () throws an InvalidCastException. Uninstalling DMOS seems to have fixed the issue.

Output log

Also, this is a really awesome mod and I get so much enjoyment from it! Thank you creating and maintaining it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...