Jump to content

[1.8.x] DMagic Orbital Science: New Science Parts [v1.4.3] [11/2/2019]


DMagic
 Share

Recommended Posts

On 12/2/2021 at 2:41 PM, Gordon Dry said:

And last but not least: the fact that this is a case since August/September 2018 even confuses me more...

Edit: I just recognized, inside GameData\DMagicOrbitalScience\UniversalStorage\ they all got

TechRequired = Unresearcheable

so they're obsolete for real.


Edit:
Not to be forgotten the fixes from https://github.com/7ranceaddic7/Orbital-Science

Hey @Gordon Dry,

sorry I'm a bit confused by your answer,

to use this mod and UniversalStorage2, do I have to change something or update it from the link you posted?

 

 

On 12/18/2021 at 3:13 PM, flart said:

I am playing around in the configs with a "ultimate" science part, that include many experiments.
For now I choose the SC-9001, and put inside 5 stock ModuleScienceExperiments  without any problem, using the 
        %hideFxModuleUI = False
        %FxModules = 0

I connected experiments and the "open door" animation.

Now I want to add there also some DMModuleScienceAnimate, but I can't connect it properly to the "open door" animation.
After some tweaking, the "Collect Hydrogen Data" action is working (open door, has a delay and EC consumption), but only after you manually "open door" and "close door".

Is there a way to bypass this limitation, and having DMModuleScienceAnimate working on "Collect Hydrogen Data" without this "warming-up" ?

 

patches for this part is in an archive:
https://1drv.ms/u/s!Alncj27YxKc-iBRaWg2BqTgK81al?e=5ibp0n

Hey @flart,

Did you get it to work?
And if so, is it compatible with Kerbalism?

Edited by N3N
Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
5 hours ago, aradapilot said:

https://github.com/DMagic1/Orbital-Science/pull/97

hopefully they see that and merge it

I'm not sure I understand.  There was only KSP 1.8.1 so updating the version file to 1.8.8 won't include any more versions than were already published.  

Frankly, it doesn't make much of a difference because you can tell CKAN to install regardless of a minor version number.   Open CKAN > Settings > Compatible game versions and list those KSP version mod compatibilities you want to be visible.  Then install to your heart's content but realize that you may not receive help for unsupported KSP versions.

Furthermore, if the mod author isn't comfortable releasing for a newer version of KSP - because of lack of testing, perhaps - they they might not want to feel compelled to offer support.

Link to comment
Share on other sites

  • 4 months later...
On 2/20/2022 at 11:04 PM, Aelfhe1m said:

The method I use is to open the GameData/ModuleManager.ConfigCache file in a text editor and then do a search for the experiment name. You should find a section of the file that looks something like:

UrlConfig
{
	parentUrl = Bluedog_DB/Resources/Scidef_bd_bioexp.cfg
	EXPERIMENT_DEFINITION
	{
		id = bd_bioexp
		title = Biological experiments
		...
	}
	...
}

Now use the shown id (bd_bioexp in this example) to do a further search for "experiment_id = xxxx". This should take you to a part that implements that experiment:

UrlConfig
{
	parentUrl = Bluedog_DB/Parts/ProbeExpansion/Biosat/bluedog_Biosat_Adapter.cfg
	PART
	{
		name = bluedog_Biosat_Adapter
		module = Part
		author = CobaltWolf
		...
		title = Biosat Adapter Section
		...
		MODULE
		{
			name = ModuleScienceExperiment
			experimentID = bd_bioexp
			experimentActionName = Perform Biological Experiments
			...
		}
		...
	}
}

This gives you the title of the part to search for in the VAB ("Biosat Adapter Section" in this case)

I don't have an exact match for the other two experiments in my current game - check the exact text being displayed in the contract. My best guess is they are the Tantares experiments "Ultraviolet Light Camera" and "Infrared Light Camera". (If you have Tantares and TantaresSP installed then there are multiple experiments with the same name but different internal ids which come on separate parts)

 

Now that Would be a GREAT Mod... One that identifies the correct component to run specific science!  I don't know how many times I've Overloaded my ship with science equipment trying to find out Which one will do the trick.  Your Above method appears to be my future answer to do just that.

Hello Everyone,

    I'm in the process of one-by-one reinstalling All 300 of my favorite mods since upgrading to 1.12.4 and this one mod threw 13 errors into my log as listed below:

    Line  8915: [ERR 08:21:37.224] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8921: [ERR 08:21:37.239] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8927: [ERR 08:21:37.254] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8933: [ERR 08:21:37.270] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8939: [ERR 08:21:37.295] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8945: [ERR 08:21:37.319] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8951: [ERR 08:21:37.345] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8957: [ERR 08:21:37.362] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8963: [ERR 08:21:37.381] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8969: [ERR 08:21:37.403] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8975: [ERR 08:21:37.422] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8981: [ERR 08:21:37.445] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8987: [ERR 08:21:37.461] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 

Anyone have a way to fix these?  If it was already provided I didn't see it and apologize in advance.

Link to comment
Share on other sites

  • 2 months later...
On 11/15/2022 at 3:51 PM, Xtra said:

Now that Would be a GREAT Mod... One that identifies the correct component to run specific science!  I don't know how many times I've Overloaded my ship with science equipment trying to find out Which one will do the trick.  Your Above method appears to be my future answer to do just that.

Hello Everyone,

    I'm in the process of one-by-one reinstalling All 300 of my favorite mods since upgrading to 1.12.4 and this one mod threw 13 errors into my log as listed below:

    Line  8915: [ERR 08:21:37.224] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8921: [ERR 08:21:37.239] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8927: [ERR 08:21:37.254] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8933: [ERR 08:21:37.270] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8939: [ERR 08:21:37.295] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8945: [ERR 08:21:37.319] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8951: [ERR 08:21:37.345] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8957: [ERR 08:21:37.362] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8963: [ERR 08:21:37.381] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8969: [ERR 08:21:37.403] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8975: [ERR 08:21:37.422] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8981: [ERR 08:21:37.445] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
    Line  8987: [ERR 08:21:37.461] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 

Anyone have a way to fix these?  If it was already provided I didn't see it and apologize in advance.

I have found the same issue:

Spoiler

[ERR 18:29:39.855] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:39.861] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USASERT/USASERT/dmUSAsert' has no database record. Creating.
[LOG 18:29:39.862] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:39.863] DragCubeSystem: Creating drag cubes for part 'dmUSAsert'
[LOG 18:29:39.872] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USGooMat/USGoo/dmUSGoo'
[ERR 18:29:39.873] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:39.876] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USGooMat/USGoo/dmUSGoo' has no database record. Creating.
[LOG 18:29:39.876] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:39.876] DragCubeSystem: Creating drag cubes for part 'dmUSGoo'
[LOG 18:29:39.890] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USGooMat/USMat/dmUSMat'
[ERR 18:29:39.891] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:39.895] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USGooMat/USMat/dmUSMat' has no database record. Creating.
[LOG 18:29:39.895] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:39.896] DragCubeSystem: Creating drag cubes for part 'dmUSMat'
[LOG 18:29:39.910] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USGoreSat/USGoreSat/dmUSGoreSat'
[ERR 18:29:39.911] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:39.915] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USGoreSat/USGoreSat/dmUSGoreSat' has no database record. Creating.
[LOG 18:29:39.915] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:39.917] DragCubeSystem: Creating drag cubes for part 'dmUSGoreSat'
[LOG 18:29:39.940] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USImagingPlatform/USImagingPlatform/dmUSImagingPlatform'
[ERR 18:29:39.941] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:39.945] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USImagingPlatform/USImagingPlatform/dmUSImagingPlatform' has no database record. Creating.
[LOG 18:29:39.945] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:39.947] DragCubeSystem: Creating drag cubes for part 'dmUSImagingPlatform'
[LOG 18:29:39.965] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USProbeSci/MagBoom/dmUSMagBoom'
[ERR 18:29:39.966] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:39.971] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USProbeSci/MagBoom/dmUSMagBoom' has no database record. Creating.
[LOG 18:29:39.971] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:39.972] DragCubeSystem: Creating drag cubes for part 'dmUSMagBoom'
[LOG 18:29:40.001] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USProbeSci/RPWS/USRPWS'
[ERR 18:29:40.002] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:40.007] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USProbeSci/RPWS/USRPWS' has no database record. Creating.
[LOG 18:29:40.007] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:40.009] DragCubeSystem: Creating drag cubes for part 'USRPWS'
[LOG 18:29:40.025] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USScope/USScope/dmUSScope'
[ERR 18:29:40.026] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:40.031] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USScope/USScope/dmUSScope' has no database record. Creating.
[LOG 18:29:40.031] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:40.032] DragCubeSystem: Creating drag cubes for part 'dmUSScope'
[LOG 18:29:40.051] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USSoilMoisture/USSoilMoisture/dmUSSoilMoisture'
[ERR 18:29:40.051] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:40.057] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USSoilMoisture/USSoilMoisture/dmUSSoilMoisture' has no database record. Creating.
[LOG 18:29:40.057] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:40.059] DragCubeSystem: Creating drag cubes for part 'dmUSSoilMoisture'
[LOG 18:29:40.079] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USSolarParticles/USSolarParticles/dmUSSolarParticles'
[ERR 18:29:40.079] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:40.084] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USSolarParticles/USSolarParticles/dmUSSolarParticles' has no database record. Creating.
[LOG 18:29:40.084] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:40.085] DragCubeSystem: Creating drag cubes for part 'dmUSSolarParticles'
[LOG 18:29:40.105] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USStock/ACCGRAV/dmUSAccGrav'
[ERR 18:29:40.105] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:40.114] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USStock/ACCGRAV/dmUSAccGrav' has no database record. Creating.
[LOG 18:29:40.114] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:40.115] DragCubeSystem: Creating drag cubes for part 'dmUSAccGrav'
[LOG 18:29:40.134] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USStock/ATMOSSENSE/dmUSAtmosSense'
[ERR 18:29:40.135] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

[LOG 18:29:40.139] PartLoader: Part 'DMagicOrbitalScience/UniversalStorage/USStock/ATMOSSENSE/dmUSAtmosSense' has no database record. Creating.
[LOG 18:29:40.139] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 18:29:40.139] DragCubeSystem: Creating drag cubes for part 'dmUSAtmosSense'
[LOG 18:29:40.151] PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USStock/PRESTEMP/dmUSPresTemp'
[ERR 18:29:40.152] PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

Any ideas?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...