Jump to content

Chaka Monkey - Closed Development Thread


Recommended Posts

I just got to try out your latest version and ran into this problem again...

[ERR 19:53:39.271] [shipConstruct]: Trying to load Monkey Cargo System Type II - No AvailablePart found for XKzProcFairingBaseRing3.75

[ERR 19:53:39.372] [shipConstruct]: Trying to load Monkey Launch System - Munar 2x - No AvailablePart found for XKzProcFairingBaseRing8

[ERR 19:53:39.470] [shipConstruct]: Trying to load Monkey Launch System - Rover - No AvailablePart found for XKzProcFairingBaseRing8

However, I figured out what was going on. I was deleting the Keramzit folder because I already have procedural fairings installed. You might want to move those configs out of the Keramzit folder and into their respective parts packs folders (Structural and Aero?) to avoid confusion for the clueless (like me).

I did get to fly the Orion System II. Very nice ride! I flew it all the way to Munar orbit and back and only encountered three problems.

1) It likes to tumble over to 270 on ascent if SAS is off. I did not find it automatically flew a nice parabola with SAS on.

2) I EVA'd Bill, who promptly shot off at a 0 degree tangent to the pod at high velocity. RIP Bill.

3) The parachute cords appear to run through the entire pod (see pic). While this might help with anchoring, I suspect it'd be uncomfortable for the crew, and they'd burn off on reentry anyway.

Oh, and could you delineate where the hatch on the pod is more clearly? Just a stylistic preference on my part I'm sure.

FYI, for anyone who cares: I use Active Texture Management (Aggressive config) which has trouble with some of the normal maps, particularly the pod. I'm feeling lazy, so for now, I just told ATM to ignore CMES with this config in the BoulderCo folder.

ACTIVE_TEXTURE_MANAGER_CONFIG

{

folder = CMES

enabled = false

}

CJANJs6.png

Edited by lincourtl
Link to post
Share on other sites
I use Active Texture Management too but, I didn't get that , Did you delete the old 1 first ?

Didn't get what? The weird shadows on the pod and a couple of the tanks? I didn't see them on this go because I added the ATM config in anticipation of having seen them before.

I have the latest ATM, GreenSkull ATM configs, and CMES installed. I did delete the previous versions.

Link to post
Share on other sites

Hey guys thank you for the test flights!

I'm glad the missing parts problem turned out to be simple. When you put the Keramzit files from this back did they interfere with anything else you had?

Orion is a work in progress. Bobcat made the model originally and we sruggle with it sometimes. Sorry to hear about Bill. I have a list of things to work out with that capsule so I'l keep an eye out for the EVA ejection issue, I've never seen that before.

The parachutes problem comes from my novel dock port attach point and scale. Also, today I saw one of it's texture glitches. I had thought previously that it was the texture size issue but this is a new one, also related to my novel dock port settings.

I think the best solution is to make an entirely new dock port from scratch, one with working RCS thrusters in the holes, docking lights, and real chute etc.

The Monkey Orion system has a few flaws and actually flies worse than the larger rocket. When I spoke about flying itself to a nice parabola I was describing the larger rocket. I'm gonna do a review of the Orion rocket design and re make it from the ground up for the next version.

Link to post
Share on other sites
Hey guys thank you for the test flights!

Oh, believe me, it's my pleasure. Once these are done, I may well delete most of my stock parts. They are so beautiful.

I'm glad the missing parts problem turned out to be simple. When you put the Keramzit files from this back did they interfere with anything else you had?

Haven't tried yet. I assume I can just delete the .dll and the regular Keramzit configs since they're duplicated.

Orion is a work in progress. Bobcat made the model originally and we sruggle with it sometimes. Sorry to hear about Bill. I have a list of things to work out with that capsule so I'l keep an eye out for the EVA ejection issue, I've never seen that before.

Isn't that what Bill's for? We need Jeb to fly the ship, Bob for ballast...

The parachutes problem comes from my novel dock port attach point and scale. Also, today I saw one of it's texture glitches. I had thought previously that it was the texture size issue but this is a new one, also related to my novel dock port settings.

Ah! I was just curious what that string was hanging down from the heatshield. If it was intended I was going to suggest putting a label there. "Do not cut under penalty of law of gravity."

The Monkey Orion system has a few flaws and actually flies worse than the larger rocket. When I spoke about flying itself to a nice parabola I was describing the larger rocket. I'm gonna do a review of the Orion rocket design and re make it from the ground up for the next version.

Well, tipsiness aside, it was really quite nice. I was really surprised at the power. That upper stage got me all the way to a circular Munar orbit, and back to Kerbin. I never even needed the service module engine.

JSe8sYs.png

Link to post
Share on other sites
...Well, tipsiness aside, it was really quite nice. I was really surprised at the power. That upper stage got me all the way to a circular Munar orbit, and back to Kerbin. I never even needed the service module engine.

http://i.imgur.com/JSe8sYs.png

:P you can thank the solids for all that delta. It has too much power though we need to tone it down a little. It's supposed to have just enough to get you to the Mun and then the service module is for getting home.

EDIT: PS please test rover.

Link to post
Share on other sites

lyuc.jpg

EVA and he's feelin fine lol

q9e8.jpg

Note standard config dockport. This will fix the glitchy texture issue. We will drop the novel dockport config.

We need more testing to understand ejection.

I'm gonna define the Orion EVA hatch the way it is on the rover in the next version.

Also, there will be a new Orion System, Type IV! This one features six solids, three of which light on liftoff, then the other three ignite when the first three sep. Also there are solid separation motors so the boosters don't just slide down the core stage.

vd9a.jpg

The new system has just enough power to get to the moon and then it's service module for orbital insertion. Upper stage ignition takes place much earlier in the flight path which feels more natural. Also, the pancake tanks are gone, they were causing the instability, so its slightly shorter and more rigid.

exko.jpg

y2sv.jpg

Edited by YANFRET
Link to post
Share on other sites

Monkey Rover issues...

0) (metaissue) 245 parts! That's too many for my system. Launching I had like 5 fps. I wonder if there isn't a way of getting that part count down significantly in the final release version -- perhaps using config "welds"?

1) Spawns with inverted controls, probably because upside down pod is root part

2) (no image) Too little control authority over launcher

3) SRBs collision on separation (I know you said you were adding separation motors)

4) Explodey

5) (Hyperedit test not shown) Using just the pod + rover/lander I hyperedited it into Munar orbit. I separated the pod from the rover/lander and noticed the staging was messed up. If I had staged to activate the lander engine, I would have decoupled the lander from the rover.

Other than that, once I cheated the rover onto the Mun's surface, it worked fine. :D

Sorry if I sound hypercritical. These are really minor issues.

On edit: You do say, "Disable torque on A.L.C.O.R. pod AND Rover Base before launch. Set "Control Here" on Remote Guidance Unit below rover." I'm not sure how to do that on the launchpad when all that is hidden by the fairings. If the user has Tweakable Everything installed, I believe they can action group "Control from here" on docking ports, but I don't think it can be done on probe cores.

Javascript is disabled. View full album
Edited by lincourtl
Link to post
Share on other sites
Monkey Rover issues...

0) (metaissue) 245 parts! That's too many for my system. Launching I had like 5 fps. I wonder if there isn't a way of getting that part count down significantly in the final release version -- perhaps using config "welds"?

1) Spawns with inverted controls, probably because upside down pod is root part

2) (no image) Too little control authority over launcher

3) SRBs collision on separation (I know you said you were adding separation motors)

4) Explodey

5) (Hyperedit test not shown) Using just the pod + rover/lander I hyperedited it into Munar orbit. I separated the pod from the rover/lander and noticed the staging was messed up. If I had staged to activate the lander engine, I would have decoupled the lander from the rover.

Other than that, once I cheated the rover onto the Mun's surface, it worked fine. :D Jeb needs to learn to brake better he fly's alittle fast on the landing.

Sorry if I sound hypercritical. These are really minor issues.

On edit: You do say, "Disable torque on A.L.C.O.R. pod AND Rover Base before launch. Set "Control Here" on Remote Guidance Unit below rover." I'm not sure how to do that on the launchpad when all that is hidden by the fairings. If the user has Tweakable Everything installed, I believe they can action group "Control from here" on docking ports, but I don't think it can be done on probe cores.

http://imgur.com/a/1V7Pk

Did you throw error when decouple lander from rover ? and as my mun landing wasn't good the pod made it lol but didn't see how you would exit the lander if it stayed together ?

EDIT don't remember what it was will try to launch 1 later and see what it was throwing and hope it land safer this time :D

Edited by Mecripp2
Link to post
Share on other sites
Did you throw error when decouple lander from rover ? and as my mun landing wasn't good the pod made it lol but didn't see how you would exit the lander if it stayed together ?

No error when decoupling the lander from the rover. It was only an issue of the decoupler and the lander engine being in the same stage.

Link to post
Share on other sites

Hey what you do is zoom in through the fairing from an above view

Edit; I had no idea the parts count was an issue I hadn't noticed that. I generally run with all the terrain settings turned way down though.

Later there will be a more simple rocket with just tr rover and no lander... Sorry about the staging glitch. I usually sep with the mouse just in case.

The booster doesn't have a lot of dynamic control while the solids are on to reduce stress on the structure. Once you get the hang of it the flight procedures will make more sense

Edited by YANFRET
Link to post
Share on other sites
Hey what you do is zoom in through the fairing from an above view

I never have any luck doing that. I can never right click on the right part. Wouldn't it be easier to use SelectRoot to make the probe core the root part?

Link to post
Share on other sites

Well.. I can load one of the four craft files. The Cargo System TypeII works. But not so much for the others. Again are there any parts in the crafts that are not supplied in the download?

EDIT: Nevermind im sorry im not playing this on a clean install. Theses duplicate parts most likely.

Edited by Motokid600
Link to post
Share on other sites
Well.. I can load one of the four craft files. The Cargo System TypeII works. But not so much for the others. Again are there any parts in the crafts that are not supplied in the download?

EDIT: Nevermind im sorry im not playing this on a clean install. Theses duplicate parts most likely.

Actually if you're able to narrow down what it's conflicting with i'd like to know

Link to post
Share on other sites
Well I had the entire American Pack installed at the same time so that couldn't have helped. But.. are you saying the two SHOULD coincide? If so ill try a process of elimination to which one conflicts.

Yeah one of my design goals is non interference with other packs so I would absolutely like to know if you're able to figure it out.

Link to post
Share on other sites

So apparently there is a stock part in the craft files. I put all of squads parts back in and the craft files load.

EDIT: Now that im able to fly the rockets.. they keep flipping. I use FAR and im guessing these rockets are meant to perform with that mod? I start my gravity turn at around 1km when my speed hits 100m/s. But just the smallest bit of input and rocket goes into an uncontrollable stall and flips around. The best I could do was 500m/s before the rocket flips. I mean.. it takes only a few degrees off prograde and I loose all control.

Edited by Motokid600
Link to post
Share on other sites
So apparently there is a stock part in the craft files. I put all of squads parts back in and the craft files load.

EDIT: Now that im able to fly the rockets.. they keep flipping. I use FAR and im guessing these rockets are meant to perform with that mod? I start my gravity turn at around 1km when my speed hits 100m/s. But just the smallest bit of input and rocket goes into an uncontrollable stall and flips around. The best I could do was 500m/s before the rocket flips. I mean.. it takes only a few degrees off prograde and I loose all control.

Whats the stock part that interferes? I'l change its ID.

Go higher and faster before agressive gravity turn. I like to pitch kick right at the beginning and then build up speed before going further. Alot higher and alot faster. I havent tested it with FAR but thats a good idea.

To help you visualize a good flight path, turn off FAR (to eliminate that from the equation until I can test it)

Then, try the mechjeb ascent guidance with a path that looks like this

xtq4.jpg

That's the most efficient

As always KJR is a requirement. It might not necessarily need it, but I don't test without it so...

Edited by YANFRET
Link to post
Share on other sites

I'll have to wait until tomorrow before I can strip the rockets down to see what stock parts there are. But I can tell you one is the inline probe core ( unless this ones already been reidentified ) below the rover. I'll give that flight path a go as well.

Link to post
Share on other sites
I'll have to wait until tomorrow before I can strip the rockets down to see what stock parts there are. But I can tell you one is the inline probe core ( unless this ones already been reidentified ) below the rover. I'll give that flight path a go as well.

Ohh I get it... you're saying not a modified stock part, but that I included a stock part in the craft, and you had removed your stock parts.

MMMMM now i get it.

Yeah that would be the probe core as well as the standard light.

EDIT;

PS The Mun is nice tonight. The docking port alignment was almost right on my second try but we need to raise the port on the hab by one hand width for the next version.

bcxi.jpg

Edited by YANFRET
Link to post
Share on other sites

Coming Soon:

Monkey Orion System Type VI

z1ez.jpg

xe9l.jpg

38ud.jpg

8ybp.jpg

Re made from the ground up to be more* safe!

*DISCLAIMER: "more" and "safe" are Chaka's subjective opinion. Non-Monkey results may vary

Edited by YANFRET
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...