Jump to content

Chaka Monkey - Closed Development Thread


Recommended Posts

Think I found a bug with the Orion pod. Looks like it cant store science. I used it for an asteroid capture mission and when I tried to get back in the pod with my sample it said it could not store the experiment. There is also no option for making crew reports. Guessing its an old config from before the career mode update. I know that pack isnt really setup for career mode yet but figured I would let you know.

Link to post
Share on other sites

This will add it to start in career mod and add the science stuff hope he don't mind.https://www.dropbox.com/s/w0ioaf69trsbn12/CMES.zip

Edit just the pod will try and go through the rest.

Edit 2 added some more hubs and a cfg to add them to start if there is no Tech in the part file.

Edit 3 Just copy file over to KSP/GameData all should go where it needs.

Edit 4 added the Altair_pod

Edited by Mecripp2
Link to post
Share on other sites
What happen to the LLL Antennas that was on the rover ?

...

They're back! I spoke with Lack the other day about licensing and they are on the craft once again.

k5nv.jpg

I think that LLL antenna is my favorite part in all of KSP.

87jd.jpg

This Hi Rise lander is really cool. I hope it works!

ytou.jpg

EDIT; It does!

Edited by YANFRET
Link to post
Share on other sites

I use a Module Manager config to get all the parts in career mode. Makes it nice and easy just make sure you have the module manager .dll installed, most mods now days come with it so you probable do. Make a config file, just a text file with its extension changed to .cfg put in it

@PART[*]:HAS[~TechRequired[]]:Final

{

TechRequired=advScienceTech}

You can change the tech required to what ever you want, this on sticks it at the end of the tech tree seeing as its all advanced stuff. What it does is any part you have installed without a tech requirement will be added to that node. Easy way to handle WIP mods that don't have career support yet.

Link to post
Share on other sites

You mean under the upper stage engine in MLS?

If so then there is a complicated reason for that which is moot because the adapter ring is gone in the latest revision so you'll never see it again.

In previous versions of KSP it helped define the lines of force through the rocket but it's not needed anymore, plus it explodes alot on stage sep so it's bad.

Link to post
Share on other sites

Just tried out the rover / hab lander craft very cool man.

Two slight problems, the cupola half of the craft explodes bits of itself everywhere leaving a Kerbal in the centre of the destruction when you EVA from it. As I found shortly after touching down on the Mun :D I LMAO though so in a way it could be considered a feature.

That and the lights on the cupola don't work.

Apart from that awesome.

Link to post
Share on other sites
Just tried out the rover / hab lander craft very cool man.

Two slight problems, the cupola half of the craft explodes bits of itself everywhere leaving a Kerbal in the centre of the destruction when you EVA from it. As I found shortly after touching down on the Mun :D I LMAO though so in a way it could be considered a feature.

That and the lights on the cupola don't work.

Apart from that awesome.

LOL yes features! The only way out of the rover support hab is through the rover. Oops forgot the light bulbs! Thanks for the reminder

Glad you had a nice flight!

Link to post
Share on other sites

Are there any plans to add more functionality to the big hab module things? They look really cool but are mostly just very heavy weights with no use. Not sure exactly what those functions would be... As some one that uses TAC life support I would love to see large resource storage for those but I know not every one wants to use life support mods, maybe optional configs for that? Easy one would be the stock science lab, could add the functionality of that to some of them.

Link to post
Share on other sites
Are there any plans to add more functionality to the big hab module things? They look really cool but are mostly just very heavy weights with no use. Not sure exactly what those functions would be... As some one that uses TAC life support I would love to see large resource storage for those but I know not every one wants to use life support mods, maybe optional configs for that? Easy one would be the stock science lab, could add the functionality of that to some of them.

Absolutley. Once we get to the beta stage I want to explore hab function. We'l probably spend a lot of time on that. On the outside I'd like to see science activity such as robot arms for taking samples, moving things around, drilling. I'd like to make a supply lander with packages that can be set on the ground as well. On the inside we will get up to date with the latest functions that Sumghai is developing for these modules which we are licensing from him.

Link to post
Share on other sites

I think I found a problem with the ALCOR Monkey Rover Pod. Every time I try and use it, even if its the only part, it locks up my game after a few sec. I tried to get an error log but the way it locks up I cant get much. "NullReferenceException: Object reference not set to an instance of an object" was filling the log screen when it locks up and as it sits there locked up the ram use of KSP go's threw the roof tell it crashes. Dont know if its a bug with the part or a conflict with another mod. Mods I am using that are plugin heavy or effect command pods are Deadly Reentry, FAR, TAC life support and KSPInterstellar-v0.11. Hope that helps.

I just installed the original ALCOR mod and made sure to get all the dependent mods, that one also crashes so I am guessing it is a conflict or I just have something installed wrong. I could not find any posts on that mods page about the problem I am having. Any one else having problems with the ALCOR pods?

Edited by pilfit
Link to post
Share on other sites
I think I found a problem with the ALCOR Monkey Rover Pod. Every time I try and use it, even if its the only part, it locks up my game after a few sec. I tried to get an error log but the way it locks up I cant get much. "NullReferenceException: Object reference not set to an instance of an object" was filling the log screen when it locks up and as it sits there locked up the ram use of KSP go's threw the roof tell it crashes. Dont know if its a bug with the part or a conflict with another mod. Mods I am using that are plugin heavy or effect command pods are Deadly Reentry, FAR, TAC life support and KSPInterstellar-v0.11. Hope that helps.

I just installed the original ALCOR mod and made sure to get all the dependent mods, that one also crashes so I am guessing it is a conflict or I just have something installed wrong. I could not find any posts on that mods page about the problem I am having. Any one else having problems with the ALCOR pods?

Did you install rpm (raster prop monitor)? If you did get all the dependencies it should be there tho. (Maybe one of the dependencies/installed mods arent 23.5 compatible). the lack of this would cause the issues you are describing

Edited by landeTLS
Link to post
Share on other sites
I think I found a problem with the ALCOR Monkey Rover Pod. Every time I try and use it, even if its the only part, it locks up my game after a few sec. I tried to get an error log but the way it locks up I cant get much. "NullReferenceException: Object reference not set to an instance of an object" was filling the log screen when it locks up and as it sits there locked up the ram use of KSP go's threw the roof tell it crashes. Dont know if its a bug with the part or a conflict with another mod. Mods I am using that are plugin heavy or effect command pods are Deadly Reentry, FAR, TAC life support and KSPInterstellar-v0.11. Hope that helps.

I just installed the original ALCOR mod and made sure to get all the dependent mods, that one also crashes so I am guessing it is a conflict or I just have something installed wrong. I could not find any posts on that mods page about the problem I am having. Any one else having problems with the ALCOR pods?

Also since you have so many mod plugins I would start turning them off one by one until you find which is causing the problem.

Link to post
Share on other sites

Just seating on the pad with ASET installed https://dl.dropboxusercontent.com/u/72893034/screenshot0.png

that cleared up when uninstalled it, I think but monitor are not working right and getting https://dl.dropboxusercontent.com/u/72893034/screenshot1.png

EDIT At looking at some of the ALCOR_Monkey_Rover/Props/ALCORMFD40x20 cfg there pointing to the wrong place

// --------------------Page 01 ----------------------------------------

PAGE

{

button = buttonR1

name = pALCORAscDes40x20

text = ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/ALCORAscDes40x20.txt <----- here

cameraTransform = ALCORExt_B_CamTransform

zoomFov = 5,60,3

zoomButtons = 0,1

flickerChance = 1

flickerRange = 100

}

PAGE

{

name = pALCORLanding40x20

button = buttonR1

text = ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/ALCORLanding40x20.txt <----- here

cameraTransform = ALCORExt_B_CamTransform

}

didn't go through them all but bet there the same.

Edited by Mecripp2
Link to post
Share on other sites

In the instructions it says for this release you must have the standard ALCOR pod installed for IVA props because I didn't have time to change all the references.

But its probably better to test this on something at least a little closer to a clean install of 23.5 :)

Link to post
Share on other sites

Please install update RasterPropMonitor 15 here https://github.com/Mihara/RasterPropMonitor/releases/download/v0.15/RasterPropMonitor.0.15.zip and went through and changed all that, I seen and it as unlock_MJ_Buttons (for RPM v0.15 and MJ v2.2.x ONLY)_2 already installed If you use this just copy the file below to KSP/GameData

DO NOT DELETE your old CMES just copy over.

https://www.dropbox.com/s/w0ioaf69trsbn12/CMES.zip

Edited by Mecripp2
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...