ZodiusInfuser

[WIP] MSI's Infernal Robotics - Model Rework (v02 Pre-Release Beta)

Recommended Posts

12 hours ago, lazaruz76 said:

This is to do with how KSP itself works. Parts DO NOT have collision with each other when they are part of the same vessel, only with other vessels. When you dock 2 vessels together, to you and me, we see 2 vessels connected together. But to KSP, the game sees 1 vessel in total. The game combines both vessels into 1 until you undock them. This is why the wheels fall through the floor. Your rover is a heavy part that is now only supported by the docking port connection.

1 way you could work around this is to use the winch from KAS to lift the rover back in, then attach struts either with kerbals or use either robo-struts or quantum struts (different mod). Personally I like to use multiple winches in my cargo bay on all sides of my rover as tie-down points and just leave out the docking port. This method allows me to have a load that is not perfectly aligned  and can shift a little if I'm not careful how I "strap it down". For me it's more fun but in the end it comes down to what you want for yourself in terms of design and how you load up your cargo.

Edit: Almost forgot, If you use the winch as I do make sure to connect it Undocked. It's listed as an option in the right-click menu when you have a kerbal close to it. This makes the game keep them as 2 vessels. the only problem with this is that you need to disconnect all of your winches before you switch vessels or else when you come back the winches will be broken and unusable. This also applies to leaving the game completely. I think it has something to do with how the game saves things but I'm not 100% on that.

why is it then that when I first launch the plane with the container docked with the same docking ports, the wheels DO obey collision rules with the floor?  Or is that because upon launch the docking ports are treated as a 'decouple' connection and not a 'dock' connection, and KJR is strengthening the crap out of it so it just looks like they're obeying collision rules?

I'm going to try to make a 4 winch crane loader into a ventral Mk4 cargo bay and see how that works out...

... it did not.  The winches connected to KAS ports ... let's just say the KAS ports attachment strength to both the container and the winch are not sufficient for the job.  tried to pull it in.. got part way and then everything fell apart, everything exploded, and it actually caused KSP to crash.  Going to try modifying some KAS part configs and see if I can increase their strength.. as the entire mod is pretty useless for heavy cargo lifting.  Was really hoping I could .. hm.. maybe if I use my pull-the-container-into-the-cargo-bay-on-wheels idea but then use more winches to connect the rear and then strut everything together.. sigh.. this is getting really complicated.  Hope 1.1 addresses this.

Edited by ss8913
documenting my epic failure

Share this post


Link to post
Share on other sites

OK so.. @ZodiusInfuser I'm losing my part textures when I load up.. if I delete the ATM cached textures for it, it's ok, but on subsequent loads of KSP, every part is just black.  Only happening with the WIP new parts though, not any other mod including the standard "production" IR parts.

Share this post


Link to post
Share on other sites
5 hours ago, ss8913 said:

OK so.. @ZodiusInfuser I'm losing my part textures when I load up.. if I delete the ATM cached textures for it, it's ok, but on subsequent loads of KSP, every part is just black.  Only happening with the WIP new parts though, not any other mod including the standard "production" IR parts.

Just don't use ATM or set it to exclude IR parts. IR parts use texture sharing, so they use minimal RAM.

Share this post


Link to post
Share on other sites

@ZodiusInfuser

i got the part already. Not sure if you see my edit. The link in the op leads to the beta download (which is corrupted upon rar-extracting for me). While there is another link for alpha download (that includes the parts)

Share this post


Link to post
Share on other sites
42 minutes ago, Kerbalmann said:

@ZodiusInfuser

i got the part already. Not sure if you see my edit. The link in the op leads to the beta download (which is corrupted upon rar-extracting for me). While there is another link for alpha download (that includes the parts)

Are you using winrar or equivalent to open the rar file? I downloaded it (a while ago) with no issues, and it had all the parts.

Share this post


Link to post
Share on other sites

I downloaded the beta last night without issue. I definitely recommend using the beta over the alpha if you can as it fixes a number of collision mesh issues that made parts fall through the floor.

Share this post


Link to post
Share on other sites

@ZodiusInfuser What do you think about a double length Extendatron? The half length are great and a double would be a welcome addition for building things like cranes or boom lifts with long booms.

Edited by V8jester

Share this post


Link to post
Share on other sites

Ok i figured out what is truely the problem. I installed Noscript on FF and somehow the download bugged out at 99% or something like that and it gives me an uncomplete rar package.

http://imgur.com/NE1Pzm6

http://imgur.com/bnNIvFs

 

I then used Google Chrome where I didnt install Noscript and voila the rar file works just fine. Apparently Noscript messes up the downloading process with cubby.com.

Edited by Kerbalmann

Share this post


Link to post
Share on other sites
23 hours ago, V8jester said:

6 posts oh ho, fresh meat!

Welcome to the forums :)

If you run into problems, one of us will be more than happy to help you get an arm working. IR can be a bit of a learning curve. But it's well worth the effort.

Thanks! It's not getting it working, entirely. I can do that. But rather gotta find just the right parts and placement in a MK3 Cargo part so it still leaves room for other stuff.

Share this post


Link to post
Share on other sites

Hi Zodius

 

When i download the v02, i get a 3 Mb file that has like three parts in it? Should i just use older pack that i might have?

Also, great parts mr. Infuser :)

 

EDIT: Right, i am dumb. They were under the probe-folder...my bad :P

 

Edited by Makeone

Share this post


Link to post
Share on other sites
On 3/8/2016 at 2:57 AM, Ziw said:

Just don't use ATM or set it to exclude IR parts. IR parts use texture sharing, so they use minimal RAM.

how do you tell ATM to exclude *all* the IR parts in one go?  Why is it only this mod that is causing this problem?  I ask these things because my install will crash while loading (ie, it cannot even get to the main menu screen), without ATM.

Share this post


Link to post
Share on other sites
3 hours ago, ss8913 said:

how do you tell ATM to exclude *all* the IR parts in one go?  Why is it only this mod that is causing this problem?  I ask these things because my install will crash while loading (ie, it cannot even get to the main menu screen), without ATM.

 

Make a cfg file by opening notepad. Paste the bellow code and save as a (.cfg) not a (.txt) with any name you'd like. Save it in the "MagicSmokeIndustries" folder and poof! No more ATM  texture headaches for IR :)

ACTIVE_TEXTURE_MANAGER_CONFIG
{
    folder = MagicSmokeIndustries
    enabled  = false
    
    OVERRIDES
    {
      	MagicSmokeIndustries/.*
        {
            compress = false
            mipmaps = false
            scale = 1
            max_size = 0
            make_not_readable = false
        }
    }
}

 

You may be able to just use this as well

ACTIVE_TEXTURE_MANAGER_CONFIG
{
    folder = MagicSmokeIndustries
    enabled  = false
}

 

Edited by V8jester

Share this post


Link to post
Share on other sites

Is it possible to have a gantry rail of configurable length. I find there are a lot of occasions where I need a rail, but the ones I have available are just too long, or too big, or too short. Is that at all possible? 

Share this post


Link to post
Share on other sites
2 hours ago, MrMeeb said:

Is it possible to have a gantry rail of configurable length. I find there are a lot of occasions where I need a rail, but the ones I have available are just too long, or too big, or too short. Is that at all possible? 

Not yet, but it might be a good idea for IR. I've added it to my possible new features list.

Share this post


Link to post
Share on other sites
5 minutes ago, Ziw said:

Not yet, but it might be a good idea for IR. I've added it to my possible new features list.

Also, the current/old IR gantry rails do kind of lack a rework model, just like the sliders...

Share this post


Link to post
Share on other sites
On 3/15/2016 at 7:51 PM, V8jester said:

 

Make a cfg file by opening notepad. Paste the bellow code and save as a (.cfg) not a (.txt) with any name you'd like. Save it in the "MagicSmokeIndustries" folder and poof! No more ATM  texture headaches for IR :)

>snip<

You may be able to just use this as well


ACTIVE_TEXTURE_MANAGER_CONFIG
{
    folder = MagicSmokeIndustries
    enabled  = false
}

 

Thank you!

Short version seems to work fine.  Be sure to delete the MagicSmokeIndustries folder from the atm texturecache folder, or it won't help though :)

update - black textures came back after a game crash, msi folder in atm texturecache folder came back also.  i'll try the longer config

Edited by mughi

Share this post


Link to post
Share on other sites
2 hours ago, Friethjoph said:

Also, the current/old IR gantry rails do kind of lack a rework model, just like the sliders...

That's something @ZodiusInfuser has had on the back burner a while. As a roboticist I'm sure he keeps super busy in real life

 

 

Share this post


Link to post
Share on other sites
On 3/16/2016 at 10:19 PM, V8jester said:

That's something @ZodiusInfuser has had on the back burner a while. As a roboticist I'm sure he keeps super busy in real life

Prioritizing real-world robots ahead of KSP virtual robots is anti-virtual bigotry, and should not be tolerated!

OTOH, it probably pays better. ;)

Share this post


Link to post
Share on other sites

Suggestion: make a tech upgrade available to strengthen the parts... some kind of meta-materials node or something on CTT... I have needs to move 300-1000 ton cargo kontainers around (MKS Kontainers) and the current parts, even the new ones, are just not strong enough to hold on to them.  magnets, hooks, etc.. just can't hold that much weight at least not in Kerbin's gravity.  I want like a super super powerful electromagnet, really... one that I can power with a KSPIE antimatter reactor + electric generator.  I suppose I could hack one myself from the current part config, but I don't like hacking other peoples' mods, feels wrong :)

 

Share this post


Link to post
Share on other sites

Is it possible to make the robot strut extend farther ? I need it to hold the moving parts among the stuff that is attached to the sliding rail (it wobbles too much). The robot strut extends too short and it stops the movable parts :(

Edit: I tried to edit the "maxLength" in config file but it doesnt seem to work. Not sure if i use it right but sometimes it can extend far, and sometimes it refuses to extend even just a bit.

Edited by Kerbalmann

Share this post


Link to post
Share on other sites
On 3/16/2016 at 5:57 PM, mughi said:

 

Thank you!

Short version seems to work fine.  Be sure to delete the MagicSmokeIndustries folder from the atm texturecache folder, or it won't help though :)

update - black textures came back after a game crash, msi folder in atm texturecache folder came back also.  i'll try the longer config

I tried the long version, still doesn't work.  Only way to get the textures to load is to blow away the ATM cache before each launch of KSP.  It doesn't break the functionality of the parts, just the textures...

Share this post


Link to post
Share on other sites

Sooo i was trying out the Mecatrons... are there plans to make them easier to set up? Such a cool idea, but it took 6 Actiongroups to get full functionality.

UDyFs34.jpg

Share this post


Link to post
Share on other sites
3 hours ago, achroma said:

Sooo i was trying out the Mecatrons... are there plans to make them easier to set up? Such a cool idea, but it took 6 Actiongroups to get full functionality.

UDyFs34.jpg

They are meant to be driven by the included kOS script (mecanum.ks if I remember correctly).

Unfortunately they will no longer work in KSP 1.1, until Zodius has some major free time to update the wheels (which is not a simple thing to do).

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.