ZodiusInfuser

[WIP] MSI's Infernal Robotics - Model Rework (v02 Pre-Release Beta)

Recommended Posts

On 06/05/2016 at 9:21 PM, DrRansom said:

I was interested in using Infernal Robotics for a swing-wing aircraft. But it looks like getting the wings to rotate isn't working right now. Is it possible to create a rotator part with very high load capabilities?

The way I solved the problem :

You don't need more parts, you need more engineering :D

Share this post


Link to post
Share on other sites

PSA: I've re-uploaded the RePack with cfg fixes to KAS magnet and grappling hook for increased breakForce mimicking default KAS settings for 1.1.2

Share this post


Link to post
Share on other sites
15 hours ago, varsass said:

The way I solved the problem :

You don't need more parts, you need more engineering :D

Some kOS script that autodetect craft speed and automatically change wing shape in different flight regime will make this craft even more awesome.

Share this post


Link to post
Share on other sites

Hi

I don't see in download the folders we had in 1.0.5 "Rework_Expansion" folder, "Rework_Core" folder and "Rework_Utility" folder with their robotic parts like Foldatron, adaption, Rotatron....

Is it still WIP ?

Thank's

Share this post


Link to post
Share on other sites
On 5/12/2016 at 2:12 PM, Angstinator said:

Could this please be Spacedocked and/or CKANned?

 

20 hours ago, gilflo said:

Hi

I don't see in download the folders we had in 1.0.5 "Rework_Expansion" folder, "Rework_Core" folder and "Rework_Utility" folder with their robotic parts like Foldatron, adaption, Rotatron....

Is it still WIP ?

Thank's

It is still WIP, just paused. Try using the repack I made for 1.1.2 (see the last link on my signature).

Share this post


Link to post
Share on other sites

small problem, the parts dont show up in any category. shouldnt they all be set too Utility instead of none? i remember theres supposed too be some sort off extra category that has the parts but thats not present in 1.1.2 i think.

Share this post


Link to post
Share on other sites

Re-packed those awesome parts into nice and tidy smaller package with DDS textures and without texture clones/substitutes. 5-10 seconds faster loading and a bit of memory saving. PARTS ONLY package.

http://www.filedropper.com/irreworkparts

Recommend such folder structure for next mod update.

P.S. No, robostruts and wheels won't work. I didn't touch any plugin code - just re-packed the parts.

Share this post


Link to post
Share on other sites
5 minutes ago, Dr. Jet said:

Re-packed those awesome parts into nice and tidy smaller package with DDS textures and without texture clones/substitutes. 5-10 seconds faster loading and a bit of memory saving. PARTS ONLY package.

http://www.filedropper.com/irreworkparts

Recommend such folder structure for next mod update.

P.S. No, robostruts and wheels won't work. I didn't touch any plugin code - just re-packed the parts.

the mecanum wheels? thats odd, they should work like the other IR rotors, no? 

Share this post


Link to post
Share on other sites

does the v-02 prerelease work? like, can u download it, install it, and place the parts on a vessel in the VAB? because it doesent for me. theres no tab where it is located in. is there something needed? because i dont see the tab with the IR parts like i used too do in 1.0.5 .

Share this post


Link to post
Share on other sites
4 hours ago, Dr. Jet said:

Re-packed those awesome parts into nice and tidy smaller package with DDS textures and without texture clones/substitutes. 5-10 seconds faster loading and a bit of memory saving. PARTS ONLY package.

http://www.filedropper.com/irreworkparts

Recommend such folder structure for next mod update.

P.S. No, robostruts and wheels won't work. I didn't touch any plugin code - just re-packed the parts.

I believe you should've asked @ZodiusInfuser first before posting any repacks. This pack is not abandoned and he visits forums quite often. Moreover we have an 1.1.2 compatible repack already, with plugins updated and part configs fixed to accommodate for 1.1.x changes (IR and KAS related mostly)

Edited by Ziw

Share this post


Link to post
Share on other sites
4 hours ago, Dr. Jet said:

Re-packed those awesome parts into nice and tidy smaller package with DDS textures and without texture clones/substitutes. 5-10 seconds faster loading and a bit of memory saving. PARTS ONLY package.

http://www.filedropper.com/irreworkparts

Recommend such folder structure for next mod update.

P.S. No, robostruts and wheels won't work. I didn't touch any plugin code - just re-packed the parts.

Hi Dr Jet,

I appreciate the effort that you went in to convert the textures to DDS and reorganise the parts; however, as Ziw said, you should have really contacted me first. There is a reason the parts are set up the way, and by releasing an alternative you're introducing complications for anyone who downloads any future versions of the mod that I release. Now I cannot do anything to stop people downloading your version, but I would encourage people not to and instead go for the version Ziw posted: http://forum.kerbalspaceprogram.com/index.php?/topic/59359-wip-msis-infernal-robotics-model-rework-v02-pre-release-beta/&do=findComment&comment=2564645

On an unrelated topic, I do see every post people make here, but due to my current workload (I have 4 months left to complete my PhD in Robotics) I don't have time to reply. So, thank you to everyone who has been active here and responding to comments and user issues in my absence! It means a lot!

-Zodius

Share this post


Link to post
Share on other sites

Hello here,
First a big thanks to everyone involved in that mod ( close or far ), great job ! So much fun building with those ! :D
I just wonder about the textures, in game most of the part look plain color, and the plain white is pure white, i tried adding a little "Metal noise" to the TGA map, but seems that it is not the way (got missplaced texture ingame)
So, is it a way to simply change the map ? :rolleyes: (as i saw, it's only one used for most of the part)

Thanks again :)

Share this post


Link to post
Share on other sites
On 15.05.2016 at 6:39 PM, ZodiusInfuser said:

Hi Dr Jet,

I appreciate the effort that you went in to convert the textures to DDS and reorganise the parts; however, as Ziw said, you should have really contacted me first. There is a reason the parts are set up the way, and by releasing an alternative you're introducing complications for anyone who downloads any future versions of the mod that I release. Now I cannot do anything to stop people downloading your version, but I would encourage people not to and instead go for the version Ziw posted: http://forum.kerbalspaceprogram.com/index.php?/topic/59359-wip-msis-infernal-robotics-model-rework-v02-pre-release-beta/&do=findComment&comment=2564645

It's just a suggestion. Could be a pull request if original version was on GitHub. To use it or not is completely up to you. 

But if I understand KSP engine correctly, same textures placed in different folders are treated as different textures thus occupying excess memory. Shared assets folder layout prevents it.

Share this post


Link to post
Share on other sites

Can anyone give an estimation of when the Utility Pack will be up and working for KSP 1.1.2? Not trying to sound impatient or ungrateful, just excited to get to use it!

Share this post


Link to post
Share on other sites
1 hour ago, maranble14 said:

Can anyone give an estimation of when the Utility Pack will be up and working for KSP 1.1.2? Not trying to sound impatient or ungrateful, just excited to get to use it!

10 days ago: http://forum.kerbalspaceprogram.com/index.php?/topic/59359-wip-msis-infernal-robotics-model-rework-v02-pre-release-beta/&page=80#comment-2564645

Share this post


Link to post
Share on other sites
16 hours ago, maranble14 said:

Can anyone give an estimation of when the Utility Pack will be up and working for KSP 1.1.2? Not trying to sound impatient or ungrateful, just excited to get to use it!

Please note that rover wheels (including mecanums) are not included, they require much more work than just a config update to work in 1.1.2

 

On 15 May 2016 at 9:01 PM, theblacktiger said:

Hello here,
First a big thanks to everyone involved in that mod ( close or far ), great job ! So much fun building with those ! :D
I just wonder about the textures, in game most of the part look plain color, and the plain white is pure white, i tried adding a little "Metal noise" to the TGA map, but seems that it is not the way (got missplaced texture ingame)
So, is it a way to simply change the map ? :rolleyes: (as i saw, it's only one used for most of the part)

Thanks again :)

It is being worked on slowly, but if you want to help and have the time and skills (because I don't and Zodius is busy) - PM me or Zodius

Share this post


Link to post
Share on other sites

Is there a way to enable the usual custom category for IR parts? So far changing category from none to Utility in the CFG for the rework parts works, but I was wondering if I did something wrong.

Thanks!!

Share this post


Link to post
Share on other sites
On 5/7/2016 at 4:52 PM, Ziw said:

Bearing parts are early WIP,  but you can try using this pack below for stations

It is quite old, but should still work.

 

My apologizes for asking silly questions, but I can't seem to find the Ring component for this mod.  The core part shows up fine, but for the life of me I can't see the Ring anywhere in any of the part categories.  Is there some other sort of jiggery-pokery that I need to get it to show up?

My log file is here, I hope some sense can be made of it.  https://drive.google.com/file/d/0Bx7P5dhGg6O4ZGVna1BUTHFWbVk/view?usp=sharing

Share this post


Link to post
Share on other sites
5 minutes ago, tsaven said:

My apologizes for asking silly questions, but I can't seem to find the Ring component for this mod.  The core part shows up fine, but for the life of me I can't see the Ring anywhere in any of the part categories.  Is there some other sort of jiggery-pokery that I need to get it to show up?

My log file is here, I hope some sense can be made of it.  https://drive.google.com/file/d/0Bx7P5dhGg6O4ZGVna1BUTHFWbVk/view?usp=sharing

The ring is not robotic, so it should be in your Utility folder. It is similar to bearing rotatron from Zodius pack where you have a non robotic part combined with robotic one.

5 hours ago, Drakenex said:

Is there a way to enable the usual custom category for IR parts? So far changing category from none to Utility in the CFG for the rework parts works, but I was wondering if I did something wrong.

Thanks!!

It seems your IR is not installed properly. Try to make a clean install (delete the folder completely and install fresh copy from github).

Share this post


Link to post
Share on other sites
7 minutes ago, Ziw said:

The ring is not robotic, so it should be in your Utility folder. It is similar to bearing rotatron from Zodius pack where you have a non robotic part combined with robotic one.

The core is in the Utilities folder, but the Ring isn't.  According to their config files, I think they should both be in the Utilities folder and when sorted by name should be right next to each other.  Search function doesn't pull up anything, and I've combed through every other catagory manually looking for it.  No such luck.  Is it possible that it's using the wrong icon or something?

*edit* oh I guess I can't paste images in here.  Hang on, uploading.

9QH9Tkt.png

 

Edited by tsaven

Share this post


Link to post
Share on other sites
19 minutes ago, tsaven said:

The core is in the Utilities folder, but the Ring isn't.  According to their config files, I think they should both be in the Utilities folder and when sorted by name should be right next to each other.  Search function doesn't pull up anything, and I've combed through every other catagory manually looking for it.  No such luck.  Is it possible that it's using the wrong icon or something?

*edit* oh I guess I can't paste images in here.  Hang on, uploading.

9QH9Tkt.png

 

I'll take a look later today, I don't have access to KSP at the moment. BTW they might not have the similar names, try sorting by Manufacturer

Share this post


Link to post
Share on other sites

I appreciate it man, I was hoping it was something simple or I was doing something dumb.  Interestingly I don't see Magic Smoke Industries listed as a manufacture under the Advanced Mode > Filter By option. 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.