ZodiusInfuser

[WIP] MSI's Infernal Robotics - Model Rework (v02 Pre-Release Beta)

Recommended Posts

On 6 mai 2016 at 0:03 PM, Ziw said:

With @ZodiusInfuser's permission I'm proud to present a repack of latest beta release

https://mega.nz/#!rdlHkLAJ!ZizDvd8s7zCIG529FtO8b7wM0avJ8yC3pldIaf6BGFw

This pack has updated configs to accommodate for latest IR 2.x and IRS 1.x changes and has most parts from beta, except wheels and mecanums, because they need much more than just a config fix.

Also in this pack there is an experimental build of ActiveStruts, but please DON'T use the FreeAttach functionality, or it might crash your game. Use TargetAttach or StraightUp attach.

Updated version of IRSurfaceSampler plugin was kindly provided by @DMagic himself, so it should work with our surface sampler part in 1.1.2

Hello ZIW

This is unzippable on Mac OS X.

Could you make a unzip package please?

Thank's

Share this post


Link to post
Share on other sites
1 hour ago, gilflo said:

Hello ZIW

This is unzippable on Mac OS X.

Could you make a unzip package please?

Thank's

There is a bug with Safari&Mega interaction resulting in incorrectly downloaded files. Please try downloading using Chrome or Opera, and everything should work.

Share this post


Link to post
Share on other sites
10 hours ago, Ziw said:

It seems your IR is not installed properly. Try to make a clean install (delete the folder completely and install fresh copy from github).

Got it! it was a conflict with Wild Blue Industries Modcategorizer mod. May be you must specify that in the OP. thanks!

Share this post


Link to post
Share on other sites
7 hours ago, sojourner said:

Are active struts updated for 1.1.2?  Last I asked they were broken.

There is an updated version included with the repack available via last link on my signature.

It has issues with free-attach but mostly works.

 

Share this post


Link to post
Share on other sites

It is now, sure, but at some point it won't be, right? I mean, you are planning to release it at some point, I would think; at least I would hope so. At that point, will it be made available via CKAN?

Edited by OldLost

Share this post


Link to post
Share on other sites
34 minutes ago, OldLost said:

It is now, sure, but at some point it won't be, right? I mean, you are planning to release it at some point, I would think; at least I would hope so. At that point, will it be made available via CKAN?

Oh right, I missed the bit about "at some point". Yes, eventually it will be on CKAN like the previous releases were, although those were added on there by someone else without my consent.

Edited by ZodiusInfuser

Share this post


Link to post
Share on other sites

Great, thanks. This looks really cool, but I will wait until it's officially released. Hopefully that will be sooner rather than later. :)

Share this post


Link to post
Share on other sites
On 5/18/2016 at 2:30 AM, Ziw said:

I'll take a look later today, I don't have access to KSP at the moment. BTW they might not have the similar names, try sorting by Manufacturer

I mention this as a follow-up in case anyone else asks you about this in the future, or if it comes up again, but I figured out the problem.

The Ring section was missing the Tech Level information in the cfg file, so while it would show up fine in Sandbox games, there was no way to get it to show up in Career.  Copying in the relevant information from the Bearing's Config file made it show up. :)

Share this post


Link to post
Share on other sites
30 minutes ago, tsaven said:

I mention this as a follow-up in case anyone else asks you about this in the future, or if it comes up again, but I figured out the problem.

The Ring section was missing the Tech Level information in the cfg file, so while it would show up fine in Sandbox games, there was no way to get it to show up in Career.  Copying in the relevant information from the Bearing's Config file made it show up. :)

Can you please PM me the changes needed so I can include it to the next update?

Share this post


Link to post
Share on other sites
On May 6, 2016 at 6:03 AM, Ziw said:

With @ZodiusInfuser's permission I'm proud to present a repack of latest beta release

https://mega.nz/#!rdlHkLAJ!ZizDvd8s7zCIG529FtO8b7wM0avJ8yC3pldIaf6BGFw

This pack has updated configs to accommodate for latest IR 2.x and IRS 1.x changes and has most parts from beta, except wheels and mecanums, because they need much more than just a config fix.

Also in this pack there is an experimental build of ActiveStruts, but please DON'T use the FreeAttach functionality, or it might crash your game. Use TargetAttach or StraightUp attach.

Updated version of IRSurfaceSampler plugin was kindly provided by @DMagic himself, so it should work with our surface sampler part in 1.1.2

Can we get a download from somewhere other then Mega? My computer won't download from there

Share this post


Link to post
Share on other sites

This may have been addressed in a previous post which I haven't found, but how do I get the wheels to show up in the VAB? I installed both regular and legacy packs through ckan. Are they simply not implemented yet?

Share this post


Link to post
Share on other sites
3 hours ago, Kelpbot said:

This may have been addressed in a previous post which I haven't found, but how do I get the wheels to show up in the VAB? I installed both regular and legacy packs through ckan. Are they simply not implemented yet?

KSP 1.1 changed how wheels work, causing the IR wheels to break. I currently don't have time to work on a fix for them so for now they have been removed from the downloads.

Share this post


Link to post
Share on other sites
15 hours ago, ZodiusInfuser said:

KSP 1.1 changed how wheels work, causing the IR wheels to break. I currently don't have time to work on a fix for them so for now they have been removed from the downloads.

Ahh thank you that makes sense. Too bad about the wheels, but I'm loving the mod otherwise.

Share this post


Link to post
Share on other sites

Im a bit late for the party for this but, I have installed the latest version of Infernal Robotics Model Rework and the new hinges, rotatrons etc are not there, only the original grey ones are. Are the newer white and orange parts being worked on currently, or are they just hidden around in the parts folder and are failed to be loaded into the game? Thanks for the help.

Share this post


Link to post
Share on other sites
1 hour ago, RYU AZUKU99 said:

Im a bit late for the party for this but, I have installed the latest version of Infernal Robotics Model Rework and the new hinges, rotatrons etc are not there, only the original grey ones are. Are the newer white and orange parts being worked on currently, or are they just hidden around in the parts folder and are failed to be loaded into the game? Thanks for the help.

I belive that this is latest proper links:
IR core mod V2.0.4 , IR sequencer, beta release of IR repacked parts, Worked for me, at least.

Share this post


Link to post
Share on other sites

Thanks I'll give it a try. Maybe I just found bad links.  Nope it still wont show a lot of the rework parts, it still shows the base IR parts but none of the newer ones.

Edited by RYU AZUKU99
Tried new links, still do not work.

Share this post


Link to post
Share on other sites
3 hours ago, RYU AZUKU99 said:

Nope it still wont show a lot of the rework parts, it still shows the base IR parts but none of the newer ones.

First check "\GameData\MagicSmokeIndustries\Parts" folder. You should have 3 subfolders there: "Rework_Core", "Rework_Expansion" and "Rework_Utility"

New parts should be in "Rework_Expansion" folder, if you installed everything properly. If it is not install issue then you probably have some conflict with other mods.
For anyone be able to help you further with this, you need to upload output log and MM cache file. I can't prommise that I will be able to figure out from output log what went wrong, but somebody probably will.

Share this post


Link to post
Share on other sites
7 hours ago, kcs123 said:

First check "\GameData\MagicSmokeIndustries\Parts" folder. You should have 3 subfolders there: "Rework_Core", "Rework_Expansion" and "Rework_Utility"

New parts should be in "Rework_Expansion" folder, if you installed everything properly. If it is not install issue then you probably have some conflict with other mods.
For anyone be able to help you further with this, you need to upload output log and MM cache file. I can't prommise that I will be able to figure out from output log what went wrong, but somebody probably will.

Then it's a conflicting mod, I have all of the folders/new parts as well. I cannot upload the logs just yet as I have stuff to do, but I will later today

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.