ZodiusInfuser

[WIP] MSI's Infernal Robotics - Model Rework (v02 Pre-Release Beta)

Recommended Posts

Is it possible at all to do swing-wings currently, and if yes, how to do so?

Because the way I tried it (hinge or joint, with a wing attached to it) the wing would not rotate with the joint/hinge when I actuate it, and yes, the joint itself is moving.

Share this post


Link to post
Share on other sites
14 hours ago, Zuthal said:

Is it possible at all to do swing-wings currently, and if yes, how to do so?

Because the way I tried it (hinge or joint, with a wing attached to it) the wing would not rotate with the joint/hinge when I actuate it, and yes, the joint itself is moving.

This is a complex but totally possible thing to build. I use the legacy controlled Docking Washers.

I first attach them in mirror symetry.

Use the offset tool to pull them out where I can see them. (Then offset them back where they go after setup)

Attach my wings / control surfaces to the docking washers.

then mess with the limits of one washers. Legacy washers don't work the same as the rework stuff so you don't invert one wing like you would with rework stuff.

Now, in the SPH one wing will work properly and the other will be reversed. But in flight they will both work correctly. This sometimes take a few jumps in and out of the SPH to get just right. Last trick is use Quantum struts to lock the wings to the fuselage in either swept or forward configurations. Usually 1-2 struts per wing based on overall scale does the trick for me. This way you can move the wings during level flight. But really run a plane through its paces and not snap off a noodle wing :)

Share this post


Link to post
Share on other sites

just wanted to throw my voice in and mention that i really hope the surface sampler will make a (functional) return soon! i loved that part dearly, and i'd think it would be fairly easy to get it working again, unlike the wheels...

Share this post


Link to post
Share on other sites
On 03/11/2016 at 10:30 AM, Axilourous said:

basically I can't use F1 for screenshots on KSP because I have it on steam. F12 button wont work in ksp, i don't know why. and my computer is really old so it cant screenshot.

EDIT: Sorry I forgot you were talking about folder. So basically like I said my computer is to old for screenshots.

You can still do f1 for screenshots if you have KSP on Steam, it doesn't change anything about that.  The screenshots are stored in a folder in your KSP install folder.  Also Windows has been able to do screenshots since Windows 98, so your computer can't be too old to take screenshots, unless it's also too old to run KSP.

Share this post


Link to post
Share on other sites
2 minutes ago, SpartanJack17 said:

You can still do f1 for screenshots if you have KSP on Steam, it doesn't change anything about that.  The screenshots are stored in a folder in your KSP install folder.  Also Windows has been able to do screenshots since Windows 98, so your computer can't be too old to take screenshots, unless it's also too old to run KSP.

It has broken things and one of them is to screenshot, and I found the ksp screenshot folder, but nothing wants to show up when i screenshot...

Also, i don't know what the reason for needing a screenshot was, but i think it was getting this mod to work in 1.2.X. And i have fixed that.

Edited by Axilourous

Share this post


Link to post
Share on other sites
1 minute ago, Axilourous said:

It has broken things and one of them is to screenshot, and I found the ksp screenshot folder, but nothing wants to show up when i screenshot...

So you press f1 and nothing shows up?  Does your keyboard have a "fn" key?  Because if it does you might have to press "fn" and "f1" at the same time.  This is especially likely if you have a laptop, but quite a few keyboards are like this.

Share this post


Link to post
Share on other sites

Fn key? I have heard of it, but have never seen it. And the computer I use for anything like modding, video games, or any game engine, is not a laptop.

Share this post


Link to post
Share on other sites
2 minutes ago, Axilourous said:

Fn key? I have heard of it, but have never seen it. And the computer I use for anything like modding, video games, or any game engine, is not a laptop.

So you don't have one then?  It's usually down on the bottom row near the spacebar.  What version of windows do you have?  If it's windows 10 you can press the windows button and printscreen at the same time to save a screenshot to the pictures folder.  If you're on mac or linux I'm afraid I have no idea.

Edited by SpartanJack17

Share this post


Link to post
Share on other sites

I have windows, and yeah any screenshots dont get recognized as existent on my computers files... except for for some reason, on roblox... IDK why, but its annoying when I have problems and I need a screenshot. I have gotten only a few to work, but, of course I was on a friend's computer. 

Share this post


Link to post
Share on other sites
1 minute ago, Axilourous said:

I have windows, and yeah any screenshots dont get recognized as existent on my computers files... except for for some reason, on roblox... IDK why, but its annoying when I have problems and I need a screenshot. I have gotten only a few to work, but, of course I was on a friend's computer. 

And that's with steam screenshots?  Have you tried the screenshot system that's built into windows?

Share this post


Link to post
Share on other sites

Yeah, ive tried everything, it just doesnt want to screenshot... I even asked a person that works with computers and can fix stuff like this, they said I would have to get a new one, and then again, my uncle got it for not even $30, so I expect things to go wrong.

Share this post


Link to post
Share on other sites
1 minute ago, Axilourous said:

Yeah, ive tried everything, it just doesnt want to screenshot... I even asked a person that works with computers and can fix stuff like this, they said I would have to get a new one, and then again, my uncle got it for not even $30, so I expect things to go wrong.

So what version of windows does it have?  I'm sorry, it's just that like I said earlier windows has been able to do screenshots for almost 20 years, so it's unlikely that that's the problem.  Have you tried Fraps?  It's a free program that lets you set up a shortcut to take and save a screenshot.  If all else fails third party programs are usually the way to go.

Share this post


Link to post
Share on other sites

windows 10 i think

Fraps, I once used that for recording but I just couldnt get that working, It was confusing:/... But I can try again tomorrow.

Share this post


Link to post
Share on other sites

It's easy to tell if it's windows 10, if your start menu looks something like this then that's what if it is.  If pressing the start menu gives you a full screen thing then it's windows 8.  If it is windows 10 then try the windows key and Prt SCr at the same time.  If it works the screen will dim for a second.

 

To use fraps just open it, right click the little icon in the taskbar and go to "screenshots".  Then just choose the folder, button and format you want.

Share this post


Link to post
Share on other sites

Oh ok, thanks. I have tried the Windows + Prt Scr thing, and i have windows 10, I will try fraps again tomorrow, but im tired and kinda depressed cuz of a show... So ima get some sleep xD

good night, depending on time zone, but for me its 00:29.

Share this post


Link to post
Share on other sites

AutoLoadGame seems to be incompatible with this mod for some reason :/

The "new" white Robot parts all disappear, but not the structural ones, the landing foot and some others. They're in the research tree but not the build menu. The older style hinges and things appear in the build menus, but don't work and the IR Editor Window doesn't appear.

Pity since I love AutoLoadGame :/

Edit: I should note that I have a bunch of mods (39), and it's the only one that does it.

Edited by Tubal
Additional information

Share this post


Link to post
Share on other sites

Enyone else have issues with unloading and building robots with KIS? Wanted to make a nice antenna tower with rotating dish thingy on top. Used the tweakables to get my rotatrons and what not the correct size. Loaded that up in a KIS container, shot it to Minmus. Now Bill is on a ladder constructing the thing. When I first unload the resized stuff from the container it pops into the correct size. With some nice quicksave work and dropping the items first before attaching its working. But with the last bit, an oversized Communotron 88 my whole base got lifted off the ground a bit. I did'nt notice it when I saved. But now on the reload my whole base jumps into the air. Well into space actually, there is no air on Minmus.

Anyone know some trick to get my base on the ground again? Don't have a save from before... Maybe some save file editing?

Share this post


Link to post
Share on other sites
On 2017-01-07 at 10:37 PM, GabLam said:

Anyone know some trick to get my base on the ground again? Don't have a save from before... Maybe some save file editing?

Hyperedit's landing feature? VesselMover maybe?

Share this post


Link to post
Share on other sites

I think I've finally got everything loaded almost right.  Got the robotic interface, the legacy parts show up and can move in SPH/VAB correctly (outside SPH/VAB, not so much but I digress).  The rework parts also show up but that's where my next problem lies.  They don't have any textures.  They're just black.  I'm pretty new to KSP and I'm not really sure where to start troubleshooting.  Can someone point me in the right direction?  Here's what I'm seeing:

bh5pyov.jpg

 

Also, although the legacy parts do move outside of SPH/VAB (just not correctly) the rework parts only move in SPH/VAB.  I'm sure I'm doing something stupid so any advice would be appreciated.  Hopefully this isn't a known issue that I missed.  I've been researching but it's pretty confusing with all the different threads and the fact that the top post in the threads doesn't seem to have the latest information and instead I'm trying to glean it from the last few pages of posts on the various threads.  Because I was having issues with the legacy parts moving correctly (they get all jumpy after a few degrees of movement) I thought I'd load the new parts but now I'm stuck here.  No textures and no movement outside of SPH/VAB.

 

 

 

Edited by DoubleUU
Clarity

Share this post


Link to post
Share on other sites

Hi everyone, I just download IR for the first time, I have the latest pre-release from the github.

 

I was wondering if it is a common issue to have the pistons and rails bend and point in weird directions, and sometimes break? I can't seem to get them to work at all. I can't seem to find an answer in the forum page either.

I'd be very grateful if someone would help me out? :) 

Very cool idea for a mod, I hope I can get it to work so I can make a lift on the underside of my SSTO :D 

Edited by Chase842

Share this post


Link to post
Share on other sites
On 1/22/2017 at 3:19 AM, Chase842 said:

I was wondering if it is a common issue to have the pistons and rails bend and point in weird directions, and sometimes break? I can't seem to get them to work at all. I can't seem to find an answer in the forum page either.

You can see which way your joints and pistons will move in the VAB/SPH while you're configuring them. In the IR UI you can reverse the rotation of a joint if it isn't to your liking. More than that, you can adjust the min/max angle and length parts will move as well as the speed at which each individual IR part will move. To be sure, you can do more than that too! But play around in the VAB. If things aren't doing what they doing outside the VAB, then that's a different issue. Best of luck!

edit: Also, I would recommend trying the version linked below. I'm not sure if the latest github release is the same. 

 

Edited by Swedishish

Share this post


Link to post
Share on other sites
15 minutes ago, AirArs said:

how do I install this to version 1.2.2 of ksp?

For those having install / KJR issues

List of IR download files to work with KSP 1.2.2 courtesy of: @Agustin @V8jester

 

Steps to install Infernal Robotics

1) install Core Download which is the plugin and "core Files" of IR  (No parts are in this download)

2) Install Parts Pack (Legacy is the original parts, and Rework are the new white parts. You can have both installed if you wish)

3) Optional -  If you wish to use the Surface sampler (Install the Surfacesampler.dll into GameData/MagicSmokeIndustries/Parts/Rework_Utility/Plugins)

4) Optional  - If you are using KJR you will need to use the supplied DEV Version Linked below.

 

Core Download

Infernal Robotics (Ziw) 2.0.10 https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/download/2.0.10/IR-2.0.10-Final-Core.zip

 

Parts

Legacy Parts (Ziw) https://github.com/MagicSmokeIndustries/InfernalRobotics/releases/download/2.0.0/IR-LegacyParts.zip

IR Rework Parts (Zodiusinfuser) https://mega.nz/#!rdlHkLAJ!ZizDvd8s7zCIG529FtO8b7wM0avJ8yC3pldIaf6BGFw

IR Surface Sampler dll (Ziw) https://github.com/MagicSmokeIndustries/IR-Surface-Sampler/tree/master/GameData/MagicSmokeIndustries/Parts/Rework_Utility/Plugins

 

Utility

Thread link for IR Sequencer (Ziw) http://forum.kerbalspaceprogram.com/index.php?/topic/104547-12-ir-sequencer-v101-add-on-to-infernal-robotics-updated-30102016/

 

Kerbal Joint Reinforcement - Fixed for IR

"Dev version - use at your own risk"

Dev version of KJR (Ferram4) https://github.com/ferram4/Kerbal-Joint-Reinforcement

 

Please feel free to repost / update this list every so often to help a lot of the new comers

Edited by V8jester

Share this post


Link to post
Share on other sites

Ok I got every thing working.

 

Is there "landing foot" in the pack?

i don't have it 

i have everything downloaded but this landing foot is missing

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.