ZodiusInfuser

[WIP] MSI's Infernal Robotics - Model Rework (v02 Pre-Release Beta)

Recommended Posts

8 hours ago, The-Doctor said:

Thanks. Um, what exactly does the surface sampler do?

It allows you to do surface samples on other planets and asteroids without needing to take a Kerbal

Share this post


Link to post
Share on other sites
3 hours ago, ZodiusInfuser said:

It allows you to do surface samples on other planets and asteroids without needing to take a Kerbal

Good to see you still sneaking around in the shadows Zodius :)

Share this post


Link to post
Share on other sites

i don't have the wheels.

they don't appear in my parts list.

can anybody sent like a link for the wheels?

Edited by TheGentleCat

Share this post


Link to post
Share on other sites
On 22/06/2017 at 9:44 AM, The Grand Teki said:

Any plans to update for 1.3?

There is literally a post on the previous page on this topic :wink:

That said, I seem to have issues with this build and the parts. Whenever I go to flight mode, my servos start drifting. Anyone had this happen before? There are no keys bound, and I haven't given a target preset or anything...

Edit: Oh.. I'm dumb, the one I fitted is uncontrollable..

Edited by Tivec

Share this post


Link to post
Share on other sites

I allowed myself to recompile ActiveStruts for 1.2 and it seems to work. Going to do so for 1.3. It may or may not work - it's in no way an official release, it just works for me. Use at your own risk. Hope I didn't do something that will be frowned upon. Pull request sent to maintainers.

DLL and source on GitHub   

Share this post


Link to post
Share on other sites
1 hour ago, Angeltxilon said:

What happened with mecatrons?

They were removed when KSP updated to a new wheel physics system and broke Kerbal Foundries. I hear that KF has recently been updated though, so maybe they can be made to work again.

Share this post


Link to post
Share on other sites

Yep. KF have nice set of new available wheels. It is always nice to have more choices, but even more important is new plugin that KF provide.

Share this post


Link to post
Share on other sites

Just tried installing these and there are almost no parts at all in-game. Some of the structural parts ar eshowing up but nothing else. None of the moving parts are in any of the parts lists at all.

Share this post


Link to post
Share on other sites
11 hours ago, Krahazik said:

Just tried installing these and there are almost no parts at all in-game. Some of the structural parts ar eshowing up but nothing else. None of the moving parts are in any of the parts lists at all.

Follow steps provided in this post:

 

Share this post


Link to post
Share on other sites

Hi

Is there a problem with using hinges on hinged parts?

I am trying to create extending arms for a crane, so I can launch it in a sensible payload.

I have 1 hinge, then a modular girder, then another hinge, another girder and then engines.  The setup works fine in the VAB, but when launched, the second hinge clips through the second girder, and the engines hang limply. When I manually extend the hinge, all of the engines rotate in the same direction.

Thanks

Using ksp 1.3, heavily modded.  most of the parts are from stock or Near Future construction/engines.  Followed the installation correctly, using legacy parts.

Thanks

 

Edit: I found the problem - autostruts - I have got the active struts plugin, and I thought this solved this problem?  Rovers/landing legs work fine with wheels from other mods.

Thanks

 

 

 

Edited by 7thGalaxy
more details

Share this post


Link to post
Share on other sites

Ok, so I admit defeat.... I have read the above pages etc. and I still can't get any of the parts to do anything! They're all there in the VAB/SPH and can attach to stuff, have stuff attached to them etc, but I cant assign any action, o get any movement in the vab or on pad. 

Could anyone point out my obvious dumb mistake, i'd be really pleased! Thanks :)

Share this post


Link to post
Share on other sites
4 hours ago, Andetch said:

Ok, so I admit defeat.... I have read the above pages etc. and I still can't get any of the parts to do anything! They're all there in the VAB/SPH and can attach to stuff, have stuff attached to them etc, but I cant assign any action, o get any movement in the vab or on pad. 

Could anyone point out my obvious dumb mistake, i'd be really pleased! Thanks :)

Forgive me if this sounds like a captain obvious moment.... But....

When you say "can't make them move with AG"

You do know how to use the GUI in the VABSPH as well as the flight scene to control everything, yes?

Share this post


Link to post
Share on other sites
On 22/08/2017 at 9:59 PM, V8jester said:

Forgive me if this sounds like a captain obvious moment.... But....

When you say "can't make them move with AG"

You do know how to use the GUI in the VABSPH as well as the flight scene to control everything, yes?

Probably not..... I know how to make things fly usually in KSP and am fairly pleased with some of my designs, but I am finding more features daily. It is more complex than it seems on the surface.... Any way I try I can't get movement other than by hitting the part on the ground so it falls off - but that isn't the sort of movement we want......right?

Share this post


Link to post
Share on other sites

You got enough electrical charge ? Does electric current can flow to IR parts (some separators and structural partd does not allow fuel and electric feeed). Some in flight(on runway) screenshots of craft might help to debug issue easier than pure guessing.

Share this post


Link to post
Share on other sites

But even without electricity you should be able to move the part in sph, no? Like when you right click a part in sph you can see the part function, say opening a cargo bay door or extending a ladder etc. And then in flight same thing........

Also, is 5x 1k batteries enough for a single move or do they take insane amounts of power? I admit I didn't study the part description to work out how much is needed, I just worked on my standard assumption that 5K - 10K charge is enough for most ksp things....

Reason I haven't pictured a craft is mainly because my initial attempts to check part function have failed. As in a golden control core, a ton of batteries, an aerial, a bit of structural fusalage, a hinge from this, then another bit of fusalage - all held up on a single launch stability assist tower. I can check the craft functions with a known working action part like a thermometer sending science data, but the hinge won't move or even display any action when I right click on it. 

I am sure it is something really stupidly simple, like is there a control module or something for the parts that you need....... Or they control in a different manner to that I am accustomed to.... I just don't know. I've even pulled my career save out of the ksp folder, deleted and reinstalled ksp, re-modded it following the guide (which I know off by heart now anyway), started a new sandbox game and it still won't do anything! 

On 24/08/2017 at 7:39 PM, kcs123 said:

You got enough electrical charge ? Does electric current can flow to IR parts (some separators and structural partd does not allow fuel and electric feeed). Some in flight(on runway) screenshots of craft might help to debug issue easier than pure guessing.

 

Share this post


Link to post
Share on other sites
4 hours ago, DiscoveryPlanet said:

does this mod still work in ksp 1.3? and why this mod not upgraded yet? ;.;

Yes, it does mostly--check this post in the main IR thread in Releases which detail how to go about it, instructions, etc. (And yes it's working in my install, with a ton of other mods, though have not extensively tested everything yet). 

https://forum.kerbalspaceprogram.com/index.php?/topic/104535-112-magic-smoke-industries-infernal-robotics-202/&do=findComment&comment=3140574

As to why it's not upgraded... well, at least it still works even in 1.3, so the lack of an update is not generally breaking in any way.

Share this post


Link to post
Share on other sites
20 minutes ago, B-STRK said:

Yes, it does mostly--check this post in the main IR thread in Releases which detail how to go about it, instructions, etc. (And yes it's working in my install, with a ton of other mods, though have not extensively tested everything yet). 

https://forum.kerbalspaceprogram.com/index.php?/topic/104535-112-magic-smoke-industries-infernal-robotics-202/&do=findComment&comment=3140574

As to why it's not upgraded... well, at least it still works even in 1.3, so the lack of an update is not generally breaking in any way.

wohoo thanks dude jajajajaja  :D

Share this post


Link to post
Share on other sites

Hey, my name is Vito and there wouldn't be a 1.3 version of this would there? If anyone has a working copy, could you please tell me where you got it from? Thanks.

Share this post


Link to post
Share on other sites
7 hours ago, CGiuffre164 said:

Hey, my name is Vito and there wouldn't be a 1.3 version of this would there? If anyone has a working copy, could you please tell me where you got it from? Thanks.

Info is burried in other IR thread:

 

Share this post


Link to post
Share on other sites

I recently had to reinstall all mods and seem to have lost most the parts for IR iv got the basic hinges, pistons and what not but cant seem to find the downloads for foldatrons or any of the other sexy sleek parts. does any one know where the rest of the parts are?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.