Jump to content

HotRockets! Particle FX Replacement + Tutorial


Recommended Posts

I launched the same craft that I had been using before for a quick Mun trip. I still experienced slowdown during the launch, but I think it may have improved slightly. Upon returning to Kerbin I was able to recover normally. Thank you! I didn't try isolation testing the SRBs, but there are a lot of them on launch stage, so I wouldn't be surprised if they were responsible.

Edit - Several more flights. It's working reliably. Cheers.

Edited by Khatharr
Link to post
Share on other sites
Is there anywhere to get this other than on Curse? The download stops at 175kb and then cancels itself.

Edit: Nevermind, found it on the Spaceport. You should consider adding the Spaceport link to the OP.

You can try here http://forum.kerbalspaceprogram.com/threads/65754-HotRockets%21-Particle-FX-Replacement-Tutorial?p=1147180&viewfull=1#post1147180

Link to post
Share on other sites
I launched the same craft that I had been using before for a quick Mun trip. I still experienced slowdown during the launch, but I think it may have improved slightly. Upon returning to Kerbin I was able to recover normally. Thank you! I didn't try isolation testing the SRBs, but there are a lot of them on launch stage, so I wouldn't be surprised if they were responsible.

Edit - Several more flights. It's working reliably. Cheers.

So it makes sense why the config worked for you and not for me. I'm using B9 SRB sepratrons, which don't have an updated config to fix whatever is causing the issue.

-edit-

I don't think it's the B9 stuff. I think it's the NASA LFO boosters. I don't know enough about the configs to test this theory though.

Edited by pantheis
Link to post
Share on other sites

Reporting back in. I just built a new craft and it's causing the same bug again. I used larger SRBs on this one (a pair of really big KW ones) I'll try to track down which specific part(s) is doing it as this is a much simpler craft.

Okay, now I can't recreate it. -.-

Sorry. I'll keep paying attention to it and respond again if I find out anything useful.

Edited by Khatharr
Link to post
Share on other sites

The smoke pretty sure it's a setting you can change but with smoke like that your going to have people crying about the lag you can check out this mod and hold it on the pad bad thing was he set it so the smoke clears to fast. http://forum.kerbalspaceprogram.com/threads/16866-Horizon-Aeronautics-Development-Thread

Edit- But guess you could change that setting too.

Edited by Mecripp2
Link to post
Share on other sites

It seems I get some lag effect while using Novapunchs 3.75m Little Mother engine... every 2 or so seconds a hiccup. The rest of squad, b9, novapunch engines i have unlocked so far in my career seem to run smooth. Without hotrockets the Little Mother does not lag either. I have 51 mods installed and no lags besides that engine:)

Link to post
Share on other sites

Those pics on the bottom there are from B9 Aerospace. Speaking of which, bac9 recently posted saying he's working on a new update for the pack... yay! :)

Nazari, would you be able to put a bluish clear effect on the Skipper? I always think of it as a J-2 equivalent, which used cryogenic LH2 and LOX. It's exhaust was bluish clear, it's water vapor. It would also help break up the chain of most of the engines having a yellow exhaust.

I love what you've done so far, it's just an idea. I know it's not meant to be all that realistic but I just thought it might be something to mess with, something like the exhaust on the KSO main engines. :)

Link to post
Share on other sites
It seems I get some lag effect while using Novapunchs 3.75m Little Mother engine... every 2 or so seconds a hiccup. The rest of squad, b9, novapunch engines i have unlocked so far in my career seem to run smooth. Without hotrockets the Little Mother does not lag either. I have 51 mods installed and no lags besides that engine:)

Unless it was fixed the new fx that comes with NovaPounch will have too FX with hotrockets and through a bug best to zip up the NP.cfg in hotrockets folder.

Link to post
Share on other sites
It seems I get some lag effect while using Novapunchs 3.75m Little Mother engine...

It's got a boatload of emitters on it. I guess it'd lag less if the emission value was turned down for them though.

Nazari, would you be able to put a bluish clear effect on the Skipper? I always think of it as a J-2 equivalent, which used cryogenic LH2 and LOX. It's exhaust was bluish clear, it's water vapor. It would also help break up the chain of most of the engines having a yellow exhaust.

You can try switching it to use the "flamejet" effect as used in the sabre engines, and tweak its settings, like size, emission, and energy.

Link to post
Share on other sites

i'm having trouble resizing the effects to fit a smaller engine

cJL2Ide.png

both have a similar config, but the one on the right has the bolded lines added, yet remains the same size no matter what i set it to?


MODEL_MULTI_PARTICLE
{
name = flameion1
modelName = MP_Nazari/FX/flameion
transformName = ThrustTransform
emission = 0.0 0.0
emission = 0.05 0.75
emission = 0.75 .82
emission = 1.0 1.0
[B] size = 0.0 0.25
size = 1.0 0.25
scale = 0.0 0.25
scale = 1.0 0.25[/B]
speed = 0.0 1.70
speed = 1.0 1.65
}

am i doing something wrong?

Edited by BobsYerUncle
Link to post
Share on other sites
So just to clarify Nazari, if the original numbers are 1.0 0.5 to half the size of the effect you change it to 1.0 0.25?

yes the first number is throttle level, second is size (based on the size of the original particle in the .mu)

Link to post
Share on other sites
You need SmokeScreen, and changing the second value on each line for size will work for that. The effect needs to be MODEL_MULTI_PARTICLE_PERSIST.

Ahhhhhh. now its working perfectly. Thank you :)

qZqBX2U.png

So just to clarify Nazari, if the original numbers are 1.0 0.5 to half the size of the effect you change it to 1.0 0.25?

i had been changing the #s a few times just trying to get an effect, i started with .5 and thats what i used in the pic above.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...