Jump to content

HotRockets! Particle FX Replacement + Tutorial


Recommended Posts

Those pics on the bottom there are from B9 Aerospace. Speaking of which, bac9 recently posted saying he's working on a new update for the pack... yay! :)

Nazari, would you be able to put a bluish clear effect on the Skipper? I always think of it as a J-2 equivalent, which used cryogenic LH2 and LOX. It's exhaust was bluish clear, it's water vapor. It would also help break up the chain of most of the engines having a yellow exhaust.

I love what you've done so far, it's just an idea. I know it's not meant to be all that realistic but I just thought it might be something to mess with, something like the exhaust on the KSO main engines. :)

I made an edit of the skipper that has this effect using the jet engine exhaust, as soon as I get home I'll message you the section to get that look. The J2 is what I think of the skipper as too :)

I made a Saturn V based around that idea.

Link to post
Share on other sites
sorry for lame question how to generate // find ?

coz game work normally just without fx

KSP/KSP_Data, output_log.txt. If it's large just zip it. Also did you install it properly? You should have MP_Nazari and SmokeScreen in GameData.

Link to post
Share on other sites

This is cool, and frankly we're thinking of BORGing the B9 stuff once you fix it for the latest SmokeScreen.

I'll note though, the civilian jets shouldn't have any flames - commercial turbofans don't do that :P

Link to post
Share on other sites

@Nazar1382:

Maybe you could update the pircutres of the engines in the first post?

For me it was quite disapointing to see the poodle only with this tiny almost invisible flame, but having this awesome effect seen in the post.

Link to post
Share on other sites

Do you take requests?

In the process of moving the B9 engines to ModuleEnginesFX we've noticed there's no MULTI_PARTICLE flameout spark, and the PERFABs aren't easily resizeable ... they're missing altogether from your current config, but regardless of how realistic it is its useful to have them from a gameplay perspective.

Link to post
Share on other sites
Wasn't there someone working on a dust effects from landing? Whatever happened with that?

U know from digging around in the .cfgs you can turn on collisions on the particles and have them deflect off the terrain. I'm in the process of testing this as we speak. This post will be updated in about 5 min with some result pics.

EDIT: So no, all it does is instantly cancel out the smoke particles' vertical velocity and allow them to move off tangent while retaining their horozontal velocity, so the smoke kind of 'collects' there on the ground. The demonstration way earlier had the smoke particles retaining all their velocity and redirecting it tangent to the ground.

Images:

KEi2Moz.png

VkIHFs4.png

rLKTY8m.png

Edited by Captain Sierra
Link to post
Share on other sites
all it does is instantly cancel out the smoke particles' vertical velocity and allow them to move off tangent while retaining their horozontal velocity.

There's values to change that, at least in SmokeScreen 2.0.

You can see it in the ingame SmokeScreen editor (you are using Toolbar, right?).

Link to post
Share on other sites
There's values to change that, at least in SmokeScreen 2.0.

Duely noted, great!

You can see it in the ingame SmokeScreen editor (you are using Toolbar, right?).

No and Yes respectively. I have toolbar but I see no editor. I'll double check later.

Link to post
Share on other sites

enable the button in the toolbar options while in a craft.

click it, youll get a window with a list of applicable fx.

select one, click the editor checkbox and click the rebuild button. make your changes, click apply.

Screenshot_47.png

Link to post
Share on other sites

The updated SmokeScreen (2.0) and HotRockets don't seem to be getting on, things seem fine at launch, but at ~25,000m ~750m/s the exhaust detaches and starts emitting in space nearby instead of from the engines

Could this be related to Proot's Renaissance package, is anyone with default SmokeScreen 2.0 and HotRockets seeing weird exhaust effects?

uDSl7gX.jpg

Those blue dots are the engine effects which are now emitting in space nearby rather than from the engines

Followed by later on in space

8s72VTY.jpg

Edited by NoMrBond
Link to post
Share on other sites

I can confirm the same issue. I am not using Proot's Renaissance, I am using better atmosphere, not sure that matters.

And I'm still getting my error log spammed with "[Exception]: NullReferenceException" whenever I have HotRockets installed, causing me to be unable to revert a flight or go back to the space center.

Edited by pantheis
Link to post
Share on other sites
And I'm still getting my error log spammed with "[Exception]: NullReferenceException" whenever I have HotRockets installed, causing me to be unable to revert a flight or go back to the space center.

Having the full exception text whould help, because NullReferenceException is then most common exception you can get with a KSP mod.

And as Taverius said I'll look into it. Since it starts at 750m/s it's related to KrakenBane and use worldspace set to false.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...