problemecium

[1.0.x; Part, Plugin] parameciumkid's Jump Drive 0.6 (compatibility update)

Recommended Posts

So I installed this, and the jump beacons are showing up in the VAB, but not the Jump Drive. I have my tech tree maxed out, I've watched the log and it seems to load okay, and the jump drive shows up in the part database. I'm not sure why I'm only getting the beacon and not the drive?

Share this post


Link to post
Share on other sites
So I installed this, and the jump beacons are showing up in the VAB, but not the Jump Drive. I have my tech tree maxed out, I've watched the log and it seems to load okay, and the jump drive shows up in the part database. I'm not sure why I'm only getting the beacon and not the drive?

I had this problem some time ago. In my case it was because I had stock tech tree, and IIRC the Jump Drive is in a tech node that is hidden or isn't "defined" in stock tech tree (like Experimental Rocketry or something simillar). Check sandbox mode and if the part is there, try changing its tech node.

Share this post


Link to post
Share on other sites

Oops.

I better go fix that xD I just realized I didn't double-check after they changed the stock tree in 1.0.

In the meantime, do what xfrankie said.

Share this post


Link to post
Share on other sites

Hey paramecium, if I wanted to try to use the blue crackling electricity kind of animation that runs on the jump beacon on another part, but wanted it much larger and offset, how would I do that? Would you be willing to give me some direction on this?

Share this post


Link to post
Share on other sites

Unfortunately that can't be done with this version. Unlike most special effects in KSP, which are stored as separate files in an "FX" folder, the blue plasma effect was actually built into the part using PartTools when I made the model.

I have another art pass slated for sometime in the future, during which I intend to correct this. I want to wait for KSP 1.1 to come out first so I can make use of some Unity 5 features.

Share this post


Link to post
Share on other sites

nice. Does this mean that we can also decouple the jump module from the specific part, or would it stay tied to the jump drive even if i were to rewrite another part with the module. Can't tell you how much this mod alone means to my interstellar empire.

Share this post


Link to post
Share on other sites

I appear to be having an issue with this mod. I am attempting to jump a probe with a few antimatter collectors to a beacon i have placed at Jool. After i jump, all solar bodies (including the sun and Kerbin) are removed from the game. All of the objects i have in space have retained their orbits, but the planets are gone. The only way to fix this is to completely quit out of the game and reload the save.

Share this post


Link to post
Share on other sites

This actually appears to be an issue with KSPI Extended, actually. A ship that does not have an antimatter collector will jump with no issues, but one WITH an antimatter collector will destroy every solar body.

Share this post


Link to post
Share on other sites

That's probably related to the antimatter collector's behavior being based on speed of movement through space, which is infinite if you teleport, as well as not my problem ;)

UPDATE:

Jump Drive has not been expressly tested with KSP 1.0.5 yet, but should presumably work the same as before. If anyone would like to report on whether it doesn't, feel free. The next update is planned for whenever KSP 1.1 becomes available, as it is to include another art pass involving a Unity 5 shader.

Teaser:

RAlIwgUm.png

Edited by parameciumkid
1.0.5 update or lack thereof

Share this post


Link to post
Share on other sites
I never understood why this mod never got fully released and always stayed in the add-on development subforum. Always works fine and I consider it fairly balanced. One of my favs.

Expect an avalnche of rep points from me if that cool effect gets included in the next version.

Share this post


Link to post
Share on other sites

Any plans for TweakScale integration?  You could have the charge time decrease or increase with size, and the Jumpdrive part really does not fit very well in many situations.

Share this post


Link to post
Share on other sites
25 minutes ago, elijahlorden said:

Any plans for TweakScale integration?  You could have the charge time decrease or increase with size, and the Jumpdrive part really does not fit very well in many situations.

You'd probably find that very simple to achieve if you took a shot at it yourself - just take a look at a part with existing Tweakscale intergration and either edit it in or write an MM patch for it.

I myself don't like putting the drive on everything that might need it, so I do the following:

* Create a 'drive module' that consists of the drive, RCS, a variety of docking ports (I personally find one standard and one Jr at either end is fine for what I need), a drone control, power source obviously, engines (radial if needs be) and some fuel tanks (optional).

* Optional: Create an Orbital Dock around Kerbin (or every destination, over time) and fit it with a beacon. Dock a drive module on to however many Orbital Docks you want them at (Jump Drives currently work from the surface, making this trivial).

* Always put at least one matching docking port on any craft that wants to jump.

* Get into orbit and either go to the dock / module or get the module to come to you.

* Dock your ship to the module.

* Jump out (tada - it works on 'both' craft!).

* Undock and send the module back home (unless you want it hanging around for later).

Voila, no need to put one on everything!

Share this post


Link to post
Share on other sites

The way I use Jumpdrives is the very reason most people consider this mod OP.  I normally launch a beacon out to the highest possible orbit around Kerbin.  Then I take whatever im trying to launch into space, slap some SRBS on using radial decouplers, and attach a jumpdrive to the bottom with a stack decoupler.  

BTW, im pretty sure you meant to say that they work from NEAR the surface.  if you use it straight from the launchpad it sinks into the ground and your entire ship explodes.

Edited by elijahlorden
Forgot to say something

Share this post


Link to post
Share on other sites
On 1/23/2016 at 4:54 AM, elijahlorden said:

BTW, im pretty sure you meant to say that they work from NEAR the surface.  if you use it straight from the launchpad it sinks into the ground and your entire ship explodes.

I know the sinking effect you're talking about, but I've not seen an explosion.  I only ever 'launched' craft in that fashion once and I used launch clamps.  Although it definitely started to sag, it was away from the ground for plenty of time to jump and thus didn't get a chance to collide.

Share this post


Link to post
Share on other sites

Ooh, yes! I can see this being incredibly handy with LS mods and distant stations. Gotta be careful about your kerbals not dying before their resupply get there: now a resupply could be mere hours away!

Share this post


Link to post
Share on other sites

I tried adding Jump Beacon settings to the CFG for a custom welded part, but I am getting NREs: 

A null ref was found in the Beacon's Awake()

I assume this is because my part doesn't have the jump animation. I wonder if there is any workaround?

 

Share this post


Link to post
Share on other sites

Love this idea, but a few quick questions:
1. does this mod conflict with KSPI-E? because i'de most likely have your drives installed on Antimater powered SSTOs

2. can you use more than one on a ship at once in tandem?

Share this post


Link to post
Share on other sites
On 2016年1月18日 at 9:37 AM, elijahlorden said:

Any plans for TweakScale integration?  You could have the charge time decrease or increase with size, and the Jumpdrive part really does not fit very well in many situations.

I edited the Jump Drive CFGs to rescale the parts to 0.375m, and added the ability to surface attach the drives.

Share this post


Link to post
Share on other sites

So this supposedly works in 1.0.5 (which I'm still using), and everything seemed grand, until I went to launch my ship. After sitting on the launch pad for all of two seconds the screen went black and it teleported me to the surface of the Sun. How do I know this? Because my ForScience mod actually gathered a crew report from the surface of the Sun and I got a screenshot of it:D. (Not very impressive, just says 5 data, no flavor text). Pod was damaged, but crew some how survived (after loading screen), although screen still black. Please advise.

(look in upper left, not very exciting, sorry)

ePpYuHz.png

Share this post


Link to post
Share on other sites
On 11/4/2015 at 0:33 AM, parameciumkid said:

That's probably related to the antimatter collector's behavior being based on speed of movement through space, which is infinite if you teleport, as well as not my problem :wink:

UPDATE:

Jump Drive has not been expressly tested with KSP 1.0.5 yet, but should presumably work the same as before. If anyone would like to report on whether it doesn't, feel free. The next update is planned for whenever KSP 1.1 becomes available, as it is to include another art pass involving a Unity 5 shader.

Teaser:

RAlIwgUm.png

Against better judgement I tested your latest available version in 1.1.2, but as to be expected it unfortunately didn't work.

Loading the Jump drive part in a scene gave me this message;

[Exception]: TypeLoadException: Could not load type 'Callback' from assembly 'JumpDrive'.

Pushing the 'Activate' button showed me this one;

[Exception]: TypeLoadException: Could not load type 'ConfigNode' from assembly 'Assembly-CSharp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 

Was planning a base on Duna and your technology would really help save me time/frustration getting it up and running :wink:

So my question to you is if you're still planning on updating this extremely useful mod like mentioned above?

 

Cheers mate

Share this post


Link to post
Share on other sites

Yeeeahhh, um, it's gotten hard with the changes to KSP's underlying mechanics. I may well have to rebuild most of this thing from scratch, and that might take some time. Sorry!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.