Jump to content

[1.10.0] Final Frontier - kerbal individual merits 1.10.0-3485


KSP 1.1.0  

706 members have voted

  1. 1. Is FinalFrontier working in KSP 1.1.0?

    • Yes
      238
    • No
      59
    • It doesn't matter; this poll was just created to remove the outdated old one...
      438


Recommended Posts

  • 4 weeks later...
  • 2 weeks later...
On 11/9/2019 at 2:49 PM, Gordon Dry said:

@Krakatoa When I add it to KSP 1.8.1 then the initial RAM usage after reaching the main menu is about 2.8 GB higher than without it (in my modded install)... just saying.

I don't think that this means "it's okay for KSP 1.8.1"

It's just fine if you have 32GB of RAM in your system. ;-)

Link to post
Share on other sites
1 hour ago, Gordon Dry said:

@panarchist it's all about principles. Creating loopholes of code because mankind "invented more RAM" never was a good idea. :D

Pretty sure in this case, it wasn't deliberate. Funny to see FF drawing that kind of RAM, though - never thought there was anything in that mod likely to do so. Then again, didn't Squad just change GC in 1.8.x?

EDIT: Ok, I fired up my Win64 instance on Windows 10, with 42 mods (including Kerbalism and Final Frontier) and I draw a bit over 6.6GB of RAM. Without FF, it's 3.8GB. That's consistent with the 2.8GB you mentioned. Ouch.

Edited by panarchist
updated with results from my instance
Link to post
Share on other sites
On 11/19/2019 at 4:44 PM, panarchist said:

Pretty sure in this case, it wasn't deliberate. Funny to see FF drawing that kind of RAM, though - never thought there was anything in that mod likely to do so. Then again, didn't Squad just change GC in 1.8.x?

EDIT: Ok, I fired up my Win64 instance on Windows 10, with 42 mods (including Kerbalism and Final Frontier) and I draw a bit over 6.6GB of RAM. Without FF, it's 3.8GB. That's consistent with the 2.8GB you mentioned. Ouch.

It does seem to be GC related, as without, at the KSC memory usage is about 3.2GB at startup, then it drops to around 500MB. With it, it stays at 3.2GB then steadily climbs. I don't see any errors in the console even with the logging in FF set to Trace, and I did try compiling for 1.8.1.  Would definitely need a more skilled coder to take a look.

Link to post
Share on other sites

Hi all,

Since I'd like to use this, I decided to do some tests in 1.8, and the results were quite interesting. I'm hoping to get some help here.

I compiled it for 1.8 (using @mwerle's fork), and dropped it into my dev system.  The interesting result was that there was no detectable memory usage.  3121 meg without, 3145 with, and that's within normal variations.  This was, of course, without any play time.

So, if one or more of you would send me a save file which demonstrates the memory issues, it would be useful to have as a test.

A 1.7.3 game would be acceptable.  If you do want to share, please zip up the entire save folder.  You can get it to me via a private PM if you don't want to put the game here

 

 

Edited by linuxgurugamer
Link to post
Share on other sites
On 11/9/2019 at 5:49 PM, Gordon Dry said:

@Krakatoa When I add it to KSP 1.8.1 then the initial RAM usage after reaching the main menu is about 2.8 GB higher than without it (in my modded install)... just saying.

I don't think that this means "it's okay for KSP 1.8.1"

Were you running a version built for 1.8?  See my above post

Link to post
Share on other sites
9 hours ago, linuxgurugamer said:

Hi all,

Since I'd like to use this, I decided to do some tests in 1.8, and the results were quite interesting. I'm hoping to get some help here.

I compiled it for 1.8 (using @mwerle's fork), and dropped it into my dev system.  The interesting result was that there was no detectable memory usage.  3121 meg without, 3145 with, and that's within normal variations.  This was, of course, without any play time.

So, if one or more of you would send me a save file which demonstrates the memory issues, it would be useful to have as a test.

A 1.7.3 game would be acceptable.  If you do want to share, please zip up the entire save folder.  You can get it to me via a private PM if you don't want to put the game here

 

 

How long did you let the game run? I also used @mwerle's fork to build for 1.8.1, and without, my memory using was around that at approx 3200, but then dropped significantly after a few minutes, and that was just sitting at KSC.  This is on a recently (yesterday) 1.8.1 install, some mods, new save with no pilot data, but I can send it if that helps.  Ill also start a second save and play awhile if real data helps.

Link to post
Share on other sites
2 hours ago, Jade_Falcon said:

How long did you let the game run? I also used @mwerle's fork to build for 1.8.1, and without, my memory using was around that at approx 3200, but then dropped significantly after a few minutes, and that was just sitting at KSC.  This is on a recently (yesterday) 1.8.1 install, some mods, new save with no pilot data, but I can send it if that helps.  Ill also start a second save and play awhile if real data helps.

I ised QuickStart to get to a flight scene.  Had about 20 mods installed.  

I ran it several times to be sure.

Link to post
Share on other sites
12 hours ago, linuxgurugamer said:

Hi all,

Since I'd like to use this, I decided to do some tests in 1.8, and the results were quite interesting. I'm hoping to get some help here.

I compiled it for 1.8 (using @mwerle's fork), and dropped it into my dev system.  The interesting result was that there was no detectable memory usage.  3121 meg without, 3145 with, and that's within normal variations.  This was, of course, without any play time.

So, if one or more of you would send me a save file which demonstrates the memory issues, it would be useful to have as a test.

A 1.7.3 game would be acceptable.  If you do want to share, please zip up the entire save folder.  You can get it to me via a private PM if you don't want to put the game here

 

 

Ok, PM sent for a save that has the problem, I also included a mod list if that helps. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...