Nereid

[1.7.1] Final Frontier - kerbal individual merits 1.5.3-3465

KSP 1.1.0  

637 members have voted

  1. 1. Is FinalFrontier working in KSP 1.1.0?

    • Yes
      223
    • No
      54
    • It doesn't matter; this poll was just created to remove the outdated old one...
      389


Recommended Posts

Two minor bugs found:

  1. Stock toolbar button remains visible in the main menu after quitting a game
  2. Mission time is not correctly calculated. (well... math...)

I will try to solve these, but its late...

- - - Updated - - -

Uploaded to KerbalStuff. NanoGauges is next...

If there are issues with KSP 1.0, please report. I have just done a few (well, quite a few) quick tests. I have not yet started my own career or sandbox game in 1.0.

S.A.V.E will get an update the next few days. I will have to test it more carefully.

Edited by Nereid

Share this post


Link to post
Share on other sites
Two minor bugs found:

  1. Stock toolbar button remains visible in the main menu after quitting a game
  2. Mission time is not correctly calculated. (well... math...)

I will try to solve these, but its late...

- - - Updated - - -

Uploaded to KerbalStuff. NanoGauges is next...

If there are issues with KSP 1.0, please report. I have just done a few (well, quite a few) quick tests. I have not yet started my own career or sandbox game in 1.0.

S.A.V.E will get an update the next few days. I will have to test it more carefully.

Thank you for all the hard work!

Share this post


Link to post
Share on other sites
Stock toolbar button remains visible in the main menu after quitting a game

there are reports of some silent changes to the AppLauncher code, take a look at the Kerbal Alarm Clock source that may provide some insight, helped one mod author squish the problem of multiple buttons appearing after scene changes

Share this post


Link to post
Share on other sites

KSP career mode just isn't right without this.

Share this post


Link to post
Share on other sites
there are reports of some silent changes to the AppLauncher code, take a look at the Kerbal Alarm Clock source that may provide some insight, helped one mod author squish the problem of multiple buttons appearing after scene changes

Well, in this case the cause was more.... well... lets say stupid. A button can be assigned to a bunch of scenes. You can show the button in space center, flight, tracking station, ... and always. Well, for an unknown reason (testing purposes?) I had chosen "always".

But you are right. There were some silent changes. Registering for an event on awake when the AppLauncher is ready to install the button was not working for FF anymore. I think because FF awakens multiple times (it's on my todo list to change this) and the AppLauncher is already ready then. So my workaround was to check if its ready, just install the callback if its not and install the button directly otherwise. Works. Correct way to do this? I dunno. But who cares? ;)

Share this post


Link to post
Share on other sites

Should have a first female kerbal in space award.

Share this post


Link to post
Share on other sites

And a first male in space, if a female kerbal was first. ;) Nut, nice idea. :) I will see what I can do.

Share this post


Link to post
Share on other sites

Any news on the ribbons disappearing?

If there was a clue maybe I could fix it. I have minor code ability

Share this post


Link to post
Share on other sites

small bug..: When using the mod named " Kerbal addon version checker", then I see a pop up where it say that

Final frontier 0.7.4.870 was made for 0.90 and may not be compatible.

I downloaded final frontier from https://kerbalstuff.com/mod/428/Final%20Frontier and it is current version: 0.7.4-870

Fix..: Well since you updated it to work with V1.0 then I think you might have forgot to change the version number somewhere inside the mod.

It would be nice if you could fix the "version" check so that it work properbly.

PS: I really LOVE your amazing mod.. It bring so much to KSP game.. Personaly I think your mod should have been in the stock game ;-)

Thank you for creating your mod, it is fantastic and I can feel your love for your "creation" ;-)

Share this post


Link to post
Share on other sites

Strange. But I will take a look and fix it. I can't remember any version number other than KSP-AVC which should behave correctly.

Share this post


Link to post
Share on other sites

Fantastic mod! Thank you for the quick update.

One minor, nitpicking suggestion: would it be possible to save the ribbon stats in $ROOTPATH/saves/$GAME/FinalFrontier.dat rather than in $ROOTPATH/GameData/FinalFrontier.dat? When I upgrade KSP, I normally backup my saves directory and then wipe everything else to make sure I have a clean install. I'm sure at some point I'll forget that FinalFrontier.dat isn't in saves and wind up deleting all my ribbons.

Share this post


Link to post
Share on other sites
would it be possible to save the ribbon stats in $ROOTPATH/saves/$GAME/FinalFrontier.dat rather than in $ROOTPATH/GameData/FinalFrontier.dat?

The ribbons stats are not saved in this file. They are saved in the persistent file in $ROOTPATH/saves/$GAME.

The file $ROOTPATH/GameData/FinalFrontier.dat just stores general settings of FinalFrontier. Such as window positions, window names, etc. All those things you can change in the configuration window. if you lose it, all ribbons are still there.

- - - Updated - - -

Any news on the ribbons disappearing?

If there was a clue maybe I could fix it. I have minor code ability

Unfortunately that's the problem. We are missing the clue more often than some ribbons at the moment. ;)

Edited by Nereid

Share this post


Link to post
Share on other sites

Sorry if it was talked about earlier on, but if I add this mod to an already-existing save file, how can I give ribbons to Kerbals in such save which have already conquered feats?

And a first male in space, if a female kerbal was first. ;) Nut, nice idea. :) I will see what I can do.

I don't think you should do that; to have a "first female Kerbal in space" ribbon would imply female Kerbals are less capable than male ones, and having the same ribbon for male Kerbals would be redundant. It's your call, though.

Share this post


Link to post
Share on other sites
Sorry if it was talked about earlier on, but if I add this mod to an already-existing save file, how can I give ribbons to Kerbals in such save which have already conquered feats?

I don't think you should do that; to have a "first female Kerbal in space" ribbon would imply female Kerbals are less capable than male ones, and having the same ribbon for male Kerbals would be redundant. It's your call, though.

Gonna agree with Tadpole on this one :P no reason to have a seperate ribbon for female vs male , im my humble opnion

Share this post


Link to post
Share on other sites
No. Why discriminate?

Because that sort of detail is something that actually gets talked about a lot (i.e., first woman in space was... :) ).

For the record, I'm all in favour. As a teacher, I'm fighting against some pretty heavy big time pink forces when it comes to encouraging girls to get interested in STEM areas of study.

Share this post


Link to post
Share on other sites

I seem to keep encountering an issue that I have been having since 0.90.

Currently I am using FF 0.7.4-870 on KSP 1.0

It's hard to nail down when or why this happens (as it doesn't ALWAYS or consistently):

- I take a Kerbal (Jeb) on a mission... everything goes allright.. He gets ribbons and his mission count goes up by 1. Good.

- I take a new Kerbal (Bob) on a new mission... everything goes allright... He gets ribbons and his mission count goes up by 1. Good.

- I take yet another new Kerbal (Bill or Valentina) on a new mission... everything goes allright... They get ribbons and their mission count goes up by 1. Good.

- I take a look at the FF stats in the space center scene and Bob's (second mission I did) mission count is now 0 instead of 1 as it was previously, but his ribbons are still there. wha????

As I said earlier, I have had this exact same bug in previous versions of the game and FF... Anyone else have this bug? Anyone know what is going on?

***Update***

I just loaded up my game again and the last Kerbal I used (Valentina) lost the mission count as well.... now Only Jeb is marked as "1 Missions". But she still has her earned ribbons... :confused:

Edited by DesTroy
Update

Share this post


Link to post
Share on other sites
I seem to keep encountering an issue that I have been having since 0.90.

Currently I am using FF 0.7.4-870 on KSP 1.0

It's hard to nail down when or why this happens (as it doesn't ALWAYS or consistently):

It's really strange, because I have still never noticed this myself on any of my tests. And I'm starting missions, recover missions, save, load, quickload,... very often. Because it was reported I keep an eye on mission count and mission time and have never seen this so far. PS: I'm playing sandbox most of the time. And I'm testing in sandbox, too. Maybe that is the clue we are looking for.

We need a strategy to get more information when this happens (well... that is a major part of my work in real life; but I do not have to do it by forum/mail and not in english most times).

My suggestions if some wants to take part in the analysis:

  • Make a backup of a save everytime KSP starts or more often (but keep track of time and date of a backup).
  • Set the log level of FF at least to INFO (better: DETAIL)
  • If this bug happens quit KSP (in the main menu and NOT by closing the window) and make a copy of the KSP log.
  • Try to remember was was done at the time the bug occurs (recover, load, quickload, launch, return to space center, kerbal promotion ;), whatever...).
  • A very important question: did it happen in Sandbox, Science or Career?
  • Make a backup of the current game.
  • Restore an old save/backup and check mission times/counters (or ribbons).
  • If the mission time/counts are ok in the old save or backup, send me a private message and if I ask send me the KSP.log and both save games (backup before the bug happens and the current game after the bug happens). Include a list of all used mods (including version).

That would be my first try for a strategy to solve this. But every other useful idea is appreciated, too.

Edited by Nereid

Share this post


Link to post
Share on other sites

Could it be an issue with other mods. Those of you experiencing this, is there any common mods you all use? Or us this happening with just FF installed. I had issues with disappearing ribbons pre 1.0 but I had other mods.

Share this post


Link to post
Share on other sites
um do the ribbons get given automatically? i dont know if its working or not

Most of the were given automatically. I do not plan to change this.

Top priority on my list is solving the lost ribbons and lost mission stats bugs. I think both are completely independent. The lost ribbon bug were introduced by using the persistent file for storing the ribbon data. Because lost ribbons are eays to detect (all ribbons were gone), the mission stats problem is of more importance.

But still no idea here what could cause this. Maybe the way FF starts up (it starts again each scene change) has something todo with this. Unfortunately it is not that easy to change. I will need a few hours without work or other distractions in between to change this or to try it at least. I was never very satisfied with the current implentation of this part in FF. But prior to 0.90 all attempts to change this failed. In S.A.V.E I have tried a different approach succesfully. It starts and awakens just once.

FF is using some singletons to provide access to some kind of global data. Older versions of FF were not really thread safe in using them (but I don't think they need to). I have changed this a while ago, but well... no luck. Bug is still reported. It's very frustrating for me, because I have never ever seen it myself. Log outputs to check if the singletons were created multiple times were added, but again no luck. All logs are clean so far.

I got a report of other things vanishing not related to FF in career mode. I'm not playing in career often. Maybe the bug in FF is related to a strange bug in KSP that happens sometimes just in career mode.

The strange aspect is: I'm doing quite a few strange things in my tests. I'm using HyperEdit, changing orbits on the fly, quicksave, quickload, save, load, kill KSP, restart KSP, ... all this with only very few other mods (HyperEdit, KSP-AVC - nothing else most times). And there are no problems. But in a regular game (maybe because KSP runs for a while?) the bug seems to occur infrequently.

Sorry guys, but at this point I just need more information. We need a pattern, a hint in the log or a way to reproduce this bug at least more often. Or we will have to wait until I will face it myself.

- - - Updated - - -

Could it be an issue with other mods. Those of you experiencing this, is there any common mods you all use? Or us this happening with just FF installed. I had issues with disappearing ribbons pre 1.0 but I had other mods.

Currently I don't think so. Prior to 1.0 I have used quite a few mods myself but it has never happened to me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.