Sign in to follow this  
jamis

Mod bundler for "Real Solar System" (DEFUNCT)

Recommended Posts

Ah well that's interesting. I got an SSL error. Turns out it was on my end. For some reason my windows clock loses time all the damn time and the time difference cause the error. I set the right time and it worked.

Share this post


Link to post
Share on other sites

Whew, okay :) Glad it was an easy fix. More like that, please. :)

Share this post


Link to post
Share on other sites

Btw how do I know where this installs the mods to? I have KSP outside of steam. I have steam on my HDD and I wanted KSP to be on my SSD so I just transferred it over and have been playing from the SSD. I just checked the gamedata and the mods aren't there. Is there something I missed here?

Share this post


Link to post
Share on other sites

@Dhan, the bundler doesn't actually install anything. It just builds a zip file (rss.zip by default, for the Real Solar System), which you must then move to your main KSP directory, and then unzip.

Share this post


Link to post
Share on other sites

Boo, I was hoping for an idiot proof install :P. And yeah I figured it out so I went ahead and did the transfers. Saved me a lot of headaches. Thanks buddy

Share this post


Link to post
Share on other sites

Can someone explain in an idiot-proof way why I can open the .bat but why it then immediately vanishes? I've always wanted to do RSS but never managed to find the motivation to track down every single mod. This would be a great tool if only I could make it work :P

Share this post


Link to post
Share on other sites

@Sauron, this happens because Java isn't installed (or isn't installed correctly) on your machine. Phenom Anon X wrote a pretty good guide to getting that ironed out:

http://forum.kerbalspaceprogram.com/threads/67668-Mod-bundler-for-Real-Solar-System-%282014-02-25%29?p=977803&viewfull=1#post977803

Basically, as Phenom explains, you need to:

  • Download and (re)install Java
  • Update your system PATH variable so programs can find Java

Share this post


Link to post
Share on other sites

Right. This is the non-idiot-proof bit :) My Java is current (32 and 64 bit), but I'm not clear on how to actually add (do I add?) the path. It's just not entirely clear whether I'm changing something, adding a new thing, etc.

Share this post


Link to post
Share on other sites

Phenom's post (linked above) talks about how to add the path. If it's not clear there, ask again, and hopefully someone can help you. (I don't use Windows myself, so I'm afraid I'd lead you astray if I tried to give you specific instructions.)

Share this post


Link to post
Share on other sites

When I try to execute the command in Terminal I get 'Error: Unable to access jarfile jars/real-solar-system.jar'. I also tried launching real-solar-system.jar separately but it failed to launch. Help?

Share this post


Link to post
Share on other sites

You should replace this command:

java -Xmx500m -jar .\jars\real-solar-system.jar %*

with this one:

start javaw -Xmx500m -jar .\jars\real-solar-system.jar %*

This way there wont be a cmd window open in the background :)

Share this post


Link to post
Share on other sites
You should replace this command:

java -Xmx500m -jar .\jars\real-solar-system.jar %*

with this one:

start javaw -Xmx500m -jar .\jars\real-solar-system.jar %*

This way there wont be a cmd window open in the background :)

It still won't work :(

The code I put into Terminal is as follows:

#!/bin/sh

set -e

CLASSPATH=./jars/zip4j_1.3.2.jar
start javaw -Xmx500m -jar .\jars\real-solar-system.jar %*

What should happen after that? I got

-bash: start: command not found

and nothing happened

(I'm on Mac, just to clarify)

Share this post


Link to post
Share on other sites

@paxy97, ah-ha! that's the command I was looking for. I'll get that changed in the next release.

@MrMeeb, when running it on a Mac, make sure you're running the real-solar-system.sh file (not the .bat) file. Also, make sure you're running it from the directory where it lives--in other words, change to that directory first, from the terminal, and then run "./real-solar-system.sh" (without the quotes, of course).

Does that work any better?

Share this post


Link to post
Share on other sites

So, my issue was definitely a mod I installed outside of the bundler, probably RCS Sounds. I had previously tried removing RCS Sounds and it still hung, so it may have actually been something else, but have not yet tried to isolate it. In any case, I am having plenty of fun playing RSS with the straight bundler install. Thanks!

Share this post


Link to post
Share on other sites
@MrMeeb, when running it on a Mac, make sure you're running the real-solar-system.sh file (not the .bat) file. Also, make sure you're running it from the directory where it lives--in other words, change to that directory first, from the terminal, and then run "./real-solar-system.sh" (without the quotes, of course).

Does that work any better?

Yeah, it's working now. Thanks! :D

Share this post


Link to post
Share on other sites

@Tangle, I'm assuming you're on Windows? Would you please look at this post by Phenom Anon and see if it helps get things going for you? Most people who have trouble getting the bundler running find it's because Java is not installed (or not installed correctly).

http://forum.kerbalspaceprogram.com/threads/67668-Mod-bundler-for-Real-Solar-System-%282014-02-25%29?p=977803&viewfull=1#post977803

Share this post


Link to post
Share on other sites

Sorry for the confusion, Tangle. In the next release I'll fix that. My windows-fu is weak, but @paxy97 showed me how to make that command window go away.

Share this post


Link to post
Share on other sites

well, seems we are doing the same thing.

I have advertised the "realistic KSP"(short for RKSP,lol) in one of the Chinese communities for months.

My cores are:

DeadlyReentryCont_v4.3

RealFuels_v4_3

RealismOverhaul_v3

RealSolarSystem_v5_5)

EngineIgnitor-V3.2

FerramAerospaceResearch_v0.12.5.2

KerbalJointReinforcement_v2.1

TacLifeSupport_0.8.0.4

RemoteTech2_1.3.3

while my extras are:

CrewManifest v0.5.6.2

UniverseReplacer v4.0 (Raredens Skybox rev4 )

RcsSounds V3.1

RealChute-v0.3.3.2

TacFuelBalancer_2.3.0.2

VOID-0-9-20

VisualEnhancements-6-7

ProcFairings_2.4.3

EnhancedNavBall [v1.2]

PreciseNode 0.8.1

StretchySRB_v8.1

targetron_1_3_4

RasterPropMonitor (Multi-function Display)

[WIP]RandomFailure

(the pictures seems to be dead and cannot be used outside Chinese internet. Anyone could tell me how to insert a picture?)

8871418da97739120eab2ad6fa198618377ae26f.jpgf5a6811c8701a18b4e8bbdf89c2f07082938fe9c.jpg

Edited by Himidori Shuumoto

Share this post


Link to post
Share on other sites
well, seems we are doing the same thing.

I have advertised the "realistic KSP"(short for RKSP,lol) in one of the Chinese communities for months.

My cores are:

DeadlyReentryCont_v4.3

RealFuels_v4_3

RealismOverhaul_v3

RealSolarSystem_v5_5)

EngineIgnitor-V3.2

FerramAerospaceResearch_v0.12.5.2

KerbalJointReinforcement_v2.1

TacLifeSupport_0.8.0.4

RemoteTech2_1.3.3

while my extras are:

CrewManifest v0.5.6.2

UniverseReplacer v4.0 (Raredens Skybox rev4 )

RcsSounds V3.1

RealChute-v0.3.3.2

TacFuelBalancer_2.3.0.2

VOID-0-9-20

VisualEnhancements-6-7

ProcFairings_2.4.3

EnhancedNavBall [v1.2]

PreciseNode 0.8.1

StretchySRB_v8.1

targetron_1_3_4

RasterPropMonitor (Multi-function Display)

[WIP]RandomFailure

(the pictures seems to be dead and cannot be used outside Chinese internet. Anyone could tell me how to insert a picture?)

http://imgsrc.baidu.com/forum/pic/item/8871418da97739120eab2ad6fa198618377ae26f.jpghttp://imgsrc.baidu.com/forum/pic/item/f5a6811c8701a18b4e8bbdf89c2f07082938fe9c.jpg

use imgur or photobuckets... at least the latter one works for me.

Share this post


Link to post
Share on other sites

My Windows 7 x64 system is a Java rebel. I tried eveything I've read here, about checking on the browser, setting PATH system variable, checking versión on command line... it still said Java wasn't found.

I ended up making a copy of java.exe from it's rightful place to where I downloaded this... and it worked xD

Share this post


Link to post
Share on other sites

@Demon_82, glad to hear you've tamed that unruly system of yours. :) If moving java.exe helped, then it was probably something funky with your PATH, but I don't know enough Windows to say how to go about fixing that. Anyway, glad it's working now!

Himidori Shuumoto, that's awesome! I'd love to see more of your system, to see how it compares to my approach. I'm not happy with how I've bundled all mod definitions into a single file..it makes it unwieldy to grow the list. I'm considering--perhaps after 0.24--looking into separate files for each mod definition, as well as figuring out how to update an install in-place (so you can upgrade outdated mods, for instance). Have you addressed any of that with your RKSP stuff?

Share this post


Link to post
Share on other sites

I was wondering when someone would write this. Very cool !

I started something like that on my side but kinda forgot about it. Mine was in mono, to work on all system with ksp.

Share this post


Link to post
Share on other sites

So whenever i try to run the script on mac i always get the same error message, i try to go to the same directory as it and it still won't run, i run an anti-virus program called Norton which may have interfered with the execution. (i am an admin on my computer)

Code:

-bash: start: command not found

Can someone please help, am i running it wrong(i put the file into terminal)(i also tried to run the actual code), is it something to do with Norton or am i just being dumb and didn't realize something?

Edited by SolarMojo13

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this