Sign in to follow this  
jamis

Mod bundler for "Real Solar System" (DEFUNCT)

Recommended Posts

@SolarMojo13, are you running the real-solar-system.bat file, or the real-solar-system.sh file? The "start" command not being found suggests you're running the wrong file.

On a Mac, you'll want to be in the real-solar-system directory (not the jars directory, the one just above it), and you'll want to run the real-solar-system.sh file. Also, you'll almost certainly need to install Java, since Apple doesn't install it by default.

Share this post


Link to post
Share on other sites

@jamis i am trying to run the .sh file not the .bat file and it still won't work i also sometimes get this error message as well (i checked in the forums for this and i get the second error message when i change the code pg11)

Unable to access jarfile jars/real-solar-system.jar

Edited by SolarMojo13

Share this post


Link to post
Share on other sites

I've been doing some work on KER to fix various bugs and shortcomings and I've just tried to set up a new copy of KSP using this tool so that I can modify the various readouts in KER to correctly account for RealFuels. I used the default mods (plus KER and alarm clock and then replaced the KER dlls with my own versions). I ran KSP and started a sandbox game and tried to load and fly one of the stock craft supplied (the FAR Orbiter 1) but I am unable to vary the throttle of most of the engines. The throttle control on the navball appears to work but at anything above flameout level the engines just go to full throttle (the thrust displayed on the engine readout panels doesn't change when changing the throttle). The engine on the final stage appears to work normally. It looks like a 909 so it may be that stock engines are working and others are not but I haven't confirmed this with any other stock engines...

Is this expected behaviour? If not, has anyone seen anything similar or can anyone make any educated guess as to what may be wrong?

Many thanks

Share this post


Link to post
Share on other sites

@SolarMojo13 -- so, without changing ANYTHING, you get that error about "start" not being a command? Something is very wrong. I would recommend deleting the bundler directory and downloading/reinstalling it. Then, trying it again fresh and without modifying anything, please let me know the exact error message you get.

@Padishar, that's expected behavior if you're using RealFuels--it adds tech levels to the engines, so that engines become more effective as your grow technologically. Also, it (realistically) makes many engines so that they are not throttleable, especially in early techlevels. Look at the engine descriptions, and you'll see a "min throttle" value, which describes what the lowest throttle amount for that engine is. (Almost more than anything else, this particular feature has made KSP quite challenging for me, especially when trying to mimic the performance profile for a particular real-life mission.)

Share this post


Link to post
Share on other sites

Using RSS w/ Real Fuels means real engine configs. Means most engines aren't deeply throttlable. Either On or Off for most of them.

Share this post


Link to post
Share on other sites

That makes sense, thanks. I did suspect it might be expected but a quick scan of a few threads didn't confirm it one way or another. Given that I will need to test KER quite thoroughly, is there an easy way to force a higher tech level so that (some) engines become throttleable? By all means point me at relevant documentation and I'll read up about it...

Share this post


Link to post
Share on other sites

You can change the techlevel on the same view where you change the fuels in a fuel tank: select the "action groups" tab in the VAB, and then click on the part you want to edit. (In this case, an engine on your ship.) A window will pop up on the left, which will let you adjust the tech level. You can also see what the current ISP and minimum thrust for the engine are, as well.

Share this post


Link to post
Share on other sites

Thank you (again). I managed to work out how to fill the tanks with the correct types of fuels and also to change the last stage engine to a fuel type that I actually had available but I didn't notice the option to change the tech level. I should be able to run the tests I need to now...

Share this post


Link to post
Share on other sites

I posed this question in the Mission Controller thread, but thought maybe someone here might know. I just used this java program to build out my RSS install. When I run the game, mission controller has all the RSS mission packs "greyed out" and I cannot select them. Is this because I'm missing a mod or a parts pack or something?

Share this post


Link to post
Share on other sites

I'm not aware of any RSS mission packs--the bundler doesn't install any by default, but if you know of some, I'd be happy to look into bundling them, too.

I've seen other grayed out mission packs in MCE before, too, but I don't know what causes that, or how to "un-gray" them.

Share this post


Link to post
Share on other sites

I did a little more digging and the files in question are .sp and .backup where-as the other's that show up are .mpkg files. (This all shows up in the \Kerbal Space Program\GameData\MissionController\Plugins\PluginData\MissionController folder.)

So I'm guessing that these are not infact missoin packs but something else, as to why they show up in the selection list I can't say.

Share this post


Link to post
Share on other sites

Is the LR34 supposed to have 1033 thrust? Judging from its size, and my attempts to dive through the config files, I'm guessing no, but thats how much it says in the VAB. I ask because I may have done something wrong in the install.

Share this post


Link to post
Share on other sites

@IonMage, that doesn't look right. In my install, the LR34 has 195 max thrust at tech level 1, using Kerosene/LOX fuel. Even at tech-level 7, maxthrust is still only 246.8. Maybe you've got another mod installed that's not playing nice?

Share this post


Link to post
Share on other sites

I only used the ones in the bundler :(. Any combinations in the bundle that are incompatable? Only one mentioned is ECLSS and TAC, which I of course chose only one of.

Share this post


Link to post
Share on other sites

What mods are you installing? Also, where are you seeing the 1033 max thrust? Can you share a screenshot? I'm not aware of any mod combinations in the bundler that would cause that. In fact, I've run with most of the mods installed, with no problem.

Share this post


Link to post
Share on other sites

It was showing this in the VAB, but its no matter. I tried it a second time, and its now looking right, as it should. Must have been a freak one-off glitch.

Share this post


Link to post
Share on other sites
NathanKell's "Real Solar System" mod (http://forum.kerbalspaceprogram.com/threads/55145) is all the hotness these days, and no wonder. But anyone who's tried to set it up will understand when I say that it's not a task for the faint of heart. There is a maze of dependencies to navigate, and the lists of supported and recommended mods rarely have links to point you at where to download them.

In navigating this maze myself, I took some notes, and these notes turned into a list, and the list turned into a simple script. The purpose of this script is to pull in all the needed dependencies and install them, and after testing it for a week or so, I've found it works quite well. Well enough to share with others who might find themselves in the same quandary I was in.

Just grab the bundler here:

http://jamisbuck.org/files/real-solar-system-20140225.zip (20MB)

Unzip it somewhere (NOT IN YOUR KSP FOLDER), and then click on the "real-solar-system.bat" (Windows) or "real-solar-system.sh" (Mac/Linux) to launch the UI.

http://jamisbuck.org/files/mod-bundler.png

Also, while the manifest file itself (which defines the mods that can exist in this bundle) is always downloaded automatically every time you launch the app, there may be times when you want to tweak the list, or change a mod that has been updated recently. (I will always try to keep the manifest up-to-date, but I'm human and sometimes fall behind.) In that case, you can download the manifest itself here:

https://github.com/jamis/KSP-RealSolarSystem-Bundler/blob/master/real-solar-system.manifest

That will be a YAML-formatted list of mods, and you can tweak that in any text editor. Then, from the bundler, you can choose the "File" menu and open your local manifest that way.

Alternate Manifest Files

The following are provided experimentally. I do not make any promises to keep them up-to-date, but I'll try. These are mostly made available to demonstrate how alternate manifests might work.

I'd love feedback, as well as pull requests to make the process simpler. Sadly, please do not ask for the generated bundle of mods itself, because I am not permitted to distribute it. It contains the work of many others, and I'm not allowed to share all of that without explicit permission.

Lastly, here is the list of (most of) the mods (optional and otherwise) referenced by my bundler, with links to their corresponding forum threads:

core mods

extra mods

interesting mods

part mods

support mods

utility mods

Contributing

If you're interested in helping out, the source code is hosted on GitHub:

https://github.com/jamis/KSP-RealSolarSystem-Bundler

Pull requests are gratefully received!

CHANGELOG


2014-02-25
* Fixed a file processing bug that caused some files and directories to be incorrectly ignored (like the Module Manager config files for RealChutes)

2014-02-13
* Include descriptions of and links to the referenced mods
* Only the "default" set of mods is displayed, by default, but you can change the filter via the dropdown above the list
* Added more robust config file manipulation to support mods like Kethane that need significant tweaking
* Window is slightly larger, to see the list better
* Added a grundle of optional mods, and updated a few existing ones

2014-02-11-2
* Fixed a bug that caused spaceport downloads to fail on 64-bit windows

2014-02-11
* The manifest file now uses a more robust method for downloading files, which will hopefully make things less fragile when a mod is updated.
* Mods are now organized by category
* You can now open a manifest file manually via the "File" menu, if you want to tweak the existing manifest (or make your own!)
* Added a few more (optional) mods to the manifest

2014-02-03
* A new graphical interface for choosing mods, and building your bundle! No more command-line (unless you want it)
* Updated the mods list to include recent updates to various dependencies

2014-01-30
* Windows support!
* Switched to JRuby, to allow the script to be more easily bundlable
* The mods.yml (dependency database) is now read directly from the git repository, allowing mod updates to be distributed without needing the script to be downloaded each time

Hey when ever I tried to install it, I keep getting the error "Unable to access jarfile jars/real-solar-system.jar". Any idea whats wrong?

Share this post


Link to post
Share on other sites

@heyimchandler, can you let me know:

  • What OS are you using?
  • What steps (exactly) are you taking to run the bundler?

Share this post


Link to post
Share on other sites

I'm on Mac, and currently I've tried right clicking and selecting open with Terminal, as well as opening terminal, typing sh , dropping the file in the box, and hitting enter.

Share this post


Link to post
Share on other sites

Does double-clicking the "real-solar-system.sh" file work? Or, from the terminal, typing "./real-solar-system.sh" (without quotes) and pressing enter?

Share this post


Link to post
Share on other sites

I'm getting the same issue. I downloaded it, unzipped the file, moved the folder to my desktop, right click > open with Terminal, and I get:

"Unable to access jarfile jars/real-solar-system.jar"

Am I doing something wrong?

Share this post


Link to post
Share on other sites

Alright, sounds like you need to do this from the Terminal. Once in the Terminal, make sure you change to the same directory as the real-solar-system.sh file. If you get "no such file or directory", it means you're not in the right directory. If you've got the folder on your Desktop, for instance, you'll want to change directory by doing something like this, at the Terminal: "cd ~/Desktop/real-solar-system-20140225" (without quotes) and then press enter. Then, type "./real-solar-system.sh" (whout quotes) to start the bundler.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this