Jump to content

[1.1.x] CoolRockets! Cryo and Launch Particle FX


Do you like it?  

162 members have voted

  1. 1. Do you like it?

    • No. It slows down my machine at launch. I need my CPU cycles elsewhere.
      16
    • No. I don't like the engine effects.
      9
    • No. I don't like the tank effects.
      108
    • Yes. I especially like the engine effects.
      122
    • Yes. I especially like the tank effects.
      103
    • Yes. It even runs smoothly.
      37
    • What is this all about?
      36
    • I'd like to use this in my mod.
      25
    • I'd like to contribute somehow.
      6


Recommended Posts

  • 2 weeks later...
Any word on compatibility for other mods? And how simple/difficult is it to add new ones?

just needs a MM cfg to add to other tanks, fairly simple aside from artistic talent

or copy/paste the effects from existing tanks of the same shape/size

Link to post
Share on other sites
I decided to add the effects to the launch clamps myself. Isn't very hard.

http://i.imgur.com/ccw2rS9.png

download here: https://www.dropbox.com/s/rczgthu31643a5i/stock_extended.cfg

place in GameData\Klockheed_Martian_CoolRockets\

edit: I've added FASA umbilical tower support:

http://i.imgur.com/qtkggy9.png

https://www.dropbox.com/s/krjv062d662m44i/stock_extended_v2.cfg

Was hoping someone (including this poster) still had these config files since the link 404's. I'm attempting to add them to the stock and ALL the FASA launch clamps. It will save me some time if I don't have to do it manually, however I can figure out the correct positioning for the smoke myself if no one else has a copy of these configs. Thank you :)

- - - Updated - - -

just needs a MM cfg to add to other tanks, fairly simple aside from artistic talent

or copy/paste the effects from existing tanks of the same shape/size

This; however if an engine is a different size than anything the current config set covers you may have the adjust the xyz values of the pre/post effects in the .cfg files of whatever engines you're planning on adding these to.

Link to post
Share on other sites
  • 3 weeks later...
  • 4 weeks later...
  • 2 weeks later...
  • 2 weeks later...

I once again had a look at configs but also if other mods using smokescreen (eg realplume) would interfere with or overwrite this one (yes, I like it that much!).

I can get everything working, including the debug tool, and even add the effect to other parts, such as the launch clamp. The tool tips in the parts list show "pre-launch effect by dtobi" and that it's using the KM_PreLaunchEffect_SmkS,  but it only works in the VAB.

The effect stops once the launch pad loads. The "toggle" buttons are still there for the engines and tanks, but appear to be non-functional. I fired up the KSP debug tool and the module appears to be loaded, and I did not see any error messages, but I have to qualify this with "as far as I can tell with my limited knowledge".

Because of these results it feels like I'm missing something simple, but I do realize that this feeling could be due to my lack of insight into coding.

I did a bunch of reading up on MM configs as well but now at this point it is very technical for me and I do not know enough about coding/programming language to go further.

 

Link to post
Share on other sites
  • 2 weeks later...
  • 3 months later...

Works great in 1.1 with the new smokescreen (although the debug mode is a bit wonky, I suspect this is known)

I made a couple of quick configs to get the boil off effect for the launch clamps as well as the FASA umbilical tower:

Quote

@PART[launchClamp1]
{
    
    MODULE
    {
        name = KM_PreLaunchEffect_SmkS
        effectName = PreLaunchEffectEngine1
        checkBottomNode = true
        
        model = CoolRockets/FX/cryo-1m/model
        position = 0.0, -1.0, 0.0
        scale = 1.0, 1.0, 1.0
        rotation = 0, 0, 0
        parent = thrustTransform
        debug = false

        width = 0.2
        height = 14
        xOffset = 0
        yOffset = 2.2
        zOffset = 0.5
        numP = 25    
        speedX = 0
        speedY = -0.2
        speedZ = 0
        size = 1.5
    }
}

and

 

Quote

@PART[FASAUmbilicalTower]
{
    
    MODULE
    {
        name = KM_PreLaunchEffect_SmkS
        effectName = PreLaunchEffectEngine1
        checkBottomNode = true
        
        model = CoolRockets/FX/cryo-1m/model
        position = 0.0, -1.0, 0.0
        scale = 1.0, 1.0, 1.0
        rotation = 0, 0, 0
        parent = thrustTransform
        debug = false

        width = 0.2
        height = 14
        xOffset = 0
        yOffset = 3.5
        zOffset = 4.5
        numP = 25    
        speedX = 0
        speedY = -0.2
        speedZ = 0
        size = 1.5
    }
}

 

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

How using SmokeScreen would be a workaround since I ask to install it in the instruction ? And if you have error and want them fixed you could do something like sharing a log with said errors ?

Link to post
Share on other sites
13 hours ago, Duski said:

is there any launch effects for the stock SSME? and if not, how do you add them?

One of the things I love about module manager is how easy it is to add or tweak things.

To add the SSME effect, first make a new txt file, and rename it to "SSME.cfg" or whatever you like, so long as the file extension is .cfg

Find an engine that has a coolrockets effect already, and is about the same size nozzle/bell. I chose the Skipper.

Now go into the coolrockets folder and open the stock.cfg file. You will find an entry that says @PART[engineLargeSkipper]

Everything below that up to the next engine is the coolrockets config for the skipper engine. Copy and paste those lines into your newly made SSME.cfg file

To have the effect work on the SSME and not the skipper, we need to change the @PART[engineLargeSkipper] in our new cfg file to the name of the engine, in this case it is SSME, so we change it to @PART[SSME]

Note that some engines have different file/game engine names than what they are called in game. For example, the Mainsail is called liquidEngine1-2

You should end up with something like this:

Quote

@PART[SSME]
{
    
    // Nozzle
    MODULE
    {
        name = KM_PreLaunchEffect_SmkS
        effectName = PreLaunchEffectEngine1
        checkBottomNode = true
        
        model = CoolRockets/FX/cryo-1m/model
        position = 0.0, 0.0, 0.0
        scale = 1.0, 1.0, 1.0
        rotation = 0, 0, 0
        parent = thrustTransform
        
        width = 0
        height = 16
        xOffset = 0
        yOffset = -0.5
        zOffset = 0
        numP = 30    
        speedX = 0
        speedY = -0.3
        speedZ = 0
        size = 1.5
    }
    
    // Exhaust
    MODULE
    {
        name = KM_PreLaunchEffect_SmkS
        effectName = PreLaunchEffectEngine2
        checkBottomNode = true
        
        width = 0
        height = 2
        xOffset = -0.5
        yOffset = -0.4
        zOffset = 0
        numP = 15
        speedX = -0.2
        speedY = -0.6
        speedZ = 0
        size = 0.4
    }
}

Now copy your SSME.cfg file into the coolrockets folder and fire up the game.

You will likely need to do some testing and some tweaking of the size, position, shape, direction, and speed of your effect. For the most part, the entries in the cfg file are self-explanatory as you can see.

There is a wiki that can help with the others. Engines with multiple nozzles/bells will have multiple module entries. Have a look at the stock ones to see how it works. 

Also note that everything is case sensitive.

Imo it's a very elegant system.

You can add the line debug = true after the checkBottomNode line if you want to mess with the values in the VAB. I am having trouble with this feature at the moment, but I do not fully understand how it works....yet :D

 

Edited by OneEyedBob
typos
Link to post
Share on other sites

Ok, thanks for your help :). I am trying developing a space shuttle which is fully dysfunctional and is perfectly safe. I just needed launch effects for my main engines as I like realistic things like this.

Link to post
Share on other sites
7 hours ago, speedwaystar said:

CoolRockets/Smokescreen effects are working fine on the launchpad, but in the VAB the "show in editor" buttons do nothing, and if debug=true, the editable values appear in the properties menu but the sliders don't work.

I noticed that too, but figured that it was obvious and therefore a known issue.

I have played around with it a bit, and it appears that if you go to the Launchpad and then revert the flight to the VAB it will show the adjusted values. I'm not entirely sure however as I have not mucked around with it in a number of weeks.

Link to post
Share on other sites
  • 3 weeks later...

Awesome mod.
Sadly, the particles do not show up in the editor in V1.1.2 when using the "Show" button, which makes tweaking new configs a bit tedious.

@sarbian Also, would it be possible to add a "spark" effect for a couple of seconds when an engine is activated via staging?
Like the sparkler system on real rockets that are there to burn excess oxidizer during the ignition sequence.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...