Jump to content

[1.1.x] CoolRockets! Cryo and Launch Particle FX


sarbian
 Share

Do you like it?  

167 members have voted

  1. 1. Do you like it?

    • No. It slows down my machine at launch. I need my CPU cycles elsewhere.
      16
    • No. I don't like the engine effects.
      9
    • No. I don't like the tank effects.
      108
    • Yes. I especially like the engine effects.
      123
    • Yes. I especially like the tank effects.
      104
    • Yes. It even runs smoothly.
      38
    • What is this all about?
      37
    • I'd like to use this in my mod.
      25
    • I'd like to contribute somehow.
      7


Recommended Posts

  • 9 months later...
23 hours ago, Mecripp said:

I would like to see what you come up with :)

Thanks @Mecripp, I had it mostly working, but now I added a HAS block to filter for engines with Cryo propellants and something broke. I'm not sure the proper way to require specific propellants within the moduleEngines node. Any ideas?

//Apply cryogenic engine effects to any engine that burns oxidizer or liquefied propellants
@PART[*]:HAS[!MODULE[KM_PreLaunchEffect_SmkS],@MODULE[ModuleEngines*]:HAS[@PROPELLANT[Oxidizer],@PROPELLANT[Lqd*]]]:NEEDS[SmokeScreen] 
{	
	MODULE
	{
		name = KM_PreLaunchEffect_SmkS
		effectName = PreLaunchEffectEngine1 // the name of the particle system in the .mu. You can have several systems with same or different names.
		checkBottomNode = true // deactivate if something is attached at the bottom node (for engines)
		debug = false // show or don't show the debug context menu in the VAB tweakables.
		
		model = CoolRockets/FX/cryo-1m/model
		position = 0.0, -1.0, 0.0
		scale = 1, 1, 1
		rotation = 0, 0, 0
		
		parent = #$../ModuleEngines*/thrustVectorTransformName$
		size = 2 //1.5 //sizeof the particles. It ranges from x/2 to x
		width = 0.2 // width of the particle syste
		height = 14 // height or lifetime of the particles
		xOffset = 0
		yOffset = 0
		zOffset = 0
		
		numP = 25	//number of active particles in the system
		speedX = 0.0 // direction of the particles
		speedY = -0.5 //-.2// direction of the particles
		speedZ = 0 // direction of the particles
		
		rndVelocity = 0.2  //0.1// random movement in all directions
        runningTime = 5 // stop x seconds after launch
    }    
}

 

Link to comment
Share on other sites

1 hour ago, Nightside said:

Thanks @Mecripp, I had it mostly working, but now I added a HAS block to filter for engines with Cryo propellants and something broke. I'm not sure the proper way to require specific propellants within the moduleEngines node. Any ideas?

//Apply cryogenic engine effects to any engine that burns oxidizer or liquefied propellants
@PART[*]:HAS[!MODULE[KM_PreLaunchEffect_SmkS],@MODULE[ModuleEngines*]:HAS[@PROPELLANT[Oxidizer],@PROPELLANT[Lqd*]]]:NEEDS[SmokeScreen] 
{	
	MODULE
	{
		name = KM_PreLaunchEffect_SmkS
		effectName = PreLaunchEffectEngine1 // the name of the particle system in the .mu. You can have several systems with same or different names.
		checkBottomNode = true // deactivate if something is attached at the bottom node (for engines)
		debug = false // show or don't show the debug context menu in the VAB tweakables.
		
		model = CoolRockets/FX/cryo-1m/model
		position = 0.0, -1.0, 0.0
		scale = 1, 1, 1
		rotation = 0, 0, 0
		
		parent = #$../ModuleEngines*/thrustVectorTransformName$
		size = 2 //1.5 //sizeof the particles. It ranges from x/2 to x
		width = 0.2 // width of the particle syste
		height = 14 // height or lifetime of the particles
		xOffset = 0
		yOffset = 0
		zOffset = 0
		
		numP = 25	//number of active particles in the system
		speedX = 0.0 // direction of the particles
		speedY = -0.5 //-.2// direction of the particles
		speedZ = 0 // direction of the particles
		
		rndVelocity = 0.2  //0.1// random movement in all directions
        runningTime = 5 // stop x seconds after launch
    }    
}

 

Would be easier to maybe check for ~PROPELLANT[ what ever ] or at lease shorter ?

EDIT- And THANKS :)

EDIT2 -  So lost now with MM does  (   !  ) mean the same there as (  ~  )  ?

Edited by Mecripp
Link to comment
Share on other sites

31 minutes ago, Mecripp said:

EDIT2 -  So lost now with MM does  (   !  ) mean the same there as (  ~  )  ?

hmm.. i always thought declarations of *checking* for/against presence of stuff, that ( ! ) means NOT .... *not* delete something vOv

But yeah... Ive never been clear on the difference between ! and ~ ... While MM generally has excellent documentation, I always thought that section was pretty cloudy :P

Edited by Stone Blue
Link to comment
Share on other sites

40 minutes ago, Stone Blue said:

hmm.. i always thought declarations of *checking* for/against presence of stuff, that ( ! ) means NOT .... *not* delete something vOv

That's what lost me has 

!foo = DELETE deletes foo completely.

and this was for ~ ( missing ) 

but at start @part[*]:HAS[ there are the same or flip flop ? 

Edited by Mecripp
Link to comment
Share on other sites

14 minutes ago, Mecripp said:

That's what lost me has 

!foo = DELETE deletes foo completely.

and this was for ~ ( missing ) 

but at start @part[*]:HAS[ there are the same or flip lop ? 

well, in this instance
 

@PART[*]:HAS[!MODULE[KM_PreLaunchEffect_SmkS]

I read that to mean if all parts HAS <NOT> <this MODULE> ... basically to check for parts that do NOT have that MODULE..... especially in this case, where if it was to delete it, its the same module its meant to *add*... vOv

Link to comment
Share on other sites

3 hours ago, Nightside said:

Thanks @Mecripp, I had it mostly working, but now I added a HAS block to filter for engines with Cryo propellants and something broke. I'm not sure the proper way to require specific propellants within the moduleEngines node. Any ideas?

It's choking on this line:

parent = #$../ModuleEngines*/thrustVectorTransformName$

It should be:

parent = #$../MODULE[ModuleEngines*]/thrustVectorTransformName$

 

Link to comment
Share on other sites

@Mecripp, @Stone Blue, @Jso Thanks for the help, I got it working!

//Apply cryogenic engine effects to any engine that burns oxidizer

@PART[*]:HAS[!MODULE[KM_PreLaunchEffect_SmkS],@MODULE[ModuleEngines*]:HAS[@PROPELLANT[Oxidizer]]]:NEEDS[SmokeScreen] 
{	
	MODULE
	{
		name = KM_PreLaunchEffect_SmkS
		effectName = PreLaunchEffectEngine1 // the name of the particle system in the .mu. You can have several systems with same or different names.
		checkBottomNode = true // deactivate if something is attached at the bottom node (for engines)
		debug = false // show or don't show the debug context menu in the VAB tweakables.
		
		model = CoolRockets/FX/cryo-1m/model
		position = 0.0, -1.0, 0.0
		scale = 1, 1, 1
		rotation = 0, 0, 0
		
		parent = #$../MODULE[ModuleEngines*]/thrustVectorTransformName$
		size = 1.5 //sizeof the particles. It ranges from x/2 to x
		width = 0.2 // width of the particle system
		height = 14 // height or lifetime of the particles
		xOffset = 0
		yOffset = 0
		zOffset = 0
		
		numP = 25	//number of active particles in the system
		speedX = 0.0 // direction of the particles
		speedY = -0.5 //-.2// direction of the particles
		speedZ = 0 // direction of the particles
		
		rndVelocity = 0.2  //0.1// random movement in all directions
        runningTime = 5 // stop x seconds after launch
    }    
}

 

Aside from messing up the variable, I think I was doing the :HAS[ This OR That] wrong, but this way works for stock(Oxidizer). I think I will just run it again looking for Lqd* for Real Fuels/CRP compatibility.

Edited by Nightside
Link to comment
Share on other sites

  • 1 year later...

Hi @Nightside i really loved your mod and have used it many times over the years but i was wondering if there will be a 1.9 update for this mod as it is starting to become incompatible with KSP, if not is there an alternative you know of that does the same thing? i really love this mod and what it does for the immersion of the game.

On 12/22/2018 at 11:15 PM, Nightside said:

@Mecripp, @Stone Blue, @Jso Thanks for the help, I got it working!

//Apply cryogenic engine effects to any engine that burns oxidizer

@PART[*]:HAS[!MODULE[KM_PreLaunchEffect_SmkS],@MODULE[ModuleEngines*]:HAS[@PROPELLANT[Oxidizer]]]:NEEDS[SmokeScreen] 
{	
	MODULE
	{
		name = KM_PreLaunchEffect_SmkS
		effectName = PreLaunchEffectEngine1 // the name of the particle system in the .mu. You can have several systems with same or different names.
		checkBottomNode = true // deactivate if something is attached at the bottom node (for engines)
		debug = false // show or don't show the debug context menu in the VAB tweakables.
		
		model = CoolRockets/FX/cryo-1m/model
		position = 0.0, -1.0, 0.0
		scale = 1, 1, 1
		rotation = 0, 0, 0
		
		parent = #$../MODULE[ModuleEngines*]/thrustVectorTransformName$
		size = 1.5 //sizeof the particles. It ranges from x/2 to x
		width = 0.2 // width of the particle system
		height = 14 // height or lifetime of the particles
		xOffset = 0
		yOffset = 0
		zOffset = 0
		
		numP = 25	//number of active particles in the system
		speedX = 0.0 // direction of the particles
		speedY = -0.5 //-.2// direction of the particles
		speedZ = 0 // direction of the particles
		
		rndVelocity = 0.2  //0.1// random movement in all directions
        runningTime = 5 // stop x seconds after launch
    }    
}

 

Aside from messing up the variable, I think I was doing the :HAS[ This OR That] wrong, but this way works for stock(Oxidizer). I think I will just run it again looking for Lqd* for Real Fuels/CRP compatibility.

 

 

 

 

Link to comment
Share on other sites

17 hours ago, bghyt said:

Hi @Nightside i really loved your mod and have used it many times over the years but i was wondering if there will be a 1.9 update for this mod as it is starting to become incompatible with KSP, if not is there an alternative you know of that does the same thing? i really love this mod and what it does for the immersion of the game.

Hi @bghyt, I too love this mod, but it is not mine, but belongs to the estimable @sarbian

I have not actually upgraded to 1.9.1 yet myself. I'm still on 1.8.1 so I cannot speak for the functionality of the mod. What issues are you seeing?

That said, Cool Rockets is simply an effects package for Smokescreen. If that mod is not working, it would be useful to describe your issues in that thread.

Edited by Nightside
Link to comment
Share on other sites

  • 2 months later...
  • 7 months later...

Sorry for posting in this thread i noticed the last post has been several months ago. I tried downloading this mod on CKan and it just royally messed my camera up when launching a rocket, im on the latest release so im assuming this definitely isn't working anymore?

Link to comment
Share on other sites

31 minutes ago, JSlone said:

Sorry for posting in this thread i noticed the last post has been several months ago. I tried downloading this mod on CKan and it just royally messed my camera up when launching a rocket, im on the latest release so im assuming this definitely isn't working anymore?

You should always read the last few pages of a mod, especially one that hasn't had a release in a long time.  Above, others reported issues that were difficult to work around.  Because of the shear amount of time that has passed since CoolRockets released, there is likely issues with it beyond those reported.

If you want @sarbian to try to address this issue (if he's still supporting this mod), you'll have to provide a few things:

  • Logs (see the first link in my signature).
  • A better description that describes exactly what went wrong with the camera; screenshots will help.
  • A minimum set of other mods (besides CoolRockets and its dependencies ModuleManager and SmokeScreen)
    and the steps that produces the bug.

Even current mods can have weird bug interactions, which is why it's important to remove other mods to simplify things.  CKAN is very helpful here.

Link to comment
Share on other sites

  • 2 weeks later...
On 2/2/2014 at 6:42 AM, blackheart612 said:

Niiiiice. Looking into it now

Edit:

Okay, so I downloaded it and put it in GameData. I didn't see anything?

Am I dumb or am I dumb? XD

I think you need to also download ColdRockets which is in the installation instructions. :happy:

Edited by Jebediah Nom
ins changed to in
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...