helldiver

[0.90] Kerbin Shuttle Orbiter System v4.13

Recommended Posts

I'm getting a crash while loading KSO/Spaces/ksotug/internal

Share this post


Link to post
Share on other sites
0.24 compatability

Seems to be strange at the moment. I had to remove my squad folder because it wouldn't load and get stuck on Squad/Spaces/PodCockpit/Model007

Despite the warnings, I was able to load and build a KSO just fine.

RPM that comes with KSO works fine

No problems with the KM_Gimbal

I'm not sure about hotrockets. Currently testing (I had it removed when I ran my .24 tests just now).

After installing ATM, crashing on the same load point. Definitely something is up.

Share this post


Link to post
Share on other sites

Seems the crashes are memory related, my log says "ran out of memory".

Seems like Squads MBM format was changed so ATM isn't able to compress them or something.

Also you may have some luck loading by running KSP as an administrator.

Share this post


Link to post
Share on other sites
Seems the crashes are memory related, my log says "ran out of memory".

Seems like Squads MBM format was changed so ATM isn't able to compress them or something.

Also you may have some luck loading by running KSP as an administrator.

That is interesting, because I'm using the 64-bit version.

*Update*

64-bit + Admin works.

Edited by enneract

Share this post


Link to post
Share on other sites
it's a bug with ATM, remove it and KSP loads normally

Neg. x64 + KSO, stock GameData crashes. Same with admin launch works.

Share this post


Link to post
Share on other sites

Quick, temporary fix for KSOS 0.24 compatability

-You must use Active Texture Management.

-You must run KSP_64.exe as an Administrator

-Look for Config.cfg found in your GameData\ActiveTextureManagement\ folder

--Add the lines:


@ACTIVE_TEXTURE_MANAGER_CONFIG:HAS[#folder[Squad]]
{
@enabled = false
}

This is a temporary fix until Rbray takes a look at what's going on with ATM. Basically these lines ignore Squads new texture format.

Regarding Firespitter

-Firespitter works fine so far on all of the tests I've run.

-The crashing error seems to be pointing to out of memory issues and not the KSOS proper or its plugins (with the exception of ATM which may be the root of the issue).

Additional Notes

-Texture Replacer Mod seems to be causing issues (including repeated error log spam). If you are running this mod you may need to remove/disable until they have an ATM/0.24 compatible version.

-Toolbar seems to throws up a warning, but I'm not sure if it's causing issues.

-KAS seems to throws up a warning and may be broken.

Mods I am running

ActiveTextureManagement (with the above quickfix)

BouderCo (part of ATM)

Chatterer

Environment Visual Effects

FASA

Firespitter **required by KSOS**

Raspter Prop Monitor (JSI) **required by KSOS** (this includes the folders MechJeb2RPM and SCANsatRPM)

Space Shuttle Engines Mod (Klockheed Martian) **required by KSOS**

KSO **required by KSOS**

NASAmission

Final Frontier Ribbon mod (Nereid)

Hotrockets (SmokeScreen) **required by KSOS**

Squad

Mods I had to remove

Toolbar

Crew Manifest

KAS

MechJeb2

Texture Replacer

Share this post


Link to post
Share on other sites
Quick, temporary fix for KSOS 0.24 compatability

-You must use Active Texture Management.

-You must run KSP_64.exe as an Administrator

-Look for Config.cfg found in your GameData\ActiveTextureManagement\ folder

--Add the lines:


@ACTIVE_TEXTURE_MANAGER_CONFIG:HAS[#folder[Squad]]
{
@enabled = false
}

This is a temporary fix until Rbray takes a look at what's going on with ATM. Basically these lines ignore Squads new texture format.

Regarding Firespitter

-Firespitter works fine so far on all of the tests I've run.

-The crashing error seems to be pointing to out of memory issues and not the KSOS proper or its plugins (with the exception of ATM which may be the root of the issue).

Additional Notes

-Texture Replacer Mod seems to be causing issues (including repeated error log spam). If you are running this mod you may need to remove/disable until they have an ATM/0.24 compatible version.

-Toolbar seems to throws up a warning, but I'm not sure if it's causing issues.

-KAS seems to throws up a warning and may be broken.

Mods I am running

ActiveTextureManagement (with the above quickfix)

BouderCo (part of ATM)

Chatterer

Environment Visual Effects

FASA

Firespitter **required by KSOS**

Raspter Prop Monitor (JSI) **required by KSOS** (this includes the folders MechJeb2RPM and SCANsatRPM)

Space Shuttle Engines Mod (Klockheed Martian) **required by KSOS**

KSO **required by KSOS**

NASAmission

Final Frontier Ribbon mod (Nereid)

Hotrockets (SmokeScreen) **required by KSOS**

Squad

Mods I had to remove

Toolbar

Crew Manifest

KAS

MechJeb2

Texture Replacer

MechJeb was updated to support .24 I thought... As was ship manifest and crew manifest.

Share this post


Link to post
Share on other sites
MechJeb was updated to support .24 I thought... As was ship manifest and crew manifest.

Got the latest version, dragged and dropped it in, and I keep crashing. Removed it and everything loads ok (aside from the Firespitter popup).

Share this post


Link to post
Share on other sites

For those that don't want to fudge with your Active Texture Management config, navigate to:

KSP Folder/GameData/BoulderCo/ActiveTextureManagementConfigs

and look for:

Squad.cfg

Open it in a txt editing program

Change the line enabled = true to enabled = false


ACTIVE_TEXTURE_MANAGER_CONFIG
{
folder = Squad
enabled =[COLOR="#FF0000"] true[/COLOR]
NORMAL_LIST
{
texture = Squad/Spaces/mk1CockpitInternal/model002
texture = Squad/Spaces/mk1CockpitInternal/model004
texture = Squad/Parts/FuelTank/RCSTank1-2/model001
texture = Squad/Parts/Aero/winglet2/model001
}
}

Change it to:


ACTIVE_TEXTURE_MANAGER_CONFIG
{
folder = Squad
enabled = [COLOR="#008000"]false[/COLOR]
NORMAL_LIST
{
texture = Squad/Spaces/mk1CockpitInternal/model002
texture = Squad/Spaces/mk1CockpitInternal/model004
texture = Squad/Parts/FuelTank/RCSTank1-2/model001
texture = Squad/Parts/Aero/winglet2/model001
}
}

Additional Issues

It seems Firespitter and 0.24 version of MechJeb2 aren't getting along. You may experience crashes when loading the default MechJeb2 command pod. If you are using KSOS and MechJeb2, odds are you will crash to desktop. Currently the only solution is for a Firespitter update.

Edited by helldiver

Share this post


Link to post
Share on other sites

So, I tried loading up last night, and it's a no go for me as well. I've got quite a few mods, so it's no surprise I'm out of the game.

Well, looks like a good time to take a vacation from KSP. I can finally get around to playing some of my impulse buys from the Steam sale. :)

Share this post


Link to post
Share on other sites

It appears to be working for me, but loading up the default block 7 craft file the engines have to be replaced to show up in staging

Share this post


Link to post
Share on other sites

Default craft was messed up for me but swapping out the engines worked just fine. Oh yea... all without Active Texture Management or the squad fix but WITH the firespitter temp dll. I've been having a crash with ATM installed so I've avoided it thusfar.

Edited by SaSquatch

Share this post


Link to post
Share on other sites

For those having firespitter issues

0.24 preliminary firespitter.dll

https://github.com/snjo/Firespitter/blob/master/For%20release/Firespitter/Plugins/Firespitter.dll?raw=true

Replace your old Firespitter.dll with this one.

I did not check if it fixes the crashes with MechJeb2. Will run more tests.

Notice: I'm aware that Active Texture Management is currently not fully functional in 0.24.

-Those of you running lots of mods will experience crashes when using KSOS. We are waiting for an update to ATM, Rbray is aware of the issue.

-The reason for the crashes is because you have no texture/resource memory manager running in the back ground.

Edited by helldiver

Share this post


Link to post
Share on other sites
For those having firespitter issues

0.24 preliminary firespitter.dll

https://github.com/snjo/Firespitter/blob/master/For%20release/Firespitter/Plugins/Firespitter.dll?raw=true

Replace your old Firespitter.dll with this one.

I did not check if it fixes the crashes with MechJeb2. Will run more tests.

Notice: I'm aware that Active Texture Management is currently not fully functional in 0.24.

-Those of you running lots of mods will experience crashes when using KSOS. We are waiting for an update to ATM, Rbray is aware of the issue.

-The reason for the crashes is because you have no texture/resource memory manager running in the back ground.

Just tried to launch the game with the new dll, no joy, it still CTD when I have mechjeb (latest version) installed. Here is the first part of the error log:

Unity Player [version: Unity 4.5.2f1_9abb1b59b47c]

Unknown caused an Access Violation (0xc0000005)
in module Unknown at 0033:03720000.

Error occurred at 2014-07-19_124902.
D:\Steam\SteamApps\common\Kerbal Space Program\KSP_x64.exe, run by RoBoC.
22% memory in use.

On a related note, I spotted that steam defaults to the 32bit application when you launch from the steam window. I had to manually create a shortcut to use the 64bit.

Hope this helps identify the issue, great mod.

RoBoC

Share this post


Link to post
Share on other sites
I wouldn't set it down at anything less than 100 m/s.

I get to about 160m/s and the most I can get out of it is about a 20-25 degree descent, even with the OMS fuel tank almost dry.

I thought I'd gotten that behavior under control, at least outside the VAB. But FAR really doesn't like this cargo bay.

Yeah. I thought automagical FAR-shielding was going to be the dogs danglies, but so far it's just made me abandon some of my favourite mods. I'm still getting shielding in the VAB/SPH fairly reliably but also getting the wings shielded in flight if I open/close the cargo bay. Problematic. I've tried tinkering with the FAR configs for the wings but I've done more damage than good so far.

edit: Changed the CoM offset to -3.5, increased the taper ratio and semi span slightly and found something that I can control a bit better. Haven't found a fix for the shielding of wings mid-flight. Currently experiencing cognitive dissonance; heart is telling me to cull FAR and have fun, brain is telling me that stock aero sucks.

Edited by Milkshakefiend

Share this post


Link to post
Share on other sites

MechJeb2 and Firespitter are now working for me...

I have no idea what I did. I'm using the latest version of MechJeb 2.3.0.0 and the 0.24 preliminary Firespitter plugin. Started it up to send Snjo a report and couldn't get the thing to crash KSP. No idea if something got updated.

Anyone else that can confirm?

Share this post


Link to post
Share on other sites
MechJeb2 and Firespitter are now working for me...

I have no idea what I did. I'm using the latest version of MechJeb 2.3.0.0 and the 0.24 preliminary Firespitter plugin. Started it up to send Snjo a report and couldn't get the thing to crash KSP. No idea if something got updated.

Anyone else that can confirm?

Ah the joys of computer programs... sometimes they crash... and then they suddenly start working with no explanation...

Share this post


Link to post
Share on other sites
Ah the joys of computer programs... sometimes they crash... and then they suddenly start working with no explanation...

Sometimes dangling the PC out the window by its ankles does the trick.

Share this post


Link to post
Share on other sites
Sometimes dangling the PC out the window by its ankles does the trick.

Ah yes, otherwise known as the Michael Jackson approach.

Share this post


Link to post
Share on other sites

3 days of trying to get this to load with 64bit I have finally come to an impass, if I install all the dependencies it will crash if I remove hot rockets and Klockhead martian plugin can get to the Vab and load and do everything your supposed to do. When i move it to the pad gameover it crashes this is in my main install with lots of other mods. I loaded it into a test scenario where its really the only mod with its dependencies I can get to the space centre enter the VAB crashes, I have updated the firespitter plugin updated mechjeb made sure the file structure is correct nowhere left to go, the one and only time i managed to get it to the pad I got this happening no throttle control no mechjeb nothing just a nice light show and havent been able to load it again.

ib05is8.png

I have included my x64 outout log if its any help

http://www./view/warncdmvwzansd0/output_log.txt

File structure

sQgJ1ww.png

Windows 8.1

I7 Cpu

32GB Ram

Samsung SSD

Asus GTX680-DC2T-2GD5

Edited by Virtualgenius

Share this post


Link to post
Share on other sites
Ah yes, otherwise known as the Michael Jackson approach.

I was thinking more along the lines of making it apologize.

3 days of trying to get this to load with 64bit I have finally come to an impass, if I install all the dependencies it will crash if I remove hot rockets and Klockhead martian plugin can get to the Vab and load and do everything your supposed to do. When i move it to the pad gameover it crashes this is in my main install with lots of other mods. I loaded it into a test scenario where its really the only mod with its dependencies I can get to the space centre enter the VAB crashes, I have updated the firespitter plugin updated mechjeb made sure the file structure is correct nowhere left to go, the one and only time i managed to get it to the pad I got this happening no throttle control no mechjeb nothing just a nice light show and havent been able to load it again.

http://i.imgur.com/ib05is8.png

I have included my x64 outout log if its any help

http://www./view/warncdmvwzansd0/output_log.txt

File structure

http://i.imgur.com/sQgJ1ww.png

Windows 8.1

I7 Cpu

32GB Ram

Samsung SSD

Asus GTX680-DC2T-2GD5

Yeah, I'm pretty much in the same boat as you. Looks like we're in a holding pattern until the plug-ins get updated.

EDIT:

So after updating the required plug-ins (atm, firespitter, rpm, klockheed_martian, mechjeb, scansat, smokescreen, and modulemanager) for 0.24 I have some functionality. I can only get the game to reliably boot up in 32 bit. With ATM 64 bit CTD in the middle of loading. Sometimes it boots up, but most often not. 32 bit, no problem. The original KSO craft file has duplicate entries in the context menu of the engines and oms and I get the same error as Virtualgenius. It falls (cockpit falls through shuttle on load) apart when I try my custom craft file as shown below. I launched it anyway. I haven't tried building it from scratch again yet.

For your amusement:

Javascript is disabled. View full album

The Super 25 craft seems to work no problem although there is log spam. I haven't checked out the rest of the parts yet.

Edited by qnistNAMEERF

Share this post


Link to post
Share on other sites

KSO should work perfectly fine with 0.24

-Standard KSO (Block 7) has its LRB's broken. I'll have Nazari look at it before I post the rebuilt Block 8.

-Using latest version of Firespitter for 0.24

-Latest version of MechJeb2

-Running 64bit.

-I will be posting my build tomorrow after I'm able to contact Nazari so we can look at the KSO Standard's boosters and why they're bugging out. Could be they are using old code, we may as well upgrade it to use the same code base the Super 25 is using (such as FSLift Surface for flaps).

-You cannot run KSOS if you're running a lot of mods! There is currently no texture management being run as Active Texture Management is not fully functional.

[edit]I just discovered I did not run KSP through Steam! It seams you can start KSP by making a shortcut directly to the KSP_64.exe and running as Administrator

Javascript is disabled. View full album

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.