helldiver

[0.90] Kerbin Shuttle Orbiter System v4.13

Recommended Posts

Could you get him to fix hot rockets as well there is an issue which i am sure he is aware off

Share this post


Link to post
Share on other sites
Could you get him to fix hot rockets as well there is an issue which i am sure he is aware off

What's the issue with Hot Rockets?

Share this post


Link to post
Share on other sites
KSO should work perfectly fine with 0.24

-Standard KSO (Block 7) has its LRB's broken. I'll have Nazari look at it before I post the rebuilt Block 8.

-Using latest version of Firespitter for 0.24

-Latest version of MechJeb2

-Running 64bit.

-I will be posting my build tomorrow after I'm able to contact Nazari so we can look at the KSO Standard's boosters and why they're bugging out. Could be they are using old code, we may as well upgrade it to use the same code base the Super 25 is using (such as FSLift Surface for flaps).

-You cannot run KSOS if you're running a lot of mods! There is currently no texture management being run as Active Texture Management is not fully functional.

[edit]I just discovered I did not run KSP through Steam! It seams you can start KSP by making a shortcut directly to the KSP_64.exe and running as Administrator

http://imgur.com/a/7w6nK

Aside from the lack of throttle control with the LRB's on the original KSO, I believe it's just the craft file has been corrupted by 0.24. I can launch the original KSO just fine if I rebuild it myself and if I don't want to throttle back the LRB's.

This is what it looks like for me in-game:

Javascript is disabled. View full album

The OMS context menu functions properly on the Super 25.

My current setup:

- KSP v0.24 32 bit (64 bit won't load with KSOS on my system - appears to be ATM mostly)

- KSOS v402a

- ATM v3.2 aggressive with both Squad.cfg and NasaMission.cfg set to false.

- Firespitter.dll updated from one in this thread for 0.24 (from crash log: firespitter.dll version: 7.0.5312.33148, compiled for KSP 0.24.0)

- RPM v0.18

- Klockheed_Martian Gimball.dll v1.4.3

- MechjebRPM.dll from SpaceplanesPlus v1.3 (SP+ not installed)

- SCANsat v6.1

- SmokeScreen v2.4.0.0

- ModuleManager 2.2.0

I would love to get 64 bit to work.

Edited by qnistNAMEERF

Share this post


Link to post
Share on other sites

Well when i managed to get 1 launch to the pad the engines where already running no throttle control no sound not anything, engines providing no thrust just going through the motions so to speak.

Also I have reduced my crash rate by forcing KSP to use opengl it might help others using 64 bit it is also lighter on memory but doesnt perform quite as well as dx9

Edited by Virtualgenius

Share this post


Link to post
Share on other sites
Well when i managed to get 1 launch to the pad the engines where already running no throttle control no nothing engines providing no thrust just going through the motions so to speak

Yeah, they do that for me too if I load the Block 7 craft and launch it. That's what I have loaded in that last imgur album. You can see the engines "running" in the last screenshot, but everything is duplicated in the context menu for all the engines (LRB, OMS, and Thrustmax 200). If I stage it, it just falls down.

If I take the KSO LRB and place the KSO mechjeb (or KSO flight computer) part on it I can launch, but there is no throttle control.

Edited by qnistNAMEERF

Share this post


Link to post
Share on other sites
I was thinking more along the lines of making it apologize.

Oh I know, but my computer is my baby, so I went with MJ. lol

Share this post


Link to post
Share on other sites

If I take the KSO LRB and place the KSO mechjeb (or KSO flight computer) part on it I can launch, but there is no throttle control.

The LRBs for the Standard KSO function as if they were SRBs. Once they start burning, they do not stop, and do not have throttle control. You can change that if you wish by going into the 'boosterkso.cfg' file and finding the line: 'throttleLocked = True' and changing it to 'False'. That will give you throttle control over the Standard KSO's boosters. Similarly if you want to lock throttle control on the EWBCL's boosters you can go into their config and find the same line and change it from 'False' to 'True'.

Share this post


Link to post
Share on other sites
The LRBs for the Standard KSO function as if they were SRBs. Once they start burning, they do not stop, and do not have throttle control. You can change that if you wish by going into the 'boosterkso.cfg' file and finding the line: 'throttleLocked = True' and changing it to 'False'. That will give you throttle control over the Standard KSO's boosters. Similarly if you want to lock throttle control on the EWBCL's boosters you can go into their config and find the same line and change it from 'False' to 'True'.

Uh, if that's true then the Super25 LRB does not do that for me. I have full control of the throttle on the Super25 LRB, but not the standard KSO LRB in KSP 0.24. I'm pretty sure I had throttle control on both in 0.23.5 but I've been known to make mistakes so when I get time I'll load up 0.23.5 and test it again.

EDIT: Whoops, never mind, I shouldn't read when I'm tired. They are functioning as you described for me.

Edited by qnistNAMEERF

Share this post


Link to post
Share on other sites
Uh, if that's true then the Super25 LRB does not do that for me. I have full control of the throttle on the Super25 LRB, but not the standard KSO LRB in KSP 0.24. I'm pretty sure I had throttle control on both in 0.23.5 but I've been known to make mistakes so when I get time I'll load up 0.23.5 and test it again.

EDIT: Whoops, never mind, I shouldn't read when I'm tired. They are functioning as you described for me.

Its all good.

But yes:

Standard KSO LRBs function as SRBs. Burn to empty once ignited and have no throttle control.

EWBCL LRBs function as LRBs. Have throttle control, and can be shut off.

The behaviour of both of these can be changed in their respective configs (boosterkso or super25boosterkso) but changing the 'throttlelocked' line.

Share this post


Link to post
Share on other sites
Its all good.

But yes:

Standard KSO LRBs function as SRBs. Burn to empty once ignited and have no throttle control.

EWBCL LRBs function as LRBs. Have throttle control, and can be shut off.

The behaviour of both of these can be changed in their respective configs (boosterkso or super25boosterkso) but changing the 'throttlelocked' line.

So the only thing messed up on KSOS for me is the block 7 craft file then. To be fair, all my KSOS shuttle craft files I had saved got messed up in the context menu in some manner or another. Only the block 4 Super25 craft file survived the update for me. The replacement craft files I've made in 0.24 are working properly, though.

Share this post


Link to post
Share on other sites



The 76th of my STS KSO Shuttle Missions! STS 176 is the sixth flight of Ascension the Super 25 Flagship! STS 176's objective is to deploy the Colony Habitat Module #1 on Asteroid Kerpophis. Due to corporate sponsorship, the Loyalists have changed their name to the Corporatists! No comment yet from the Rebels on this new, more profitable name.

STS 177 will deploy the Kerpophis Colony Utilities Module!

Most of the footage shown in 20x speed for quicker viewing.

Share this post


Link to post
Share on other sites
Does this mod work on ksp 0.24?

Version 3.10, 32bit only

http://www./download/x7vpd0btv4vvtbq/KSOS_v310.zip

-You may be able to run it in 64 bit. However, a few plugins conflict with it and you may have random crashes to desktop.

-You must install Active Texture Management first. Additionally you may need Texture Replacer as well, especially if you're running a lot of mods.

0.18 RPM

-I was not able to touch bases with Nazari today, but as soon as I'm able I'll see about bringing RPM up to version 0.18. version 3.10 is still using the previous version of RPM.

Share this post


Link to post
Share on other sites
Version 3.10, 32bit only

http://www./download/x7vpd0btv4vvtbq/KSOS_v310.zip

-You may be able to run it in 64 bit. However, a few plugins conflict with it and you may have random crashes to desktop.

-You must install Active Texture Management first. Additionally you may need Texture Replacer as well, especially if you're running a lot of mods.

0.18 RPM

-I was not able to touch bases with Nazari today, but as soon as I'm able I'll see about bringing RPM up to version 0.18. version 3.10 is still using the previous version of RPM.

I really wish 64-bit wasnt a pile of crud... its so unstable... like no better than the community hack that we got a couple weeks ago...

Share this post


Link to post
Share on other sites
Version 3.10, 32bit only

http://www./download/x7vpd0btv4vvtbq/KSOS_v310.zip

-You may be able to run it in 64 bit. However, a few plugins conflict with it and you may have random crashes to desktop.

-You must install Active Texture Management first. Additionally you may need Texture Replacer as well, especially if you're running a lot of mods.

0.18 RPM

-I was not able to touch bases with Nazari today, but as soon as I'm able I'll see about bringing RPM up to version 0.18. version 3.10 is still using the previous version of RPM.

So the extremely RAM-hungry mod doesn't work with the version of the game which gives us a usable amount of RAM? :(

What are some examples of plugins which 'conflict'?

I really wish 64-bit wasnt a pile of crud... its so unstable... like no better than the community hack that we got a couple weeks ago...

It... isn't a pile of crud? It... is basically the community 'hack' from a couple weeks ago. They just started building KSP against the 64-bit windows Unity Player, and did so fairly late in the development cycle. There are a small handful of bugs which haven't been ironed out, but KSP_x64 is very playable - far moreso than the 32-bit game if you use any more than a couple mods.

Share this post


Link to post
Share on other sites
So the extremely RAM-hungry mod doesn't work with the version of the game which gives us a usable amount of RAM? :(

What are some examples of plugins which 'conflict'?

It... isn't a pile of crud? It... is basically the community 'hack' from a couple weeks ago. They just started building KSP against the 64-bit windows Unity Player, and did so fairly late in the development cycle. There are a small handful of bugs which haven't been ironed out, but KSP_x64 is very playable - far moreso than the 32-bit game if you use any more than a couple mods.

You may wish to try reading my post again...

To be honest... many mods dont work on KSP x64... because KSP x64 is an absolute [word we don't say on our forum, even in scrambled form]

Edited by Vanamonde

Share this post


Link to post
Share on other sites
You may wish to try reading my post again...

To be honest... many mods dont work on KSP x64... because KSP x64 is an absolute fluffybunnies...

The only mod which has x64-specific bugs is KAS, which hasn't even been updated for .24.

Your groundless negativity is annoying.

Edited by Rich

Share this post


Link to post
Share on other sites
The only mod which has x64-specific bugs is KAS, which hasn't even been updated for .24.

Your groundless negativity is annoying.

Groundless? Im sorry... I cant even get to the menu in 64-bit. The menu! The one part of the game where I might even be able to start playing, and I cant even get there. No mods work in 64-bit beause the game doesnt work in 64-bit! I havent been able to get into the game since the day after .24 came out and I tested a hotfix for the KSO, it worked then, but now the game just insists on not loading. My negativity is far from groundless, and very much based on the fact that Squad have implemented something that was not better than a community hack into a release of the game, that as a result, I cant play. So, enneract, I'm sorry if my negativity is annoying to you... but you'll just have to live with it, wont you?

Share this post


Link to post
Share on other sites
Groundless? Im sorry... I cant even get to the menu in 64-bit. The menu! The one part of the game where I might even be able to start playing, and I cant even get there. No mods work in 64-bit beause the game doesnt work in 64-bit! I havent been able to get into the game since the day after .24 came out and I tested a hotfix for the KSO, it worked then, but now the game just insists on not loading. My negativity is far from groundless, and very much based on the fact that Squad have implemented something that was not better than a community hack into a release of the game, that as a result, I cant play. So, enneract, I'm sorry if my negativity is annoying to you... but you'll just have to live with it, wont you?

Sorry but the pure clear stock KSP x64 version works flawless.

Don't take the heavy modded 23.5 version and just update the KSP stuff.

Share this post


Link to post
Share on other sites

There's nothing interesting changed between 0.17 and 0.18 RPM that would prevent 0.18 RPM from working with KSO if it worked with 0.17. Any changes refer to third part mods RPM supported: MechJeb, if you use it, needs to be 2.3.0 or later, and SCANsatRPM.dll needs to be deleted, so that SCANsat 0.6.1 can do it's magic. No changes to KSO files should be required.

Incidentally, I only test RPM on x64, myself, so if anything breaks in x64, it's not me. :)

Share this post


Link to post
Share on other sites
Groundless? Im sorry... I cant even get to the menu in 64-bit. The menu! The one part of the game where I might even be able to start playing, and I cant even get there. No mods work in 64-bit beause the game doesnt work in 64-bit! I havent been able to get into the game since the day after .24 came out and I tested a hotfix for the KSO, it worked then, but now the game just insists on not loading. My negativity is far from groundless, and very much based on the fact that Squad have implemented something that was not better than a community hack into a release of the game, that as a result, I cant play. So, enneract, I'm sorry if my negativity is annoying to you... but you'll just have to live with it, wont you?

Uhm. Ok, there is a lot wrong with basically everything you just said.

1) using the 64-bit client is optional. Just run KSP.exe (or launch the game via steam if you have it on steam), and it will run the 32-bit version of the game. If that doesn't work for you, reinstall\reverify the game, because your problem has nothing to do with the 64-bit implementation.

2) If you cannot get the game loaded at all, with no mods installed, that is not the fault of any mod.

3) The community 'hack' is more or less how Unity works, bro. The flaws have to do with specific aspects of Squad code which doesn't take quirks of the 64-bit Unity engine into account, which will, frankly, take some time and iteration.

I'm reminded of a quote from a signature '"It's in Alpha" isn't an excuse, it's an objective assessment. It's not my fault that it continues to be relevant.'

Share this post


Link to post
Share on other sites
Sorry but the pure clear stock KSP x64 version works flawless.

Don't take the heavy modded 23.5 version and just update the KSP stuff.

This was a clean .24 install, with only mods updated for .24, or confirmed to work as is in .24 installed. The only thing copied over was my .23.5 save. (Which is backed up along with my entire .23.5 install because I forsaw .24 being bad.)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.