helldiver

[0.90] Kerbin Shuttle Orbiter System v4.13

Recommended Posts

Hi Helldiver, been reading a few ungrateful comments toward you with regards to this mod.

It's a small token but id like to apologies on behalf of anyone that's moaned (even though nothing to do with me), and say thank you for all your hard work on this great mod, im over in the UK and greatly appreciate your time and effort on this ! :)

Just thought id post something positive and true for once! :)

Share this post


Link to post
Share on other sites

For all those moaning lets see what you have offered up as a top quality mod nothing would be my guess. The 64 bit version of the game came with a bit of a caveat it was unstable the Devs new this the people who tested the hack new this but in the light of all the interest they decided to release an official version, so it doesnt work what about chipping in and providing logs and information as to why it didnt work and maybe we can get something done about it there is thread for it. I to would like to apologise for poor attitude displayed I think the KSO team have done a fantastic job, I have followed it from the very start and understand the trials and tribulations involved. KSO team take a bow for a very well presented product and look forward to the remaining phases to come well done.

A round of applause please for the KSO team

Share this post


Link to post
Share on other sites

can someone post screen ofnewly added block 8?

Share this post


Link to post
Share on other sites
Clean install as reference to 'not taking a heavily modded .23.5 install and updating the KSP bits' in the post I was responding to. Kindly read.

False.

When mod authors say they have recompiled their mods for .24 to ensure compatibility, I would expect that it would be 'kosher' as you put it. If a mod says [.24] in the title, with no other caveats, I EXPECT it to work for all .24 builds.

Additionally... save games are only suspect if the developer (in this case Squad), says the update will break save games. As it was, I saw no such warning about .24.

Well, as has been demonstrated, this is an unrealistic expectation.

Who said savegames are only suspect if they say they are?

In your experience, is alpha-software generally forgiving of heavy modification and alteration of code?

The *expectation* should be with every significant update, you will probably need a new save.

One mod author might test their mod and find it compatible, but do they test with your combination of mods? No.

Try with a clean-clean save and more than likely the game will start - then you can begin the process of re-adding mods a few at a time.

Its irrtating, but thats the reality, you cant say that that is not correct, because, well, look what happened.

Anyhoo, I hope you get it working, myself Im going to wait a few weeks for the mod scene to adjust to .24 before I get stuck into it proper.

Share this post


Link to post
Share on other sites

I installed this just before I realized that I needed to make my KSP lower res.. It's now Permanently broken my KSP..because I can't find the files I need to uninstall!

Share this post


Link to post
Share on other sites

Geezus. You guys want some cheeze with that whine?:P

Helldivers part only pack only uses plugins made by others so its not his fault your having troubles. In any case all the mod authors are doing this for free and ksp 64 bit is still buggy. Most crashes iwe had have been unity caused so nothing external assembly related even shows up on the log. It will take some time before all plugins work properly with it. So just butter yourselves with patience:cool:

Share this post


Link to post
Share on other sites

YUSH IT'S UPDATED! Only 6 more mods and then all my mods are up to date. Helldiver, Nazari, I already say this a lot, but thank you guys for all your hard work on the KSO.

Also the 32bit only limitation doesn't matter for me as I wasn't planning on going to 64bit anyway.

Share this post


Link to post
Share on other sites
I installed this just before I realized that I needed to make my KSP lower res.. It's now Permanently broken my KSP..because I can't find the files I need to uninstall!

If you just need to adjust your resolution, I believe you can do that by changing the height and width values in the settings.cfg file in the root of your KSP installation directory. Modify, save, then launch.

-These are the lines you'll want to look for in settings.cfg file:


SCREEN_RESOLUTION_WIDTH = 1280
SCREEN_RESOLUTION_HEIGHT = 800
FULLSCREEN = True

If you need to delete KSOS and all other mods to start over, just open up the GameData folder in your KSP installation directory and remove all folders except for Squad and NASAmission to revert to stock.

Edited by qnistNAMEERF

Share this post


Link to post
Share on other sites
One of the things that has helped me reduce crashing with the 64 bit build was to move it out of the x86 folder Sarbian made a comment that windows maybe restricting execution of something, so i moved my steam install to c:\games\Steam its slowed down a bit of the random crashing and allowed me to actually make it to the space centre
I installed this just before I realized that I needed to make my KSP lower res.. It's now Permanently broken my KSP..because I can't find the files I need to uninstall!

It's right where you left it, GameData/KSO/

Or at least that's where it was supposed to be installed.

Share this post


Link to post
Share on other sites

Okay, I've got something I've never seen before, and I can't send logs, 'cause the game isn't making any. I put in the newest KSO, with the newly updated ATM, start the game, and it runs the loading screen with the progress bar, when it fills up and should start the game, Ksp starts a second copy of itself, and starts loading again, then starts switching between games, like someone's alt-tabing between them. If you let it run long enough to fully load the second game, it starts loading a third, at which point my computer just turns off. Its not producing any logs, and if I remove KSO, it works just fine.

Share this post


Link to post
Share on other sites

I know it says on the first post that this mod is 32-bit only, but is that referring only to the 64-bit Windows KSP, or to the Linux 64-bit KSP binaries as well?

Share this post


Link to post
Share on other sites
I know it says on the first post that this mod is 32-bit only, but is that referring only to the 64-bit Windows KSP, or to the Linux 64-bit KSP binaries as well?

i am not sure because it works fine forr me on 64 bit windows and i also have KW rocketry installed...

Share this post


Link to post
Share on other sites
Okay, I've got something I've never seen before, and I can't send logs, 'cause the game isn't making any. I put in the newest KSO, with the newly updated ATM, start the game, and it runs the loading screen with the progress bar, when it fills up and should start the game, Ksp starts a second copy of itself, and starts loading again, then starts switching between games, like someone's alt-tabing between them. If you let it run long enough to fully load the second game, it starts loading a third, at which point my computer just turns off. Its not producing any logs, and if I remove KSO, it works just fine.
that can't be good but for some reason I would love to watch that XD. Though I would NOT be happy if that happed to me

Share this post


Link to post
Share on other sites

@Helldiver:

MODEL
{
model = AlewxMod/Parts/Structural/Station_Core_Hub/scc3
// parent = anotherModelTransform
position = 0.0, 0.0, 0.0
scale = 1.0, 1.0, 1.0
rotation = 0, 0, 0
texture = model000, Squad/Parts/Structural/stationHub/model000
texture = model001, Squad/Parts/Structural/stationHub/model001
}

Just as promised, here is a code snipped from a part.cfg that contains an extern model and two textures.

it works perfectly, at least in 23.5, wasn't in 0.24 today.

Share this post


Link to post
Share on other sites

Give Helldiver a break, people. His KSO mod is one of the most accomplished I've had the pleasure of flying. And he gives us it for free.

Seems more than a tad churlish to complain about 0.24 x64 bugs beyond his control that he's busy trying to remedy anyway

Thanks for your hard work, Helldiver.

Share this post


Link to post
Share on other sites
Ah, v3.10 includes already the phase 4 sounds (?). :)

I keep forgetting to delete it. But it should be harmless.

@Helldiver:

Just as promised, here is a code snipped from a part.cfg that contains an extern model and two textures.

it works perfectly, at least in 23.5, wasn't in 0.24 today.

Thank you for the suggestion. However, this isn't the issue we're having. Rather, it's being able to share resources between items such as IVAs and such. We're not having an issue right now really. It was my response in reference to why KSOS uses a lot of resources (i.e. RAM) :D

Give Helldiver a break, people. His KSO mod is one of the most accomplished I've had the pleasure of flying. And he gives us it for free.

Seems more than a tad churlish to complain about 0.24 x64 bugs beyond his control that he's busy trying to remedy anyway

Thanks for your hard work, Helldiver.

Oh trust me, I'm cool. Hope Enneract is cool also and didn't take any of this to heart.

Now with my awesome co-pilot, everything is just lovely :D

RgmfaOh.jpg

Thread: http://forum.kerbalspaceprogram.com/threads/87594-Kim-Kerman?p=1293971#post1293971

Share this post


Link to post
Share on other sites
Oh trust me, I'm cool. Hope Enneract is cool also and didn't take any of this to heart.

No worries. It is hard to express conversational irony in text, I think I can see how you misunderstood my post.

Share this post


Link to post
Share on other sites
I keep forgetting to delete it. But it should be harmless.

Thank you for the suggestion. However, this isn't the issue we're having. Rather, it's being able to share resources between items such as IVAs and such. We're not having an issue right now really. It was my response in reference to why KSOS uses a lot of resources (i.e. RAM) :D

I still dont understand that. Internals can make use of the same texture declarations as externals. What part exactly doesnt work?

Share this post


Link to post
Share on other sites
I still dont understand that. Internals can make use of the same texture declarations as externals. What part exactly doesnt work?

The texture gets loaded twice. Every time you declare a texture, an instance of it gets loaded into memory. The game does not attempt to re-use loaded assets.

At least, that is my understanding.

Share this post


Link to post
Share on other sites
that can't be good but for some reason I would love to watch that XD. Though I would NOT be happy if that happed to me

Its the most bizzare behavior I've ever seen out of Kerbal. I don't even know what in the world I've messed up to cause it. I know it has to be on my end, no one else has reported it, and its waaay to weirdly unique to be a bug.

Share this post


Link to post
Share on other sites
Thank you for the suggestion. However, this isn't the issue we're having. Rather, it's being able to share resources between items such as IVAs and such. We're not having an issue right now really. It was my response in reference to why KSOS uses a lot of resources (i.e. RAM) :D

Ok, sad that internals work different from parts, it would smooth things a lot.

Share this post


Link to post
Share on other sites
I keep forgetting to delete it. But it should be harmless.

I think so, just unassigned sounds. Sadly there is not more accidentally left inside. ;)

So, is Kim part of phase 4? :blush:

Share this post


Link to post
Share on other sites
Well, as has been demonstrated, this is an unrealistic expectation.

Who said savegames are only suspect if they say they are?

In your experience, is alpha-software generally forgiving of heavy modification and alteration of code?

The *expectation* should be with every significant update, you will probably need a new save.

One mod author might test their mod and find it compatible, but do they test with your combination of mods? No.

Try with a clean-clean save and more than likely the game will start - then you can begin the process of re-adding mods a few at a time.

Its irrtating, but thats the reality, you cant say that that is not correct, because, well, look what happened.

Anyhoo, I hope you get it working, myself Im going to wait a few weeks for the mod scene to adjust to .24 before I get stuck into it proper.

Who said save games are always suspect after every major update? Thats bonkers. Thats bad for players. Period.

The expectation in regards to save games should not be that major updates will probably require a new save, but that the developer will NEVER break a save in a major update. Breaking saves is bad programming. Unless you really really really need to, because youre fixing something thats so mindbogglingly broken that theres no way around it.

Thes are mods that have worked together in the past, most of which Ive been using since I started my .23.5 save... so I expect, that if mod authors say it works on .24, that it works, and works with other mods, particularly those it has worked with before.

But on top of this... the save isnt the issue... because the save isnt loaded until I click on it to load it in the menu. Which is the place I cant get to. I could remove my save from the game completely, and I'd still be stuck in the same position I am.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.