helldiver

[0.90] Kerbin Shuttle Orbiter System v4.13

Recommended Posts

I thank you for the help bud. I'm just not gonna use this mod for safe measure right now. Not until 64bit gets a little more stable.

Share this post


Link to post
Share on other sites

I was going to post that it is too nose heavy and it was dropping nose first into the ground, and was forcing me to use RCS, or engine power to fly level.

But looks like you found out what it was already. Also, I have had issues with the right and left landing gear clipping though the wing and Creating instability during landing and heavy braking. I do have a screen shot of the gear poking though the wing top, and will post it if needed. I feel that maybe the location of the landing gears node and the node that it connects to may need adjusted to maybe be centered top of the gear.

Share this post


Link to post
Share on other sites
3.11 Hot Fix

I stupidly changed the lift coefficient on the CSE's without realizing the effect.

Lift has been restored on the KSO Super 25.

Did it have anything to do with the stuff I mentioned?

Share this post


Link to post
Share on other sites

Attempted recovery of a capsule using a light utility helicopter, interesting, however this does raise the thought would it be possible to have a 'Kerbal King' (Sea King variant) medium utility helo?

Share this post


Link to post
Share on other sites

Those little helicopters, and everything else you've shown from phase 4, looks incredible. Can't wait!

Share this post


Link to post
Share on other sites
Did it have anything to do with the stuff I mentioned?

No, it was the lift values on the CSEs, not the rudders.

The bug in the rudders is a mystery. If you know how to fix it, feel free to let me know.

Share this post


Link to post
Share on other sites
V4.03 Alpha test Album, attempted recovery with heli:

Dude, what did you do to the firetruck? The wheels!

Share this post


Link to post
Share on other sites
Dude, what did you do to the firetruck? The wheels!

I'm not sure what happened there, after I parked the fire truck there I went back to the hangar to try a patrol car and when it loaded it was really lagging bad, so I reverted to the hangar and when to flights and when I came back to the firetruck the wheels were gone, I haven't had a chance to quit the game completely and reload, but I'll let you know if the wheels come back!

Share this post


Link to post
Share on other sites
I'm not sure what happened there, after I parked the fire truck there I went back to the hangar to try a patrol car and when it loaded it was really lagging bad, so I reverted to the hangar and when to flights and when I came back to the firetruck the wheels were gone, I haven't had a chance to quit the game completely and reload, but I'll let you know if the wheels come back!

That usually means you have outdated craft files. May want to delete them all and rebuild them.

I will double check.

Note to testers

Yeah, please rebuild the vehicles. They are still 0.23 and may have node attach errors.

Share this post


Link to post
Share on other sites
No, it was the lift values on the CSEs, not the rudders.

The bug in the rudders is a mystery. If you know how to fix it, feel free to let me know.

Sounds like a task for the weekend :)

Which 3d software did you use to create the mesh?

Share this post


Link to post
Share on other sites

Kerbostar testing

-This turned into 5 hours of back and forth with Snjo :D

-We discovered the transforms were off, so it required reprogramming of Firespitter.dll

-Yeah I'm playing without ATM. Although I am running TextureReplacer.

Share this post


Link to post
Share on other sites

@Helldover, sorry for blaming KSO rudders beeing the Problem with my Lifting. but as it turned you you were right and it is just displaying the direction wrong.

But I have a question quite similar. If I attach the rudders at the side like wings, what is the reason that no other lift is calculated into the gizmo? If you move these rudders attached to the plane it is like you have all the lift in the hand.

I already reduced dragCoeff and deflectionLiftCoeff but nothing changed this behaviour.

Share this post


Link to post
Share on other sites

For those interested I have started to stream KSP on twitch As of 6:30pm mountain I have I'm Live with 64bit KSP, ATM, And KSOS with a few smaller mods running also. If you wish to watch and all join me at http://www.twitch.tv/damaske I will note that this is my frist time streaming and may be quite as i build or say random stuff as i build.

Share this post


Link to post
Share on other sites

Um there seems to be a problem with KSO! I didn't get my test build! :D :D

I know I'm not getting one. :(

Share this post


Link to post
Share on other sites

have you talked with Snjo about the new helicopter rotor code in Firespitter 7.0?

In the video he posted recently, the new rotors will have rpm control, and colective control... :P

Share this post


Link to post
Share on other sites

WHY THE KRAKEN are there SEPARATE IMAGES for all the different phases when they all have the SAME DOWNLOAD LINK. Why can't I JUST download the station parts huh? Why can't you have a SEPARATE DOWNLOAD? I spent half an hour on my slow internet downloading it, trying to get just the station parts when I got the whole of KSOS.

Also, why do I have to have special effects for the engines? Why not just have regular engine effects and a separate patch for HotRockets? This whole mod is VERY frustrating. It makes it very inconsistent with stock parts, when all I wanted was what I clicked on the picture for. The STATION PARTS.

what's that? Uppercase letters are for starting sentences? Oh well!

Share this post


Link to post
Share on other sites
WHY THE KRAKEN are there SEPARATE IMAGES for all the different phases when they all have the SAME DOWNLOAD LINK. Why can't I JUST download the station parts huh? Why can't you have a SEPARATE DOWNLOAD? I spent half an hour on my slow internet downloading it, trying to get just the station parts when I got the whole of KSOS.

Also, why do I have to have special effects for the engines? Why not just have regular engine effects and a separate patch for HotRockets? This whole mod is VERY frustrating. It makes it very inconsistent with stock parts, when all I wanted was what I clicked on the picture for. The STATION PARTS.

what's that? Uppercase letters are for starting sentences? Oh well!

We are prepping for the release of Phase IV where all the phases will be separated into distinct downloads. Additionally, the custom effects for the rockets are the mod authors vision and make the shuttle look very good.

Share this post


Link to post
Share on other sites
We are prepping for the release of Phase IV where all the phases will be separated into distinct downloads. Additionally, the custom effects for the rockets are the mod authors vision and make the shuttle look very good.

Why not make it an option? or have it toggleable? I don't like having to use HotRockets and it's just more memory usage. Also, why is ActiveMemoryReduction required? If it's so large that it in itself needs A.M.R. installed maybe it needs to be optimized.

You release a wonderful piece of art, but make it unusable for the part-mod-only users who might not care about RPM, HotRockets, or Shuttles that can be built into only one ship in one configuration.

EDIT: Message to self: Forumers are people just like yourself, try not to convey an angry tone.

Share this post


Link to post
Share on other sites
We are prepping for the release of Phase IV where all the phases will be separated into distinct downloads. Additionally, the custom effects for the rockets are the mod authors vision and make the shuttle look very good.

Oh man.... can't wait for this!!!! I have KOS installed my 64x version. Everything loads fine, I haven't used it yet so....

Looking forward to the separate downloads but have to ask... will 64x be supported?

Share this post


Link to post
Share on other sites
Why not make it an option? or have it toggleable? I don't like having to use HotRockets and it's just more memory usage. Also, why is ActiveMemoryReduction required? If it's so large that it in itself needs A.M.R. installed maybe it needs to be optimized.

You release a wonderful piece of art, but make it unusable for the part-mod-only users who might not care about RPM, HotRockets, or Shuttles that can be built into only one ship in one configuration.

EDIT: Message to self: Forumers are people just like yourself, try not to convey an angry tone.

Im going to let helldiver speak to why ATM is required, how the textures are done and why, specifially, HotRockets is used for the effects.

However... this isnt just a parts pack. Its a complete shuttle system.

Oh man.... can't wait for this!!!! I have KOS installed my 64x version. Everything loads fine, I haven't used it yet so....

Looking forward to the separate downloads but have to ask... will 64x be supported?

I cant speak to support for x64, thats really up to helldiver. I can tell you that you can use KSO in x64 just fine, but x64 is unstable at best so diagnosing crashes is hard and may just cause issues with support KSO-based issues on that build. (Its a thing of we wouldnt know whether the crash was caused because of the KSO or just because of it being x64).

Edited by Avalon304

Share this post


Link to post
Share on other sites

Hey, does anyone else here use RealFuels? I use RealFuels. I wrote up a ModuleManager patch that makes the orbiter work with RealFuels:

https://www.dropbox.com/s/wshk7htvw8i3k8o/KSO_realfuels_v1.cfg

Main engines are set up for liquid hydrogen, side boosters for kerosene/LOX, OMS thrusters for MMH/N2O4. If you set up your staging to jettison the external tank at the same time as you activate the OMS thrusters, you'll switch over automatically, because the orbiter itself doesn't hold fuel for the main engines.

I tested both orbiters to orbit (with FAR), but this is just a rough first draft, so there might be some bugs, let me know if anything horrible happens.

Share this post


Link to post
Share on other sites
Why not make it an option? or have it toggleable? I don't like having to use HotRockets and it's just more memory usage. Also, why is ActiveMemoryReduction required? If it's so large that it in itself needs A.M.R. installed maybe it needs to be optimized.

You release a wonderful piece of art, but make it unusable for the part-mod-only users who might not care about RPM, HotRockets, or Shuttles that can be built into only one ship in one configuration.

EDIT: Message to self: Forumers are people just like yourself, try not to convey an angry tone.

yikes dude a little late for that edit haha.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.