helldiver

[0.90] Kerbin Shuttle Orbiter System v4.13

Recommended Posts

I don't know, i just clicked on the mod download part but there's written that the mod is uploaded at this date : 2015-02-14

P.S : You've perhaps saw that my english is not as good as an native english-man, and i'm sorry about that.

Share this post


Link to post
Share on other sites
Hm... the mod is in V_413

Well, thats the problem. v4.13 is for KSP.90 and no KSP v1.0.4.

You can try to use this version:

http://www./download/0cpv4e53q5mh1tp/KSO_v4.2_CompletePack.zip

It will work (it was intended for 1.0.2), but if you intend to leave renentry heating on, you may have an issue with the shuttle exploding on reentry... I dont know when we'll be updating it for 1.0.4.

Share this post


Link to post
Share on other sites

Yes, the shuttle keeps exploding on reentry. I really like these shuttles, I was just wondering if you guys would do this cockpit that will fit the Mk3 parts?

Share this post


Link to post
Share on other sites

HEY! Helldiver please listen to this, can you turn this mod to a NASA mod so you could have mini Mercury, Gemini, Apollo, Shuttle, Orion and also the X-37?

Share this post


Link to post
Share on other sites
HEY! Helldiver please listen to this, can you turn this mod to a NASA mod so you could have mini Mercury, Gemini, Apollo, Shuttle, Orion and also the X-37?

Thats a bit out of this mods scope.

Share this post


Link to post
Share on other sites
HEY! Helldiver please listen to this, can you turn this mod to a NASA mod so you could have mini Mercury, Gemini, Apollo, Shuttle, Orion and also the X-37?

You might want to take a look at Tantares (which has a lot of Russian parts, but also some Gemini), Tantares+/Bloeting Corp (which uses Tantares textures to add a Mercury capsule, and OMSK launchers (which has Redstone and Atlas LVs).

Share this post


Link to post
Share on other sites

Running into trouble with the landing gears on the KSO_25, they remain stuck in the deployed position and when I land the whole ship rips apart.

- - - Updated - - -

Ok NVM got it working now, had to update firespitter to ver 7.1.4

Share this post


Link to post
Share on other sites

So I'm having trouble with the... Phase IV vehicles, oddly enough. I was driving around with the Sedan, and with the engine fully throttled up (what exactly is the throttle supposed to do on it? It barely moves with it at 0%, yet still heats up), the car wants to overheat. Checking the debug menu, it got to something like 1500! Isn't there something I can put in the config to make it disperse heat easier?

EDIT: So I looked into it the part configs. The firetruck had a heatProduction value of 23. However... the sedan and everything else for some reason had a heatProduction of 211. I think that was a typo for 21, and got copy-pasted around. For comparison, the stock Ant has 25. So, considering that car engines aren't rockets, I'd say that 20-something is a good number.

I also lowered the sedan to 19, and bumped the bus to match the firetruck, at 23, while the lorry is at 21.

However... I still don't understand why they have engines, and don't just run on electricity. I mean... they do. Just not the sedan? Like, I dunno, it doesn't make sense. The sedan clearly drives faster only when it's throttled up, but the other vehicles just drive like a normal rover.

So... upon further inspection, what's happening is that when the sedan (or patrol) spawns, it just instantly has no electric charge. (The sedan starts with only 100 electric charge, when it has a maxAmount of 125, curiously.)

So it seems to be a bug with the sedan's electric charge. I looked through the configs, but I have no idea how to fix it. But... please look into making some of those changes I mentioned, please. I'm just trying to help!

EDIT 2: I think I've figured it out. The bug might be caused by the fact that the alternator is on the same part as the electric charge. Every vehicle besides the sedan has its electric charge stored in the chassis. Like with a stock rocket engine that holds a charge (for its alternator), at launch the engine has 0 electric charge. I'm not sure how to impliment a change on this for the sedan, but I'm almost certain this is the problem.

Edited by Z3R0_0NL1N3

Share this post


Link to post
Share on other sites

I feel foolish for asking this (yet again) but I know that KSOS in the very first posting of the thread is for KSP 0.90. I’ve downloaded the link that Avalon304 (On Page 637 on this Tread) as he stated it for KSP 1.0.2 & should work for 1.0.4 but with needed mods updated for 1.0.4, however I’m sure which mods that I need since I can’t find the list of them.

I’m mainly after the Glowing Glo Lights at this time.

Thanks,

Share this post


Link to post
Share on other sites

I may be asking too much, but is there a way to get the 4.2 (or newer) version of pack 2 only ? (the station parts)

Thank you !

Share this post


Link to post
Share on other sites

Ok so i'm not a modder but I understand a little bit of the cfg code (enough to break things probably lol), and was looking at the cfg for one of the wings:

mass = 0.47

thermalMassModifier = 5 // the dang things are light, so 3200 kJ/tonne-K

heatConductivity = 0.05 // half default

emissiveConstant = 0.95

dragModelType = none

maximum_drag = 0.02

minimum_drag = 0.02

angularDrag = 2

crashTolerance = 15

maxTemp = 4500 // = 3400

explosionPotential = 0.1

fuelCrossFeed = True

bulkheadProfiles = srf

i see max temp and such, would playing with these numbers enable one to find the sweet spot so the kso shuttles could survive re-entry? I don't know exactly what each modifier does nor where to find out, but I'm more than willing if I could get a little guidance on where to start I'd love to help update cfgs to get kso working w/ 1.4 as, aside from the heat issues, everything else seems to work fine. I love this mod its awesome, as its the shuttle system but kerbalized, i was use the css shuttle but its to lifelike so doesn't "fit" the game quite right.

Edited by ironhawx

Share this post


Link to post
Share on other sites
0802Q8R.jpgWhelp with some tweaking of cfgs, managed to get the KSOS working in 1.04, its a bit tough as you have to keep it with in a certain a.o.a. during rentry or she'll burn up quick, but she works and I don't mind the challenge of having to thread the needle. Check out pics from latest mission using the KSOS http://imgur.com/a/2p9aa#0 Edited by ironhawx

Share this post


Link to post
Share on other sites

That is a beautiful screenshot! Makes me want to pull up my old .25 save and finish up KSOS. :) Glad you got the shuttle working in 1.0.4.

Share this post


Link to post
Share on other sites
Ok so i'm not a modder but I understand a little bit of the cfg code (enough to break things probably lol), and was looking at the cfg for one of the wings:

mass = 0.47

thermalMassModifier = 5 // the dang things are light, so 3200 kJ/tonne-K

heatConductivity = 0.05 // half default

emissiveConstant = 0.95

dragModelType = none

maximum_drag = 0.02

minimum_drag = 0.02

angularDrag = 2

crashTolerance = 15

maxTemp = 4500 // = 3400

explosionPotential = 0.1

fuelCrossFeed = True

bulkheadProfiles = srf

i see max temp and such, would playing with these numbers enable one to find the sweet spot so the kso shuttles could survive re-entry? I don't know exactly what each modifier does nor where to find out, but I'm more than willing if I could get a little guidance on where to start I'd love to help update cfgs to get kso working w/ 1.4 as, aside from the heat issues, everything else seems to work fine. I love this mod its awesome, as its the shuttle system but kerbalized, i was use the css shuttle but its to lifelike so doesn't "fit" the game quite right.

Don't know why it would have

thermalMassModifier = 5 // the dang things are light, so 3200 kJ/tonne-K
heatConductivity = 0.05 // half default

Has thought that would add heat so looks like someone try to boost the

maxTemp = 4500 // = 3400

thats to funny.

Share this post


Link to post
Share on other sites
That is a beautiful screenshot! Makes me want to pull up my old .25 save and finish up KSOS. :) Glad you got the shuttle working in 1.0.4.

Ty Sir, its all thanks to all the modders out there and their hard work that I was able to capture it. Mod still needs some work as re-entry heat effects don't show up when in iva view, the ofd (the globe thing) doesn't work in iva just black screen. So its got some tweaking needing to be added/updated which is beyond my skill, but for now I've got it working for the most part and can't be happier.

Thinking I will probably look into messing w/ cfgs further to allow for the switch of tanks to hold hydrogen and such to possibly be able to make long distance/explorer shuttles with addon engine mods and extra planetary launchpad(think thats the mod name) as obviously they wouldn't make it to orbit.

@MeCripp thats orginal code for the cfg, I changed it along w/ most all the other cfgs that are shuttle related to maxtemp 2900// = 3400 and seems to work I don't know what the other modifiers do so left them alone. It all works but you can't really vear off a 5 or -5 aoa for to long before the parts start to heat up quickly and blow, so one has to really thread the needle when de-orbting and shooting for the ksc. (once you get through re-entry shes free to fly).

Edited by ironhawx

Share this post


Link to post
Share on other sites
You think you can post a link of the files on Dropbox?

If author of mod give me the ok sure, i'll msg helldiver and see if he says its ok, I don't want to redistribute someone else's work w/o permission.

Edited: I've msg'd helldiver awaiting response if if he gives me the go ahead I'll post link here. Be advised this was a rough pass, it works but is a bit finicky you have to be on the ball or it will still burn up.

Edited by ironhawx

Share this post


Link to post
Share on other sites
Well, thats the problem. v4.13 is for KSP.90 and no KSP v1.0.4.

You can try to use this version:

http://www./download/0cpv4e53q5mh1tp/KSO_v4.2_CompletePack.zip

It will work (it was intended for 1.0.2), but if you intend to leave renentry heating on, you may have an issue with the shuttle exploding on reentry... I dont know when we'll be updating it for 1.0.4.

Sorry its been a while guys. Thanks for making v1.0.2-1.0.4 compatible KSO. I've downloaded this new pack yesterday, updated Firespitter, and installed the new 1.0.4 compatible Deadly Reentry (DRE) mod and I've had pretty flawless flying so far. My first flight on the Mini-KSO it looked like something in the nosecone exploded but no signs of damage. This happened to me in beta a few times as well. One noticeable difference I can tell however (and this maybe because now I'm no longer using FAR) the shuttle only glides so far, I haven't been able to drop it from high altitude and angle it to get lift, but that makes sense, the actual space shuttle flies like a brick too, it's not meant to do that stuff. I noticed this though because I calculated my reentry in the Super25 using the Mini-KSO numbers and overshot the runway far.

The reason I'm posting this is because, In search of tutorials and tips for flying these badboys, I've noticed alot of discussion over shuttles being lost on reentry and I felt compelled to share my experiences. In BETA all the way to .90 I used many mods, however the KSO mod was so large, I cut back my use on most of them. FAR, DRE, KSO I considered to be essential and are the mods I will be focusing on. I have not used a patch a modified .cfg or anything, just the stock mods.

In BETA; FAR, DRE, KSO Installed - Lost on reentry 75% of the time, realized my angle was too steep, learned to coast it until the plasma burns away as I come into the atmosphere just before the mountain range west of KSC. After that I had no problems.

In 1.0.4 (Missed 1.0.2); DRE, KSO Installed - No problems yet, on either shuttle. (Other than that occasional nosecone explosion on the Mini-KSO)(Also, the nosecone did NOT have KSO Avionics mounted inside so not sure what happened.)

So I'm not sure if you have any mods that may affect physics in game other than what I was using but I've had smooth sailing once I figured it out. :D

Edited by RandyRawgust

Share this post


Link to post
Share on other sites

Will the Limited Edition EWBCL Livery ever be converted to DDS? I still hold onto my old copies of KSOS for the Limited Edition Livery, and was wondering if it'll ever be covnerted to DDS or if I'll be stuck with a TGA version.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.