helldiver

[0.90] Kerbin Shuttle Orbiter System v4.13

Recommended Posts

So, I'm just coming back to KSP after being away for a couple months. Is the latest with KSO that it's functional in 1.0.4 but that there are stability issues on reentry? Is that the general consensus or am I misreading the boards. If that is the case, is anyone close to a fix?

Share this post


Link to post
Share on other sites
So, I'm just coming back to KSP after being away for a couple months. Is the latest with KSO that it's functional in 1.0.4 but that there are stability issues on reentry? Is that the general consensus or am I misreading the boards. If that is the case, is anyone close to a fix?

That is the long and short of it, yes. If you have the version that works in 1.0.2 it will work in 1.0.4, but it may burn up on reentry or generally not be as stable as it was in earlier versions.

Share this post


Link to post
Share on other sites

I've had good results with the handling, though. Much improved over using the 0.90 version in 1.0.4. Only issue is the aforementioned squirrelyness with roll, but I find that's only at lower atmospheric pressure and higher speeds. Once you're below about 250 m/s and 30 000 km it handles fine.

The "skipping" in higher atmosphere is a bit of an issue though, but not insurmountable. I've had good results with setting my re-entry point to be slightly behind the KSC mountains from a 75x75 km-ish orbit. The "skip" carries you over the mountain and leaves you with most of your speed bled off on approach to KSC. S-turns from there. Granted, this is only with the Super 25... The payloads I've been hauling preclude use of the standard KSO. :D

Share this post


Link to post
Share on other sites
I've had good results with the handling, though. Much improved over using the 0.90 version in 1.0.4. Only issue is the aforementioned squirrelyness with roll, but I find that's only at lower atmospheric pressure and higher speeds. Once you're below about 250 m/s and 30 000 km it handles fine.

The "skipping" in higher atmosphere is a bit of an issue though, but not insurmountable. I've had good results with setting my re-entry point to be slightly behind the KSC mountains from a 75x75 km-ish orbit. The "skip" carries you over the mountain and leaves you with most of your speed bled off on approach to KSC. S-turns from there. Granted, this is only with the Super 25... The payloads I've been hauling preclude use of the standard KSO. :D

The 0.90 version shouldnt have even flown without some serious modification... 1.0 broke the crap out of the aero handling. I have a video from back when Naz and I were getting the 1.0.2 hotfix version ready of the regular KSO... and man... it was crazy... maybe I'll post it one day....

As for the regular KSO... it never was the pinnacle of flight handling in the first place... I remember back when helldiver was working on Phase 3 he mentioned wanting to go back and revisit it and revise it to make use of some of the concepts he had used in the Super 25... I dunno what came of that though.

Share this post


Link to post
Share on other sites

I just noticed this on IVA... For some reason this seems to be happening on both the KSO and Super 25... I suspected a Firespitter error but I've reinstalled FS and the KSO multiple times, and it hasn't fixed it. (EDIT: Meant RPM, not FS. FS is fine.) :confused:

Any idea what's causing it that I can fix?

k9f4XRW.jpg

UPDATE: I've been testing with previous RPM versions. The bundled one with the 4.20 KSO solves the PFD and ADI issues, but not the SIP_6.3 stuff. Weird.

UPDATE 2: After much experimenting with previous RPM versions, I've learned this. RPM versions prior to V 4.13 do that "random texture thing" and don't work. The RPM version bundled with 4.13 doesn't do that, but doesn't do much of anything either.

Edited by Luna-Industries
fixed link and more stuff. Updated. Updated.

Share this post


Link to post
Share on other sites

I hate to beat a Dead Horse to death; however the “Mini Shuttle†is one of my very favorite Mods. To me KSP isn’t the same without it! I download the “KSO_v4.2_CompletePack†version which I think was updated for 1.0.2.

Would someone please be kind enough to tell me what mods I need to update to fly it in 1.0.4?

Thanks,

Share this post


Link to post
Share on other sites

Turk, everything should work nominally from that pack in 1.0.4. You can update the various other plugins to their newest versions. (Firespitter, RPM, etc.) :)

Speaking of update, the latest version of Raster Prop Monitor FINALLY decided to work with my KSO. Except the {SIP_6.3} stuff, which is oddly persistent across multiple instances of RPM. Since RPM displays speeds just fine in other capsules, and indeed even other windows of the KSO MFD, I assume something is borked with my KSO install as opposed to RPM. Only problem is I still have no idea what... :confused:

UPDATE AGAIN:

Turns out CKAN was installing RPM 20 as opposed to 22... Yay. Latest version of RPM is still hella borked with the KSO it would seem. :(

AGAIN WITH THE INTERMINABLE UPDATES:

Okay I fixed the {SIP_6.3 stuff}... misplaced $ sign in infoTakeoff.cfg... At this point I'm probably just rambling to nobody, but if anybody else has the same problem, in that .txt, $&SURFSPEED $ORBTSPEED should be $&$SURFSPEED ORBTSPEED.

Edited by Luna-Industries
Updated

Share this post


Link to post
Share on other sites

With all these patches and forum user fixes I'm starting to wonder if the KSO system is on it's way to the grave, I hope not!

Share this post


Link to post
Share on other sites
With all these patches and forum user fixes I'm starting to wonder if the KSO system is on it's way to the grave, I hope not!

When I see people commenting on a mod that is dead or dying I often recall the words of the great master Yoda......

"Death is a natural part of life. Rejoice for those around you who transform into the Force. Mourn them do not. Miss them do not. Attachment leads to jealously. The shadow of greed, that is."

Share this post


Link to post
Share on other sites
With all these patches and forum user fixes I'm starting to wonder if the KSO system is on it's way to the grave, I hope not!

There is plenty of precedent in the Kerbal modding community of mods being maintained by user patches and end up being further developed by the original creators at a later date. B9 come to mind or AIES.

Share this post


Link to post
Share on other sites

I definitely doubt the KSO is going to die. Just that Helldiver seems to be otherwise occupied with something that's probably going to be awesome.

Plus, this is probably all a delaying tactic anyway. I expect most everything will break with Unity 5 in 1.1, and everything will again have to be rejiggered. Oh well... :) Such is life.

Share this post


Link to post
Share on other sites
With all these patches and forum user fixes I'm starting to wonder if the KSO system is on it's way to the grave, I hope not!

When I last spoke with Helldiver a couple of months ago, I brought up my own similar fears and he said he wanted to get his new project to a good self sustaining point before returning to the KSOS. The time will come when that project is in a good position and he can return to making/updating things here.

To be honest, with Unity 5 coming, this is probably the best thing that could happen anyway, as there really is no telling what it will break (the answer is: it will probably break all the things), so dont worry, the KSOS will return, its just in a holding pattern for the time being.

Share this post


Link to post
Share on other sites

So my odyssey of RPM not working continues... I've figured out why it doesn't work, though. RPM changed significantly at v 0.20.0, and I don't think the KSO configuration followed suit. Should be a simple fix. Only problem is the KSO has a lot of .cfgs for RPM that I find redundant... Not gonna mess with that. Might be a while, but if I get a fix for these .cfgs I'll post them here for anyone else having the same issues.

UPDATE ON THAT:

I've got the KSO mostly working with RPM... Mostly. Some things have been added to RPM that the KSO never had to support, so I'm setting those up from scratch. Only the ADI left to go, everything else seems to be working fine.

Edited by Luna-Industries
Update

Share this post


Link to post
Share on other sites
When I last spoke with Helldiver a couple of months ago, I brought up my own similar fears and he said he wanted to get his new project to a good self sustaining point before returning to the KSOS. The time will come when that project is in a good position and he can return to making/updating things here.

To be honest, with Unity 5 coming, this is probably the best thing that could happen anyway, as there really is no telling what it will break (the answer is: it will probably break all the things), so dont worry, the KSOS will return, its just in a holding pattern for the time being.

Yea, that's a good point, with switch to U5 that probably would be best to wait on.

Share this post


Link to post
Share on other sites
When I last spoke with Helldiver a couple of months ago, I brought up my own similar fears and he said he wanted to get his new project to a good self sustaining point before returning to the KSOS. The time will come when that project is in a good position and he can return to making/updating things here.

To be honest, with Unity 5 coming, this is probably the best thing that could happen anyway, as there really is no telling what it will break (the answer is: it will probably break all the things), so dont worry, the KSOS will return, its just in a holding pattern for the time being.

What is helldiver working on? (just curious, I know it's not a KSP thing)

Share this post


Link to post
Share on other sites
What is helldiver working on? (just curious, I know it's not a KSP thing)

That isnt for me to say, as its not my project. When hes ready to disclose what it is, he will.

Share this post


Link to post
Share on other sites

Alright alright alright! I've mostly got the KSO functional with RPM v0.22.2. Most everything is up to the new RPM config specifications and functional. Just a few more bugs to squash, then I need to do a pass and make sure everything behaves like it did before. Shouldn't be too long, I expect to be fully finished sometime tomorrow...

Share this post


Link to post
Share on other sites

The problem with KSOS is in memory. You can't pretty much have any other parts mods installed besides it. Hope it would get better with Unity 5.

Oh, and anther thing keeping me back is the FAR compatibility. I can't play without FAR, so used to proper drag and lift behaving like I learned it should in the university.

UPD: Would be awesome to have that camera pod set up as BDarmory targeting pod. It can still have the functionality of RPM camera at the same time, it would just require one additional transform.

Edited by sashan

Share this post


Link to post
Share on other sites

Is pack 4 functional? As far as I remember it only uses default RPM props...

EDIT: Anyone got Kerbostar to work?

Edited by sashan

Share this post


Link to post
Share on other sites

I cannot get the External Fuel Tank to attach to the orbiter no matter what! Can Somebody please Help?

I see the green attachment node on both the tank and the shuttle, but they wont attach!

Share this post


Link to post
Share on other sites
I cannot get the External Fuel Tank to attach to the orbiter no matter what! Can Somebody please Help?

I see the green attachment node on both the tank and the shuttle, but they wont attach!

Start reading past pages until you see the update that Avalon put up.

Share this post


Link to post
Share on other sites
I cannot get the External Fuel Tank to attach to the orbiter no matter what! Can Somebody please Help?

I see the green attachment node on both the tank and the shuttle, but they wont attach!

I assume you are talking about the Standard KSO. Hit Alt+F12 and check the 'Non Strict Part Checking' option in the cheats menu. (The option may be named slightly differently, but it similar to what I wrote.)

Share this post


Link to post
Share on other sites

Has the memory issue been fixed? If I remember right, the basic KSO systems are working, but it eats so much memory you can hardly have any other mods in a simple install.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.