Sign in to follow this  
codepoet

[0.90] [Up for adoption] Connected Living Space v1.1.2.0 (27th Feb 2015) Hatches and Highlighting

Recommended Posts

It worked for me, I have not fully tested functionality however

Share this post


Link to post
Share on other sites

Thanks for checking and reporting - my gaming rig is still in boxes, and I am in no position to start fixing up mods in a hurry ATM!

Share this post


Link to post
Share on other sites

I have one strange phenomenon in 0.24 that I'm still not able to track down to a specific mod, but I suspect it might be CLS: I use it together with Kerbal Crew Transfer and the contextual menu for each docking port shows three entries for "open/close hatch" instead of one. Minor issue, but it makes the menus pretty long.

Other than that just want to mention how much I appreciate your work on CLS - that mod helps so much with game immersion. Great work!

Share this post


Link to post
Share on other sites
I have one strange phenomenon in 0.24 that I'm still not able to track down to a specific mod, but I suspect it might be CLS: I use it together with Kerbal Crew Transfer and the contextual menu for each docking port shows three entries for "open/close hatch" instead of one. Minor issue, but it makes the menus pretty long.

Other than that just want to mention how much I appreciate your work on CLS - that mod helps so much with game immersion. Great work!

Are you using an upgraded save file or a new one? If you are able to, it would be helpful to know if the problem happens for you on either / both of these.

Share this post


Link to post
Share on other sites
Are you using an upgraded save file or a new one? If you are able to, it would be helpful to know if the problem happens for you on either / both of these.

Wow - great guess! I didn't notice when I wrote the original message, but you are right, I see the triple-"open/close hatch" options only for craft that I built in .23.5 - I upgraded that save file to .24 and ships (or even components of ships) built in .24 don't have this issue.

I have a Mun transporter that was built in .23.5 and the internal docking ports have triple-hatch-options, but the attached Mun lander built in .24 has docking ports that have only the expected single open/close hatch option.

EDIT: I also just now upgraded to the latest .24-compiled Kerbal Crew Transfer and that does not change this situation, so I guess this is really CLS-related.

Edited by munseeker

Share this post


Link to post
Share on other sites
Wow - great guess! I didn't notice when I wrote the original message, but you are right, I see the triple-"open/close hatch" options only for craft that I built in .23.5 - I upgraded that save file to .24 and ships (or even components of ships) built in .24 don't have this issue.

I have a Mun transporter that was built in .23.5 and the internal docking ports have triple-hatch-options, but the attached Mun lander built in .24 has docking ports that have only the expected single open/close hatch option.

EDIT: I also just now upgraded to the latest .24-compiled Kerbal Crew Transfer and that does not change this situation, so I guess this is really CLS-related.

Thanks for checking.

If you have a game with the triple hatch open problem - what happens if you same that game and then reload it? Does the problem persist? If it does I would be grateful if you could send me a copy of the save file so I can take a look. I will send you my email address in a PM.

Share this post


Link to post
Share on other sites

I have just got Connected Living Space and applied it to some of my old saves. The game did not seem to recognise that the pods where connected http://imgur.com/a/8w4CX. Is there any way to update my old saves so that they will work Connected Living Space?

Share this post


Link to post
Share on other sites
I have just got Connected Living Space and applied it to some of my old saves. The game did not seem to recognise that the pods where connected http://imgur.com/a/8w4CX. Is there any way to update my old saves so that they will work Connected Living Space?

Are you sure that you have got module manager installed? From what you posted it looks as if none of the CLS configuration has been read in.

Share this post


Link to post
Share on other sites

Excellent. Very happy to find you are keeping this mod current, I certainly want to keep using it :).

Share this post


Link to post
Share on other sites

I do not want it to die, but I do not have the time to do exciting new stuff with it. I am hoping the it is becoming sufficiently established and supported by other mods, that it is the other mods that can do exciting new stuff with it.

Share this post


Link to post
Share on other sites

Great news! Love this mod, great to increase game immersion if you are building large crafts and stations. Thanks for your work!

Share this post


Link to post
Share on other sites

For some reason, I'm having no luck with Ship Manifest moving Kerbals between modules - all the tunnel space is correct, hatches are open. Configs are correct, I've even added a few to try them out. Same in Career or Sandbox. If I turn off CLS in Ship Manifest, I can move them around. Any ideas?

Share this post


Link to post
Share on other sites

codepoet, you may remove the SDHI config from your next release of CLS, as SDHI SMS V2.0+ now natively supports it :)

Share this post


Link to post
Share on other sites
codepoet, you may remove the SDHI config from your next release of CLS, as SDHI SMS V2.0+ now natively supports it :)

Thanks for letting me know

Share this post


Link to post
Share on other sites

I have an issue were CLS brought up the debug console and it wont go away even after I restart the game. It isnt showing any failures on boot it just wont go away, and the CLS button which is now on the native toolbar does not give me any options to modify CLS its just a blank screen... I would like to move it back to the other toolbar and stuff and turn off the debug window but cant. Any ideas?

Share this post


Link to post
Share on other sites

Sorry about this. I am not quite sure what you mean when you say that "CLS brought up the debug console". Could you provide step by step instructions for reproducing the problem, and I will take a look at it?

Thanks

Share this post


Link to post
Share on other sites

Sorry I take it back... Ignore my stupid statements I apparently cannot read it was a ship manifest debug window, that was talking about CLS I checked it a few times trying to figure it out but I guess I can't see the obvious in front of me HAHAHA ... thanks for the quick response and sorry again! :)

Share this post


Link to post
Share on other sites

Would you kindly add CLS configs for the Near Future parts, mainly the construction parts? That would be awesome, or you could show me a sample on how to add a module for the parts, and I'll deal with it myself!

Share this post


Link to post
Share on other sites

There are example configs that ship with CLS. There is also a HOWTO document that describes what the config options do. If you get Near Future parts working with CLS do let me (or the mod author) have a copy of the .cfg and it can be shipped with a future release.

Share this post


Link to post
Share on other sites

Hey there, I didnt see it in the README, but how do I close the debug menu? Even after a new download and restart, it opens the debug menu on load.

Share this post


Link to post
Share on other sites

There is no debug menu provided by CLS. I think you might be referring to a Ship Manifest feature. Try asking on the ShipManifest thread.

Share this post


Link to post
Share on other sites

Hey here's a cfg for Near Future command pods and the service container:



@PART[inlineCmdPod]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true

}
}

@PART[mk3-9pod]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}

@PART[utilityCabin]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}

I saw on the last page someone asked for the cfg for the construction parts? I wasn't sure what was meant by that as they don't look passable to me but hopefully this helps anyway.

Share this post


Link to post
Share on other sites
Hey here's a cfg for Near Future command pods and the service container:



@PART[inlineCmdPod]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true

}
}

@PART[mk3-9pod]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}

@PART[utilityCabin]:HAS[!MODULE[ModuleConnectedLivingSpace]]
{
MODULE
{
name = ModuleConnectedLivingSpace
passable = true
}
}

I saw on the last page someone asked for the cfg for the construction parts? I wasn't sure what was meant by that as they don't look passable to me but hopefully this helps anyway.

Thanks for this I have asked the author of the near future mod if they are willing to ship it with their mod. If they are not then I will bundle it into the next release of CLS.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this