timmers_uk

[1.3.0] Ambient Light Adjustment 2.6.3.8 [09/06/2017] continued)

Recommended Posts

KSP 1.1 build id = 01183
Ambient Light Adjustment v2.5.6.3
Log clean noo more NPE from your mod!!!
mm detect correct AmbientLightAdjustment v2.5.6.3 aka this time you was not forget to update code :)
Single bad msg what came is "[WRN 20:40:08.130] File 'D:/Games/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/AmbientLightAdjustment/settings.dat' does not exist" but i seen similar msg done by other to & i undestend is nothing to worry soo now all is working fine
Cheer mate & glad you nail the problem
P.S. small thing on http://spacedock.info/mod/184/Ambient%20Light%20Adjustment > change log section it say "Version 2.5.6.4 when it was supose to be 2.5.6.3 for Kerbal Space Program 1.1" what my be it can create confusion :)

Share this post


Link to post
Share on other sites
27 minutes ago, Blacks said:


Single bad msg what came is "[WRN 20:40:08.130] File 'D:/Games/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/AmbientLightAdjustment/settings.dat' does not exist" but i seen similar msg done by 
P.S. small thing on http://spacedock.info/mod/184/Ambient%20Light%20Adjustment > change log section it say "Version 2.5.6.4 when it was supose to be 2.5.6.3 for Kerbal Space Program 1.1" what my be it can create confusion :)

Settings.dat is just that there's no saved settings - I'm guessing you deleted the ambientlightadjustment folder before dropping in the update?

On spacedock ... GAH! It'll just have to stay there for now

Share this post


Link to post
Share on other sites

yes always when i test something what it get updated i will delete old folder to be a clean version but how i say is fine :)

Share this post


Link to post
Share on other sites
On 5.4.2016 at 2:44 PM, timmers_uk said:

Ok I'm not waiting on Blizzy's toolbar for 1.1 ...

New release on first page - build for 1.1 Prerelease, supports Stock Applauncher (toolbar), but *in theory* will switch to using Blizzy's toolbar when that is available for 1.1 assuming the interface stays the same (untested).

Default slider position is top left because I can't see a nice way to get the applauncher position (unlike Blizzy's toolbar, which handles this nicely), but I've added support for dragging the slider elsewhere on the screen.

 

Edit to add : Note - right now the stock mode doesn't support middle/right click on Applauncher to reset/switch to setting2 - I'd be interested to know if people would be ok with buttons next to the slider for doing these things (reset to default + setting1/2 toggle) - I'm kindof inclined that way as it makes operation a bit more obvious.

 

.... I'm also not ignoring requests for per-scene settings, but want to get this working for 1.1 first.

Thanks for updating it several times. Though I am bit worried that it isn't on CKAN anymore neither this nor the older versions.

Share this post


Link to post
Share on other sites
1 hour ago, Bizz Keryear said:

Thanks for updating it several times. Though I am bit worried that it isn't on CKAN anymore neither this nor the older versions.

That's odd, according to spacedock, its on CKAN, and the metadata is in the netkan repo (https://github.com/KSP-CKAN/NetKAN/blob/master/NetKAN/AmbientLightAdjustment.netkan) ... but its out of date.

Not sure if this is something to take up with the spacedock people or the CKAN people.

update : sounds like the spacedock bot for updating CKAN was broken - should be fixed on next release - will probably do a delete + re-release of current version on spacedock to tickle the bot.

Edited by timmers_uk

Share this post


Link to post
Share on other sites
On 7.4.2016 at 0:23 PM, timmers_uk said:

That's odd, according to spacedock, its on CKAN, and the metadata is in the netkan repo (https://github.com/KSP-CKAN/NetKAN/blob/master/NetKAN/AmbientLightAdjustment.netkan) ... but its out of date.

Not sure if this is something to take up with the spacedock people or the CKAN people.

update : sounds like the spacedock bot for updating CKAN was broken - should be fixed on next release - will probably do a delete + re-release of current version on spacedock to tickle the bot.

Good to hear. This was a sad sight. 

Spoiler

J8HAhr8.png

Share this post


Link to post
Share on other sites

What is the link I should be using for ambient light to work in the 1.1 update?

Thanks! :)

Share this post


Link to post
Share on other sites

You can download either from github or spacedock - links on first post.

Not that there would have been a problem using the last release, but I've pushed 2.5.6.4 which is rebuilt against the 1.1 KSP release.

Hopefully this will also cause the appropriate spacedock->CKAN voodoo to be triggered so it notices ambientlight for 1.1 exists.

 

(I also cleaned up the spacedock release - the last release claimed to be 2.5.6.4 even though it wasn't really).

Share this post


Link to post
Share on other sites

Just posting to let you know about an issue with Ambient Light Adjustment, CKAN says it has an update available but it can`t be downloaded.

Failed to download "https://spacedock.info/mod/184/Ambient Light Adjustment/download/2.5.6.4a" - error: The remote server returned an error: (404) Not Found.

Looking at spacedock the update is not there (2.5.6.4a) only the previous version (2.5.6.4)

It seems the CKAN voodoo got confused...

Share this post


Link to post
Share on other sites

Wouod there be any conflicts running this with a wide assortment of graphic overhaul mods and extra planets?

Share this post


Link to post
Share on other sites

So has Blizzy's Toolbar been updated? Last I saw it had not, and this mod requires it - or used to, last time I used it. The first post hasn't been updated to state otherwise.

EDIT: Aha, I see that it has! Great. :)

Edited by LameLefty

Share this post


Link to post
Share on other sites

I love your mod. I do hope you get time to updated it to 1.1.2 or at least the time to see if it will break in 1.1.2.  Thanks for your contribution to the community, it is very much appreciated. :)

Share this post


Link to post
Share on other sites
4 minutes ago, mcirish3 said:

I love your mod. I do hope you get time to updated it to 1.1.2 or at least the time to see if it will break in 1.1.2.  Thanks for your contribution to the community, it is very much appreciated. :)

You could also check it yourself. If you did, you'd find (like I did) that it works just fine in 1.1.2.

Share this post


Link to post
Share on other sites
On ‎2016‎-‎04‎-‎23 at 5:54 AM, timmers_uk said:

You can download either from github or spacedock - links on first post.

Not that there would have been a problem using the last release, but I've pushed 2.5.6.4 which is rebuilt against the 1.1 KSP release.

Hopefully this will also cause the appropriate spacedock->CKAN voodoo to be triggered so it notices ambientlight for 1.1 exists.

 

(I also cleaned up the spacedock release - the last release claimed to be 2.5.6.4 even though it wasn't really).

I see the brief chatter above my comment here mentioning that this seems to work on v1.1.2.  Can you, the mod author, confirm that this is the case?

Share this post


Link to post
Share on other sites
On 05/05/2016 at 7:07 AM, MisterFister said:

I see the brief chatter above my comment here mentioning that this seems to work on v1.1.2.  Can you, the mod author, confirm that this is the case?

Sadly I can't right now as I don't have the mojo to fire up 1.1.2 (yay I caught a cold during the first good weather of the year!).

 

On 08/05/2016 at 11:15 AM, MisterFister said:

Hmm.  What is the difference between this Ambient Light Adjustment (the mod this thread is dedicated to) and this other mod called Minimum Ambient Lighting

Not sure haven't used it, but I'd guess the other mod overrides the ambient light level if it is below a threshold value, rather than straight overriding it all the time.

Share this post


Link to post
Share on other sites
2 hours ago, timmers_uk said:

Sadly I can't right now as I don't have the mojo to fire up 1.1.2 (yay I caught a cold during the first good weather of the year!).

That sucks, man.  Hope you feel better soon.

2 hours ago, timmers_uk said:

Not sure haven't used it, but I'd guess the other mod overrides the ambient light level if it is below a threshold value, rather than straight overriding it all the time.

Ok.  I'm perfectly willing to experiment with them side-by-side on my own, of course, but as a preliminary item, are you aware of any technical reason not to attempt to run them side by side?  (Other than overlapping effect?)

Share this post


Link to post
Share on other sites

Bummer you're under the weather, @timmers_uk.  Get well soon!

1 hour ago, MisterFister said:

I'm perfectly willing to experiment with them side-by-side on my own, of course, but as a preliminary item, are you aware of any technical reason not to attempt to run them side by side?  (Other than overlapping effect?)

Both mods are trying to affect the same thing, ambient lighting, probably through the same mechanism, but neither one was coded expecting the other to be fiddling things too.

Testing them together will give you an idea if they play nice together.  But I'd likely just install whichever one worked best for me in the current context (I can easily switch mods).  I use Ambient Light Adjustment, but I can see the appeal of a mod that you can set to a threshold that will automatically lighten dark scenes just enough.

Share this post


Link to post
Share on other sites
4 hours ago, timmers_uk said:

Sadly I can't right now as I don't have the mojo to fire up 1.1.2 (yay I caught a cold during the first good weather of the year!).

 

Not sure haven't used it, but I'd guess the other mod overrides the ambient light level if it is below a threshold value, rather than straight overriding it all the time.

Drink heavily.  Beer and or Scotch.  May not help the cold, but you won't care.

Also, tons of bacon.  BLT's, bacon ice cream and deep fried bacon.

This will help, as the blood clogs up, the bad bugs will get stuck to it and die.

Then you will feel better,

Maybe,

But you wont care. Drunk and full of bacon, the only way to fly, program, etc.

Cheers.  Get feeling better soon.

Share this post


Link to post
Share on other sites
On May 5, 2016 at 1:07 AM, MisterFister said:

I see the brief chatter above my comment here mentioning that this seems to work on v1.1.2.  Can you, the mod author, confirm that this is the case?

It works. When you first load KSP, you get a warning from the AVC plugin that you're not using version KSP version 1.1 (you're not, you're using 1.1.2) but in the game, the mod works fine.

Edited by LameLefty

Share this post


Link to post
Share on other sites

I am seeing a problem in 1.1.2.  ALA appears to just increase the gamma of my ship and not the planet/background.  that is I can crank it up until my ship is totally blown out and the background stays pitch black???

I'll try and grab screen shot next time I am in game.

 

I am running EVE, scatterer, planet shine.  I know planet shine and ALA can conflict so I am going to pull planet shine and see if it changes things and visa versa to try and isolate the problem to one or the other.

Edited by ctbram

Share this post


Link to post
Share on other sites
15 hours ago, ctbram said:

I am seeing a problem in 1.1.2.  ALA appears to just increase the gamma of my ship and not the planet/background.  that is I can crank it up until my ship is totally blown out and the background stays pitch black???

I'll try and grab screen shot next time I am in game.

 

I am running EVE, scatterer, planet shine.  I know planet shine and ALA can conflict so I am going to pull planet shine and see if it changes things and visa versa to try and isolate the problem to one or the other.

Its been a while (and I'm still not back up and running), but I don't think Planetshine and ambient light adj. play nice.

Share this post


Link to post
Share on other sites

I think there might be a problem again with ambient light and ckan. 

Quote

Failed to download "https://spacedock.info/mod/184/Ambient Light Adjustment/download/2.6.7.4" - error: Remote server has responded with Error: (404) Not found.

Edit: error essage was translated by me into english

Edited by Bizz Keryear

Share this post


Link to post
Share on other sites
9 hours ago, Bizz Keryear said:

I think there might be a problem again with ambient light and ckan. 

Edit: error essage was translated by me into english

Gah! Its because I pushed up a duff 2.6.7.4 to spacedock then realised my error and removed it ... I'll see if I can find a CKAN someone on IRC and ask them to poke the current version back down to 2.5.6.4 (or whatever the correct number is - at work right now so shouldn't be going looking).

9 hours ago, Bizz Keryear said:

I think there might be a problem again with ambient light and ckan. 

Edit: error essage was translated by me into english

Gah! Its because I pushed up a duff 2.6.7.4 to spacedock then realised my error and removed it ... I'll see if I can find a CKAN someone on IRC and ask them to poke the current version back down to 2.5.6.4 (or whatever the correct number is - at work right now so shouldn't be going looking).

 

 

edit to add : spoke to Captain_B + plague_006 on IRC ... should be fixed shortly.

Edited by timmers_uk

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.