sarbian

[1.7.x] SmokeScreen 2.8.5 - Extended FX plugin (July 25th 2019)

Recommended Posts

Thank you for the lightning fast response!

The density curve not working is indeed due to my own stupidity. The addition of that flag would be awesome, the effect i have for ignition is way over the top and looks weird when used while the throttle is down.

Allright so the stock sparks are off limits. How should i go about copying that with smokescreen? The "Stretch" render mode doesn't work it seems (particles are generated and appear in the counter in the UI, but are invisible), and i have no clue what shader, if any, i could use to make particles "trail" like that

Share this post


Link to post
Share on other sites

Version: SmokeScreen-2.6.2.0.zip here it came log from game only open with out open any save, or any new game

[LOG 14:16:00.956] Load(Assembly): SmokeScreen/SmokeScreen

[LOG 14:16:00.956] AssemblyLoader: Loading assembly at D:\Games\Kerbal Space Program\GameData\SmokeScreen\SmokeScreen.dll

[LOG 14:16:01.970] AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

[LOG 14:16:41.576] Load(Texture): SmokeScreen/SmokeScreen

SmokeScreen v2.6.2.0

[LOG 14:17:44.912] [ModuleManager] :BEFORE[sMOKESCREEN] pass

[LOG 14:17:44.924] [ModuleManager] :FOR[sMOKESCREEN] pass

[LOG 14:17:44.937] [ModuleManager] :AFTER[sMOKESCREEN] pass

[LOG 14:18:56.296] [smokeScreen PersistentEmitterManager] : OnDestroy

[LOG 14:18:57.280] AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

[LOG 14:18:58.661] [smokeScreen PersistentEmitterManager] : OnSceneChange

[LOG 14:18:59.333] [smokeScreen PersistentEmitterManager] : OnDestroy

[LOG 14:19:01.647] AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

[LOG 14:19:20.361] [smokeScreen PersistentEmitterManager] : OnDestroy

Load(Assembly): SmokeScreen/SmokeScreen

AssemblyLoader: Loading assembly at D:\Games\Kerbal Space Program\GameData\SmokeScreen\SmokeScreen.dll

Non platform assembly: D:\Games\Kerbal Space Program\GameData\SmokeScreen\SmokeScreen.dll (this message is harmless)

AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

Load(Texture): SmokeScreen/SmokeScreen

SmokeScreen v2.6.2.0

[ModuleManager] :BEFORE[sMOKESCREEN] pass

[ModuleManager] :FOR[sMOKESCREEN] pass

[ModuleManager] :AFTER[sMOKESCREEN] pass

[smokeScreen PersistentEmitterManager] : OnDestroy

AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

[smokeScreen PersistentEmitterManager] : OnSceneChange

[smokeScreen PersistentEmitterManager] : OnDestroy

AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

[smokeScreen PersistentEmitterManager] : OnDestroy

Edited by Blacks

Share this post


Link to post
Share on other sites

And ? Do you have a bug ?

Share this post


Link to post
Share on other sites

well i have nothing special to complain only i see this from time to time in debug panel, i don't know if is normal or not, at this point i doo a lot parsing log data to identifie other problem, i seen is a new release, i install i pull data from log & i post it

AddonLoader: Instantiating addon 'PersistentEmitterManager' from assembly 'SmokeScreen'

[smokeScreen PersistentEmitterManager] : OnDestroy

how i say i not know if is normal or not but when i see OnDestroy it capture my atention, if is normal i will ignore

Share this post


Link to post
Share on other sites

It is normal. I should remove some of those since they are not needed anymore.

Share this post


Link to post
Share on other sites

Looks like there's a couple of problems with last release of KOSMOS URM engines, see here (I believe "upstream" wildcard .cfg may need to be patched, hehe)

Share this post


Link to post
Share on other sites

Hello!

My SmokeScreen implementation has stopped working. The number of particles shows as 0 even though I set it at 8,000. I have uninstalled and erased KSP 1.0.2 and plugins completely and installed again with only SmokeScreen and Toolbar, with no luck. The menu shows the "Open ModelMultiParticlePersistFX UI: list as empty" as opposed to before where it would show all the parts that contributed to smoke effects.

What is happening?

Share this post


Link to post
Share on other sites

You removed the mods that brings the smokescreen configs like "hotrockets!" ?

Share this post


Link to post
Share on other sites

2.6.3 Remove lengthScale & velocityScale curves (a Unity limitation made them not that usefull).

Rescale effect when used with the ProceduralSRB of Procedural Parts

new initalVelocityOffsetMaxRadius curve that adds its value to the randomInitalVelocityOffsetMaxRadius value.

Download : SmokeScreen-2.6.3.0.zip

Edited by sarbian

Share this post


Link to post
Share on other sites
2.6.2 Remove lengthScale & velocityScale curves (a Unity limitation made them not that usefull).

Rescale effect when used with the ProceduralSRB of Procedural Parts

new initalVelocityOffsetMaxRadius curve that adds its value to the randomInitalVelocityOffsetMaxRadius value.

Download : SmokeScreen-2.6.3.0.zip

Why is the changelog for V 2.6.2 when the version is 2.6.3? or is it meant as "changes from 2.6.2" (to 2.6.3)?

Share this post


Link to post
Share on other sites

Felger contribution :

2.6.5 add randConeEmit, xyForce and zForce curves

Share this post


Link to post
Share on other sites

The last update completely destroyed HR configs,i don't say it's bad thing just more work.

P.S.can you please update "Spoiler: Default Config"also.

thank you

Share this post


Link to post
Share on other sites

In RO also every effect now looks weird, I guess there will be fixes during the next days though

Share this post


Link to post
Share on other sites

Seem to be getting smoke whilst in space, as reported a few pages back. The current update plus the .dll fix posted above still produce it, though i don't see a circle pattern anymore.

Share this post


Link to post
Share on other sites

2.6.6 with the fix is out.

Subcidal : this is a problem with the configs you use, not SmokeScreen.

Share this post


Link to post
Share on other sites

With the latest release (2.6.6), the engine exhaust seems to be coming out through the engine as if the point of origin is inside the engine (with Laztek Launch pack and Realism Overhaul)

I'm not sure if this mod is causing this though as the latest update fixed my other problem

2W6E7qr.png

Share this post


Link to post
Share on other sites

kendoka15 : most likely a config problem with the new RO config. They will improve with time

2.6.7 is out and fix an error spam when an active engine got out of physic range

Share this post


Link to post
Share on other sites

I'm not 100% sure if this is me being silly or a genuine problem, but I can't seem to find the SmokeScreen menu. If I recall correctly, it should be an app in the app bar during a flight scene, correct? If that's the case, it doesn't seem to be working for me. :/

Share this post


Link to post
Share on other sites
I'm not 100% sure if this is me being silly or a genuine problem, but I can't seem to find the SmokeScreen menu. If I recall correctly, it should be an app in the app bar during a flight scene, correct? If that's the case, it doesn't seem to be working for me. :/

Well,you need to install Toolbar,and set the icon to be visible.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.