Jump to content

[1.8.x-1.10.x] SmokeScreen 2.8.14 - Extended FX plugin (18 April 2020)


Recommended Posts

5 minutes ago, coolguy8445 said:

Looks like the 1.4 update majorly broke 1.3.1 for me.

Yeah, it s for 1.4 not 1.3.x...

Edit: damned, I messed up my CKAN meta again...

Edited by sarbian
Link to post
Share on other sites
  • 2 weeks later...

I wonder if this is coming from SmokeScreen since the latest updates of this addon, console sometimes spamming me with

[ERR 00:17:27.959] Can't remove ParticleSystem because FXPrefab (Script) depends on it

I'm unsure what mod could cause this or what in specific, but I assume it's from mods that are not yet updated for this release of SmokeScreen or some debugging spam what causing it.

Link to post
Share on other sites
  • 2 weeks later...
4 hours ago, Battou said:

Any way to increase particle count over 1000? CFG editing or ingame configs dont work.(

Maybe a 1.4 bug? I have mine set to 8000 in 1.3.x using the toolbar button to bring up the GUI to enter the number

Link to post
Share on other sites

Hey, @sarbian, I noticed that older smokescreen compatable mods like the KSO, aren't showing any rocket effects, even though I've updated Smokescreen to the latest version.  I noticed the changelog said something about MODEL_MULTI_PARTICLE_PERSIST being depriciated, would that cause what I'm seeing with the KSO?  What do I need to change in the mod's smokescreen config to fix that?

Output log:

https://www.dropbox.com/s/xcstvdgyx5xi4kv/output_log.txt?dl=0

 

Edited by Capt. Hunt
Link to post
Share on other sites
On 15/04/2018 at 9:33 AM, Capt. Hunt said:

Hey, @sarbian, I noticed that older smokescreen compatable mods like the KSO, aren't showing any rocket effects, even though I've updated Smokescreen to the latest version.  I noticed the changelog said something about MODEL_MULTI_PARTICLE_PERSIST being depriciated, would that cause what I'm seeing with the KSO?  What do I need to change in the mod's smokescreen config to fix that?

Output log:

https://www.dropbox.com/s/xcstvdgyx5xi4kv/output_log.txt?dl=0

 

Change MODEL_MULTI_PARTICLE_PERSIST into MODEL_MULTI_SHURIKEN_PERSIST  

Link to post
Share on other sites

Where does this 1000 hardlimit comes from? It cuts offthe smoke after just 1000 particles. :( 

qge4rKGoNT4b.png

 

When I open the ingame Config Editor if found following: 

modelName = RealPlume/MP_Nazari_FX/smokelaunch
transformName = thrustTransform
renderMode = "Billboard"
layer = TransparentFX
collide = False
collideRatio = 0
localRotation = 0,0,0
localPosition = 0,0,0
offsetDirection = 0,0,1
fixedScale = 1
emissionMult = 1
sizeClamp = 250
initialDensity = 0.59999999999999998
physical = False
stickiness = 0.90000000000000002
dragCoefficient = 0.10000000000000001
timeModulo = 10
singleEmitTimer = 0
randomInitalVelocityOffsetMaxRadius = 0
particleCountLimit = 1000
angle = 1
distance = 1
emission
{
  power = 1
  density = 1
  mach = 1
  parttemp = 1
<...>

i greped all cfgs but could not find any entry about the particleCountLimit

particleCountLimit = 1000

Changing it in the ingame editor also doesn't change anything

Edit... found it it the Code 

https://github.com/sarbian/SmokeScreen/blob/master/ModelMultiShurikenPersistFX.cs
 

[Persistent]
public int particleCountLimit = 1000;

should this not be configurable?

 

Cheers

WeirdCulture

Edited by WeirdCulture
found it in the code
Link to post
Share on other sites
32 minutes ago, WeirdCulture said:

should this not be configurable?

This is configurable. That's why there is a "[Persistent]" above it.  It should be set in the effect config.

If it is missing in the effect then add it.

Edited by sarbian
Link to post
Share on other sites
  • 4 weeks later...

@sarbian or anyone that can help with some insight - I'm working on using physics particles for ground smoke and the effect is nice but I don't want the smoke after the rocket takes off. This is my config right now

MODEL_MULTI_SHURIKEN_PERSIST
{
  transformName = thrustTransform
  localRotation = 0,0,0
  localPosition = 0,0,0
  fixedScale = 0.05
  name = smoke
  modelName = RealPlume/MP_Nazari_FX/smokelaunch
  particleCountLimit = 8000
  speed = 8
  grow = 0.0 0
  grow = 1.0 1
  renderMode = "Billboard"
  collide = true
  physical = true
  collideRatio = 0
  stickiness = 0.25
  sizeClamp = 5
  angle = 0.0 1.0
  angle = 50.0 1.0
  distance = 0.0 1.0
  distance = 100.0 1
  logGrow
  {
    density = 1.0 20
    density = 0.1 25
    density = 0.0 2
  }
  logGrowScale
  {
    density = 1.0 2
    density = 0.8 2.5
    density = 0.46 3
    density = 0.2 3
    density = 0.1 3
    density = 0.0 5
  }
  linGrow
  {
    density = 1.0 0
    density = 0.46 0
    density = 0.2 0
    density = 0.05 5
    density = 0.0 10
  }
  emission
  {
    density = 1.0 5.0
    density = 0.98 0
  }
  energy
  {
    density = 1.0 3
    density = 0.3 3
    density = 0.05 0.1
    density = 0.0 0.0
  }
  size
  {
    density = 1.0 1
    density = 0.8 1.2
    density = 0.6 2
    density = 0.2 3
    density = 0.0 7
  }
}

I thought the emission curve would take care of it but the smoke just keeps coming even after launch. Any ideas? I only spent about an hour on it and it's 1am now so probably mission something dumb. Will revisit it after some sleep...

Link to post
Share on other sites
On 5/22/2018 at 7:14 AM, Drew Kerman said:

@sarbian or anyone that can help with some insight - I'm working on using physics particles for ground smoke and the effect is nice but I don't want the smoke after the rocket takes off. This is my config right now

I thought the emission curve would take care of it but the smoke just keeps coming even after launch. Any ideas? I only spent about an hour on it and it's 1am now so probably mission something dumb. Will revisit it after some sleep...

Try with 

emission
  {
    density = 1.0 5.0
    density = 0.98 0
    density = 0 0
  }

 

Link to post
Share on other sites
3 hours ago, sarbian said:

Try with  

emission
  {
    density = 1.0 5.0
    density = 0.98 0
    density = 0 0
  }

 

it does cut out now, but still not low enough from the ground, even if I tried 0.99999 instead of 0.98. Bummer. Any other ideas? If not I'll just switch camera angles between the initial launch smoke start and the actual lift off and just disable the emitter in between

Link to post
Share on other sites
On 5/24/2018 at 3:31 AM, Drew Kerman said:

it does cut out now, but still not low enough from the ground, even if I tried 0.99999 instead of 0.98. Bummer. Any other ideas? If not I'll just switch camera angles between the initial launch smoke start and the actual lift off and just disable the emitter in between

There is nothing in SS that will make this work currently. Using the atmo would work just for in kerbin at sea level.

Stocks uses ModuleSurfaceFX but it does not have much config available.

Link to post
Share on other sites
9 minutes ago, sarbian said:

Stocks uses ModuleSurfaceFX but it does not have much config available.

Yup, which is why I tried SS. I tried months ago to get the stock FX small enough to look good for smaller rockets to no avail. Oh well. It just means I can't do a continuous video shot of lift-off and need to cut to a diff view and manually disable the smoke emitter in between. No biggie

Link to post
Share on other sites
53 minutes ago, sarbian said:

Unfortunately I do not have time to mod anything currently or I would have added something... 

Like I said, no worries I can make it work as is. Thanks though - maybe a low-priority item to add at some point

Link to post
Share on other sites
  • 1 month later...

Hello!

I'm having a strange behaviour on particle emissions.

It get intermittent emissions, and i wanna it to be stream smooth jet of particles, like a oven flame.

I believe that could be a Unity problem, but is there a way to get the result i'm locking for?

Config:
            

Quote

MODEL_MULTI_SHURIKEN_PERSIST
            {
                modelName = Omicron/FX/O_rcs_particle
                transformName = RCS_Thruster
                randomInitalVelocityOffsetMaxRadius = 0.03
                logGrow = 1.33
                velocityScale = 25
                density = 2
                emission = 2
                energy = 0 0.2
                energy = 1 0.4
                speed
                {
                    power = 1
                    density = 2.5
                    mach = 1
                    parttemp = 1
                    externaltemp = 1
                    time = 1
                }
                localRotation = -90, 0, 0
                particleCountLimit = 200
            }

Here a Youtube showing how it is now.

 

And here a example pic of what i wanna it to be:

 

flame jet

 

I already try increase density, emission, energy, and it won't change  solve it.

Please, if anyone can help, i appreciate.

Thank you!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...